Ubuntu

video tearing when composite is enabled on nvidia card

Reported by Chen Tao on 2009-10-11
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
Undecided
Unassigned
nvidia-graphics-drivers-180 (Ubuntu)
Undecided
Unassigned
Declined for Maverick by Sebastien Bacher

Bug Description

After upgrading to Karmic recently, I found serious image tearing during video playback. The tearings mostly occur at the upper part of the screen, especially when there is a horizontally moving object in the video. Perhaps there was also video tearing when I was using Jaunty, but not obvious enough. I've tried to set "Sync to VBlank" in nvidia-settings and compiz config settings manager, and also the correct refresh rate in compiz, but none helped. I included a screenshot to show the tearing problem. Note that I only see the tearings marked with red in video playback, the tearings marked with blue only appears in screenshots.

When metacity is used instead of compiz, the tearings are still there. And I tried nvidia drivers 173,185,190, the results are the same. Later I found by disabling composite in xorg.conf, the tearing is gone. But then I won't be able to use compiz. So I think the problem lies in composite extension of nvidia driver.

ProblemType: Bug
Architecture: amd64
CheckboxSubmission: 4b1f7cb9d4a347d4f4732ef8b266b061
CheckboxSystem: 425f2b13f62e035c9c858016dd99e2d4
Date: Sun Oct 11 11:02:24 2009
DistroRelease: Ubuntu 9.10
MachineType: Quanta TW8/SW8/DW8
NonfreeKernelModules: nvidia
Package: nvidia-glx-185 185.18.36-0ubuntu4
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-13-generic root=UUID=a405134b-cddd-45ad-8961-293324a810d3 ro quiet splash
ProcEnviron:
 LANGUAGE=zh_CN.UTF-8
 LANG=zh_CN.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-13.43-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.7.0~git20091009.db828ed7-0ubuntu0tormod
 libdrm2 2.4.15~git-0ubuntu0tormod
 xserver-xorg-video-intel 2:2.9.0-1ubuntu1
 xserver-xorg-video-ati N/A
SourcePackage: nvidia-graphics-drivers-180
Uname: Linux 2.6.31-13-generic x86_64
dmi.bios.date: 01/12/2009
dmi.bios.vendor: INSYDE
dmi.bios.version: Q3C61
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: TW8/SW8/DW8
dmi.board.vendor: Quanta
dmi.board.version: 03
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: Quanta
dmi.chassis.version: US
dmi.modalias: dmi:bvnINSYDE:bvrQ3C61:bd01/12/2009:svnQuanta:pnTW8/SW8/DW8:pvrTBD:rvnQuanta:rnTW8/SW8/DW8:rvr03:cvnQuanta:ct1:cvrUS:
dmi.product.name: TW8/SW8/DW8
dmi.product.version: TBD
dmi.sys.vendor: Quanta
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: x86_64kernel: 2.6.31-13-generic

Chen Tao (pro711) wrote :
theenduser (stijnverwaaijen) wrote :

Same problem here. Thnx for the workaround (disabling composite in xorg)!

salous (salous) wrote :

I can confirm this,
I use nvidia 185 driver and have severely tearing video playback with compiz turned on.

salous (salous) wrote :

After turning on the "vsync to black" option both in nvidia and compiz(through CCSM),
the problem is solved,
could you please fix this issue since it's really annoying and could totally ruin the user experience for new users,
thank you very much!

freddy3980 (freddy3980) wrote :

Please fix this annoying bug asap...

Florentin (elmophp) wrote :

Please notice that you need to run ccsm on the screen where the tearing is happening.
If you have a TV and you use a "separate X screen", run ccsm on that screen and make the changes there.
Changing "vsync to black" on your monitor won't affect the other screens (a TV or the second monitor running another X screen)
Thank you salous for the solution, it works in Ubuntu 9.10 (karmic koala) with mplayer.

keithy (keith-waller) wrote :

Thank the lord. I was about to go back to windows!

Bryce Harrington (bryce) on 2010-03-18
tags: added: karmic
tags: added: lucid maverick

Same problem with nvidia-graphics-drivers-195 in Lucid and Maverick.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers