Mouse pointer gets stuck on the rightmost X screen

Bug #444154 reported by vivia on 2009-10-06
62
This bug affects 11 people
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
Medium
nvidia-graphics-drivers-180 (Ubuntu)
Undecided
Unassigned
xserver-xorg-input-synaptics (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

Hello,

I am having the bug described in http://bugs.freedesktop.org/show_bug.cgi?id=12145 .

I am trying to use a dual-monitor setup on a laptop. As soon as I move the mouse pointer to the rightmost screen, I can only take it back to the leftmost one using the USB mouse. The touchpad doesn't work, I really need to have my USB mouse connected.

I don't understand the internals of Xorg well enough, but I think the bug report means that there is a patch released. I would like to see this packaged in Karmic.

Thank you.

ProblemType: Bug
Architecture: i386
Date: Tue Oct 6 03:44:34 2009
DistroRelease: Ubuntu 9.10
MachineType: FUJITSU SIEMENS AMILO Pi 3540
NonfreeKernelModules: nvidia
Package: xorg 1:7.4+3ubuntu5
ProcCmdLine: root=UUID=323e7c44-9fec-417a-afaf-4ecbd22a97d5 ro quiet splash clocksource=hpet
ProcEnviron:
 LANG=el_GR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0~git20090817.7c422387-0ubuntu7
 libdrm2 2.4.13-1ubuntu1
 xserver-xorg-video-intel 2:2.8.1-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu2
SourcePackage: xorg
Uname: Linux 2.6.31-11-generic i686
dmi.bios.date: 08/14/2008
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 1.06C
dmi.board.name: F47
dmi.board.vendor: FUJITSU SIEMENS
dmi.board.version: 01
dmi.chassis.type: 10
dmi.chassis.vendor: FUJITSU SIEMENS
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr1.06C:bd08/14/2008:svnFUJITSUSIEMENS:pnAMILOPi3540:pvr10600934650:rvnFUJITSUSIEMENS:rnF47:rvr01:cvnFUJITSUSIEMENS:ct10:cvr:
dmi.product.name: AMILO Pi 3540
dmi.product.version: 10600934650
dmi.sys.vendor: FUJITSU SIEMENS
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-11-generic

[lspci]
01:00.0 VGA compatible controller [0300]: nVidia Corporation G98 [GeForce 9300M GS] [10de:06e9] (rev a1)
     Subsystem: Fujitsu Technology Solutions Device [1734:1137]

vivia (vivia) wrote :
Bryce Harrington (bryce) on 2009-10-06
affects: xorg (Ubuntu) → nvidia-graphics-drivers-180 (Ubuntu)
Bryce Harrington (bryce) on 2009-10-09
tags: added: karmic
Bryce Harrington (bryce) on 2009-10-09
description: updated

Architecture: amd64
DistroRelease: Ubuntu 9.10
MachineType: Dell Inc. Studio 1537
NonfreeKernelModules: fglrx
Package: nvidia-graphics-drivers-180 (not installed)
ProcCmdLine: root=UUID=97c53658-3213-4ba5-8dd9-f815b6280068 ro quiet splash crashkernel=384M-2G:64M,2G-:128M
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.7.0~git20091114.57f40b18-0ubuntu0sarvatt~karmic
 libdrm2 2.4.15+git20091107.89cc98c0-0ubuntu0tormod
 xserver-xorg-video-intel 2:2.9.0+git20091111.dbb68168-0ubuntu0sarvatt
 xserver-xorg-video-ati 1:6.12.99+git20091112.0c4710c6-0ubuntu0tormod~karmic
UdevDb: Error: [Errno 2] No such file or directory
Uname: Linux 2.6.31-14-generic x86_64
UserGroups: adm admin audio cdrom dialout lpadmin mpd netdev plugdev sambashare
Xrandr:
 Error: command ['xrandr', '--verbose'] failed with exit code 1: Xlib: extension "RANDR" missing on display ":0.0".
 RandR extension missing
dmi.bios.date: 12/03/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A07
dmi.board.name: 0P132H
dmi.board.vendor: Dell Inc.
dmi.board.version: A07
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A07
dmi.modalias: dmi:bvnDellInc.:bvrA07:bd12/03/2008:svnDellInc.:pnStudio1537:pvrA07:rvnDellInc.:rn0P132H:rvrA07:cvnDellInc.:ct8:cvrA07:
dmi.product.name: Studio 1537
dmi.product.version: A07
dmi.sys.vendor: Dell Inc.
fglrx:

system:
 distro: Ubuntu
 architecture: x86_64kernel: 2.6.31-14-generic

tags: added: apport-collected
aarons (aarons-ubuntu) wrote :

I was playing around with a second screen yesterday and experienced the exact same problem. However, it isn't specific to the 'right most' screen, it's whatever the second screen is, independent of relative positions. I configured the second screen with the ATI Control Center app that comes with the fglrx drivers, and the bug showed up with separate X screens, or with xinerama, but not with one unified screen (which makes sense). I also tried configuring the screens with the gnome display properties app, but got the same results.

I can also verify that hooking up a usb mouse allows you to move the pointer back to the main screen.

Because my apport-collect was run without the second screen attached, I've manually added one of the dual-head xorg.confs that was causing me the problem.

With a dual-head setup with separate screens (with or without xinerama) the pointer when controlled with the ALPS trackpad on my laptop can move to the second screen, but not back to the first screen. The cursor can be moved back to the first screen with a USB mouse.

This downstream bug has more information:

https://bugs.launchpad.net/bugs/444154

that bug was originally filed against the nvidia driver, but I have ATI, so problem is either in the server or input driver, I assume.

aarons (aarons-ubuntu) wrote :

I noticed that this bug is within the nvidia graphics driver, but I have ATI graphics, so I think the bug is in the xserver.

Changed in xorg-server:
status: Unknown → Confirmed

Same issue here, using a Dell inspiron 1520. After updating the nvidia driver from 180.00 to 195.22 this issue persisted, I cannot move the pointer from the the screen on the right back to the left screen without attaching a USB mouse to my laptop.

takavar@takavar-laptop:~$ lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation G84 [GeForce 8600M GT] (rev a1)

mrej (mrej-junk) wrote :

Exact same behavior on Asus F9s, after my upgrade to Karmic.

joecarter (joe-carter) wrote :

Same issue with an Asus 4350 (ATI). Interestingly I could get my mouse to the other screen with the menus if I created a file, kicked off an editor and dragged it right. At that point the mouse was working properly. Dragging was partially broken as it would only drag to halfway across the problem screen. Enabling/disabling one screen fixed the problem.

Jean (alessandro-lai85) wrote :

Same bug on Toshiba Satellite Pro P100, nVIdia 7600. It seems to affect both ATI and nVidia, maybe is X11 or Gnome's fault.

Jean (alessandro-lai85) on 2010-03-12
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: New → Invalid
Jean (alessandro-lai85) wrote :

So it seems that the bug is on just when the mouse is controlled by a touchpad, and not when a usb mouse is in use?

Jean (alessandro-lai85) wrote :

I'm also getting full-system freeze after enabling the two separated x screens, just after the automatic logon. That's really weird.

themuddler (mike-udall) wrote :

Still a problem on Lucid RC. Could this be fixed before the final release? Any ideas whether there is work in progress upstream?

Changed in xorg-server:
importance: Unknown → Medium
Dav Clark (davclark) wrote :

Affects me on a Lenovo ThinkPad T510 with the nvidia discrete graphics chip (NVS 3100M / GT 218 core). Interestingly, the trackpoint cursor control gets me across the screen boundary either direction, while the touchpad only works in one direction. (i.e., the trackpoint yeilds the same behavior as a USB mouse - full functionality)

Changed in xorg-server:
importance: Medium → Unknown
Changed in xorg-server:
importance: Unknown → Medium

From the following links, I suspect the bug to be in xserver-xorg-input-synaptics package.

https://bugs.archlinux.org/task/8732

http://www.freebsd.org/cgi/query-pr.cgi?pr=116664&cat=ports

Changed in xserver-xorg-input-synaptics (Ubuntu):
status: New → Opinion

Server bug, affects all absolute devices.

Problem is simply that when we scale an axis range into [0..screen width], the latter is actually one past the highest possible coordinate and triggers the screen crossing. 0 is still part of the screen and does not trigger the screen cross. Hence you can only change screens to the right/bottom.

Changed in xorg-server:
status: Confirmed → In Progress

Fixed with the commits leading up to

commit 401150d7dcad08be7c1f07e076f810cd61e2105c
Author: Peter Hutterer <email address hidden>
Date: Tue Oct 4 11:41:17 2011 +1000

    input: change pointer screen crossing behaviour for multiple ScreenRecs

This is a large change, so I don't expect it to be back-ported to 1.11.

Changed in xorg-server:
status: In Progress → Fix Released
To post a comment you must log in.