Xorg crashed with SIGSEGV in strtol()

Bug #429114 reported by Ken N9VV on 2009-09-14
58
This bug affects 7 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-180 (Ubuntu)
High
Unassigned

Bug Description

my /etc/X11/xorg.conf was not working and I had no graphics whatsoever. I tried to get to a root prompt. FInally DHCP gave up and I could copy xorg.conf.failsave ---> xorg.conf and get my graphics back. Using Intel 945 dual-core Dell with Nvidia 8600GT card. Usually works perfectly. This time I was really confused. I tried e2fsch and all the other options with no luck. Perhaps another option should be start-in-sane-X-mode.
thanks,
Ken
Naperville, IL USA

ProblemType: Crash
Architecture: i386
Date: Sun Sep 13 13:28:33 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/Xorg
MachineType: Dell Inc. Dell DM051
NonfreeKernelModules: nvidia
Package: xserver-xorg-core 2:1.6.3-1ubuntu6
PccardctlIdent:

PccardctlStatus:

ProcCmdLine: root=UUID=92d02786-7c21-463a-a25d-32c9bdd86b0c ro quiet splash
ProcCmdline: /usr/bin/X :0 -br -verbose -auth /var/run/gdm/auth-for-gdm-K6FmYd/database -nolisten tcp vt7
ProcEnviron:
 LANG=en_US.UTF-8
 PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.31-10.32-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0~git20090817.7c422387-0ubuntu3
 libdrm2 2.4.13-1ubuntu1
 xserver-xorg-video-intel 2:2.8.1-1ubuntu1
 xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu1
SegvAnalysis: Failure: Unknown offset literal: *%eax
Signal: 11
SourcePackage: xorg-server
StacktraceTop:
 ?? () from /lib/libc.so.6
 strtol () from /lib/libc.so.6
 RegisterExtensionNames ()
 AddExtension ()
 ?? () from /usr/lib/xorg/modules/extensions//libglx.so
Title: Xorg crashed with SIGSEGV in strtol()
Uname: Linux 2.6.31-10-generic i686
UserGroups: root
dmi.bios.date: 01/08/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A07
dmi.board.name: 0HJ054
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 6
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA07:bd01/08/2007:svnDellInc.:pnDellDM051:pvr:rvnDellInc.:rn0HJ054:rvr:cvnDellInc.:ct6:cvr:
dmi.product.name: Dell DM051
dmi.sys.vendor: Dell Inc.
fglrx: Not loaded
glxinfo: Error: command ['glxinfo'] failed with exit code -11:
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-10-generic

[lspci]
01:00.0 VGA compatible controller [0300]: nVidia Corporation G84 [GeForce 8600 GT] [10de:0402] (rev a1)
     Subsystem: PC Partner Limited Device [174b:8610]

Ken N9VV (kenhopper1125-wowway) wrote :

StacktraceTop:*__GI_____strtol_l_internal (nptr=0xbfc9168d "001 GLX",
*__GI_strtol (nptr=0xbfc9168d "001 GLX", endptr=0xbfc91688,
RegisterExtensionNames ()
AddExtension ()
?? () from /usr/lib/xorg/modules/extensions//libglx.so

Changed in xorg-server (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Bryce Harrington (bryce) on 2009-09-15
tags: added: crash
Changed in xorg-server (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2009-09-29
visibility: private → public
affects: xorg-server (Ubuntu) → nvidia-graphics-drivers-180 (Ubuntu)
Bryce Harrington (bryce) on 2009-10-09
tags: added: karmic
Bryce Harrington (bryce) on 2009-10-09
description: updated
Bryce Harrington (bryce) on 2012-03-21
Changed in nvidia-graphics-drivers-180 (Ubuntu):
importance: Medium → High
status: Confirmed → Triaged
To post a comment you must log in.