Ubuntu

system freeze on boot with proprietary nvidia drivers 185

Reported by Massimo on 2009-08-30
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-180 (Ubuntu)
Undecided
Unassigned

Bug Description

hello all
i just installed kubuntu 9.10 (karmic koala B4 with recent updates) and i wanted to test nvidia driver
Activated the driver v185 with jockey-kde "hardware-drivers" and did a reboot.

on boot i can see the kubuntu logo for a few seconds then the screen flickered a bit printing some white little square and then got completely black.

i cannot activate numlock led anymore and neither do a remote ssh or telnet.
my hw config
Intel Quad core on Asus P5Q motherboard with 4GB RAM
video :
01:00.0 VGA compatible controller: nVidia Corporation G92 [GeForce 9800 GTX] (rev a2)

All i can do is reboot in recovery mode and replace xorg.conf's nvidia by nv driver.

Do you you need more information to debug this issue ?

Regards

Massimo
ps : i joined the nvidia-debug output log (made with nv driver )

Massimo (mtrento) wrote :
Bryce Harrington (bryce) on 2009-09-02
tags: added: kubuntu
Massimo (mtrento) wrote :

the nvidia V173 driver works with recent updates but v185 still freeze my computer.

Miloš Mandarić (mandzo18) wrote :

I have the same issue. 173 also doesn't work in my case.

/var/log/kern.log:
Sep 15 06:24:15 karmic kernel: [ 36.635454] Xorg[2636]: segfault at ab546007 ip ab546007 sp bfe5e4f8 error 4 in nvidia0[b79fa000+1000]
Sep 15 06:24:21 karmic kernel: [ 43.088979] wlan0: authenticate with AP 00:1b:11:f3:88:03
Sep 15 06:24:21 karmic kernel: [ 43.090456] wlan0: authenticated
Sep 15 06:24:21 karmic kernel: [ 43.090460] wlan0: associate with AP 00:1b:11:f3:88:03
Sep 15 06:24:21 karmic kernel: [ 43.099018] wlan0: RX AssocResp from 00:1b:11:f3:88:03 (capab=0x411 status=0 aid=1)
Sep 15 06:24:21 karmic kernel: [ 43.099021] wlan0: associated
Sep 15 06:24:21 karmic kernel: [ 43.099877] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Sep 15 06:24:21 karmic kernel: [ 43.215038] padlock: VIA PadLock not detected.
Sep 15 06:24:30 karmic kernel: [ 53.459903] Xorg[3170] general protection ip:28fd8b sp:bfaf1bdc error:0 in libc-2.10.1.so[1ac000+155000]
Sep 15 06:24:31 karmic kernel: [ 53.952009] wlan0: no IPv6 routers present
Sep 15 06:24:31 karmic kernel: [ 54.361628] Xorg[3174] general protection ip:775d8b sp:bfe1433c error:0 in libc-2.10.1.so[692000+155000]
Sep 15 06:24:32 karmic kernel: [ 55.231097] Xorg[3178] general protection ip:71ed8b sp:bf90610c error:0 in libc-2.10.1.so[63b000+155000]
Sep 15 06:24:33 karmic kernel: [ 56.100139] Xorg[3182]: segfault at 8c9c39f4 ip 8c9c39f4 sp bfebaf18 error 4 in nvidia0[b79cc000+1000]
Sep 15 06:24:33 karmic kernel: [ 57.002177] Xorg[3186]: segfault at b4fcba65 ip b4fcba65 sp bfb58598 error 4 in nvidia0[b7ad0000+1000]
Sep 15 06:24:34 karmic kernel: [ 57.871006] Xorg[3190]: segfault at bf58fef ip 0bf58fef sp bffb4588 error 4 in nvidia0[b79f5000+1000]
Sep 15 06:25:15 karmic kernel: [ 98.660071] Clocksource tsc unstable (delta = -300023203 ns)
Sep 15 06:25:37 karmic kernel: [ 120.748730] wlan0: deauthenticating by local choice (reason=3)
Sep 15 06:25:37 karmic kernel: Kernel logging (proc) stopped.
Sep 15 06:26:24 karmic kernel: imklog 4.2.0, log source = /var/run/rsyslog/kmsg started.

Miloš Mandarić (mandzo18) wrote :
Toni Ruottu (toni-ruottu) wrote :

I have the same problem with this card.

01:00.0 VGA compatible controller: nVidia Corporation NV44 [Quadro NVS 285] (rev a1)
 Subsystem: nVidia Corporation Device 029d
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at f6000000 (32-bit, non-prefetchable) [size=16M]
 Memory at f8000000 (64-bit, prefetchable) [size=64M]
 Memory at f7000000 (64-bit, non-prefetchable) [size=16M]
 [virtual] Expansion ROM at fc000000 [disabled] [size=128K]
 Capabilities: <access denied>
 Kernel driver in use: nvidia
 Kernel modules: nvidia, nvidiafb

The problem appeared after a recent update. It, how ever, does not freeze the whole computer but simply the user interface. I'm not able to do anything locally, but I can open an ssh connection to the computer. Restarting gdm or executing chvt from the remote shell does not help. Moving /etc/X11/xorg.conf to /etc/X11/xorg.conf.foo seemed to fix the issue after a reboot, by defaulting to another driver.

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: New → Confirmed
Miloš Mandarić (mandzo18) wrote :

After last update I don't have this issue. Works great.

las (bandara-ls) wrote :

lucky you.Mine got worse after last update .not it freezes like every 10 sec...I cant even find anything in logs.

lovinglinux (lovinglinux) wrote :

Version 173 works fine, but a little bit slow. Version 185 was really fast, but it freezes Ubuntu during boot for me too.

lovinglinux (lovinglinux) wrote :

It seems it has been fixed with the latest nvidia updates.

lotk (stephan-sann) wrote :

I installed Kubuntu 9.10 on my system (AMD64 / 2 x GeForce 9600) and installed the suggested nvidia-driver 185.

Got the same problem (after reboot Kubuntu-Logo and then black screen (my monitor even switches to sleeping mode)).

This problem seems to exist in the 3rd generation now:
http://ubuntuforums.org/showthread.php?t=1307653

Hope this issue will be solved soon...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers