nvidia-glx-185 on karmic hangs laptop with black screen

Bug #417373 reported by Marc Deslauriers on 2009-08-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-180 (Ubuntu)
Undecided
Unassigned

Bug Description

Last night, I dist-upgraded my karmic desktop. X wouldn't start. I then noticed that the nvidia-glx-185 package didn't replace the nvidia-glx-180 package I already had installed.

I manually installed nvidia-glx-185 (185.18.31-0ubuntu1). When booting my Thinkpad T61, when X is supposed to start, the LCD screen turns off and the laptop hangs.

I tried installing nvidia-glx-173, but the module won't build with recent karmic kernels. (See bug 397314 and bug 395635)
I had to install xserver-xorg-video-nouveau to get X again. (which I why I didn't use ubuntu-bug to generate this bug.)

This morning I again tried getting nvidia-glx-185 to work, but failed.

Attached is the Xorg.0.log when the laptop hangs.

Marc Deslauriers (mdeslaur) wrote :
Marc Deslauriers (mdeslaur) wrote :

Here the relevant part of my dpkg.log that shows the dist-upgrade.

Noel J. Bergman (noeljb) wrote :

nvidia 185.18.29 and 185.18.31 were known bad drivers and really should not have been put into the repository, in my opinion. Please use the new 185.18.36 driver. Until it is in the main repository, you can use the nvidia PPA (https://launchpad.net/~nvidia-vdpau/+archive/ppa)

I'm marking this as a duplicate of Bug 408561, which calls for 185.18.36 to be put into the repositories ASAP.

U Das (nxb76z7f001) wrote :

Just wanted to report that I hit this with Karmic on a Lenovo T61 as well. The -173 with an older kernel was doing fine, but then I have updated the system. Eagerly awaiting 185.18.36 for karmic

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers