Ubuntu

No Nvidia direct rendering unless root user (vmware)

Reported by David Clayton on 2009-05-01
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-180 (Ubuntu)
Medium
Unassigned

Bug Description

The permissions of the /dev/nvidia files cause errors when processes are launched with non-root privileges on my 64-bit 9.04 desktop system.

In my case I get Direct Rendering errors when launching a Direct Rendering enabled VM inside VMware Server, but running glxinfo without sudo shows the error:

NVIDIA: could not open the device file /dev/nvidiactl (Permission denied).

I have found many other posts with the same issue (including people using Wine), and here is my current workaround since reinstalling the 180 driver package did not fix it:

gksudo gedit /etc/rc.local

Add the following before "exit 0":

chmod 666 /dev/nvidia* &

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: vmmon nvidia
Package: nvidia-glx-180 180.44-0ubuntu1
ProcEnviron:
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.28-11-generic (buildd@crested) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009
SourcePackage: nvidia-graphics-drivers-180
Uname: Linux 2.6.28-11-generic x86_64

[lspci]
00:00.0 RAM memory [0500]: nVidia Corporation C51 Host Bridge [10de:02f0] (rev a2)
     Subsystem: Hewlett-Packard Company Device [103c:2a34]
00:05.0 VGA compatible controller [0300]: nVidia Corporation C51 [GeForce 6150 LE] [10de:0241] (rev a2)
     Subsystem: Hewlett-Packard Company Device [103c:2a34]

David Clayton (dcstar) wrote :
David Clayton (dcstar) on 2009-05-03
description: updated
Bryce Harrington (bryce) on 2009-05-05
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2009-05-06
description: updated
Bryce Harrington (bryce) wrote :

I've posted a new version of the -nvidia driver to our xorg-edgers PPA,
would you mind testing it either on Jaunty or Karmic and see if it
resolves this bug?

Get nvidia-graphics-drivers-180 - 185.18.14 here:

  https://edge.launchpad.net/~xorg-edgers/+archive/ppa

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Confirmed → New
status: New → Incomplete
David Clayton (dcstar) wrote :

No good, I installed the nvidia-180-kernel-source_185.18.14-0ubuntu1~xup~1~jaunty_amd64.deb, nvidia-180-libvdpau_185.18.14-0ubuntu1~xup~1~jaunty_amd64.deb & nvidia-glx-180_185.18.14-0ubuntu1~xup~1~jaunty_amd64.deb packages, did a reboot and (user) glxinfo says:

dc@dc-master:~$ glxinfo
name of display: :0.0
NVIDIA: could not open the device file /dev/nvidiactl (Permission denied).
display: :0 screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)

Also:

dc@dc-master:/dev$ ls -al nv*
crw-rw---- 1 root video 195, 0 2009-06-27 15:19 nvidia0
crw-rw---- 1 root video 195, 255 2009-06-27 15:19 nvidiactl

Bryce Harrington (bryce) on 2009-08-13
tags: added: jaunty
joconnor (joconnor) wrote :

I'm running Jaunty with nVidia driver 190.18.03. This is still an issue:

$ ls -la /dev/nvidia*
crw-rw---- 1 root video 195, 0 2009-09-04 23:59 /dev/nvidia0
crw-rw---- 1 root video 195, 255 2009-09-04 23:59 /dev/nvidiactl

My workaround is to add my user to the video group.

usermod -a -G video username

totzo (tim) wrote :

Same thing here, karmic with 185.18.36 and I thought it was an issue with alpha kernels- obviously not:

glxinfo
name of display: :0.0
NVIDIA: could not open the device file /dev/nvidiactl (Permission denied).
display: :0 screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)

sudo glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes

sdowney717 (sdowney717) wrote :

same here for me as well
I only get direct rendering now if i run something as root using the nvidia driver 185
google earth is zooming as root with direct rendering yes, normal user very very slow. so anyone know how to fix so user gets direct rendering?

Quote:
scott@scott-desktop:~$ glxinfo | grep direct
NVIDIA: could not open the device file /dev/nvidiactl (Permission denied).
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
scott@scott-desktop:~$ LIBGL_DEBUG=verbose

scott@scott-desktop:~$ sudo glxinfo | grep direct
[sudo] password for scott:
direct rendering: Yes
GL_EXT_depth_bounds_test, GL_EXT_direct_state_access,
scott@scott-desktop:~$ gksudo googleearth

this forum thread descirbed something similar but my groups look ok
http://ubuntuforums.org/showthread.php?t=77376

scott@scott-desktop:~$ grep video /etc/group
video:x:44:vdr,scott

scott@scott-desktop:~$ grep group /etc/nsswitch.conf
group: compat
netgroup: nis

scott@scott-desktop:~$ ls -al /dev/nvidia*
crw-rw---- 1 root video 195, 0 2009-10-31 09:42 /dev/nvidia0
crw-rw---- 1 root video 195, 255 2009-10-31 09:42 /dev/nvidiactl

scott@scott-desktop:~$ grep video /etc/group
video:x:44:vdr,scott
scott@scott-desktop:~$

sdowney717 (sdowney717) wrote :

i am running nvidia 185driver

Bryce Harrington (bryce) on 2009-11-07
summary: - No Nvidia direct rendering unless root user
+ No Nvidia direct rendering unless root user (vmware)
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Medium
Leszek Lesner (leszek-lesner) wrote :

Somehow my /dev/nvidiactl (190.42 driver) in karmic has the group www-data. So I added myself to this group and everything seems to work fine. Especially Adobes Flash Player stops flickering after that.

cyril (ivi610) wrote :

in my concern i had myself to the "video" group and now i get direct rendering.
I use kubuntu karmic and nvidia 190

bugbot (bugbot) wrote :

This bug report was filed against an old version of Ubuntu.
Can you confirm whether this is still an issue in natty?

If you don't mind, it would be very helpful if you could update the bug
report in launchpad to 'Fix Released' if it is no longer an issue for
you, or if it is still occurring under natty, please tag the bug 'natty'
so it's easier for us to track.

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Triaged → New
status: New → Incomplete
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers