Hang on Checking battery state [OK] after installing graphics drivers

Bug #367078 reported by Azelphur on 2009-04-26
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-180 (Ubuntu)
Undecided
Unassigned

Bug Description

Fresh installation of Jaunty jackalope, I did the updates, restarted, then installed the graphics drivers, restarted again. usplash shows up, gets to about 80% then it falls back to text only, and hangs. The last entry is Checking battery state [OK]

I'm using ubuntu jaunty jackalope (amd64) version 180 nvidia drivers, I have 2 graphics cards.
cshadowrun@mainpc:~$ lspci | grep VGA
03:00.0 VGA compatible controller: nVidia Corporation GeForce 8800 GT (rev a2)
04:00.0 VGA compatible controller: nVidia Corporation GeForce 8800 GT (rev a2)

Problem persists when installing drivers manually on a fresh install, too.

Azelphur (azelphur) on 2009-04-26
description: updated
Azelphur (azelphur) on 2009-04-26
description: updated
Bryce Harrington (bryce) wrote :

Hi cshadowrun,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Invalid
Stephen Buergler (sixcorners) wrote :

I also have this problem, should I post another bug or continue from this one?
Also, how do you get the files that you want onto a usb drive or something from inside the terminal?
The last few lines in the log file are
(II) Primary Device is:
(WW) Falling back to old probe method for vesa
(EE) No devices detected.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
               at http://wiki.x.org
 for help.
Please also check the log file at "/var.......

It's an intel 32bit system
There are two video cards:
VGA compatible controller: nVidia Corporation G80 [GeForce 8800 GTS] (rev a2)
VGA compatible controller: nVidia Corporation G80 [GeForce 8800 GTS] (rev a2)

lovinglinux (lovinglinux) wrote :

It happened to me too, several times. This doesn't happen with version 173 of the driver, but the performance of 180 is much better when it works.

Azelphur (azelphur) wrote :

I found out more specifically what the problem is, and a workaround.
The nvidia-xconfig utility doesn't specify a BusID in the device section. So when X starts, it doesn't know which graphics card to use, and this somehow results in "No screens found". The solution, open a terminal and type...

$ lspci | grep VGA
03:00.0 VGA compatible controller: nVidia Corporation GeForce 8800 GT (rev a2)
04:00.0 VGA compatible controller: nVidia Corporation GeForce 8800 GT (rev a2)

From this you can see my BusID's are 3:0:0 and 4:0:0

$ gksudo gedit /etc/X11/xorg.conf

Find your "device" section and add

BusID "PCI:3:0:0"

Replace PCI:3:0:0 with the BusID you got from lspci earlier.
Save, restart, all should be well now :)

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Invalid → Confirmed
Bryce Harrington (bryce) on 2010-03-18
tags: added: jaunty
mat69 (mat69) wrote :

I had the very same problem in Ubuntu 10.4 with an Intel garphics card, sometimes (not always) X failed to start. Adding the correct BusID solved it for me.

bugbot (bugbot) wrote :

This bug report was filed against an old version of Ubuntu.
Can you confirm whether this is still an issue in natty?

If you don't mind, it would be very helpful if you could update the bug
report in launchpad to 'Fix Released' if it is no longer an issue for
you, or if it is still occurring under natty, please tag the bug 'natty'
so it's easier for us to track.

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Confirmed → New
status: New → Incomplete
Pranav Ashok (pranavashok) wrote :

I just upgraded my Maverick to Natty and I started facing this bug!

Ramy (ramy-daghstani) wrote :

i am facing this bug now after updating from maverick to natty, where boot hangs after checking battery state.

The BusID fix did not work.

Recovery mode still works, i can even ssh after the hang,

not sure what data is needed
uname -a
Linux ramy-desktop 2.6.38-8-generic-pae #42-Ubuntu SMP Mon Apr 11 05:17:09 UTC 2011 i686 i686 i386 GNU/Linux

lspci | grep VGA
02:00.0 VGA compatible controller: nVidia Corporation GF100 [GeForce GTX 470] (rev a3)

some forum posts are saying to purge nvidia drivers and get nvidia-173 package. this bug is for nvidia-180 and right now there is nvidia-185. Which of these am I supposed to get? I have tried all of them but to be honest if there is a step beyond removing the old package and installing the new one then I wouldn't know about it.

has anyone found a temporary accommodation until a fix is found?

Launchpad Janitor (janitor) wrote :

[Expired for nvidia-graphics-drivers-180 (Ubuntu) because there has been no activity for 60 days.]

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers