Separate X screen blank in Jaunty (nvidia)

Bug #366743 reported by Fred on 2009-04-25
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-180 (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Fred

Bug Description

When choosing the "Separate X Screen" option to use my projector in Jaunty, the second X screen seems to exist, but the display is totally black.

Also the mouse pointer when moving from screen 0 to 1 freezes at the edge of screen 0 and then a second one appears on screen 1 (the pointer is the only thing visible on screen 1) This transition was seamless in Intrepid.

When I click Restart from the FUSA, the second X screen is briefly visible in all it's glory before the computer shuts down. So it is there! It's just hiding from me :-(

The GDM only displays on screen 0 as well.

I've experimented with TwinView and XCinerama and they still work fine.

Confirmed this in both the 32-bit and 64-bit versions of Jaunty.
Confirmed in 64-bit using version 180 and 173 of nvidia driver.

I think I was using 173 in Intrepid (which makes me think it's not the nvidia driver at fault) but I haven't re-booted my Intrepid drive to confirm that yet.

I spotted this thread on the ubuntu forums, where a few others appear to have the same issue:
http://ubuntuforums.org/showthread.php?s=bd2619d130be9c08538c7ad78f736668&t=1134302

I'm up for some experimenting if anyone has any suggestions...

[lspci]
00:00.0 Memory controller [0580]: nVidia Corporation CK804 Memory Controller [10de:005e] (rev a3)
     Subsystem: Giga-byte Technology Device [1458:5000]
08:00.0 VGA compatible controller [0300]: nVidia Corporation G71 [GeForce 7950 GX2] [10de:0294] (rev a1)
     Subsystem: CardExpert Technology Device [10b0:0401]

Andreas Moog (ampelbein) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This appears to be an X.org bug, and I am refiling this bug to them. Please run the command 'apport-collect <bug#>' which will include all the info they need for troubleshooting. Thanks in advance.

affects: ubuntu → xorg (Ubuntu)

Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: xorg 1:7.4~5ubuntu18
PackageArchitecture: amd64
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_GB.UTF-8
ProcVersion: Linux version 2.6.28-11-generic (buildd@crested) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009
Uname: Linux 2.6.28-11-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Fred (ian-bews) wrote :
Fred (ian-bews) wrote :
Fred (ian-bews) wrote :
Fred (ian-bews) wrote :
Fred (ian-bews) wrote :
Fred (ian-bews) wrote :
Fred (ian-bews) wrote :
Fred (ian-bews) wrote :
Fred (ian-bews) wrote :
Fred (ian-bews) wrote :
Fred (ian-bews) wrote :
Fred (ian-bews) wrote :
Fred (ian-bews) wrote :
Fred (ian-bews) wrote :
Martin Olsson (mnemo) on 2009-04-25
affects: xorg (Ubuntu) → nvidia-graphics-drivers-180 (Ubuntu)
Fred (ian-bews) wrote :

Actually I was using version 177 of the nvidia driver in Intrepid (which doesn't get offered for Jaunty) so maybe it is the driver.

The clone option seems to have re-appeared in version 180 though which is what I wanted to use originally, the separate X screen was a work-around for not having "clone".

Bryce Harrington (bryce) on 2009-04-28
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2009-05-06
description: updated
melo (carmeloscollo) wrote :

I can confirm this bug for nvidia-graphics-driver-173.
I was using separate X screen on my nvidia Geforce FX 5950 with my CRT (1280x1024) and TV (1024x768) since ubuntu 8.04. I set this up with nvidia-settings.

Since I updated to Jaunty I encounter exactly the same problems as Fred does.
Restarting compiz leads to the the second x-screen showing up but without any function (you see the desktop and panels but there is no interaction possible, only the mousepointer can be moved)

This was all working fine in 8.04 and 8.10. Don't know which driver-versions I used at that time (but a nvidia-driver for sure).
The only application visible on the second X screen is elisa by starting it with "DISPLAY=":0.1" elisa". (maybe because it's fullscreen?)

I really hope this gets fixed.

Bryce Harrington (bryce) wrote :

I've posted a new version of the -nvidia driver to our xorg-edgers PPA,
would you mind testing it either on Jaunty or Karmic and see if it
resolves this bug?

Get nvidia-graphics-drivers-180 - 185.18.14 here:

  https://edge.launchpad.net/~xorg-edgers/+archive/ppa

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Confirmed → New
status: New → Incomplete
Fred (ian-bews) wrote :

I have added your PPA and the upgraded the following packages via synaptic from version 180.44 to 185.18.14:
nvidia-180-kernel-source
nvidia-180-libvdpau
nvidia-180-modaliases
nvidia-glx-180

I then re-booted, altered my nvidia-settings to "separate X screen" and logged out and in again.

The bug remains.

The second screen shows only blackness with a mouse pointer on it. Instead of one seamless pointer moving over the 2 screens I have two pointers (one on each screen) and when I move from one screen to another the pointer on the old screen just freezes till I come back.

When I log out, the second screen briefly shows my wallpaper.

Also there appears to be a regression with this new driver. Ctrl-Alt-F1 - Ctrl-Alt-F6 VTs are now blank screens as well (actually on my second attempt at testing this I managed to get white flashy graphical corruption over both monitors on all VTs (even though the 2nd monitor wasn't enabled) and I had to reboot via the terminal (which works just fine even when you can't actually see it ;-D ).

I'm going to downgrade back to 180.44 for the time being.

Thanks for your help...

Bryce Harrington (bryce) on 2009-08-13
tags: added: jaunty
Peter Manis (manis) wrote :

Here is a fix until the bug is fixed, I have been using it on another computer for a different compiz related issue. I found it during a search a long time ago and had worked well.

#!/bin/bash
sleep 2
DISPLAY=:0.0 compiz --only-current-screen --replace &
disown $!
sleep 2
DISPLAY=:0.1 compiz --only-current-screen --replace &
disown $!

Brian Kinnear (kbkinnear) wrote :

I have just struggled with a similar issue for the last several days:
Ubuntu 9.04 (AMD64) with NVidia drivers
I have a primary monitor in 1024x768 and a projector in 1920x1080 and prefer to run with separate x-screens. This worked fine in Ubunty 8.04, but with Ubuntu 9.04 the 2nd screen did not work properly.

After a bunch of messing around I finally realized that the problem is that there is no "screen1" directory in /.gconf/apps/compiz. There is a "screen0" directory there though. To fix the issue I did the following:
1) Installed CompizConfig Manager using "- sudo apt-get install compizconfig-settings-manager"
2) In the CompizConfig Settings Manager -> General Options -> Display Settings
 - Disabled "Detect Outputs"
 - Set Outputs to "1024x768+0+0"
3) In a terminal
 - cd .gconf/apps/compiz
 - mkdir screen1
 - cp -r screen0/* screen1
 - cd screen1/options
 - vi %gconf.xml --> Modified resolution to "1920x1080"
4) I rebooted and everything works fine (except the mouse still has that odd behavior)

Jean (alessandro-lai85) wrote :

It seems that this bug is not nVidia's fault. There is an other bug opened here: https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-180/+bug/444154

4 people with ATI cards have the same problem, with the mouse stuck on the secondary screen. It seems the same bug to me...

Charlie Kravetz (charlie-tca) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Could test the current Ubuntu development version? It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ .

Jaunty 9.04 will be End Of Support (EOS) on 2010-10-23, so it is suggested that if you are still using this version, please upgrade your system. The latest development version, Maverick Meerkat, is now in the final week of testing before it is released as 10.10.

Thanks again and we appreciate your help.

Charlie Kravetz (charlie-tca) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers