Nvidia OpenGL graphics issues on jaunty

Bug #366677 reported by Cyr4x on 2009-04-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-180 (Ubuntu)
Undecided
Unassigned

Bug Description

Almost all OpenGL games works ugly on Jaunty (GeForce 6200). Half of textures is black and average speed is 15-20 fps. On Hardy everything was ok. No matter the driver is 180.44 (recommended by system), or 173, or even 96. It always goes the same. Tested on Enemy Territory, Quake Wars, Urban Terror, everywhere the same.

Cyr4x (marcinwlo) wrote :
Cyr4x (marcinwlo) wrote :

Problem almost solved. All games runs brilliant as a root (with sudo). It's just a problem with permissions of /dev/nvidia0 and /dev/nvidiactl. I cannot access them as a normal user. Glxinfo says, direct rendering: no, and with sudo it's a yes. The solution is to make them permanently accessible as a normal user.

Cyr4x (marcinwlo) wrote :

Finally done!
Just do this:

sudo usermod -g video your_user

And everything works ok!

affects: ubuntu → nvidia-graphics-drivers-180 (Ubuntu)
Bryce Harrington (bryce) wrote :

Hi marcinwlo,

Thanks for including an image to demonstrate the issue. Could you also please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log or Xorg.0.log.old file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: New → Incomplete
Ramius (ramius79) wrote :

Hi everyone,
I had the same problem after upgrade (8.04 -> 9.04), because I run Enemy Territory as separate unprivileged user. I have added this user to the "video" group and everithing is fine now.

Bryce Harrington (bryce) wrote :

I've posted a new version of the -nvidia driver to our xorg-edgers PPA,
would you mind testing it either on Jaunty or Karmic and see if it
resolves this bug?

Get nvidia-graphics-drivers-180 - 185.18.14 here:

  https://edge.launchpad.net/~xorg-edgers/+archive/ppa

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers