jaunty: random crash Xorg

Bug #366641 reported by Francesco Duraccio on 2009-04-25
4
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-180 (Ubuntu)
Undecided
Unassigned

Bug Description

Hi folks,

often during a normal session, occurs a random crash of Xorg, and affter a while there is the login screen.
this is the error i have found in kernel.log

pr 25 11:53:17 odo-ds9laptop kernel: [ 4999.562828] Xorg[5494]: segfault at 3c0027d ip b65a4209 sp bff60df0 error 4 in nvidia_drv.so[b6556000+3b4000]

Ubuntu 9.04
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8400M GS (rev a1)

Andreas Moog (ampelbein) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This appears to be an X.org bug, and I am refiling this bug to them. Please run the command 'apport-collect <bug#>' which will include all the info they need for troubleshooting. Thanks in advance.

affects: ubuntu → xorg (Ubuntu)

Architecture: i386
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: xorg 1:7.4~5ubuntu18
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 LANG=it_IT.UTF-8
ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #42-Ubuntu SMP Fri Apr 17 01:57:59 UTC 2009
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Francesco Duraccio (odo.) wrote :
Francesco Duraccio (odo.) wrote :
Francesco Duraccio (odo.) wrote :
Francesco Duraccio (odo.) wrote :
Francesco Duraccio (odo.) wrote :
Francesco Duraccio (odo.) wrote :
Francesco Duraccio (odo.) wrote :
Francesco Duraccio (odo.) wrote :
Francesco Duraccio (odo.) wrote :
Francesco Duraccio (odo.) wrote :
Francesco Duraccio (odo.) wrote :
Francesco Duraccio (odo.) wrote :
Francesco Duraccio (odo.) wrote :
Martin Olsson (mnemo) on 2009-04-27
affects: xorg (Ubuntu) → nvidia-graphics-drivers-180 (Ubuntu)
Bryce Harrington (bryce) on 2009-04-28
tags: added: crash
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

I've posted a new version of the -nvidia driver to our xorg-edgers PPA,
would you mind testing it either on Jaunty or Karmic and see if it
resolves this bug?

Get nvidia-graphics-drivers-180 - 185.18.14 here:

  https://edge.launchpad.net/~xorg-edgers/+archive/ppa

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Confirmed → New
status: New → Incomplete
Francesco Duraccio (odo.) wrote :

sure! it's on my way.

Francesco Duraccio (odo.) wrote :

After about 7 days of testing i can say there is no more random crash! thx

Bryce Harrington (bryce) on 2009-08-13
tags: added: jaunty
Vish (vish) wrote :

Thanks for following up. This bug report is being closed due to your last comment regarding this being fixed. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers