Half of the menus and icons dissapear in Openoffice

Bug #366612 reported by raul on 2009-04-25
6
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-180 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org

I use Jaunty final release and Openoffice 3.0, fresh install, with desktop effects in NVIDIA driver 180.x, and Ubuntu restricted extras.

Sometimes when I am using Openoffice, and I click in one of the menus or the icons they either dissapear completely or partially, I mean, they cut in half or leave the space blank.

It also happens with dialog boxes, and with the window of the document itself which cuts or becomes crazy when selecting text.

It doesn't happen outside openoffice. Please help, it is a very annoying problem when you're writing a document.

(See the black circles in the screenshot I attach).

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: openoffice.org-core 1:3.0.1-9ubuntu3
ProcEnviron:
 PATH=(custom, no user)
 LANG=es_CO.UTF-8
 SHELL=/bin/bash
SourcePackage: openoffice.org
Uname: Linux 2.6.28-11-generic x86_64

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 0c)
     Subsystem: Hewlett-Packard Company Device [103c:30cd]
01:00.0 VGA compatible controller [0300]: nVidia Corporation GeForce 8400M GS [10de:0427] (rev a1)
     Subsystem: Hewlett-Packard Company Device [103c:30cd]

raul (rausuar) wrote :
Chris Cheney (ccheney) on 2009-04-26
affects: openoffice.org (Ubuntu) → nvidia-graphics-drivers-180 (Ubuntu)
Bryce Harrington (bryce) wrote :

Hi rausuar,

Thanks for including an image to demonstrate the issue. Could you also please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log or Xorg.0.log.old file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: New → Incomplete
raul (rausuar) wrote :

Mr. Bryce,

Attached you will find what you requested. I must clarify that I haven't made any changes to xorg.conf, but I am attaching it too.

Please be aware that I have modified the name of the files to be able to name them as .txt. Be aware also that the problem is present with a fresh install of Ubuntu. I made an experiment after I sent the bug, changing the nvidia driver from 180x to the 173x, with the 173x the problem doesn't happen, so I guess the problem is from the 180x driver (but I am only guessing)...

Sincerely,

Raul

raul (rausuar) wrote :
raul (rausuar) wrote :
raul (rausuar) wrote :
Bryce Harrington (bryce) on 2009-05-01
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2009-05-06
description: updated
m2acis (m2acis) wrote :

Same issue, solved by enabling "Force synchronization between X and GLX" in CompizConfig's workaround section.

Bryce Harrington (bryce) wrote :

I've posted a new version of the -nvidia driver to our xorg-edgers PPA,
would you mind testing it either on Jaunty or Karmic and see if it
resolves this bug?

Get nvidia-graphics-drivers-180 - 185.18.14 here:

  https://edge.launchpad.net/~xorg-edgers/+archive/ppa

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Confirmed → New
status: New → Incomplete
raul (rausuar) wrote :

I have been testing the new driver, using jaunty x86, it seems that for now the problem in openoffice is solved (though I will continue testing it, and if something comes up I will let you know).

However, when I open Skype (which uses Qt) the problem persists, but that is something that is not this post related.

As mentioned by a former comment, there is a workaround in compiz config settings, which if I use, those problems doesnt happen

Let me know if you need something else...

m2acis (m2acis) wrote :

I have disabled "Force synchronization between X and GLX" workaround and the problems is gone. dpkg -s nvidia-glx-180 shows that I'm using "Version: 180.44-0ubuntu1"

Bryce Harrington (bryce) wrote :

Thanks for letting us know the issue is resolved.

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Fix Released
m2acis (m2acis) wrote :

Pardon me. Yesterday problem re-appeared. I'm not using new driver and "Force synchronization between X and GLX" workaround. I'll test new driver as soon as I'll have time to...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers