Stable NVIDIA driver 180.53 released - please upgrade in Jaunty

Bug #364965 reported by Alex Murray on 2009-04-22
64
This bug affects 7 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-180 (Ubuntu)
Medium
Unassigned
Jaunty
Medium
Unassigned
Karmic
Medium
Unassigned

Bug Description

NVIDIA have released 180.51 as the latest stable driver - see http://www.nvnews.net/vbulletin/showthread.php?t=122606 under current releases:

Current releases
------------------------
Current official release: 180.51 (x86 / x86_64)

Would be great if the package in Jaunty could be updated (although I realise with the release imminent this is unlikely, but perhaps if it could get pushed to jaunty-updates that'd be great).

-----------

Version: 180.51
Operating System: Linux x64 (AMD64/EM64T)
Release Date: April 21, 2009

Release Highlights

    * Added support for the following GPUs:
            GeForce 9600 GSO 512
            GeForce 9400 GT
            GeForce GTS 250
            GeForce GT 140
            GeForce GT 130 Updated nvidia-bug-report.sh to compress its log file; running `nvidia-bug-report.sh` now produces "nvidia-bug-report.log.gz".
  * * Addressed a problem that could lead to intermittent hangs and system crashes on some GeForce 9 and later GPUs.
    * Fixed an X server crash when viewing the website www.tim.it.
    * Fixed a DisplayPort interaction problem with power management suspend/resume events.
    * Fixed rendering corruption in the OpenGL 16-bit RGB Workstation Overlay.
    * Fixed a recent VDPAU regression that caused aborted playback >and hangs when decoding some H.264 clips on G84, G86, G92, G94, G96, and GT200 GPUs.
    * Fixed occasional X driver memory management performance problems when a composite manager is running.
    * Improved compatibility with recent Linux kernels.
    * Reduced CPU usage of nvidia-smi utility for reporting Quadro Plex information.
    * Fixed compatibility problem with LandMark GeoProbe.
    * Fixed an interaction problem that could corrupt the EDID of the Fujitsu Technology Solutions Celsius H270 notebook's internal flatpanel.
    * Fixed a bug that could interfere with the detection of display devices attached to secondary GPUs when first starting X after cold boots.
    * Fixed a problem that could result in temporary stalls when moving OpenGL application windows on GeForce 8 and later GPUs.
    * Fixed a bug that prevented VGA fonts from being saved/restored correctly on GeForce 8 and later GPUs.

Marc Deslauriers (mdeslaur) wrote :

As mentioned in the release notes, this version fixes an issue where using the NVIDIA driver currently in Jaunty on a Fujitsu Celsius H270 netbook will result in a corrupt EDID, which will persist across reboots.

See: http://www.nvnews.net/vbulletin/showthread.php?t=131849

Philip Wyett (philwyett) wrote :

Alex,

Please look at https://wiki.ubuntu.com/StableReleaseUpdates process for how to push this for a possible update.

Alex Murray (alexmurray) wrote :

Thanks Philip. As Marc mentioned above, this is a killer bug for anyone with a Fujitsu Celsius H270 netbook, so for anyone who happens to install Jaunty on one of these machines and enables the restricted nvidia driver, their machine will be bricked. Given this I think this is definitely a good reason to push for an SRU.

I'll see about producing a patch to update the current package for Jaunty.

Unfortunately, I can't really fulfill the other requirements of testing it in the current development release of Ubuntu etc since at the moment there is no development release (given Jaunty was just released).

Other than a patch against the current 180.44 package in Jaunty I can't really do much else from what I can see, but am happy to do anything else you can suggest to try and get the SRU done.

Changed in nvidia-graphics-drivers-180 (Ubuntu):
assignee: nobody → albertomilone
importance: Undecided → Medium
milestone: none → jaunty-updates
status: New → In Progress
Alberto Milone (albertomilone) wrote :

I have modified the title of the bug report since having driver 180.53 would fix bug 353502 too.

summary: - Stable NVIDIA driver 180.51 released - please upgrade in Jaunty
+ Stable NVIDIA driver 180.53 released - please upgrade in Jaunty
Colin Watson (cjwatson) on 2009-04-24
Changed in nvidia-graphics-drivers-180 (Ubuntu Jaunty):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → Medium
milestone: none → jaunty-updates
status: New → In Progress
Changed in nvidia-graphics-drivers-180 (Ubuntu Karmic):
milestone: jaunty-updates → none
Alberto Milone (albertomilone) wrote :

The new driver is available in this PPA:
https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

mercutio22 (macabro22) wrote :

Hello Alberto,

I would like to call to your attention that using 180.53 drivers in SLI mode seems to slow down my system and cause kernel panics.

It works fine out of SLI mode.

I will send any more detailed info you may want to request.

Cheers.

That's probably why they still have 180.51 listed as the current stable version.

It looks like 185.18.14 is the release candidate now, and also fixes bug 353502.

It seems that the current driver has been updated to 180.60. I presume that this version is newer than 180.53, so can it be assumed that this bug is either invalid or fix released?

Hew (hew) on 2009-06-14
Changed in nvidia-graphics-drivers-180 (Ubuntu Karmic):
assignee: Alberto Milone (albertomilone) → nobody
status: In Progress → Fix Released

really unfortunate that such essential user-experience updates such as updates to the graphics driver don't come timely through ubuntu's update mechanism repositories. That's really unfortunate

Is this still in progress in Jaunty?

Hew (hew) wrote :

At this point in time, it's very unlikely this update will be applied to Jaunty.

Changed in nvidia-graphics-drivers-180 (Ubuntu Jaunty):
assignee: Alberto Milone (albertomilone) → nobody
milestone: jaunty-updates → none
status: In Progress → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers