nvidia-settings is crashing while setting up "Clones"

Bug #364302 reported by Artur Rona on 2009-04-20
2
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-180 (Ubuntu)
Undecided
Unassigned
nvidia-settings (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: nvidia-settings

I have connected both LCD on D-Sub (native 1440x900) and TV (native 1280x768). I want to get different resolutions on displays in this form:
- one common desktop
- separate resolution for LCD 1440x900
- separate resolution for TV 1280x768
When I get Clones for TV, nvidia-settings is going down. There's a gdb:
$ gdb nvidia-settings
GNU gdb 6.8-debian
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu"...
(no debugging symbols found)
(gdb) run
Starting program: /usr/bin/nvidia-settings
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0xb743f710 (LWP 13212)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb743f710 (LWP 13212)]
0x080890cb in ?? ()
(gdb) quit

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: nvidia-settings 180.25-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
SourcePackage: nvidia-settings
Uname: Linux 2.6.28.7 i686

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub [8086:2770] (rev 02)
     Subsystem: Giga-byte Technology Device [1458:5000]
01:00.0 VGA compatible controller [0300]: nVidia Corporation G70 [GeForce 7300 GT] [10de:0393] (rev a1)
     Subsystem: Giga-byte Technology Device [1458:e000]

Artur Rona (ari-tczew) wrote :
Bryce Harrington (bryce) wrote :

Hi ari-tczew,

Thanks for including an image to demonstrate the issue. Could you also please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log or Xorg.0.log.old file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: crash
tags: added: needs-xorglog
Changed in nvidia-settings (Ubuntu):
status: New → Incomplete
Artur Rona (ari-tczew) wrote :
Artur Rona (ari-tczew) wrote :
Artur Rona (ari-tczew) wrote :
Bryce Harrington (bryce) on 2009-04-21
description: updated
Bryce Harrington (bryce) on 2009-04-28
Changed in nvidia-settings (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) on 2009-04-28
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

I've posted a new version of the -nvidia driver to our xorg-edgers PPA,
would you mind testing it either on Jaunty or Karmic and see if it
resolves this bug?

Get nvidia-graphics-drivers-180 - 185.18.14 here:

  https://edge.launchpad.net/~xorg-edgers/+archive/ppa

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Confirmed → New
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Invalid
Artur Rona (ari-tczew) wrote :

In karmic with nvidia-glx0185 185.18.36-0ubuntu2 this bug is no exist.

Changed in nvidia-settings (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers