Ubuntu

OpenGL/GLX not working

Reported by Graham Inggs on 2009-04-03
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-180 (Ubuntu)
Undecided
Unassigned

Bug Description

After Intrepid to Jaunty upgrade, then activating hardware drivers, choosing OpenGL/GLX Information in nvidia-settings give "Fail to query the GLX server vendor".
I noticed a broken softlink at /usr/lib/nvidia/libGL.so.1.xlibmesa -> libGL.so.1.
There is no libGL.so.1 in /usr/lib/nvidia, but there is one in /usr/lib.

Running glxinfo gives the following, followed by a segmentation fault:
$ glxinfo
name of display: :0.0
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig

<many repeated lines of: Xlib: extension "GLX" missing on display ":0.0". >
84 GLXFBConfigs:
   visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
 id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
Segmentation fault (core dumped)

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation 82Q963/Q965 Memory Controller Hub [8086:2990] (rev 02)
     Subsystem: Intel Corporation Device [8086:4f43]
01:00.0 VGA compatible controller [0300]: nVidia Corporation GeForce 8500 GT [10de:0421] (rev a1)
     Subsystem: Micro-Star International Co., Ltd. Device [1462:0960]

Bryce Harrington (bryce) wrote :

Hi graham-nerve,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: needs-xorglog
tags: added: needs-lspci-vvnn
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: New → Incomplete
Graham Inggs (ginggs) wrote :
Graham Inggs (ginggs) wrote :
Graham Inggs (ginggs) wrote :

Thanks Bryce, after looking through /var/log/Xorg.0.log I noticed that the softlink /usr/lib/xorg/modules/libglx.so didn't get upgraded.

The following got glxinfo working again:

sudo rm /usr/lib/xorg/modules/libglx.so
sudo ln -s /usr/lib/xorg/modules/extensions/libglx.so.180.44 /usr/lib/xorg/modules/libglx.so

I still have I noticed the broken softlink at /usr/lib/nvidia/libGL.so.1.xlibmesa though, not sure what the correct target is.

Bryce Harrington (bryce) on 2009-04-21
description: updated
jordis (serratosa) wrote :

Hi I had the same exact problem as Graham described after and Intrepid to Jaunty upgrade.
I say in /var/log/Xorg.0.log:
(EE) NVIDIA(0): Version mismatch detected between the NVIDIA X driver and the
(EE) NVIDIA(0): NVIDIA GLX module. X driver version: 180.44; GLX module
(EE) NVIDIA(0): version: 1.0-9639. Please try reinstalling the NVIDIA
(EE) NVIDIA(0): driver.

Graham suggestion to recreate the link worked beautifully!

kaydub (kevwilliams) wrote :

After doing the intrepid to jaunty upgrade I restarted the system to not have desktop effects enabled and was unable to enable it. >> compiz --replace would resolve in a window system with no title bars or ability to move windows, Metacity worked perfectly. After hunting around for hours and upgrading the nvidia drivers to 185.18.04 from TheFirstM https://launchpad.net/~thefirstm/+archive/ppa to still no resolution I used apport to auto generate the trace and stumbled across this bug in the process.

I didnt necessarily have to upgrade the drivers as the problem was the same as above where the symlink at /usr/lib/xorg/modules/extensions/libglx.so was succesfully changed during the upgrade. But the symlink at /usr/lib/xorg/modules/libglx.so was not changed and still referenced the old file. Whether or not this file is required I am uncertain at this stage but after replacing the deadlink with the correct one and rebooting the system everything works perfectly.

The target I used for the symlink is /usr/lib/xorg/modules/extensions/libglx.so.185.18.04

Bryce Harrington (bryce) on 2009-04-28
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Confirmed
damien_d (d-dusha) wrote :

I'm hoping to add signal rather than noise to this, but I have symptoms that look largely the same to this bug.

However, my story is a little different: I attempted to manually upgrade to the 185 driver directly from NVIDIA (the goal was CUDA 2.2), but it went belly-up so I have reverted back to 180 and my original xorg.conf file, which has worked since 8.04 (there may have been minor tweaks since).

There is indeed a broken link in /usr/lib/nvidia:
damien@damien-desktop:~$ ls -lah /usr/lib/nvidia/
total 288K
drwxr-xr-x 2 root root 4.0K 2009-06-09 16:56 .
drwxr-xr-x 235 root root 128K 2009-06-09 16:56 ..
lrwxrwxrwx 1 root root 18 2009-06-09 13:34 libGL.so.1.xlibmesa -> libGL.so.185.18.08 # <= BROKEN
-rw-r--r-- 1 root root 129K 2009-04-03 05:13 libnvidia-cfg.so.180.44
-rwxr-xr-x 1 root root 5.0K 2009-04-03 05:13 tls_test
-rw-r--r-- 1 root root 4.9K 2009-04-03 05:13 tls_test_dso.so

And no symlink at all in /usr/lib/xorg/modules:

damien@damien-desktop:~$ ls -lah /usr/lib/xorg/modules/
total 1.1M
drwxr-xr-x 7 root root 4.0K 2009-04-27 11:41 .
drwxr-xr-x 3 root root 4.0K 2009-04-27 11:41 ..
drwxr-xr-x 2 root root 4.0K 2009-06-09 16:56 drivers
drwxr-xr-x 2 root root 4.0K 2009-06-09 16:56 extensions
drwxr-xr-x 2 root root 4.0K 2009-04-27 11:41 input
-rw-r--r-- 1 root root 71K 2009-04-09 12:16 libexa.so
-rw-r--r-- 1 root root 131K 2009-04-09 12:16 libfb.so
-rw-r--r-- 1 root root 147K 2009-04-09 12:16 libint10.so
-rw-r--r-- 1 root root 31K 2009-04-09 12:16 libshadowfb.so
-rw-r--r-- 1 root root 27K 2009-04-09 12:16 libshadow.so
-rw-r--r-- 1 root root 27K 2009-04-09 12:16 libvbe.so
-rw-r--r-- 1 root root 27K 2009-04-09 12:16 libvgahw.so
-rw-r--r-- 1 root root 171K 2009-04-09 12:16 libwfb.so
-rw-r--r-- 1 root root 384K 2009-04-09 12:16 libxaa.so
-rw-r--r-- 1 root root 6.1K 2009-04-09 12:16 libxf8_16bpp.so
drwxr-xr-x 2 root root 4.0K 2009-04-27 11:41 linux
drwxr-xr-x 2 root root 4.0K 2009-04-27 11:41 multimedia

Please let me know if you want me to attach any logs.

damien_d (d-dusha) wrote :

I might also add that downgrading to 177 then upgrading back to 180 does _not_ solve the issue, and demonstrates the same symptoms as before.

kaydub (kevwilliams) wrote :

I also have the /usr/lib/nvidia/libGL.so.1.xlibmesa broken symlink, I dont believe that is the issue.

What does /usr/lib/xorg/modules/extensions look like? Does it have libglx.so.<version#>???

My system has 2 symlinks.
1. /usr/lib/xorg/modules/extensions/libglx.so -> libglx.so.185.18.14
2. /usr/lib/xorg/modules/libglx.so -> /usr/lib/xorg/modules/extensions/libglx.so

The 1st symlink is in /usr/lib/xorg/modules/extensions/ and links directly to the libglx.so.<version#> in the same folder.

The 2nd symlink is in /usr/lib/xorg/modules/ and links to the 1st symlink.

This is what got my system going. Hope it helps.

Bryce Harrington (bryce) wrote :

I've posted a new version of the -nvidia driver to our xorg-edgers PPA,
would you mind testing it either on Jaunty or Karmic and see if it
resolves this bug?

Get nvidia-graphics-drivers-180 - 185.18.14 here:

  https://edge.launchpad.net/~xorg-edgers/+archive/ppa

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Confirmed → New
status: New → Incomplete
Opti2009 (oddbjorn-hansen) wrote :

"nvidia-graphics-drivers-180 - 185.18.14" works perfectly for me on Jaunty (amd64). Thanks!

Bryce Harrington (bryce) wrote :

Thanks for letting us know the issue is solved with the newer driver. We've got that in karmic now, so we can close this bug now.

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Fix Released
Graham Inggs (ginggs) wrote :

I've just encountered this same problem after upgrading from jaunty to karmic.

/usr/lib/xorg/modules/libglx.so was left pointing at a non-existent /usr/lib/xorg/modules/extensions/libglx.so.180.44

As before the fix was:
sudo rm /usr/lib/xorg/modules/libglx.so
sudo ln -s /usr/lib/xorg/modules/extensions/libglx.so.185.18.36 /usr/lib/xorg/modules/libglx.so

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers