system freezes with nvidia 180.37 driver

Bug #353502 reported by Matt Clarkson on 2009-04-02
42
This bug affects 5 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-180 (Ubuntu)
Medium
Alberto Milone

Bug Description

After a few minutes of booting into x the system will completely lock up. The only thing I have found to work around the problem is booting with the maxcpus=1 parameter.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: nvidia-glx-180 180.37-0ubuntu2
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_NZ.UTF-8
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #38-Ubuntu SMP Fri Mar 27 09:00:52 UTC 2009
SourcePackage: nvidia-graphics-drivers-180
Uname: Linux 2.6.28-11-generic i686

[lspci]
00:00.0 RAM memory [0500]: nVidia Corporation MCP55 Memory Controller [10de:0369] (rev a1)
     Subsystem: Micro-Star International Co., Ltd. Device [1462:7260]
06:00.0 VGA compatible controller [0300]: nVidia Corporation G72 [GeForce 7300 LE] [10de:01d1] (rev a1)

Matt Clarkson (drmattoclarkson) wrote :
tags: added: jaunty
Bryce Harrington (bryce) wrote :

[This is an automated message]

In Jaunty (9.04), we have just updated to the latest
nvidia-graphics-drivers-180 package from nVidia, version 180.44.

This package provides fixes for a large number of bugs, and we need your
assistance in testing if it fixes the issue you reported.

To do this, please do the following:

 a. Update to the 180.44 version of -nvidia using your favorite update
     method

 b. Attempt to reproduce your bug

 c. If your bug still remains, please simply reply to this email
     indicating so.

 d. If your bug is now solved, you can help us by setting your bug
     report to Fix Released:
     * In launchpad, go to your bug report
     * Click on the downward pointing arrow under Status
     * Set the Status field to 'Fix Released'
     * Comment on the change, such as, 'Verified fixed in 180.44'
     * Click 'Save Changes'

 e. If the original problem is solved but there are now other problems,
     please close the original bug and open new ones for those issues.

Thank you!

For details on the changes in this version of -nvidia, please see:

   http://www.nvidia.com/object/linux_display_ia32_180.44.html

I have tested the 180.44 driver and the problem still exists.

2009/4/3 Bryce Harrington <email address hidden>

>
> [This is an automated message]
>
> In Jaunty (9.04), we have just updated to the latest
> nvidia-graphics-drivers-180 package from nVidia, version 180.44.
>
> This package provides fixes for a large number of bugs, and we need your
> assistance in testing if it fixes the issue you reported.
>
> To do this, please do the following:
>
> a. Update to the 180.44 version of -nvidia using your favorite update
> method
>
> b. Attempt to reproduce your bug
>
> c. If your bug still remains, please simply reply to this email
> indicating so.
>
> d. If your bug is now solved, you can help us by setting your bug
> report to Fix Released:
> * In launchpad, go to your bug report
> * Click on the downward pointing arrow under Status
> * Set the Status field to 'Fix Released'
> * Comment on the change, such as, 'Verified fixed in 180.44'
> * Click 'Save Changes'
>
> e. If the original problem is solved but there are now other problems,
> please close the original bug and open new ones for those issues.
>
> Thank you!
>
> For details on the changes in this version of -nvidia, please see:
>
> http://www.nvidia.com/object/linux_display_ia32_180.44.html
>
> --
> system freezes with nvidia 180.37 driver
> https://bugs.launchpad.net/bugs/353502
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “nvidia-graphics-drivers-180” source package in Ubuntu: New
>
> Bug description:
> After a few minutes of booting into x the system will completely lock up.
> The only thing I have found to work around the problem is booting with the
> maxcpus=1 parameter.
>
> ProblemType: Bug
> Architecture: i386
> DistroRelease: Ubuntu 9.04
> NonfreeKernelModules: nvidia
> Package: nvidia-glx-180 180.37-0ubuntu2
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_NZ.UTF-8
> SHELL=/bin/bash
> ProcVersion: Linux version 2.6.28-11-generic (buildd@palmer) (gcc version
> 4.3.3 (Ubuntu 4.3.3-5ubuntu4) ) #38-Ubuntu SMP Fri Mar 27 09:00:52 UTC 2009
> SourcePackage: nvidia-graphics-drivers-180
> Uname: Linux 2.6.28-11-generic i686
>

Bryce Harrington (bryce) on 2009-04-07
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: New → Confirmed
Dragoneyes (stiu) wrote :

I have the same problem whit the version of driver 180.40 in jaunty, my system randomly freeze. I tryed with the version 185.19, 180.29 and 180.16 of the nvidia proprietary drivers, but the problem still remain.
With Intrepid there were no problem with 180.16 and 180.29.
My nvidia card: 7300 LE

Bryce Harrington (bryce) on 2009-04-21
description: updated
xpot (xpot-uber) wrote :

Decided to add my experience with the same bug.

Running AMD64 Ubuntu 9.04

I went to nvidia's site and found a 180.51 that lists some fixes (some of which include the freezing) installed after some minor difficulties.

Everything seems alot more stable now. Have not experienced any freezing or halting or glitching after performing my normal steps in producing the symptoms with 180.44. I will keep you up to date if anything changes.

-=0)

Dragoneyes (stiu) wrote :

I'm using 180.51 version of the nvidia driver. Installed by "sudo sh nvidia.run", I had the following error: "error: unable to open '/usr/lib/xorg/modules/extensions/libglx.so' for reading (no souch file or directory)", but the installation succesfully complete. Now the sistem doesn't freeze any more. It freeze only when i go to "system - preferences - screensaver".

Dragoneyes (stiu) wrote :

I have to correct mysel: the problem still exist, there are random freeze also with 180.51 (however there are less freeze than 180.44).
Bye

xpot (xpot-uber) wrote :

Latest Report:

I concur with Dragoneyes! I too still get a freeze, although it is not as often as 180.44. My last freeze was while the system was idle and screen-saver was active.

Gung Shi Jie (ksc91u) wrote :

180.53 for Linux x86/x86-64 released
Release Highlights:

    * Fixed stability problems with some GeForce 6200/7200/7300 GPUs on multi-core/SMP systems.

I am trying right now.

xpot (xpot-uber) wrote :

Thank you for the update Gung Shi Jie:

Performed successful install of 180.53
Will provide an update in a few days to let you know if everything has stabilized with this new pre-release.

-=0)

xpot (xpot-uber) wrote :

Status Report:

Well, it has been about 5 hours and not a single hick-up! So far, so good. Screen savers seem to run smooth as well. If anything changes over the next few days I will pop in to provide an update. Until then I believe 180.53 is a pretty stable release.

-=0)

Changed in nvidia-graphics-drivers-180 (Ubuntu):
assignee: nobody → albertomilone
importance: Undecided → Medium
milestone: none → jaunty-updates
status: Confirmed → In Progress
Dragoneyes (stiu) wrote :

180.53 solved the problem: finally no more freeze.

xpot (xpot-uber) wrote :

Update:

I concur with Dragoneyes. 180.53 seems to be the best candidate. Now awaiting a fix for the vnc refresh issue -=0(

180.53 has fixed the problem for me.

Guillaume (guillaume-zin) wrote :

Hello,

I have far less freezes with 180.53, but still sometimes some troubles when closing KDE4.2.2 (jaunty 64) with compositing enabled, or for instance when editing colors with Inkscape. And sometimes, my WiFi connection seems to disconnect, it doesn't happen with nv or nouveau driver. I hope that Nvidia will release a less crapy driver.

Guillaume

boulder (boulder-get2net) wrote :

I also had a very unstable system upgrading from 8.10 -> 9.04 using Nvidia's 180.44
Switched to 180.53 and the system seems a lot more stable. Though I experience a hick up here and there.
Especially after suspend.

Ubuntu 9.04 AMD64 (SMP) Nvidia 180.53
1. Boot
2. login
3. suspend
4. start Command n' conquer 3 (wine 1.19)
5. screen just flashes the desktop ... no game (hard reset)

Ubuntu 9.04 AMD64 (SMP) Nvidia 180.53
1. Boot
2. login
3. suspend
4. start Command n' conquer 3 (wine 1.20)
5. screen just flashes the desktop ... no game (hard reset)

Ubuntu 9.04 AMD64 (SMP) Nvidia 180.53
1. Boot
2. login
4. start Command n' conquer 3 (wine 1.20)
5. Game runs but will most likely drop to desktop after 20 mins.

This was rock solid on 8.10 Nvidia 17x using win 1.19 I could play for hours.
Never used suspend on 8.10 as it was unable to "restart" the onboard network (NForce 590 sli)

Hardware:
AMD 5000+ (dual core)
3 GB RAM (ECC)
SLI Nvidia 8600 GTS (dual)
Nforce 590 sli chipset (Asus Crosshair)

Noel J. Bergman (noeljb) wrote :

FWIW, my system has been running (knock wood) for two days without a failure since May 2. That's a major improvement over recent experiences with Jaunty. I installed the 185.18.04 video driver, so that also seems to help.

boulder (boulder-get2net) wrote :

I tried the 185.18.04 and it seems more stable than 180.44
BUT ... the screen was constantly flickering during game play (Command n conquer 3)[Wine 1.20]
and it lasted about 5 min then it dropped to the desktop.
So I wont suggest this driver if you are a gamer :s

p.s
I get a minor and very strange screen tear's during gameplay in 9.04.

Noel J. Bergman (noeljb) wrote :

> FWIW, my system has been running (knock wood) for two days without a failure since May 2.

And froze this AM while it was ostensibly idle. I suppose 180.53 is worth a shot, but uncertain whether this is a driver issue or an X issue.

Jonas Petersson (catellie) wrote :

This thread was spot on for me. I have a (according to dmidecode) FUJITSU SIEMENS A8NE-FM minitower with a GeForce 7300 and since upgrading to Jaunty it has been haunted by random hangs.
I just installed 185.18.08 (had to clean out all old nvidia drivers from synaptics first) and although it's a bit early to tell if it is perfect I can certainly say it is significantly better.
One thing bugged me: In the past I've always experimented remotely from my laptop via ssh -X, but apparently this breaks the installation script sinc "X -showDefaultLibPath" will produce "X: warning; process set to priority -2 instead of requested priority 0" before the actual path. So, be sure to actually perform the installation from a text console.

Keep it up / Jonas

Guillaume (guillaume-zin) wrote :

Hello,

I have no more freeze (since a few days) with 180.53 driver and a new Intel Wireless WiFi Link 5100 driver that came with the jaynty-backports. I guess that the fault was more WiFi related.

Guillaume

boulder (boulder-get2net) wrote :

Hi

I've tried the new 180.60(beta) and its still unstable.
Nvidia seems to have bad support (or blame the problem) on SMP & SLI which I have.

So I tried using the kernel boot parameters pci=nommconf and noapic.
But its still unstable.

I'll try and bite the dust with maxcpus=1 :-(

hotani (hotani) wrote :

Isn't that a bit extreme? Why not roll back to 8.10, or roll your nvidia driver back to 180.11 (current working version in ubuntu 8.10)? There isn't any benefit in 9.04 that is worth these driver hassles. Until these video issues (ATI, intel, nvidia) get resolved I'm sticking with the older version. I just hope no one decides to "upgrade" the video drivers in 8.10.

Noel J. Bergman (noeljb) wrote :

> I just hope no one decides to "upgrade" the video drivers in 8.10.

As I've mentioned before, 8.10 does not exhibit these problems even with the newer drivers.

Jonas Petersson (catellie) wrote :

For the record: My system is still stable since the upgrade to 185.18.08 10 days ago. I'd highly recommend it to anyone experiencing a problem. BTW: my box has an AMD Athlon(tm) 64 X2 Dual Core Processor 4400+ and runs in 32 bit mode.
              / Jonas

hotani (hotani) wrote :

Thanks Jonas. I tried installing 9.04 with the 185.x driver yesterday and have had no lockups. Seems like a good solution.
Walkthru here: http://ubuntuforums.org/showthread.php?t=990978

boulder (boulder-get2net) wrote :

Ive tried the new 185.18.14 .. better than the 185.18.10 .. but still freezing after 10-15 min playing 3D games.
I tried, just for the heck of it, to set
Option "SLI" "False"
in the xorg.conf
And dang it ... it works ... so no amount of strange kernel boot parameters that Nvidia suggested worked.
But disabling SLI worked. If you can call it "work" when you lose 50% processing power.

So Ill guess Ill by an Radeon 4770 card ... to bad you Nvidia guys could'nt create a stable driver
for ubuntu 9.04 ... 8.10 was fine in SLI and dual core.

Noel J. Bergman (noeljb) wrote :

FWIW, I have been running Jaunty using 185.10.14 since Sunday without any freeze up. Lots of VMware usage, suspends, resumes, etc., and it is still going. That is sort of a new record for Jaunty since these problems started, so I am marginally hopeful.

I would certainly suggest that anyone who is still seeing problems try the newest nvidia driver (there are several PPAs that have it), and see if it helps.

Misha Koshelev (misha680) wrote :

Hi all I think I experience same problem with 185.18.14 on amd64 on Ubuntu Hardy 8.04. I see some interesting messages in syslog:
Xid (0001:00): 6, PE0001

Anyone else have these?

Thank you
Misha

Andreas Kielkopf (a-kielkopf) wrote :

Thank you all together for this Tip.

In the last 3 Month i only could work with maxcpus=1 or there would be a freeze in less then 10 Min

Now i installed 185.18.14 (amd64 with 4cores)

Since 3 Days i am now able to work with all off my 4 cores without any freeze

Andreas Kielkopf

Misha Koshelev (misha680) wrote :

Btw mine was a hardware issue. Dell replaced my motherboard and fans and no problems.

Thank you
Misha

Alberto Milone (albertomilone) wrote :

Driver 185.x will be uploaded to Karmic soon therefore the problem should be solved.

Changed in nvidia-graphics-drivers-180 (Ubuntu):
milestone: jaunty-updates → none
Alberto Milone (albertomilone) wrote :

Can anyone confirm that the problem is solved with the new driver in Karmic?

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: In Progress → Fix Committed
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers