Ubuntu

screensaver locks up X

Reported by earthforce_1 on 2009-03-05
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-180 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xorg

When the screensaver activates, the machine is unresponsive to keyboard or mouse and must be rebooted. Also, when the System->Preferences->Screensaver setup is activated, I can slide the "idle after:" bar with the mouse, but cannot click on anything else in the window. I can minimize/maximize the window normally, (there is a 1 second delay) but cannot click on any other buttons.

Additionally, after maximize/unmaximize all buttons and sliders are gone, except for the screensaver preview itself running in the "Screensaver Preferences" window. The "Close window" tooltip appears when I hover over the close, but the window refuses to close when I click on the "X". I can move the window normally, and all options work except for close. I am only able to terminate the "Screensaver Preferences" session by using the "Force misbehaving application to quit" app in the toolbar. I am up to date with all Jaunty patches so far.

lsb_release -rd
Description: Ubuntu jaunty (development branch)
Release: 9.04

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: xorg 1:7.4~5ubuntu13
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersion: Linux version 2.6.28-8-generic (buildd@yellow) (gcc version 4.3.3 (Ubuntu 4.3.3-3ubuntu5) ) #26-Ubuntu SMP Wed Feb 25 04:27:53 UTC 2009
SourcePackage: xorg
Uname: Linux 2.6.28-8-generic x86_64
Xrandr:

[lspci]
00:00.0 RAM memory [0500]: nVidia Corporation MCP78S [GeForce 8200] Memory Controller [10de:0754] (rev a2)
     Subsystem: Giga-byte Technology Device [1458:5001]
02:00.0 VGA compatible controller [0300]: nVidia Corporation GeForce 8200 [10de:0849] (rev a2)
     Subsystem: Giga-byte Technology Device [1458:d000]

earthforce_1 (earthforce1) wrote :
Bryce Harrington (bryce) on 2009-03-06
Changed in xorg:
status: New → Confirmed
aramil (starship-enterprise) wrote :

Bug still exists in Linux 2.6.28-9-generic x86_64

earthforce_1 (earthforce1) wrote :

Found something - the desktop had been randomly hanging every now and then so I tried uninstalling the NVidia version 180 closed source driver and the System->Preferences->Screensaver window now behaves normally. Unfortunately, the display is low resolution and looks crappy but if I have to, I will take this over the hang.

This is essentially the same root cause of another bug I filed where Evolution would hang on launch and sometimes corrupt the display. It also went away when I deleted the NVidia driver.
https://bugs.launchpad.net/ubuntu/+bug/333271

I am going to try with the older version 173 driver and see if it is as problematic. The version 180 driver is buggy to the point of being unusable.

earthforce_1 (earthforce1) wrote :

Works a lot better with the 173 version.

Bryce Harrington (bryce) on 2009-04-02
summary: - Jaunty screensaver locks up X, <CTL><ALT><BS> doesn't work
+ screensaver locks up X
Bryce Harrington (bryce) wrote :

[This is an automated message]

In Jaunty (9.04), we have just updated to the latest
nvidia-graphics-drivers-180 package from nVidia, version 180.44.

This package provides fixes for a large number of bugs, and we need your
assistance in testing if it fixes the issue you reported.

To do this, please do the following:

 a. Update to the 180.44 version of -nvidia using your favorite update
     method

 b. Attempt to reproduce your bug

 c. If your bug still remains, please simply reply to this email
     indicating so.

 d. If your bug is now solved, you can help us by setting your bug
     report to Fix Released:
     * In launchpad, go to your bug report
     * Click on the downward pointing arrow under Status
     * Set the Status field to 'Fix Released'
     * Comment on the change, such as, 'Verified fixed in 180.44'
     * Click 'Save Changes'

 e. If the original problem is solved but there are now other problems,
     please close the original bug and open new ones for those issues.

Thank you!

For details on the changes in this version of -nvidia, please see:

   http://www.nvidia.com/object/linux_display_ia32_180.44.html

earthforce_1 (earthforce1) wrote :

Seems to be fixed! Thank you, release date is getting close and I was getting worried this would be forgotten.

Bryce Harrington (bryce) on 2009-04-21
description: updated
Dan Simoes (dan-stumbleupon) wrote :

Bug is still present in 180.44 with stock 9.04 kernel 2.6.28-11-generic.
Display looks and works fine until screensaver activates and is active for more than 15-20 minutes (brief intervals like 1-2 mins seem to not trigger the problem). Screensaver is set to prompt for password, and it does, but after logging in, keyboard is unresponsive, CTRL-BACKSPACE fails and even CTRL-ALT-DEL fails to restart.

Bryce Harrington (bryce) wrote :

I've posted a new version of the -nvidia driver to our xorg-edgers PPA,
would you mind testing it either on Jaunty or Karmic and see if it
resolves this bug?

Get nvidia-graphics-drivers-180 - 185.18.14 here:

  https://edge.launchpad.net/~xorg-edgers/+archive/ppa

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Confirmed → New
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Invalid
Dan Simoes (dan-stumbleupon) wrote :

Using nvidia-graphics-drivers-180 - 185.18.14 under 9.04, the bug is still present.
The only way to get a usable desktop is to turn off all effects in Preferences/Appearance/Visual Effects (guessing this is compiz).

I will try upgrading to the latest development version of Ubuntu.

I updated my nvidia driver(s) as noted above and it seemed to work for a while ... then I discovered that if I left firefox running, it would lock up(!) - but only after the power management would idle the display - worked OK if screensaver running.
disabled display idle - no lockup
closed out of firefox - no lockup with idle display
Installed SeaMonkey yesterday - no lock ups since ... reenabled display idle
just a followup FYI
Thanks!

Dan Simoes (dan-stumbleupon) wrote :

Bug is still present under Karmic. Turning off visual effects as noted above works around the issue.
I'm also not convinced that this is only a screensaver bug - I've seen the same rendering issues when working with an unlocked screen. Please reopen.

Mike B. (mike-berggren) wrote :

I'm noticing the same issue with 10.04 AMD_64. The symptoms match Jim's description in comment #11.

I'm running an integrated GeForce 7025 and Nvidia 9400GT. Three monitors - three separate xscreens. Let me know what information would be useful to collect here.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers