nvidia twinview - dialogue centering and fullscreen media players

Bug #300870 reported by Druciferre
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-180 (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

I have nVidia TwinView setup under Ubuntu 8.10. My card is a 8500 GT from PNY. I have attached my xorg.conf. Most things tend to work as I would expect them to. For example when I maximise firefox it only takes up one monitor. However, some things are just minor but yet annoying. For example, when various dialogues come up like the gksu password prompt. It is centered between both monitors, as in half of the dialogue appears on one monitor and half on the other. The same can be said for various full screen media players like Adobe Flash. Also, OpenOffice Presentation. When viewing the slide show. I have attached screenshots so you can clearly see what I'm talking about. The red line indicates where the monitors are divided. Is there something I can do to fix this?

xorg.conf
http://dl.getdropbox.com/u/324709/TwinView/xorg.conf

lspci -vvnn
http://dl.getdropbox.com/u/324709/TwinView/lspci-vvnn.txt

Xorg.0.log
http://dl.getdropbox.com/u/324709/TwinView/Xorg.0.log

Xorg.0.log.old
http://dl.getdropbox.com/u/324709/TwinView/Xorg.0.log.old

OpenOffice.org Presentation
http://dl.getdropbox.com/u/324709/TwinView/Screenshot.png

YouTube Flash Player
http://dl.getdropbox.com/u/324709/TwinView/vlcsnap-2955947.png

gksu login prompt - my main concern as it is the most annoying
http://dl.getdropbox.com/u/324709/TwinView/vlcsnap-2956967.png

Revision history for this message
Noel J. Bergman (noeljb) wrote :

Drew,

Which version(s) of Ubuntu? Which version(s) of the nvidia driver?

I have used Intrepid (8.10) and OOov3 with the Sun presenter mode, and it works without the problem you see, although it does exhibit the problem of grabbing all workspaces instead of just the one it is on when it goes full-screen. I also do not reproduce the gksu problem you illustrate. Nor do I recall seeing these issues with Hardy (8.04) with OOoV2.4.

My system is a ThinkPad T61p 6457-7WU. I run the latest nvidia driver available for whichever release is in question.

Revision history for this message
Druciferre (drewchapin) wrote :

I had this problem with Ubuntu 8.04 (nvidia-glx-new) and currently with Ubuntu 8.10 (nvidia-glx-177).
I'm really more concerned with the problem illustrated by gksu. It's not just that particular dialogue though. It also occurs with the shutdown dialogue and various other things like Select Session in GDM. Also, the default GDM login themes are centered like that as well, however I managed to fix that by setting the position to 25% in the theme xml file as a opposed to 50%

Druciferre (drewchapin)
description: updated
Revision history for this message
Jonas Sundberg (jsund) wrote :

I'm having this problem as well. I'm running Ubuntu 8.10 with a 9600GT running TwinView on nvidia-glx-177. Fortunately, my left monitor is running 1920x1200 while my right monitor is running 1600x1200, so dialogues are displayed on the left monitor only. I also have the same issues with full screen.

Revision history for this message
Jaguar_fr (toolinux-ubuntu) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage.

I have classified this bug as a bug in nvidia-graphics-drivers-177,
this will subscribe the bug supervisor of this package to this bug.

For future reference you might be interested to know that a lot of applications have bug reporting functionality built in to them. This can be accessed via the Report a Problem option in the Help menu for the application with which you are having an issue. You can learn more about this feature at https://wiki.ubuntu.com/ReportingBugs.

Revision history for this message
Jonas Sundberg (jsund) wrote :

This is still a problem with the nVidia 180.11, 180.22, 180.27 and 180.29 drivers.

Revision history for this message
Bryce Harrington (bryce) wrote :

Hi druciferre,

Please attach the output of `lspci -vvnn`, and attach your /var/log/Xorg.0.log (and maybe Xorg.0.log.old) file from after reproducing this issue. If you've made any customizations to your /etc/X11/xorg.conf please attach that as well.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

Changed in nvidia-graphics-drivers-177:
status: New → Incomplete
Druciferre (drewchapin)
description: updated
Revision history for this message
Druciferre (drewchapin) wrote :

<Noel>, I see you mentioned that you are using a laptop, and used the word "workspaces." I want to verify that you understand I'm not talking about multiple workspaces, I'm talking about multiple displays, i.e. multiple monitors. The red line in the images I have provided indicates the left and right monitor, not workspaces.

Revision history for this message
Noel J. Bergman (noeljb) wrote :

Drew,

I understood. A cool thing about laptops these days is that we can, in fact, have multiple displays. ;-) This comes in very handy on the road, when I am using OOov3 for presentations, with the console on my LCD and the slides on the projector. I just don't see the problem that you reported, either with OOov3 or when connecting my laptop to a TV via HDMI or S-Video to watch videos. I reproduce a different one, which I have reported on the OOo tracker, that the Presenter mode takes over all workspaces.

Revision history for this message
Druciferre (drewchapin) wrote :

I merely wanted to make sure you were attaching another monitor to it. I'm very well aware that you can attach a secondary monitor to a laptop. This is not a new concept. Laptops have done this virtually since they came out. It's merely that you used the word "workspaces" which is a virtual concept and has nothing to do with the bug I posted. You didn't go into much detail about your setup, so I wanted to make sure.

Can you tell us more about your setup? Such as the driver versions that you use, and your screen resolutions. Possibly post a copy of your xorg.conf?

Revision history for this message
Bryce Harrington (bryce) wrote :

[This is an automated message]

In Jaunty (9.04), we have just updated to the latest
nvidia-graphics-drivers-180 package from nVidia, version 180.44.

This package provides fixes for a large number of bugs, and we need your
assistance in testing if it fixes the issue you reported.

To do this, please do the following:

 a. Update to the 180.44 version of -nvidia using your favorite update
     method

 b. Attempt to reproduce your bug

 c. If your bug still remains, please simply reply to this email
     indicating so.

 d. If your bug is now solved, you can help us by setting your bug
     report to Fix Released:
     * In launchpad, go to your bug report
     * Click on the downward pointing arrow under Status
     * Set the Status field to 'Fix Released'
     * Comment on the change, such as, 'Verified fixed in 180.44'
     * Click 'Save Changes'

 e. If the original problem is solved but there are now other problems,
     please close the original bug and open new ones for those issues.

Thank you!

For details on the changes in this version of -nvidia, please see:

   http://www.nvidia.com/object/linux_display_ia32_180.44.html

Revision history for this message
Druciferre (drewchapin) wrote : Re: [Bug 300870] Re: nvidia twinview - dialogue centering and fullscreen media players
Download full text (3.5 KiB)

I am unable to install the nVidia 180.44 driver. There is no package in the
64bit repository for Intrepid Ibex, and the download page you linked to only
contains a .run for x86 32bit systems. If you can point me to a 64 bit
version of the driver, I'll be happy to test it for you.

Output of *uname -a *
*Linux anubis 2.6.27-11-generic #1 SMP Thu Jan 29 19:28:32 UTC 2009 x86_64
GNU/Linux*

Also, I'm not entirely convinced that this is a bug with the nvidia driver.
I believe it is simply something with the window manager.

- Drew Chapin

On Thu, Apr 2, 2009 at 15:53, Bryce Harrington <email address hidden>wrote:

>
> [This is an automated message]
>
> In Jaunty (9.04), we have just updated to the latest
> nvidia-graphics-drivers-180 package from nVidia, version 180.44.
>
> This package provides fixes for a large number of bugs, and we need your
> assistance in testing if it fixes the issue you reported.
>
> To do this, please do the following:
>
> a. Update to the 180.44 version of -nvidia using your favorite update
> method
>
> b. Attempt to reproduce your bug
>
> c. If your bug still remains, please simply reply to this email
> indicating so.
>
> d. If your bug is now solved, you can help us by setting your bug
> report to Fix Released:
> * In launchpad, go to your bug report
> * Click on the downward pointing arrow under Status
> * Set the Status field to 'Fix Released'
> * Comment on the change, such as, 'Verified fixed in 180.44'
> * Click 'Save Changes'
>
> e. If the original problem is solved but there are now other problems,
> please close the original bug and open new ones for those issues.
>
> Thank you!
>
> For details on the changes in this version of -nvidia, please see:
>
> http://www.nvidia.com/object/linux_display_ia32_180.44.html
>
> --
> nvidia twinview - dialogue centering and fullscreen media players
> https://bugs.launchpad.net/bugs/300870
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “nvidia-graphics-drivers-180” source package in Ubuntu:
> Incomplete
>
> Bug description:
> I have nVidia TwinView setup under Ubuntu 8.10. My card is a 8500 GT from
> PNY. I have attached my xorg.conf. Most things tend to work as I would
> expect them to. For example when I maximise firefox it only takes up one
> monitor. However, some things are just minor but yet annoying. For example,
> when various dialogues come up like the gksu password prompt. It is centered
> between both monitors, as in half of the dialogue appears on one monitor and
> half on the other. The same can be said for various full screen media
> players like Adobe Flash. Also, OpenOffice Presentation. When viewing the
> slide show. I have attached screenshots so you can clearly see what I'm
> talking about. The red line indicates where the monitors are divided. Is
> there something I can do to fix this?
>
> xorg.conf
> http://dl.getdropbox.com/u/324709/TwinView/xorg.conf
>
> lspci -vvnn
> http://dl.getdropbox.com/u/324709/TwinView/lspci-vvnn.txt
>
> Xorg.0.log
> http://dl.getdropbox.com/u/324709/TwinView/Xorg.0.log
>
> Xorg.0.log.old
> http://dl.getdropbox.com/u/3247...

Read more...

Revision history for this message
Jonas Sundberg (jsund) wrote :

Drew, the driver is available for download here: http://www.nvidia.com/object/linux_display_amd64_180.44.html

I have tried the driver and I am still having the same problems. I am not using that computer at the moment though, so I am unable to provide information about my system.

Bryce Harrington (bryce)
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Druciferre (drewchapin) wrote :

Unfortunately, I am unable to install the latest driver. The script requires you to terminate any running Xorg sessions, and I am unable to do so due to another bug. When I try to open another TTY (CTRL+ALT+F1 - CTRL+ALT+F6) I only see a blinking cursor, and the script doesn't like being run in init level 1-2 either... I will have to resolve this first, and will post my finding at a later time.

(I recall seeing this bug report somewhere else, no I'm not posting it)

Revision history for this message
Jonas Sundberg (jsund) wrote :

Drew, I had the same troubles, but managed to install the driver by remotely connecting to my computer using SSH and installing the driver from my laptop. I don't know if you have access to another computer, but if you have it might be worth a try.

Revision history for this message
nubix (mseiz) wrote :

Hi, I have a similar problem in case you need some more testing..

but so far I only experience it with swiss tv flash movies (when going full screen) & open office 3.0 loading splash.
here you can find the swiss tv channel: http://www.sf.tv/sendungen/tagesschau/index.php

I run it on a lenovo T61p, ubuntu 9.04. cheers

Revision history for this message
Druciferre (drewchapin) wrote :

Are all of you out there having this problem experiencing it while running Compiz Fusion? I managed to accidentally crash Compiz and noticed that the positioning of windows when popping up were different when resorting back to Metacity. This got me thinking. So I started up ffmpeg and recorded my desktop while I played around with some stuff.

When Compiz is NOT running, and I full-screen a Youtube video, it displays across both monitors like so (to be honest, I'd rather it do this then what it is doing, at least I could actually see everything):
http://dl.getdropbox.com/u/324709/vlcsnap-10010194.png

When Compiz IS running, it is giving me the same problem I demonstrated earlier:
http://dl.getdropbox.com/u/324709/vlcsnap-10010295.png

(if needed I can post the recorded video)

My package details for Compiz are as follows:

Package: compiz
Priority: optional
Section: x11
Installed-Size: 68
Maintainer: Ubuntu MOTU Developers <email address hidden>
Original-Maintainer: Debian X Strike Force <email address hidden>
Architecture: all
Version: 1:0.7.8-0ubuntu4.1
...

Any new insights?

Revision history for this message
nubix (mseiz) wrote :

in my case (swiss tv flash movie) shutting down compiz doesn't make a difference. my left (external) screen displays left 50% black and on the right 50% I see the left half of the movie. on the other (laptop) screen I see my desktop and open windows. - but I might have a different problem as with youtube I don't have the issue: it goes full screen correctly (although always on the external screen independent of where I place the browser).

btw: for open office loading splash the problem is different. I see it centered between the screens - but it appears on both screens.

Revision history for this message
malteof (malteof-kth) wrote :

I can confirm, using Compiz, Twinview and trying to watch a fullscreen youtube video that only half the full screen is visible. Exactly like in http://dl.getdropbox.com/u/324709/TwinView/vlcsnap-2955947.png

/Malte

Revision history for this message
Druciferre (drewchapin) wrote :

I have discovered something. This seems to be directly related to the fact that I have three displays. If I only use two displays in TwinView on the same GPU everything works as expected (videos play only on one monitor, also AWN and Gnome-Panels are centered on the individual monitors).... When add an additional GPU and use a third monitor as a seperate X screen, this is when the problem becomes apparent. Also, this is related to the unusable TTYs. When using three displays, they don't work, when using just the two, they work.

So, for now it's live without the third display, or live with the mildly annoying problems...

To further clarify my setup...

$ lspci | grep VGA
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8500 GT (rev a1)
04:00.0 VGA compatible controller: nVidia Corporation GeForce 8400 GS (rev a1)

Two Acer 17" monitors are attached to the 8500 and setup using TwinView
Television is attached to the 8400 via s-video, and setup as a seperate X screen.

Revision history for this message
Bryce Harrington (bryce) wrote :

I've posted a new version of the -nvidia driver to our xorg-edgers PPA,
would you mind testing it either on Jaunty or Karmic and see if it
resolves this bug?

Get nvidia-graphics-drivers-180 - 185.18.14 here:

  https://edge.launchpad.net/~xorg-edgers/+archive/ppa

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Confirmed → New
status: New → Incomplete
Revision history for this message
nubix (mseiz) wrote :

as previously stated, I have reason to believe that I have a different problem. anyway:
I installed the 6 .deb's for i386 and NVIDIA X Server Settings now states Driver Version 185.18.14.
no change on the two issues I have.

Revision history for this message
nubix (mseiz) wrote :

not sure if it's related to this driver update - but today I noticed that I cannot use print screen anymore. "Alt"+"PrtSc" opens the print screen dialog normally, but the actual print screen only shows the mouse icon - otherwise it is just black.

Revision history for this message
Druciferre (drewchapin) wrote :

nubix, I would say that your issue is related to a different bug. I tested ALT+PrtScr on my machine and did experience this problem. It functioned as expected.

Revision history for this message
nubix (mseiz) wrote :

more information about the bug I reported in post #22: in my normal work environment the problem doesn't exist - but it happens when I boot the computer without it being connected to the external screen. the desktop still appears to be set two screens wide, but not for everything... for example saving something to the desktop - the icon goes to the invisible part of the desktop (left, external screen - if it would be connected) I can only see it after re-booting with the external screen. on the other hand windows cannot be moved or expanded into that area when the external screen is not connected. and as mentioned in post #22 screenshots (better name could be "window-shots") don't work properly when the computer was booted without the external screen being connected.

Revision history for this message
nubix (mseiz) wrote :

good news: as I suspected the swiss tv problem is not connected to this issue. swiss tv launched a new video portal today and now the problem I experienced is gone (nothing else changed since yesterday..).

but open office splash screen problem and screenshot problem remain.

Revision history for this message
Druciferre (drewchapin) wrote :

Bryce,

I still have this issue but haven't checked on the bug report status in a long time... I will make an image of my hard drive and then install the packages from your PPA.

Revision history for this message
Druciferre (drewchapin) wrote :

Bryce,

I can't seem to add your PPA key.

$ sudo add-apt-repository ppa:xorg-edgers/ppa
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv 165D673674A995B3E64BF0CF4F191A5A8844C542
gpg: requesting key 8844C542 from hkp server keyserver.ubuntu.com
gpgkeys: HTTP fetch error 7: couldn't connect to host
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 8844C542
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv-keys 8844C542
gpg: requesting key 8844C542 from hkp server keyserver.ubuntu.com
gpgkeys: HTTP fetch error 7: couldn't connect to host
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

$ ping -c4 keyserver.ubuntu.com
PING keyserver.ubuntu.com (91.189.89.31) 56(84) bytes of data.
64 bytes from barbadine.canonical.com (91.189.89.31): icmp_seq=1 ttl=43 time=134 ms
64 bytes from barbadine.canonical.com (91.189.89.31): icmp_seq=2 ttl=43 time=136 ms
64 bytes from barbadine.canonical.com (91.189.89.31): icmp_seq=3 ttl=43 time=130 ms
64 bytes from barbadine.canonical.com (91.189.89.31): icmp_seq=4 ttl=43 time=132 ms

--- keyserver.ubuntu.com ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 2999ms
rtt min/avg/max/mdev = 130.590/133.450/136.079/2.035 ms

Revision history for this message
Druciferre (drewchapin) wrote :

I installed the packages from the PPA, rebooted, and it made no difference...

$ apt-cache policy xserver-common
xserver-common:
  Installed: 2:1.6.5+git20091107+server-1.6-branch.2dbcb06a-0ubuntu0sarvatt~karmic
  Candidate: 2:1.6.5+git20091107+server-1.6-branch.2dbcb06a-0ubuntu0sarvatt~karmic
  Version table:
 *** 2:1.6.5+git20091107+server-1.6-branch.2dbcb06a-0ubuntu0sarvatt~karmic 0
        500 http://ppa.launchpad.net karmic/main Packages
        100 /var/lib/dpkg/status
     2:1.6.4-2ubuntu4.1 0
        500 http://security.ubuntu.com karmic-security/main Packages
     2:1.6.4-2ubuntu4 0
        500 http://us.archive.ubuntu.com karmic/main Packages

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers