Look into feasibility of using an alternatives system rather than diversions

Bug #258038 reported by Mario Limonciello
26
This bug affects 2 people
Affects Status Importance Assigned to Milestone
fglrx-installer (Ubuntu)
Fix Released
Wishlist
Alberto Milone
Lucid
Fix Released
Wishlist
Alberto Milone
mesa (Ubuntu)
Fix Released
Wishlist
Alberto Milone
Lucid
Fix Released
Wishlist
Alberto Milone
nvidia-graphics-drivers-173 (Ubuntu)
Fix Released
Wishlist
Alberto Milone
Lucid
Fix Released
Wishlist
Alberto Milone
nvidia-graphics-drivers-180 (Ubuntu)
Invalid
Wishlist
Mario Limonciello
Lucid
Invalid
Wishlist
Mario Limonciello
nvidia-graphics-drivers-71 (Ubuntu)
Invalid
Wishlist
Unassigned
Lucid
Invalid
Wishlist
Unassigned
nvidia-graphics-drivers-96 (Ubuntu)
Fix Released
Wishlist
enrico
Lucid
Fix Released
Wishlist
Alberto Milone
xorg-server (Ubuntu)
Invalid
Wishlist
Alberto Milone
Lucid
Invalid
Wishlist
Alberto Milone

Bug Description

This bug is for a concept idea to see if using an alternatives system for all OpenGL libraries provides by binary drivers will be more maintainable than the messy diversions currently in place.

Advantages:
  * Driver's don't need to conflicts/replaces each other (future proofed for later versions of the driver)
  * Less maintenance required when diversions break and need to be added

Disadvantages:
  * Extra symlinks part of a bunch of core packages

Changed in xorg-server:
assignee: nobody → superm1
Changed in mesa:
assignee: nobody → superm1
Changed in fglrx-installer:
assignee: nobody → superm1
Changed in nvidia-graphics-drivers-177:
assignee: nobody → superm1
Revision history for this message
Mario Limonciello (superm1) wrote :
Revision history for this message
Bryce Harrington (bryce) wrote :

Good day Mario,

I've just uploaded a new 8.543 version of -fglrx to Intrepid which now should work with xserver 1.5. Would you mind testing this new version and reporting back whether this issue is still present? If it is, it would be helpful if you could (re-)post your Xorg.0.log from running with this version. Thanks ahead of time.

If you don't have Intrepid installed on your system, you can test this by booting an Intrepid LiveCD (available from cdimage.ubuntu.com), using either the -vesa or -ati driver, then update to the latest version of Ubuntu, install fglrx, and then logout and back in. Your /var/log/Xorg.0.log will confirm whether you've loaded FGLRX successfully.

If you find any new issues, please report them as separate bugs. You can use the tool `ubuntu-bug fglrx-installer` which will gather the necessary files and create the launchpad report for you to fill in more easily.

Changed in fglrx-installer:
status: New → Incomplete
Revision history for this message
Bryce Harrington (bryce) wrote :

Nevermind the last comment. :-)

Changed in fglrx-installer:
importance: Undecided → Wishlist
status: Incomplete → Confirmed
Revision history for this message
Eitan Isaacson (eeejay) wrote :

Might I add the use-cae of switchable graphics.
I have a Thinkpad T400 with both Intel and Radeon chipsets.
An alternatives system will allow easy alternating between chipsets.

Revision history for this message
Alexander Rødseth (alexanro) wrote :

I have an ancient laptop where, of all things, the 3D-part of the graphics card is broken. No really, it's a hardware defect.
Being able to have a system with alternatives would be great as I could continue to use the 2D-driver, but always use software OpenGL instead of it being broken. (Even though it's currently a printer-server for the wireless network)...

Bryce Harrington (bryce)
Changed in fglrx-installer:
status: Confirmed → Triaged
Changed in mesa:
importance: Undecided → Wishlist
status: New → Triaged
Changed in nvidia-graphics-drivers-173:
importance: Undecided → Wishlist
status: New → Triaged
Changed in nvidia-graphics-drivers-177:
importance: Undecided → Wishlist
status: New → Triaged
Changed in nvidia-graphics-drivers-71:
importance: Undecided → Wishlist
status: New → Triaged
Changed in nvidia-graphics-drivers-96:
importance: Undecided → Wishlist
status: New → Triaged
Bryce Harrington (bryce)
Changed in xorg-server:
importance: Undecided → Wishlist
status: New → Confirmed
Bryce Harrington (bryce)
Changed in nvidia-graphics-drivers-177:
status: Triaged → Invalid
Bryce Harrington (bryce)
Changed in xorg-server:
status: Confirmed → Triaged
Revision history for this message
Bryce Harrington (bryce) wrote :

Looking forward a few months, I'd like to not have this bug open after Lucid. I think we need to come to a decision on it and either implement it for the LTS, or else decide to stay with the current system and close this bug.

This would be a pretty significant change, so might be a bit ambitious for an LTS (really, I guess we should have done it in karmic, but way too late now) but the benefit in terms of making it easier for users to switch between drivers could well be worth it. I think doing this post-LL would be detrimental since it would inhibit being able to backport patches, drivers, etc. to the LTS, so if we do not implement it for LL I think we should just decide not to do it (at least, not until the next LTS-1).

I'm not 100% certain how to undertake this change, as it is a touch beyond my packaging-fu, but Mario I assume you'll be at the UDS in Dallas? Would you like to work out an implementation plan for it there?

Bryce Harrington (bryce)
affects: nvidia-graphics-drivers-177 (Ubuntu) → nvidia-graphics-drivers-180 (Ubuntu)
Changed in nvidia-graphics-drivers-173 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-96 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-71 (Ubuntu):
status: Triaged → Invalid
Changed in nvidia-graphics-drivers-173 (Ubuntu):
status: Triaged → In Progress
Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: Triaged → In Progress
Changed in mesa (Ubuntu):
assignee: Mario Limonciello (superm1) → Alberto Milone (albertomilone)
Changed in xorg-server (Ubuntu):
assignee: Mario Limonciello (superm1) → Alberto Milone (albertomilone)
Changed in xorg-server (Ubuntu):
status: Triaged → In Progress
Changed in mesa (Ubuntu):
status: Triaged → Invalid
Changed in nvidia-graphics-drivers-173 (Ubuntu):
status: In Progress → Fix Released
Changed in xorg-server (Ubuntu):
status: In Progress → Invalid
Changed in mesa (Ubuntu):
status: Invalid → Fix Released
Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: In Progress → Fix Released
adonet (jeroen-adolfse)
Changed in nvidia-graphics-drivers-71 (Ubuntu):
status: Invalid → Confirmed
Changed in nvidia-graphics-drivers-71 (Ubuntu):
status: Confirmed → Invalid
Changed in fglrx-installer (Ubuntu):
assignee: Mario Limonciello (superm1) → Alberto Milone (albertomilone)
Changed in fglrx-installer (Ubuntu):
status: Triaged → Fix Committed
Martin Pitt (pitti)
Changed in fglrx-installer (Ubuntu Lucid):
milestone: none → ubuntu-10.04-beta-1
Martin Pitt (pitti)
Changed in fglrx-installer (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-1 → ubuntu-10.04-beta-2
Changed in fglrx-installer (Ubuntu Lucid):
status: Fix Committed → Fix Released
enrico (wolfe7575)
Changed in nvidia-graphics-drivers-96 (Ubuntu):
assignee: Alberto Milone (albertomilone) → enrico (wolfe7575)
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers