[Upstream] LibreOffice repeatedly freezes after resuming laptop from sleep

Bug #185600 reported by Louis-Dominique Dubeau on 2008-01-24
170
This bug affects 34 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
LibreOffice
Invalid
Undecided
Unassigned
NVIDIA Drivers Ubuntu
Undecided
Unassigned
libreoffice (Ubuntu)
Undecided
Unassigned
nvidia-graphics-drivers-180 (Ubuntu)
Low
Unassigned
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org

I've used Feisty and Gutsy but this problem has started happening only recently. Here are the steps to reproduce:

1. Open a document in oowriter.

2. Put the laptop to sleep.

3. Resume the laptop.

Here are the symptoms:

1. Scrolling in the openoffice document is jerky. Basically, if I hit page up or page down, oowriter freezes for a few seconds and compiz grays the oowriter window (to show that the app is not responding), eventually oowriter unfreezes, refreshes its screen and is responsive again. If I try to scroll again, the same freeze repeats.

2. Sometimes oowriter seems to also cause other applications to temporarily be unresponsive. The symptom here is that compiz grays *all* the windows on the screen for a few seconds until oowriter becomes reponsive again.

3. No other application freezes like that after resume. Note that symptom 2 above happens *only* when oowriter is running.

WORKAROUND: Restart OOo/LO.

WORKAROUND: Turn off compiz.

+ Possibly related to bug 745836.

OO.org packages installed:

$ dpkg-query -W openoffice.org-* | gawk '$2 {print;}'
openoffice.org-base 1:2.3.0-1ubuntu5.3
openoffice.org-calc 1:2.3.0-1ubuntu5.3
openoffice.org-common 1:2.3.0-1ubuntu5.3
openoffice.org-core 1:2.3.0-1ubuntu5.3
openoffice.org-dev 1:2.3.0-1ubuntu5.3
openoffice.org-draw 1:2.3.0-1ubuntu5.3
openoffice.org-evolution 1:2.3.0-1ubuntu5.3
openoffice.org-filter-mobiledev 1:2.3.0-1ubuntu5
openoffice.org-gnome 1:2.3.0-1ubuntu5.3
openoffice.org-gtk 1:2.3.0-1ubuntu5.3
openoffice.org-help-en-gb 1:2.3.0-1ubuntu2
openoffice.org-help-en-us 1:2.3.0-1ubuntu2
openoffice.org-help-fr 1:2.3.0-1ubuntu2
openoffice.org-help-hi-in 1:2.3.0-1ubuntu2
openoffice.org-help-zh-cn 1:2.3.0-1ubuntu2
openoffice.org-help-zh-tw 1:2.3.0-1ubuntu2
openoffice.org-hyphenation 0.2
openoffice.org-impress 1:2.3.0-1ubuntu5.3
openoffice.org-java-common 1:2.3.0-1ubuntu5.3
openoffice.org-l10n-common 1:2.3.0-1ubuntu2
openoffice.org-l10n-en-gb 1:2.3.0-1ubuntu2
openoffice.org-l10n-en-us 1:2.3.0-1ubuntu5.3
openoffice.org-l10n-en-za 1:2.3.0-1ubuntu2
openoffice.org-l10n-fr 1:2.3.0-1ubuntu2
openoffice.org-l10n-hi-in 1:2.3.0-1ubuntu2
openoffice.org-l10n-zh-cn 1:2.3.0-1ubuntu2
openoffice.org-l10n-zh-tw 1:2.3.0-1ubuntu2
openoffice.org-math 1:2.3.0-1ubuntu5.3
openoffice.org-style-andromeda 1:2.3.0-1ubuntu5.3
openoffice.org-style-crystal 1:2.3.0-1ubuntu5.3
openoffice.org-style-default 1:2.3.0-1ubuntu5.3
openoffice.org-style-human 1:2.3.0-1ubuntu5.3
openoffice.org-style-industrial 1:2.3.0-1ubuntu5.3
openoffice.org-style-tango 1:2.3.0-1ubuntu5.3
openoffice.org-thesaurus-en-us 1:2.2.0-2ubuntu1
openoffice.org-writer 1:2.3.0-1ubuntu5.3

+ Unreproducible in non-Unity Ubuntu 11.04 LibreOffice Writer, suspend to RAM via ATI proprietary drivers with Compiz enabled.

lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

apt-cache policy fglrx
fglrx:
  Installed: 2:8.840-0ubuntu4
  Candidate: 2:8.840-0ubuntu4
  Version table:
 *** 2:8.840-0ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/restricted i386 Packages
        100 /var/lib/dpkg/status

apt-cache policy compiz
compiz:
  Installed: 1:0.9.4+bzr20110415-0ubuntu2
  Candidate: 1:0.9.4+bzr20110415-0ubuntu2
  Version table:
 *** 1:0.9.4+bzr20110415-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

Chris Cheney (ccheney) on 2008-02-06
Changed in openoffice.org:
status: New → Invalid
Louis-Dominique Dubeau (ldd) wrote :

Why has this bug been marked invalid?

Chris Cheney (ccheney) on 2008-02-15
Changed in openoffice.org:
status: Invalid → New
Chris Cheney (ccheney) wrote :

Louis-Dominique,

I'm sorry I am not sure why I marked the bug as invalid, I think I must have clicked the wrong thing by accident.

To respond to the bug:

Can you reproduce this bug if you have compiz disabled?

I can't reproduce this bug myself but that is primarily due to the fact I can't easily suspend/resume my laptop to begin with.

Thanks,

Chris

Changed in openoffice.org:
assignee: nobody → ccheney
status: New → Incomplete
Louis-Dominique Dubeau (ldd) wrote :

Thanks for the reply. I've tried quickly to reproduce it after turning off compiz but the bug did not come back.

I will keep compiz turned off on my machine for a few days and see whether during my normal day to day use the bug comes back again because it might be a combination of various factors that make it manifest itself. I've set myself a TODO item for Friday the 22nd. If I get the bug again before then, I'll report right away. If not, I'll report on Friday that the bug is irreproducible with compiz turned off.

Louis-Dominique Dubeau (ldd) wrote :

At this point, I'm going to say that turning off compiz makes the bug disappear. I've used Open Office intensively yesterday and today and put my laptop to sleep several times without the bug recurring.

I'm still perplexed by the fact that when compiz is running the bug appears *only* when Open Office is also running. No other software shows this behavior. I run evolution and Firefox for long stretches of time and they go through all the same sleep/resume cycles as Open Office and yet no problem with them.

What now? Make this a compiz bug?

Chris Cheney (ccheney) wrote :

I have reassigned this bug to compiz. I am not sure why it only happens to openoffice but compiz has made lots of weird bugs pop up in the past so I am not surprised in seeing it be attributed to compiz. It may end up actually being a bug in openoffice of some sort that only is triggered when compiz is enabled.

Changed in openoffice.org:
assignee: ccheney → nobody
status: Incomplete → Confirmed
Changed in compiz:
importance: Undecided → Low
Louis-Dominique Dubeau (ldd) wrote :

I've upgraded to Ubuntu 8.04 (Hardy Heron).

I report that the problem still occurs in Ubuntu 8.04.

compiz-core:
  Installed: 1:0.7.4-0ubuntu6
  Candidate: 1:0.7.4-0ubuntu6
  Version table:
 *** 1:0.7.4-0ubuntu6 0
        500 http://us.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

openoffice.org-core:
  Installed: 1:2.4.0-3ubuntu6
  Candidate: 1:2.4.0-3ubuntu6
  Version table:
 *** 1:2.4.0-3ubuntu6 0
        500 http://us.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

glass.dimly (jmjohn) wrote :

I can report this same problem on wake up with open office and compiz. Problem happens consistently and is replicable.
Openoffice 1.2.4
Ubuntu 8.04.1
NVIDIA driver 169.12

Basically, after wake up from suspend, when I hit scroll page up or page down, I can watch my CPU usage kick up to 100% and freeze everything up. I have a 2.0 GHZ Dual Core Pentium with 4 GB RAM, Dell XPS 1330.

I've attached my /etc/default/acpi-support file, if that is helpful.

-glass.dimly

Louis-Dominique Dubeau (ldd) wrote :

I report that the problem still occurs in Ubuntu 8.10.

compiz-core:
  Installed: 1:0.7.8-0ubuntu4.1
  Candidate: 1:0.7.8-0ubuntu4.1
  Version table:
 *** 1:0.7.8-0ubuntu4.1 0
        500 http://free.nchc.org.tw intrepid-updates/main Packages
        100 /var/lib/dpkg/status
     1:0.7.8-0ubuntu4 0
        500 http://free.nchc.org.tw intrepid/main Packages

openoffice.org-core:
  Installed: 1:2.4.1-11ubuntu2.1
  Candidate: 1:2.4.1-11ubuntu2.1
  Version table:
 *** 1:2.4.1-11ubuntu2.1 0
        500 http://free.nchc.org.tw intrepid-updates/main Packages
        500 http://security.ubuntu.com intrepid-security/main Packages
        100 /var/lib/dpkg/status
     1:2.4.1-11ubuntu2 0
        500 http://free.nchc.org.tw intrepid/main Packages

Also, I've installed Open Office 3.0 from the Open Office web site to try it out. I know this is not an official Ubuntu package but for what it's worth: the problem happens with it too.

Harm van Bakel (hvbakel) wrote :

I can confirm that this problem still occurs in Ubuntu 9.04 (Jaunty)

Caleb (caleb-marcus) wrote :

Considering this is a bug that occurs extensively, during very typical laptop usage patterns, with 100% default preinstalled applications, it would be nice to see it getting more attention... having to restart OpenOffice each time I resume the system is inconvenient.

Anyone who uses suspend and resume on a laptop (quite common) capable of 3D acceleration so Compiz is enabled automatically (almost ubiquitous now) who uses word processing (who doesn't?) is affected by this rather crippling bug... I can't see editing documents while on the go as a very specialist or rare use case.

I should mention that I have not tested this with OpenOffice.org 3, on Jaunty.

Robert Ancell (robert-ancell) wrote :

Thanks for your bug report. The symptoms provided indicate this is a problem with your video drivers and is being reassigned to the xorg package. For more information on problems with visual effects and video drivers see http://wiki.ubuntu.com/VisualEffects.

affects: compiz (Ubuntu) → xorg (Ubuntu)
Bryce Harrington (bryce) on 2009-06-18
affects: xorg (Ubuntu) → nvidia-graphics-drivers-180 (Ubuntu)
Bryce Harrington (bryce) wrote :

I've posted a new version of the -nvidia driver to our xorg-edgers PPA,
would you mind testing it either on Jaunty or Karmic and see if it
resolves this bug?

Get nvidia-graphics-drivers-180 - 185.18.14 here:

  https://edge.launchpad.net/~xorg-edgers/+archive/ppa

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Confirmed → New
status: New → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Invalid
Louis-Dominique Dubeau (ldd) wrote :

I've installed 185.18.14 from the PPA as requested.

The bug is still present.

Here's the version on nvidia-180-kernel-source:

$ dpkg-query -W nvidia-180-kernel-source
nvidia-180-kernel-source 185.18.14-0ubuntu1~xup~1~jaunty

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Invalid → Confirmed

This bug also affects me.

Ubuntu 9.04
2.6.28-15-generic
nvidia-180-kernel-source 180.44-0ubuntu1
openoffice.org-core 1:3.0.1-9ubuntu3

When I hibernate with openoffice.org writer and then resume, scrolling in writer will send xorg's cpu usage up to 100%

Restarting openoffice.org fixes the problem.

geoffrey (gkgeko) wrote :

Hi, just realised that I had filed a report for the same bug, #397880, I marked mine as duplicate.

Just a couple of details that have not been mentioned here: it is actually not necessary to restart OOo to solve the problem: it is enough to close individual files and open them again to get them to work. Also, any file opened after resume will work fine, even if other files that had been opened before suspend are still presenting the problem.

I am on Jaunty 64bit, nvidia Quadro NVS 135M driver version 180.44.

geoffrey (gkgeko) wrote :

I just realised that *unmodified* OOo documents work perfectly after resume. So if I open a document and don't touch it until suspend, it will not cause the problem described. If I open a document, modify it, then suspend, I get the problem - it makes no difference if I save the document first or not.
(btw, I am now on Karmic)

Hope this helps in identifying the problem.

geoffrey (gkgeko) wrote :

edit: if I have two documents - one unmodified, and one modified - opened at the same time, then only the second will present the bug.

Download full text (3.7 KiB)

I don't know if this is related at all--but I haven't noticed this bug ever
since I fixed this related bug:
http://ubuntuforums.org/showthread.php?t=1237608. I haven't spent
significant amounts of time testing it, and can't say that wasn't something
else that fixed it--but if you use compiz and have an nvidia card it would
definitely be worth trying. Good luck.

On Wed, Nov 25, 2009 at 4:25 AM, geoffrey <email address hidden> wrote:

> edit: if I have two documents - one unmodified, and one modified -
> opened at the same time, then only the second will present the bug.
>
> --
> openoffice repeatedly freezes after resuming laptop from sleep
> https://bugs.launchpad.net/bugs/185600
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “nvidia-graphics-drivers-180” package in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: openoffice.org
>
> I've used Feisty and Gutsy but this problem has started happening only
> recently. Here are the steps to reproduce:
>
> 1. Open a document in oowriter.
>
> 2. Put the laptop to sleep.
>
> 3. Resume the laptop.
>
> Here are the symptoms:
>
> 1. Scrolling in the openoffice document is jerky. Basically, if I hit page
> up or page down, oowriter freezes for a few seconds and compiz grays the
> oowriter window (to show that the app is not responding), eventually
> oowriter unfreezes, refreshes its screen and is responsive again. If I try
> to scroll again, the same freeze repeats.
>
> 2. Sometimes oowriter seems to also cause other applications to temporarily
> be unresponsive. The symptom here is that compiz grays *all* the windows on
> the screen for a few seconds until oowriter becomes reponsive again.
>
> 3. No other application freezes like that after resume. Note that symptom
> 2 above happens *only* when oowriter is running.
>
> 4. This one is also a workaround: if I restart openoffice, the problem goes
> away.
>
> OO.org packages installed:
>
> $ dpkg-query -W openoffice.org-* | gawk '$2 {print;}'
> openoffice.org-base 1:2.3.0-1ubuntu5.3
> openoffice.org-calc 1:2.3.0-1ubuntu5.3
> openoffice.org-common 1:2.3.0-1ubuntu5.3
> openoffice.org-core 1:2.3.0-1ubuntu5.3
> openoffice.org-dev 1:2.3.0-1ubuntu5.3
> openoffice.org-draw 1:2.3.0-1ubuntu5.3
> openoffice.org-evolution 1:2.3.0-1ubuntu5.3
> openoffice.org-filter-mobiledev 1:2.3.0-1ubuntu5
> openoffice.org-gnome 1:2.3.0-1ubuntu5.3
> openoffice.org-gtk 1:2.3.0-1ubuntu5.3
> openoffice.org-help-en-gb 1:2.3.0-1ubuntu2
> openoffice.org-help-en-us 1:2.3.0-1ubuntu2
> openoffice.org-help-fr 1:2.3.0-1ubuntu2
> openoffice.org-help-hi-in 1:2.3.0-1ubuntu2
> openoffice.org-help-zh-cn 1:2.3.0-1ubuntu2
> openoffice.org-help-zh-tw 1:2.3.0-1ubuntu2
> openoffice.org-hyphenation 0.2
> openoffice.org-impress 1:2.3.0-1ubuntu5.3
> openoffice.org-java-common 1:2.3.0-1ubuntu5.3
> openoffice.org-l10n-common 1:2.3.0-1ubuntu2
> openoffice.org-l10n-en-gb 1:2.3.0-1ubuntu2
> openoffice.org-l10n-en-us 1:2.3.0-1ubuntu5.3
> openoffice.org-l10n-en-za 1:2.3.0-1ubuntu2
> openoffice.org-l10n-fr 1:2.3.0-1ubuntu2
> openoffi...

Read more...

Thanks adempewolff - however in my case the 'Force synchronization between X and GLX' option in Compiz was already checked, I tried unchecking it but nothing has changed.

Mark Baas (mark-baas123) wrote :

I have nvidia driver 195 and still have this bug. However restarting compiz is also a solution. Therefore, i developed a pm-utils hook that restarts compiz (and gnome-panel) after resuming from suspend or hibernate only in case openoffice is running.

Copy the attached file to /etc/pm/sleep.d and make it executable (chmod 755 /etc/pm/sleep.d/0000restart-compiz).

geoffrey (gkgeko) wrote :

@Mark Baas: This is great, thank you so much! I installed the script yesterday, and so far has been working perfectly.

Louis-Dominique Dubeau (ldd) wrote :

This problem is present on Ubuntu 10.04 (Lucid).

"Force synchronization between X and GLX" has no effect here.

Result of apt-cache policy on some packages:

compiz-core:
  Installed: 1:0.8.4-0ubuntu15
  Candidate: 1:0.8.4-0ubuntu15
  Version table:
 *** 1:0.8.4-0ubuntu15 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

openoffice.org-core:
  Installed: 1:3.2.0-7ubuntu4
  Candidate: 1:3.2.0-7ubuntu4
  Version table:
 *** 1:3.2.0-7ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

nvidia-current:
  Installed: 195.36.15-0ubuntu3
  Candidate: 195.36.15-0ubuntu3
  Version table:
 *** 195.36.15-0ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid-updates/restricted Packages
        100 /var/lib/dpkg/status
     195.36.15-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/restricted Packages

xserver-xorg:
  Installed: 1:7.5+5ubuntu1
  Candidate: 1:7.5+5ubuntu1
  Version table:
 *** 1:7.5+5ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

Gorka Navarrete (emrys) wrote :

As said in a duplicate of this bug, the problem persists in 10.10 (64-bits), using Openoffice or Libreoffice, with the last 260.19.06 Nvidia drivers.

Changed in nvidia-drivers-ubuntu:
status: New → Confirmed
eva dany (unsichtbarkeit) wrote :

i can confirm this bug on my machine.
i have macbook pro, and running a fresh installed ubuntu 10.10
after resume from suspend/hibernate openoffice is very slow with typing and scrolling.
killing openoffice will help.

Louis-Dominique Dubeau (ldd) wrote :

Ok, so this is happening again in 10.10. I've noticed a few more things though:

1. This bug sometimes causes X to crash. I've experienced it a few minutes ago. I had resumed from suspend maybe 4 hours ago and worked on a bunch of things in Emacs, Firefox and Evolution and a few other X clients (like xpdf). Then I turned to Open Office writer to check something in a document. The document was very slow to scroll. Writer was in effect exhibiting the symptoms described earlier in this bug report.

After paging up maybe 4 or 5 times, X crashed.

The only X client started before the suspend-resume cycle and which showed any trouble was Open Office. (Emacs, FF, Evolution were also all started before the suspend-resume cycle: no problem with them.)

2. The soffice.bin process remained running from the previous X session. Note that everything else which was X related died when the X session died. Only, soffice.bin remained. Running oowriter from the command line does nothing. The old soffice.bin must be killed before OO can be used again.

3. I checked to see whether the HD was being accessed abnormally (e.g. thrashing) but did not see anything abnormal there.

Why did I not experience X crashes before? I think the answer is just that in the past, I would very quickly close OO as soon as I experienced the bug so I was removing the opportunity for a crash. This time, I insisted on scrolling to a bit of text I needed to cut and paste to emacs. I thought I was really close to the passage I wanted to cut and paste but I was wrong and X crashed before I could get there.

It may also have to do with the document I was scrolling. This is the largest OO document I have. It also happens to contain about as much Chinese as English. So of all the documents I work with this is the one which is most taxing on oowriter.

Here are the results of apt-cache policy on the usual suspects:

compiz-core:
  Installed: 1:0.8.6-0ubuntu9.1
  Candidate: 1:0.8.6-0ubuntu9.1
  Version table:
 *** 1:0.8.6-0ubuntu9.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1:0.8.6-0ubuntu9 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main amd64 Packages

openoffice.org-core:
  Installed: 1:3.2.1-7ubuntu1
  Candidate: 1:3.2.1-7ubuntu1
  Version table:
 *** 1:3.2.1-7ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main amd64 Packages
        100 /var/lib/dpkg/status

nvidia-current:
  Installed: 260.19.06-0ubuntu1
  Candidate: 260.19.06-0ubuntu1
  Version table:
 *** 260.19.06-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/restricted amd64 Packages
        100 /var/lib/dpkg/status

xserver-xorg:
  Installed: 1:7.5+6ubuntu3
  Candidate: 1:7.5+6ubuntu3
  Version table:
 *** 1:7.5+6ubuntu3 0
        500 http://us.archive.ubuntu.com/ubuntu/ maverick/main amd64 Packages
        100 /var/lib/dpkg/status

Berezin Kirill (pechenie-k) wrote :

I can also confirm this bug under Ubuntu 10.10 and absolutely-all-fresh-updates-installed.
I also have nvidia card and proprietary drivers installed. Sounds like it is vendor-specific (nvidia) compiz problem.

I expirience this bug from 9.10, as I can remember. Reopening OO.org Writer hepls, but it is very uncomfortable to answer "Yes or no" to the response of saving changes when I can't remember what are they in such situation.

This bug is 2 years old, so sad there is still no solution.

I switched over to Fedora for awhile then went back to Ubuntu ~6 months ago and this problem has popped back up again (currently still using 10.04). Very frustrating, because as my post from 2 years ago suggests, I somehow fixed the problem on that old install. Now however, I cannot figure out how I fixed it. Force sync between X and glx isn't doing it, so it must have been something else I did back then inadvertantly.

It looks like it is just a bug for people who have Nvidia cards. If other subscribers want to try and get this bug off the ground I am game to participate in some more troubleshooting and group brainstorming.

I have noticed that not all windows lock up, and the suggestion above that only modified documents lock up sounds like a very likely explanation. I remember seeing a bug somewhere about openoffice locking up after a resume when it tries an autosave, maybe this is a related bug. Doesn't make sense why whether the document is modified or unmodified would matter if the problem is with compiz... very strange.

Well for now I am going to try the restart compiz on resume script as a workaround. I agree that this is a really silly bug to be unsolved after 2 years, especially when I could have sworn I fixed the problem once upon a time!

Another thing that might be worth noting after reading Louis-Dominique Dubeau's comment is that I have also noticed that the bug is more serious in documents with Chinese text. I've been translating texts recently, so I will have documents in both languages open simultaneously, and after a resume I sometimes won't notice the bug at first when I start using the English document, but the second I try scrolling on the Chinese document the bug is very apparent!

Gorka Navarrete (emrys) wrote :

The problem persists with a clean Natty installation. This is a serious and very frustrating bug. Particularly the fact that there seems not to be any progress here. Any idea about where this should be reported to make it more visible?

Gorka Navarrete (emrys) on 2011-05-12
summary: - openoffice repeatedly freezes after resuming laptop from sleep
+ libreoffice repeatedly freezes after resuming laptop from sleep

After waking up from suspend having a LibreOffice document opened, Libreoffice becomes unusable, freezing, etc. There is a long and old, but still prevalent, description of the problem in Launchpad. The problems it's been with us more than 2 years now.

https://bugs.launchpad.net/compiz/+bug/185600

This happens at least in Ubuntu 64-bits and seems somehow related to compiz.

affects: libreoffice → df-libreoffice
Changed in df-libreoffice:
importance: Unknown → High
status: Unknown → Confirmed

I can confirm this bug is still present with
- Ubuntu 11.04
- Libreoffice 3.4
- NVIDIA propietary 270.41.06-0ubuntu1
- Compiz 1:0.9.4+bzr20110415-0ubuntu2

after resume from suspend or switching user libreoffice is so slow that is unusable and almost makes the computer freeze.

Louis-Dominique Dubeau, this issue is unreproducible in non-Unity Ubuntu 11.04 LibreOffice Writer, suspend to RAM via ATI proprietary drivers with Compiz enabled.

lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

apt-cache policy fglrx
fglrx:
  Installed: 2:8.840-0ubuntu4
  Candidate: 2:8.840-0ubuntu4
  Version table:
 *** 2:8.840-0ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/restricted i386 Packages
        100 /var/lib/dpkg/status

apt-cache policy compiz
compiz:
  Installed: 1:0.9.4+bzr20110415-0ubuntu2
  Candidate: 1:0.9.4+bzr20110415-0ubuntu2
  Version table:
 *** 1:0.9.4+bzr20110415-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

aldebx (aldebx) wrote :

I just want to add that I'm not using Unity, instead I'm using the standard GNOME interface, still I experience this bug.

Gautham Pai (buzypi) wrote :

Same here. I am on Ubuntu 10.04 and experience this issue.

$ uname -a
Linux ananya 2.6.32-32-generic-pae #62-Ubuntu SMP Wed Apr 20 22:10:33 UTC 2011 i686 GNU/Linux
$ cat /etc/issue
Ubuntu 10.04.2 LTS \n \l
$

Gorka Navarrete (emrys) wrote :

Gautham, do you have an NVIDIA graphic card?

The problem seems arise from an interaction between NVIDIA, Compiz and Libreoffice...

Gautham Pai (buzypi) wrote :

Yes I do.

I just wanted to mention that this is not just in Unity based environments but it is present in Ubuntu 10.04.

Mahendra Tallur (mahen) wrote :

Indeed, it's happened for several Ubuntu releases already : only when Compiz is enabled (and thus, Unity as well as it's a Compiz plugin), and apparently only with Nvidia cards (proprietary driver).

Fiepel (philippe-fiepel) wrote :

Can confirm this bug on Ubuntu 11.04
NVidia driver 270.41.19
Compiz 1:0.9.4+bzr20110606-0ubuntu1~natty2
Libreoffice: 1:3.3.2-1ubuntu5

I did not have this behavior prior to upgrading from 10.10 to 11.04. I am not sure when exactly it started to occur. Maybe it has to do with the NVidia drivers that I installed from NVIDIA directly?

Upgraded a Samsung R510 from 10.10 to 11.04. Now Open Office shows the described behavior (corrupted screen and really bad responsiveness). To note that this Laptop uses a Nvidia 9200M GS. However this Problem is independent of the system state (sleep and resume) and occurs all the time. So as I understand the only workaround is to switch to ubuntu classic (without effects) because of the dist-upgrade?

Phil Colbourn (philcolbourn) wrote :

Similar prob. MacBook Pro 4,1
With binary nvidia driver

Linux max 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Happens when LibreOffice is running and laptop sleeps/resumes.

Typically Writer is very slow and causes whole laptop to pause for several seconds.

Get this error in Xorg.0.log:
[mi] EQ overflowing. The server is probably stuck in an infinite loop.

To 'fix' I rmmod bcm5974 and modprobe bcm5974 and quickly kill LibreOffice and reopen it.

The trackpad (BCM5974) clicks still function but there is no mouse cursor.

I have bcm5974 removed/reinstalled before/after a sleep/resume - does not seem to help.

No other application seems to cause this.

Need anything else?

PS: A friend with a virtually identical setup has same problem.

Phil Colbourn (philcolbourn) wrote :

Also, 1 CPU is fully utilized as I attempt to scroll.

Phil Colbourn (philcolbourn) wrote :

An odd thing that we have noticed: if you run draw, and go through a sleep/resume cycle, this problem goes away. Then you can close draw and your calc and writer will be stable through multiple sleep/resume cycles.

It may be too early to post this observation, but in my hope that it offers a valuable key I thought it worth mentioning.

Another possibility is that it is July 7 - but I doubt it somehow ;)

Possibly related to bug 745836.

Changed in libreoffice (Ubuntu):
status: New → Incomplete
status: Incomplete → New
Phil Colbourn (philcolbourn) wrote :

This lasted one day. I don't understand this fault. It is not perfectly repeatable and, as I found, it can disappear for a whole day and then reappear which makes it hard to nail-down and confirm what causes it.

Changed in libreoffice (Ubuntu):
status: New → Confirmed
Changed in openoffice.org (Ubuntu):
status: New → Confirmed
JKL (jkl102001) wrote :

I am also running the nvidia drivers, and due to this problem, I switched to metacity. Initially I thought the problem had gone away, but on the most recent resume it reappeared. Not only that, I discovered several additional issues I hadn't noticed before.

* if writer is on a different workspace and not minimzed, it takes several seconds for the writer window to repaint when switching to its workspace. During that time, the mouse cursor is moveable, but the desktop does not respond to mouse clicks, and the system monitor graphs freeze. Other windows are not repainted either (e.g. a terminal running 'top' isn't updated).

* If the writer window is minimzed, there is no problem switching workspaces.

* restoring the writer window after minimizing it takes several seconds, and during that time the desktop is freezes as when switching workspaces.

* When the system is frozen during the writer repaint, the Xorg process fully loads one CPU core. But that is the only process that uses excessive CPU time. In particular, neither the writer process nor metacity create additional load.

JKL (jkl102001) wrote :
Download full text (3.5 KiB)

Here are some interesting entries from my X log. According to the below page, a likely root cause is GPU lockup.

https://wiki.ubuntu.com/X/Troubleshooting/Freeze#Problem:__Log_shows_.22.5Bmi.5D_EQ_overflowing.22_and_X_freezes

** snip **

[ 2995.858] [mi] EQ overflowing. The server is probably stuck in an infinite loop.
[ 2995.858]
Backtrace:
[ 2995.936] 0: /usr/bin/X (xorg_backtrace+0x26) [0x4a2656]
[ 2995.936] 1: /usr/bin/X (mieqEnqueue+0x1f4) [0x4a1914]
[ 2995.936] 2: /usr/bin/X (xf86PostMotionEventM+0x97) [0x47d797]
[ 2995.936] 3: /usr/bin/X (xf86PostMotionEvent+0xd0) [0x47d9c0]
[ 2995.936] 4: /usr/lib/xorg/modules/input/synaptics_drv.so (0x7f13877e1000+0x514a) [0x7f13877e614a]
[ 2995.936] 5: /usr/lib/xorg/modules/input/synaptics_drv.so (0x7f13877e1000+0x6d66) [0x7f13877e7d66]
[ 2995.936] 6: /usr/bin/X (0x400000+0x6c687) [0x46c687]
[ 2995.936] 7: /usr/bin/X (0x400000+0x124c1e) [0x524c1e]
[ 2995.936] 8: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f138e58d000+0xfc60) [0x7f138e59cc60]
[ 2995.936] 9: /usr/lib/xorg/extra-modules/nvidia_drv.so (0x7f1388cba000+0xd9cff) [0x7f1388d93cff]
[ 2995.936] 10: /usr/lib/xorg/modules/libwfb.so (wfbBlt+0x124) [0x7f138887f7b4]
[ 2995.936] 11: /usr/lib/xorg/modules/libwfb.so (wfbCopyNtoN+0x2c0) [0x7f1388884760]
[ 2995.936] 12: /usr/bin/X (miCopyRegion+0x19d) [0x55289d]
[ 2995.936] 13: /usr/bin/X (miDoCopy+0x392) [0x552d92]
[ 2995.936] 14: /usr/lib/xorg/modules/libwfb.so (wfbCopyArea+0x4c) [0x7f13888849cc]
[ 2995.936] 15: /usr/lib/xorg/extra-modules/nvidia_drv.so (0x7f1388cba000+0x45ee89) [0x7f1389118e89]
[ 2995.936] 16: /usr/bin/X (0x400000+0xde7d2) [0x4de7d2]
[ 2995.936] 17: /usr/bin/X (0x400000+0x2a1f9) [0x42a1f9]
[ 2995.936] 18: /usr/bin/X (0x400000+0x2e2a9) [0x42e2a9]
[ 2995.936] 19: /usr/bin/X (0x400000+0x21a7e) [0x421a7e]
[ 2995.936] 20: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xff) [0x7f138d4d6eff]
[ 2995.936] 21: /usr/bin/X (0x400000+0x21629) [0x421629]

** snip **

[ 17465.130] [mi] EQ overflowing. The server is probably stuck in an infinite loop.
[ 17465.130]
Backtrace:
[ 17465.130] 0: /usr/bin/X (xorg_backtrace+0x26) [0x4a2656]
[ 17465.130] 1: /usr/bin/X (mieqEnqueue+0x1f4) [0x4a1914]
[ 17465.130] 2: /usr/bin/X (xf86PostMotionEventM+0x97) [0x47d797]
[ 17465.130] 3: /usr/lib/xorg/modules/input/evdev_drv.so (0x7f1388204000+0x5ff3) [0x7f1388209ff3]
[ 17465.130] 4: /usr/lib/xorg/modules/input/evdev_drv.so (0x7f1388204000+0x668d) [0x7f138820a68d]
[ 17465.130] 5: /usr/bin/X (0x400000+0x6c687) [0x46c687]
[ 17465.130] 6: /usr/bin/X (0x400000+0x124c1e) [0x524c1e]
[ 17465.130] 7: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7f138e58d000+0xfc60) [0x7f138e59cc60]
[ 17465.130] 8: /usr/lib/xorg/extra-modules/nvidia_drv.so (0x7f1388cba000+0xd9cff) [0x7f1388d93cff]
[ 17465.130] 9: /usr/lib/xorg/modules/libwfb.so (wfbBlt+0x124) [0x7f138887f7b4]
[ 17465.130] 10: /usr/lib/xorg/modules/libwfb.so (wfbCopyNtoN+0x2c0) [0x7f1388884760]
[ 17465.130] 11: /usr/bin/X (miCopyRegion+0x19d) [0x55289d]
[ 17465.130] 12: /usr/bin/X (miDoCopy+0x392) [0x552d92]
[ 17465.130] 13: /usr/lib/xorg/modules/libwfb.so (wfbCopyArea+0x4c) [0x7f13888849cc]
[ 17465.130] 14: /usr/lib/xorg/extra-modules/nvidia_drv.so...

Read more...

Changed in openoffice.org (Ubuntu):
status: Confirmed → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

summary: - libreoffice repeatedly freezes after resuming laptop from sleep
+ [Upstream] LibreOffice repeatedly freezes after resuming laptop from
+ sleep

Just thought I'd post that I cannot find a good workaround. I did find a *bad* workaround, which is to let the power management daemon just kill off soffice.

The reason this is better than the current bug is that the current bug has the potential to completely hang the system if you fail to kill soffice quickly. It's horrible, but I haven't found anything else that works. (One poster in the original launchpad bug suggested using compiz -replace in a pm.d script, but that did not work for me.)

Bad workaround
--------------
Create a file:
    sudo touch /etc/pm.d/sleep.d/20_kill_soffice
    sudo chmod +x /etc/pm.d/sleep.d/20_kill_soffice

Add these contents:

#!/bin/bash

PATH=/sbin:/usr/sbin:/bin:/usr/bin

SELF=kill-soffice
COMMAND=

# pm-action(8) - <action> <suspend method>
#
# On suspend|hibernate, kill soffice due to compiz-related hang:
# https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-180/+bug/185600

case "${1}" in
        hibernate)
            ;;
        resume|thaw)
            # hope soffice's recovery function works.
            pkill -f soffice.bin
            ;;
esac

(In reply to comment #1)
> Just thought I'd post that I cannot find a good workaround. I did find a *bad*
> workaround, which is to let the power management daemon just kill off soffice.
>
> The reason this is better than the current bug is that the current bug has the
> potential to completely hang the system if you fail to kill soffice quickly.
> It's horrible, but I haven't found anything else that works. (One poster in the
> original launchpad bug suggested using compiz -replace in a pm.d script, but
> that did not work for me.)
>
> Bad workaround
> --------------
> Create a file:
> sudo touch /etc/pm.d/sleep.d/20_kill_soffice
> sudo chmod +x /etc/pm.d/sleep.d/20_kill_soffice
>
> Add these contents:
>
> #!/bin/bash
>
> PATH=/sbin:/usr/sbin:/bin:/usr/bin
>
> SELF=kill-soffice
> COMMAND=
>
> # pm-action(8) - <action> <suspend method>
> #
> # On suspend|hibernate, kill soffice due to compiz-related hang:
> #
> https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-180/+bug/185600
>
> case "${1}" in
> hibernate)
> ;;
> resume|thaw)
> # hope soffice's recovery function works.
> pkill -f soffice.bin
> ;;
> esac

Line breaks got a little messed up - you will have to delete the line where I mention the bug URL, as that was supposed to be a comment.

Yotam Benshalom (benshalom) wrote :

This happens to me on libreoffice 3.4.4. with Gnome Shell and mutter as well, when compiz is not runnig. I use the nvidia drivers.
I still wonder who is the culprit: libreoffice, the compositor (mutter/compiz), or the driver (nvidia)?

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

Changed in df-libreoffice:
status: Confirmed → Incomplete

The problem persists in LO 3.5 beta 2 in Ubuntu 11.10.

Changed in df-libreoffice:
status: Incomplete → Confirmed

Gorka Navarrete, please do not toggle the Version. For more on this please see: http://wiki.documentfoundation.org/BugReport_Details#Version

David (hamassala-dicko) wrote :

I also confirm this bug, still present... and very annoying!

Ubuntu 11.10
Libreoffice LibreOffice 3.4.4 OOO340m1 (Build:402)
nVidia Corporation GT218 [Quadro FX 380M] (rev a2)
driver nvidia-current 280.13-0ubuntu6
Compiz 1.0.9.6

vsespb (vi1tsr) wrote :

workaround described here
https://bugs.launchpad.net/compiz/+bug/185600/comments/21
isn't working fine

"compiz --replace &" ran under root does not load user settings of compiz-decorator
also
"sudo -H -u USERNAME sh -c "/usr/bin/compiz --replace &"
does not work well too.. same - some settings broken

Subhasis Ray (ray-subhasis) wrote :

I confirm this bug on
Ubuntu 11.04, 64 bit,
LibreOffice 3.3.4, OOO330m19 (Build:401)
GPU: nVidia Quadro 4000
nVidia proprietary driver: 295.20
Session manager: Gnome 2.32.1
Window manager: metacity 2.30.3

Still having the problem in LibreOffice 3.5.1.2 Build ID: 350m1(Build:102) with Ubuntu 11.10.

If the system is powerful enough (8 cores, 16Gb RAM, SSD disk, etc.) it is annoying but not critical. With an inferior system, the computer becomes unusable and the only way forward is closing all LO instances.

There is anything I can o to help triage this?

tags: added: hardy hw-specific intrepid lucid maverick regression-release
description: updated
description: updated
description: updated
description: updated

Louis-Dominique Dubeau, thank you for reporting this bug and helping make Ubuntu better. Please answer the following questions:
+ Could you please execute the following at the Terminal:
apport-collect -p nvidia-graphics-drivers-180 185600
+ Does this issue occur in Precise?
+ Does this issue occur with the nouveau driver?
+ After resuming from a suspend, could you reproduce the problem then attach the following files to this report:
/var/log/kern.log
/var/log/Xorg.0.log

Thanks!

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Confirmed → Incomplete
David (hamassala-dicko) wrote :

I confirm the recurrence of this bug in Precise Pengolin, with the nvidia-current driver version 295.40-0ubuntu1 installed.
After a resume from a suspend during which LibreOffice was running (tested with writer), there is an abnormally high CPU usage (with possible hangup) when scrolling up/down or paging up/down in the document.

David, please execute the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug nvidia-current

Thanks!

bugbot (bugbot) on 2012-05-31
tags: added: natty
giuliano69 (giuliano-lotta) wrote :

confirmed:
11.10 + nvidia 295.20 + 3.5.3.2

giuliano69, please file a new report by executing the following via the Terminal and feel free to subscribe me to it:
ubuntu-bug nvidia-current

Thanks!

giuliano69 (giuliano-lotta) wrote :

Hi Christopher,
I'm having trouble in the bug feed back.
1)the ubuntu-bug is complaining that I installed a non genuine nvidia ubuntu driver (i use the swatx ppa)
2) I dont' know which option to check when prompted for (Yes, don't know, I already know the fix,...)
3) let us know if you need also the display manager log info
4) ther is an error with the log creation:
giuliano@voyager2:~$ ubuntu-bug nvidia-current
cat: /var/log/lightdm/:0.log: No such file or directory

could you please give some info on how to proceed ?

giuliano69, you cannot file a new bug because you are using a PPA, which is not supported by Ubuntu. In order to file a new report, you must change to non-PPA, Ubuntu repository software only, then follow the directions in https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-180/+bug/185600/comments/65 .

vsespb (vi1tsr) wrote :

penalvch,

I have this bug too, I am trying too
ubuntu-bug nvidia-current

but getting "This is not a genuine Ubuntu package"

however it seems that I installed nvidia from ubuntu repo, no? :

# apt-cache madison nvidia-current
nvidia-current | 195.36.24-0ubuntu1~10.04.3 | http://de.archive.ubuntu.com/ubuntu/ lucid-updates/restricted Packages
nvidia-current | 195.36.24-0ubuntu1~10.04.3 | http://security.ubuntu.com/ubuntu/ lucid-security/restricted Packages
nvidia-current | 195.36.15-0ubuntu2 | http://de.archive.ubuntu.com/ubuntu/ lucid/restricted Packages
nvidia-graphics-drivers | 195.36.15-0ubuntu2 | http://de.archive.ubuntu.com/ubuntu/ lucid/restricted Sources
nvidia-graphics-drivers | 195.36.24-0ubuntu1~10.04.3 | http://de.archive.ubuntu.com/ubuntu/ lucid-updates/restricted Sources
nvidia-graphics-drivers | 195.36.24-0ubuntu1~10.04.3 | http://security.ubuntu.com/ubuntu/ lucid-security/restricted Sources

vsespb, please file a report against xorg instead via a terminal and feel free to subscribe me to it:
ubuntu-bug xorg

Is this still an issue on a supported version of Ubuntu?

Changed in libreoffice (Ubuntu):
status: Confirmed → Incomplete
Gorka Navarrete (emrys) wrote :

In my 12.10 64-bits with LO 4.0 installed using the website debs does not happen any more.

Changed in libreoffice (Ubuntu):
status: Incomplete → Fix Released

Assuming fixed as per comment 71: LibreOffice 4 beta2 is in raring.

Changed in df-libreoffice:
status: Confirmed → Invalid
Gorka Navarrete (emrys) wrote :

I think I might have made a mistake and attributed an improvement in the situation to LO instead of to a faster computer. It is true that libreoffice does not render the system unusable after waking up from suspend but the problem somehow persists.

With a modern computer what you would notice now is a CLEAR slowing in LO (e.g. when scrolling down the page LO is very slow and unresponsive).

You still have to completely close LO and reopen it again for it to work properly.

I think I might have made a mistake and attributed an improvement in the situation to LO instead of to a faster computer. It is true that now Libreoffice does not render the system unusable after waking up from suspend but the problem somehow persists.

With a modern computer what you would notice now is a CLEAR slowing in LO (e.g. when scrolling down the page LO is slower than normal and somehow unresponsive).

You still have to completely close LO and reopen it again for it to work properly.

Changed in df-libreoffice:
status: Invalid → Confirmed

The problem persists with Ubuntu 13.04 Beta 2 and LO 4.0.2.2

Rogi (rogi) wrote :

Some changes in 13.4. After some time after resuming libreoffice writer becomes responsible. But sometimes if you enter some text in this time the problem remains. I use nvidia-313-updates.

David (hamassala-dicko) wrote :

Just installed (clean install) ubuntu 13.10 saucy salamender and sorry to say the bug is still present.

Tested with LibreOffice version 4.1.2.3
Nvidia-current version 304

Still slow performance of libreoffice if open after resuming from a suspend

Rogi / David, if you have a bug in Ubuntu, the Ubuntu Kernel team, Ubuntu Bug Control team, and Ubuntu Bug Squad would like you to please file a new report by executing the following in a terminal while booted into a Ubuntu repository kernel (not a mainline one) via:
ubuntu-bug linux

For more on this, please read the official Ubuntu documentation:
Ubuntu Bug Control and Ubuntu Bug Squad: https://wiki.ubuntu.com/Bugs/BestPractices#X.2BAC8-Reporting.Focus_on_One_Issue
Ubuntu Kernel Team: https://wiki.ubuntu.com/KernelTeam/KernelTeamBugPolicies#Filing_Kernel_Bug_reports
Ubuntu Community: https://help.ubuntu.com/community/ReportingBugs#Bug_reporting_etiquette

When opening up the new report, please feel free to subscribe me to it.

Please note, not filing a new report would delay your problem being addressed as quickly as possible.

No need exists to comment here at this time. After reading the above documentation in it's entirety, if you have further questions, you are welcome to redirect them to the appropriate mailing list or forum via http://www.ubuntu.com/support/community/mailinglists , or you may contact me directly.

Thank you for your understanding.

vsespb (vsespb) wrote :

@penalvch
Why it's marked fixed? There was no fix ever. See comments #71, #74

This doesn't look like it was ever confirmed by the QA team. Moving to UNCONFIRMED.

Changed in df-libreoffice:
status: Confirmed → New

@Gorka Navarrete
please give update of the bug status with current LibO 4.3.3.2 or 4.2.7.2 release

There has been 33 people confirming the bug since 2008 (in the Ubuntu bug report). The problem persists with LibO 4.3.2.2 (430m0(Build:2)) in Ubuntu 14.10 64bit.

To replicate, open a writer document with a few pages, suspend, wake up, scroll down.

Scrolling down is painfully slow, the LO screen grayes out and becomes completely unresponsive, along with the whole computer.

Setting to NEEDINFO until more detail is provided.

After providing the requested info, please reset this bug to UNCONFIRMED (should it be persisting) or WORKFORME (should it be solved with a newer LO version).

Changed in df-libreoffice:
status: New → Incomplete
dino99 (9d9) wrote :

That version is no more supported; please open a new bug report if the actual archive found version also has the same issue.

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Invalid
Changed in nvidia-drivers-ubuntu:
status: Confirmed → Invalid
Changed in compiz:
status: New → Invalid
Changed in df-libreoffice:
importance: High → Undecided
status: Incomplete → New
status: New → Invalid
Gorka Navarrete (emrys) wrote :

As far as I can tell, the problem is gone in 4.4.4.2 (not sure if before it).

Anyone else can confirm it so we can close this bug?

napel (napel) wrote :

I'm still experiencing this problem in Kubuntu 16.04 with LibreOffice using Nvidia drivers. Any standard Ubuntu users who also have this issue?

napel (napel) wrote :

*Xubuntu

napel, this report is closed as the original reporter hasn't responded in 6+ years, it is likely a hardware dependent issue, this report is bogged down with a tremendous amount of unhelpful "Me too!" comments, and so little debugging information was provided it is largely impossible to root cause.

If you would like your issue addressed, it will help immensely if you use the computer the problem is reproducible with, file a new report with Ubuntu by first ensuring the package xdiagnose is installed, click the Yes button for attaching additional debugging information after running the following from a terminal:
ubuntu-bug xorg

Also, please feel free to subscribe me to it.

Changed in libreoffice (Ubuntu):
status: Fix Released → Invalid
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.