Decoration Plugin: Window shadow color is not displayed as set in plugin properties on NV GeForce 8 and 9 series, using nvidia drivers

Bug #216999 reported by Kai Stempfle on 2008-04-13
14
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-177 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compiz-plugins

In Ubuntu 8.04 (Hardy Heron), windows shadows vary from yellow to pink (using standard settings from System->Preferences->Appearance->Visual Effects-Normal (and Extra)). Manually (re-)setting the shadow color using compiz-config-settings-manager does not work, either. Shadows appear yellow or pink.

Release Information:
$ lsb_release -crd
Description: Ubuntu hardy (development branch)
Release: 8.04
Codename: hardy

Package and Hardware information following as seperate attachments

Kai Stempfle (kai-stempfle) wrote :
Kai Stempfle (kai-stempfle) wrote :
Kai Stempfle (kai-stempfle) wrote :
Caroline Ford (secretlondon) wrote :

Could you add a screenshot?

Kai Stempfle (kai-stempfle) wrote :

Sure, but I have to correct myself:

panels and menus have either a yellow or pink shadow, windows do not have any at all. Sorry :)

Kai Stempfle (kai-stempfle) wrote :

Just killed the X-Server to be sure, here are the screenshots of yellow (green?) and pink shadows, as well as a screenshot of the compizconfig-settings-manager, where grey has been selected as shadow-color.

Kai Stempfle (kai-stempfle) wrote :
Kai Stempfle (kai-stempfle) wrote :
Kai Stempfle (kai-stempfle) wrote :

As you can see at the screenshots, window shadows are affected, however.

Disappearance of window shadows occurs randomly, as does the colorchange from yellow to pink or the other way around.

description: updated

Obviously, this bug is related to the nvidia driver package, since manually installing latest nvidia drivers seems to work flawlessly according to various sources I have consulted.

Since I can't find nvidia-glx-new (which seems to be the responsible package) on launchpad, I don't know what package this one is to assign to.

Regards,
Kai

Per Heldal (heldal) wrote :

Confirm.

I see pinkish shadows around windows and menus on a NV-8800GTS. There are other issues which have been blamed on composite handling in the current driver too, like a delay that is introduced in the handling of several gtk-widgets on only some of the displays in a multi-head config. Maybe it's still time for an upgrade to a more recent driver.

Per Heldal (heldal) wrote :

It seems to be something in the packaging that introduce this problem. The same version from nvidia works just fine.

I just removed nvidia-glx-new, nvidia-kernel-common and dependencies (incl all accumulated restricted-modules), then booted single-user and compiled and installed the original 169.12 driver and resumed normal boot. xorg.conf has not been touched, but 3D-shadows are now normal. (it doesn't fix the dual-head delay though).

Changed in compiz-plugins:
status: New → Confirmed
US41 (redmond-rob) wrote :

I am also experiencing pink drop shadows, shadows missing intermittently... Adjusting color in the advanced desktop settings has no effect. It is properly set to black and yet drop shadows are pink.

Running 8.04 RC on Nvidia 8500 GT.

I uninstalled the Ubuntu packages and installed the drivers from the
NVIDIA site and now it's working correctly with Compiz. :/

On Sun, Apr 20, 2008 at 3:06 PM, Kai Stempfle <email address hidden> wrote:
> ** Summary changed:
>
> - Decoration Plugin: Window shadow color is not displayed as set in plugin properties on NV GeForce 8600 GTS, using nvidia-new drivers
> + Decoration Plugin: Window shadow color is not displayed as set in plugin properties on NV GeForce 8 and 9 series, using nvidia drivers
>
> --
> Decoration Plugin: Window shadow color is not displayed as set in plugin properties on NV GeForce 8 and 9 series, using nvidia drivers
> https://bugs.launchpad.net/bugs/216999
> You received this bug notification because you are a direct subscriber
> of the bug.
>

James Schriver (dashua) wrote :

Shadow corruption is gone with 173.08 beta drivers as well on Hardy.

US41 (redmond-rob) wrote :

I have moved to a fresh install of 8.04 final.

* Using Envy NG to install new drivers has no effect.
* Color controls in the window decoration applet under advanced desktop effects has no effect on shadow color
* Sliding opacity control causes shadows to appear and disappear randomly.
* pink drop shadows remain
* RGB code in the color picker is #000000 as it should be.

This bug appears to be caused by an incorrectly symlinked file by the nvidia driver.

Read these forum posts for more information and a quick fix:

http://www.nvnews.net/vbulletin/showthread.php?t=109546&page=2
http://ubuntuforums.org/showthread.php?t=772408

Hew (hew) wrote :

Changing sourcepackage to nvidia-graphics-drivers-177. Marking fixed based on the above comments, and my own testing that those links are no longer present.

Changed in compiz-plugins:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers