package nvidia-173 (not installed) failed to install/upgrade: nvidia-173 kernel module failed to build (/var/lib/dkms/nvidia-173/173.14.22/build/nv-kernel.o: file not recognized: File format not recognized) [Lucid on 2.6.32-25]

Bug #646130 reported by Carlos Donizete Froes on 2010-09-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-173 (Ubuntu)
Medium
Unassigned

Bug Description

When I installed the driver, gave error and restart the system does not open the X.

/usr/src/linux-headers-2.6.32-25-generic/arch/x86/include/asm/compat.h: In function ‘arch_compat_alloc_user_space’:
/usr/src/linux-headers-2.6.32-25-generic/arch/x86/include/asm/compat.h:210: warning: pointer of type ‘void *’ used in arithmetic
  set -e ; perl /usr/src/linux-headers-2.6.32-25-generic/scripts/recordmcount.pl "x86_64" "64" "objdump" "objcopy" "cc" "ld" "nm" "" "" "1" "/var/lib/dkms/nvidia-173/173.14.22/build/nvacpi.o";
  ld -m elf_x86_64 -r -o /var/lib/dkms/nvidia-173/173.14.22/build/nvidia.o /var/lib/dkms/nvidia-173/173.14.22/build/nv-kernel.o /var/lib/dkms/nvidia-173/173.14.22/build/nv.o /var/lib/dkms/nvidia-173/173.14.22/build/nv-vm.o /var/lib/dkms/nvidia-173/173.14.22/build/os-agp.o /var/lib/dkms/nvidia-173/173.14.22/build/os-interface.o /var/lib/dkms/nvidia-173/173.14.22/build/os-registry.o /var/lib/dkms/nvidia-173/173.14.22/build/nv-i2c.o /var/lib/dkms/nvidia-173/173.14.22/build/nvacpi.o
/var/lib/dkms/nvidia-173/173.14.22/build/nv-kernel.o: file not recognized: File format not recognized
make[3]: ** [/var/lib/dkms/nvidia-173/173.14.22/build/nvidia.o] Erro 1
make[2]: ** [_module_/var/lib/dkms/nvidia-173/173.14.22/build] Erro 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: ** [module] Erro 1
make: ** [module] Erro 2

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: nvidia-173 (not installed)
ProcVersionSignature: Ubuntu 2.6.32-25.44-generic 2.6.32.21+drm33.7
Uname: Linux 2.6.32-25-generic x86_64
Architecture: amd64
Date: Thu Sep 23 13:13:14 2010
ErrorMessage: nvidia-173 kernel module failed to build
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
Lsusb:
 Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: PCWARE PW-945GCX
PackageVersion: 173.14.22-0ubuntu11
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-25-generic root=UUID=b695aeab-f557-4d40-a12f-f7a8a65af1a4 ro quiet splash
SourcePackage: nvidia-graphics-drivers-173
Title: package nvidia-173 (not installed) failed to install/upgrade: nvidia-173 kernel module failed to build
dmi.bios.date: 09/25/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 080012
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: PW-945GCX
dmi.board.vendor: PCWARE
dmi.board.version: 3.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: PCWARE
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr080012:bd09/25/2008:svnPCWARE:pnPW-945GCX:pvr3.0:rvnPCWARE:rnPW-945GCX:rvr3.0:cvnPCWARE:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: PW-945GCX
dmi.product.version: 3.0
dmi.sys.vendor: PCWARE
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-25-generic

Kees Cook (kees) on 2010-10-01
security vulnerability: yes → no
visibility: private → public
Daniel van Vugt (vanvugt) wrote :

Might be a duplicate of bug 694376, or vice-versa.

summary: package nvidia-173 (not installed) failed to install/upgrade: nvidia-173
- kernel module failed to build
+ kernel module failed to build (/var/lib/dkms/nvidia-173/173.14.22/build
+ /nv-kernel.o: file not recognized: File format not recognized)
Bryce Harrington (bryce) on 2011-12-02
description: updated
summary: package nvidia-173 (not installed) failed to install/upgrade: nvidia-173
kernel module failed to build (/var/lib/dkms/nvidia-173/173.14.22/build
- /nv-kernel.o: file not recognized: File format not recognized)
+ /nv-kernel.o: file not recognized: File format not recognized) [Lucid]
summary: package nvidia-173 (not installed) failed to install/upgrade: nvidia-173
kernel module failed to build (/var/lib/dkms/nvidia-173/173.14.22/build
- /nv-kernel.o: file not recognized: File format not recognized) [Lucid]
+ /nv-kernel.o: file not recognized: File format not recognized) [Lucid on
+ 2.6.32-25]
Changed in nvidia-graphics-drivers-173 (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers