package nvidia-glx-177 177.80-0ubuntu1 [modified: usr/bin/nvidia-bug-report.sh usr/bin/nvidia-xconfig usr/lib/xorg/modules/drivers/nvidia_drv.so usr/share/man/man1/nvidia-xconfig.1.gz] failed to install/upgrade: trying to overwrite `/usr/lib/xorg/modules/extensions/libglx.so', which is also in package xserver-xorg-core

Bug #283747 reported by Daniel on 2008-10-15
124
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-173 (Ubuntu)
Undecided
Unassigned
nvidia-graphics-drivers-177 (Ubuntu)
Undecided
Unassigned

Bug Description

I upgraded from hardy to intrepid and I am unable to install new nvidia driver.

I tried to install driver from nvidia and since than I can not install package from ubuntu.

daniel

ProblemType: Package
Architecture: amd64
DistroRelease: Ubuntu 8.10
ErrorMessage: trying to overwrite `/usr/lib/xorg/modules/extensions/libglx.so', which is also in package xserver-xorg-core
NonfreeKernelModules: cisco_ipsec nvidia
Package: nvidia-glx-177 177.80-0ubuntu1 [modified: usr/bin/nvidia-bug-report.sh usr/bin/nvidia-xconfig usr/lib/xorg/modules/drivers/nvidia_drv.so usr/share/man/man1/nvidia-xconfig.1.gz]
ProcVersion: Linux version 2.6.24-19-generic (buildd@king) (gcc version 4.2.3 (Ubuntu 4.2.3-2ubuntu7)) #1 SMP Wed Aug 20 17:53:40 UTC 2008

SourcePackage: nvidia-graphics-drivers-177
Title: package nvidia-glx-177 177.80-0ubuntu1 [modified: usr/bin/nvidia-bug-report.sh usr/bin/nvidia-xconfig usr/lib/xorg/modules/drivers/nvidia_drv.so usr/share/man/man1/nvidia-xconfig.1.gz] failed to install/upgrade: trying to overwrite `/usr/lib/xorg/modules/extensions/libglx.so', which is also in package xserver-xorg-core
Uname: Linux 2.6.24-19-generic x86_64
xkbcomp:

[lspci]
00:00.0 Host bridge [0600]: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub [8086:2a00] (rev 0c)
     Subsystem: Dell Device [1028:0275]
01:00.0 VGA compatible controller [0300]: nVidia Corporation GeForce 8600M GS [10de:0425] (rev a1)
     Subsystem: Dell Device [1028:0275]

Daniel (daniel-rezny-eu) wrote :
Alberto Milone (albertomilone) wrote :

can you post the output of this command?
ls -l /usr/lib/xorg/modules/extensions/

Hi,

here is it:
-rw-r--r-- 1 root root 18776 2008-10-10 13:09 libdbe.so
-rw-r--r-- 1 root root 39560 2008-10-10 13:09 libdri.so
-rw-r--r-- 1 root root 147656 2008-10-10 13:09 libextmod.so
-rwxr-xr-x 1 root root 1041184 2008-10-13 21:21 libglx.so.171.06.01
-rw-r--r-- 1 root root 31144 2008-10-10 13:09 librecord.so
-rw-r--r-- 1 root root 43488 2008-10-10 13:09 libxtrap.so

regards

daniel

Alberto Milone wrote:
> can you post the output of this command?
> ls -l /usr/lib/xorg/modules/extensions/
>
>

Alberto Milone (albertomilone) wrote :

Did you install the driver through the installer from NVIDIA's website too?

MD (sessorbsed) wrote :
Daniel (daniel-rezny-eu) wrote :

Yes I did.

daniel

Alberto Milone wrote:
> Did you install the driver through the installer from NVIDIA's website
> too?
>
>

M.Letcher (m-letcher) wrote :

Same problem with 173 and 177 on a 8800GT. I also tried the manual install of 177.80 from NV web site. Also noticed that displayconfig-gtk isn't around any more which was handy for setting the dual monitors without NV support. This is clean install from liveCD 8.10 this week. The generic driver from the liveCD at least supported the multiple resolutions and monitors, but now I can't do that and am considering another clean install and forgetting the NV drivers/effects. There's been problems with each U-upgrade, but this is pretty clearly a NV issue and I've forwarded concerns to them. I've got similar but less severe issues with their Vista drivers as well. Oh well. I'll keep looking through the forums and related bugs here to see if something installs, since there appears to be another couple reports related to this. Cheers

emillian (emilian-serbanescu) wrote :

I had the same error a few minutes ago.
First I installed drivers for my video card from NV website and after I installed envy package. I seems that Ubuntu recommended me 177.80 driver version and envy recommended 173 version. So i tried to change and activate 173 driver version from envy with gdm started. Envy crashed and after restart ubuntu gdm started in a low resolution. I tried to fix this but without any success. So I followed the steps from envy site:

First I redownloaded the NV driver from their website (because after I installed it i removed the installer package), then I pressed Ctrl+Alt+F1 and I logged in with my user and password. After I logged in I make myself root by typing:

"sudo su" and pressed enter key.
I stopped the gdm by running the command:

"/etc/init.d/gdm stop"

After this I change location to my NV installer location and then run the following command:

"sh NVIDIA_INSTALLER_NAME.sh --uninstall"

After this I started the envyng with:

"envyng -t"

and I followed the menu and when I finished I rebooted the computer.

Know it seems to recognized the NV driver (installed with Envyng - and everything works fine - except my screen refresh rate :|:|:| )
This worked for me. You can try it too, maybe will work.
More information you can find at this location:

http://www.albertomilone.com/envyngfaq.html#E

If you can help me with my screen refresh rate please send an email at emilian [dot] serbanescu [at] yahoo [dot] com to provide you with more information about my display and the problem that I have.

Thank You!
Emilian Serbanescu

Bryce Harrington (bryce) on 2008-11-14
Changed in nvidia-graphics-drivers-173:
status: New → Confirmed
Changed in nvidia-graphics-drivers-177:
status: New → Confirmed
Bryce Harrington (bryce) on 2009-01-16
description: updated
Bryce Harrington (bryce) wrote :

[This is an automated message]

In Jaunty (9.04), we are dropping the nvidia-graphics-drivers-177 package, which
is now superseded by then nvidia-graphics-drivers-180 package.

  http://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-180

To transition your bug into the new package, we need your help. Please do the following:

 a. Verify the bug occurs in Jaunty with the -180 driver
     (ISOs: http://cdimage.ubuntu.com/releases/jaunty/)
 b. If you haven't already, please include in the bug:
     * Your /var/log/Xorg.0.log
     * Your /etc/X11/xorg.conf
     * The output of `lspci -vvnn`
     * Steps to reproduce the issue
 c. Under Affects, click the down arrow to the left of 'nvidia-graphics-drivers-177'
 d. Edit the Package to change 'nvidia-graphics-drivers-177' to 'nvidia-graphics-drivers-180'
 e. Click Save Changes

Thank you!

[We'll expire the remaining -177 bugs in a month or so.]

Bryce Harrington (bryce) wrote :

[This is an automated message]

In Jaunty (9.04) we have dropped the nvidia-graphics-driver-177 package, as
it is superseded by nvidia-graphics-drivers-180.

Because of this, we are closing this bug as expired.

You are encouraged to file your -nvidia bug reports against the
nvidia-graphics-drivers-180 package.

Changed in nvidia-graphics-drivers-177:
status: Confirmed → Invalid
Bryce Harrington (bryce) on 2009-09-02
tags: added: intrepid
nion schneider (schnitzel5) wrote :

ckage nvidia-glx-177 177.80-0ubuntu1 [modified: usr/bin

Changed in nvidia-graphics-drivers-173 (Ubuntu):
status: Confirmed → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers