Hardware Acceleration Broken on Geforce FX 5200

Bug #1173890 reported by Joao Driessen on 2013-04-28
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-173 (Ubuntu)
Undecided
Unassigned

Bug Description

Hardware Acceleration is reported supported by the Nvidia-173 driver for this Device.

on clean install from ubuntu CD, unable to get to unity desktop (blank screen with cursor).

removing Nouveau and installing Nvidia-173 does not remedy the problem.

Garbage on screen during plymouth. No Hardware Acceleration avaiable for unity.

Compiz returning error messages.

effecting Ubuntu 13.04 12.10 12.04

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: xorg 1:7.7+1ubuntu4
ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
Uname: Linux 3.8.0-19-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.agp.card:
 Fast Writes: Supported
 SBA: Supported
 AGP Rates: 4x 2x 1x
 Registers: 0x1f000217:0x1f000104
.proc.driver.nvidia.agp.host.bridge:
 Host Bridge: PCI device 8086:1a30
 Fast Writes: Supported
 SBA: Supported
 AGP Rates: 4x 2x 1x
 Registers: 0x1f000217:0x00000104
.proc.driver.nvidia.agp.status:
 Status: Enabled
 Driver: AGPGART
 AGP Rate: 4x
 Fast Writes: Disabled
 SBA: Disabled
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 173.14.37 Wed Mar 6 16:56:05 PST 2013
 GCC version: gcc version 4.7.3 (Ubuntu/Linaro 4.7.3-1ubuntu1)
.tmp.unity.support.test.1:

ApportVersion: 2.9.2-0ubuntu8
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
Date: Sun Apr 28 11:25:47 2013
DistUpgraded: Fresh install
DistroCodename: raring
DistroVariant: ubuntu
DkmsStatus: nvidia-173, 173.14.37, 3.8.0-19-generic, i686: installed
ExtraDebuggingInterest: Yes
GraphicsCard: NVIDIA Corporation NV34 [GeForce FX 5200] [10de:0322] (rev a1) (prog-if 00 [VGA controller])
InstallationDate: Installed on 2013-04-22 (5 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha i386 (20130402.1)
Lsusb:
 Bus 002 Device 002: ID 12bd:d015
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Hewlett-Packard HP Vectra
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-19-generic root=UUID=9d67f927-723a-409b-b289-263f761640ef ro vesafb.invalid=1 splash nomodeset nopat quiet
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/19/2001
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: JA.01.04US
dmi.board.name: HP System Board
dmi.board.vendor: Hewlett-Packard
dmi.board.version: A08
dmi.chassis.type: 3
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Version 1.00
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrJA.01.04US:bd07/19/2001:svnHewlett-Packard:pnHPVectra:pvrVL420:rvnHewlett-Packard:rnHPSystemBoard:rvrA08:cvnHewlett-Packard:ct3:cvrVersion1.00:
dmi.product.name: HP Vectra
dmi.product.version: VL420
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.9~daily13.04.18.1~13.04-0ubuntu1
version.libdrm2: libdrm2 2.4.43-0ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 9.1.1-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.1.1-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.13.3-0ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2b2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.6-0ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
xserver.bootTime: Sun Apr 28 11:18:50 2013
xserver.configfile: /etc/X11/xorg.conf
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input Sleep Button KEYBOARD, id 8
 input AT Translated Set 2 keyboard KEYBOARD, id 9
 input ImPS/2 Generic Wheel Mouse MOUSE, id 10
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs: Output DFP-0
xserver.version: 2:1.13.3-0ubuntu6
xserver.video_driver: nvidia

Joao Driessen (joaodriessen) wrote :
Timo Aaltonen (tjaalton) wrote :

looks like the driver is blacklisted for unity

Not software rendered: [32;01myes[00m
Not blacklisted: [31;01mno[00m
GLX fbconfig: [32;01myes[00m
GLX texture from pixmap: [32;01myes[00m
GL npot or rect textures: [32;01myes[00m
GL vertex program: [32;01myes[00m
GL fragment program: [32;01myes[00m
GL vertex buffer object: [32;01myes[00m
GL framebuffer object: [32;01myes[00m
GL version is 1.4+: [32;01myes[00m

Unity 3D supported: [31;01mno[00m

affects: xorg (Ubuntu) → nvidia-graphics-drivers-173 (Ubuntu)
summary: - Nvidia Geforce FX 5200 3D not working
+ Hardware Acceleration Broken on Geforce FX 5200
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-173 (Ubuntu):
status: New → Confirmed
information type: Public → Public Security
information type: Public Security → Public
David Baucum (maxolasersquad) wrote :

I have a hp Compaq d530. It's got a Geforce Fx 5200. With the noveou drivers it runs but Unity is very slow. When I install nvidia-173 then the computer boots up in to a colored background with a cursor.

mauricio alcayaga (gusantor) wrote :

I also have a nvidia FX5200. Since I installed ubuntu 13.04, after login, I just can see black screen and cursor

I've tried some solving approaches but none of them has worked

Tobias Krais (tux-spam) wrote :

Same here on 14.04: nouveau very slow, nivida-173 with nice background and mouse arrow but nothing else.

Tobias Krais (tux-spam) wrote :

Use Gnome instead and your graphical interface will work - but not really nice.

To post a comment you must log in.