FFe: Sync nvidia-cuda-toolkit 8.0.44-1 (multiverse) from Debian experimental (non-free)

Bug #1630162 reported by Graham Inggs on 2016-10-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nvidia-cuda-toolkit (Ubuntu)
Wishlist
Unassigned

Bug Description

Please sync nvidia-cuda-toolkit 8.0.44-1 (multiverse) from Debian experimental (non-free)

Explanation of FeatureFreeze exception:
New upstream version with support for the latest GPU devices.
* Support for the Pascal GPU architecture, including the new Tesla P100, P40, and P4 accelerators;
* New Unified Memory capabilities;
* Native FP16 and INT8 computation for deep learning and other workloads;
* The new nvGRAPH GPU-Accelerated Graph Analytics library;
* Powerful new profiling capabilities;
* Improved compiler performance and heterogeneous lambda support; and
* Expanded developer platform support including Microsoft Visual Studio 2015 (updates 2 and 3) and GCC 5.4 (Ubuntu 16.04).
The packages contain pre-compiled binaries so there is no opportunity to backport fixes from future versions, so shipping the newest possible version in Ubuntu is desirable.

Note:
This has not been uploaded to Experimental yet (it was only released on 2016-09-29) and will need to clear Debian NEW, so I may end up uploading 8.0.44-0ubuntu1 directly (but using the same orig.tar.xz) as was done for LP: #1554716

I will tests snapshots of Debian's SVN in a PPA for amd64 and ppc64el.
Reverse-dependencies that need to be rebuilt: eztrace-contrib, hwloc-contrib, pycuda and starpu-contrib.

Graham Inggs (ginggs) on 2016-10-04
Changed in nvidia-cuda-toolkit (Ubuntu):
importance: Undecided → Wishlist
Stefano Rivera (stefanor) wrote :

Sure. If it seems to work.

Changed in nvidia-cuda-toolkit (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-cuda-toolkit - 8.0.44-0ubuntu1

---------------
nvidia-cuda-toolkit (8.0.44-0ubuntu1) yakkety; urgency=medium

  [ Graham Inggs ]
  * Upload from Debian pkg-nvidia's SVN. (LP: #1630162)

  [ Andreas Beckmann ]
  * New upstream release 8.0 (Sept 2016). (Closes: #822434)
  * Use gzip to compress orig tarballs containing already compressed files.
  * Revert the -D_FORCE_INLINES workaround.
  * gcc-support.patch: Remove, fixed upstream.
  * man-sections.patch, man-typos.patch, man-hyphenation.patch: Refresh.
  * Fix more typos found by Lintian.
  * Update Lintian overrides.

  [ Zhou Mo ]
  * SOVERSION bump: 7.5 => 8.0, rename all library packages.
  * Update symbols control files.
  * Ship new binary: gpu-library-advisor.
  * libnppial8.0: New package
  * libnppicc8.0: New package
  * libnppicom8.0: New package
  * libnppidei8.0: New package
  * libnppif8.0: New package
  * libnppig8.0: New package
  * libnppim8.0: New package
  * libnppist8.0: New package
  * libnppisu8.0: New package
  * libnppitc8.0: New package
  * libnvgraph8.0: New package for the nvGRAPH library.

 -- Graham Inggs <email address hidden> Wed, 12 Oct 2016 23:54:06 +0200

Changed in nvidia-cuda-toolkit (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers