[SRU] Nvidia and AMD graphics drivers should indicate whether they provide libcuda.so.1, libOpenCL.so.1, etc.

Bug #1129409 reported by Graham Inggs on 2013-02-18
556
This bug affects 188 people
Affects Status Importance Assigned to Milestone
boinc (Ubuntu)
Undecided
Gianfranco Costamagna
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
fglrx-installer (Ubuntu)
Medium
Alberto Milone
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
fglrx-installer-updates (Ubuntu)
Undecided
Alberto Milone
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
nvidia-cuda-toolkit (Debian)
Fix Released
Unknown
nvidia-cuda-toolkit (Ubuntu)
Undecided
Graham Inggs
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
nvidia-graphics-drivers-304 (Ubuntu)
Undecided
Alberto Milone
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
nvidia-graphics-drivers-304-updates (Ubuntu)
Undecided
Alberto Milone
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
nvidia-graphics-drivers-310-updates (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
nvidia-graphics-drivers-313-updates (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
nvidia-graphics-drivers-319 (Ubuntu)
Undecided
Alberto Milone
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
nvidia-graphics-drivers-319-updates (Ubuntu)
Undecided
Alberto Milone
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
nvidia-graphics-drivers-340 (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
pycuda (Ubuntu)
Undecided
Graham Inggs
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
pyopencl (Ubuntu)
Undecided
Graham Inggs
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
starpu-contrib (Ubuntu)
Undecided
Graham Inggs
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
viennacl (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned

Bug Description

[Impact]

* wine and fglrx are not coinstallable.

[Test Case]

 * try to install them
 * there is a conflict with libopencl1 in control file, preventing coinstallation.

The nvidia-cuda-toolkit package needs to depend on a minimum version of the CUDA library included in nvidia-graphics-drivers.
The current Debian version of nvidia-cuda-toolkit (5.0.35-4) does this on Debian systems by checking the version of libcuda1 and on Ubuntu systems by checking the version of nvidia-current, nvidia-curent-updates, nvidia-experimental-304 or nvidia-experimental-310.

It would greatly simplify maintenance of packages building against libcuda.so.1 and libOpenCL.so.1 if the nvidia-graphics drivers could provide virtual packages that reflect the API level, for example, libcuda-5.0-1 and libopencl-1.2-1.

It was decided that the nvidia drivers packages will provide libcuda-5.0-1, libopencl1 and opencl-icd (LP: #763457) virtual packages. Additionally, nvidia-*.shlibs would contain:
libOpenCL 1 libopencl1
libcuda 1 libcuda-5.0-1
libGL 1 libgl1

Similarly, the amd drivers package will provide libopencl1 and opencl-icd virtual packages, as well as an .shlibs containing:
libOpenCL 1 libopencl1
libGL 1 libgl1

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in boinc (Ubuntu):
status: New → Confirmed
Changed in nvidia-cuda-toolkit (Ubuntu):
status: New → Confirmed
Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
Changed in pycuda (Ubuntu):
status: New → Confirmed
Changed in starpu-contrib (Ubuntu):
status: New → Confirmed
Changed in viennacl (Ubuntu):
status: New → Confirmed
5 comments hidden view all 122 comments

what should we do on the boinc side?
the problem is in libcuda, not in boinc, right?

Graham Inggs (ginggs) wrote :

Right now, because of the dependency on nvidia-common, it is impossible to install boinc-nvidia-cuda on a system with any Nvidia driver other than nvidia-304 installed.

Because the Nvidia drivers in Ubuntu are packaged differently to Debian's, I do not know if it is possible to solve this without modifying boinc-nvidia-cuda, as was done in nvidia-cuda-toolkit, see:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=700621

I am hoping to get some feedback from Alberto Milone who packages the Nvidia drivers in Ubuntu.

Graham Inggs (ginggs) on 2013-06-04
summary: - nvidia-graphics-drivers should indicate which CUDA version they include
+ nvidia-graphics-drivers should indicate which versions of libcuda.so.1
+ and libOpenCL.so.1 they include
Graham Inggs (ginggs) on 2013-06-04
no longer affects: nvidia-graphics-drivers (Ubuntu)
Graham Inggs (ginggs) on 2013-06-04
description: updated

Fixed in 319.32-0ubuntu2

Changed in nvidia-graphics-drivers-319-updates (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
status: New → Fix Released
no longer affects: nvidia-graphics-drivers-310 (Ubuntu)
no longer affects: nvidia-graphics-drivers-313 (Ubuntu)
Changed in nvidia-graphics-drivers-319 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
status: New → Fix Released
Alberto Milone (albertomilone) wrote :

Also fixed in nvidia-graphics-drivers-304 (304.88-0ubuntu4) and nvidia-graphics-drivers-304-updates (304.88-0ubuntu5)

Changed in nvidia-graphics-drivers-304 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
status: New → Fix Released
Changed in nvidia-graphics-drivers-304-updates (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
status: New → Fix Released
Changed in nvidia-graphics-drivers-310-updates (Ubuntu):
status: New → Invalid
Changed in nvidia-graphics-drivers-313-updates (Ubuntu):
status: New → Invalid

Alberto I don't understand, should now ubuntu provide a libcuda1 package like debian does?

Alberto Milone (albertomilone) wrote :

the nvidia packages now provide the libcuda-5.0-1 and the libopencl1 virtual packages

Ok thanks, do you plan to release a libcuda1-ia32 package too?
http://packages.debian.org/it/squeeze/libcuda1-ia32

Changed in debian:
status: Unknown → New
Graham Inggs (ginggs) on 2013-07-15
no longer affects: debian
Changed in nvidia-cuda-toolkit (Ubuntu):
assignee: nobody → Graham Inggs (ginggs)
Changed in pycuda (Ubuntu):
assignee: nobody → Graham Inggs (ginggs)
Changed in pyopencl (Ubuntu):
assignee: nobody → Graham Inggs (ginggs)
Changed in starpu-contrib (Ubuntu):
assignee: nobody → Graham Inggs (ginggs)
Graham Inggs (ginggs) wrote :

pyopencl - sync request in LP: #1201078
pycuda - waiting on nvidia-cuda-toolkit
starpu-contrib - waiting on nvidia-cuda-toolkit and libGL shlibs

description: updated
Changed in nvidia-cuda-toolkit (Debian):
status: Unknown → Fix Released
Graham Inggs (ginggs) wrote :

nvidia-cuda-toolkit - sync request in LP: #1201949

Graham Inggs (ginggs) wrote :

Please merge pycuda 2013.1~git20130626-1 (multiverse) from Debian unstable (contrib)

pycuda (2013.1~git20130626-1) unstable; urgency=low

  * New upstream release, adding new CURAND support.

 -- Tomasz Rybak <email address hidden> Sun, 30 Jun 2013 18:10:45 +0200

pycuda (2013.1~git20130616-1) unstable; urgency=low

  * New upstream release.
  * Add Python 3 package.
  * Add *-dbg packages.
  * Remove *-headers package; upstream now ships headers in python directory.
  * Upstream switched to setuptools, update patches to deal with it.
  * Do not call dh_sphinxdoc for architecture dependent builds, build
    documentation in separate step in debian/rules.
  * Fix CUDA library build-dependencies, remove old libcuda1-dev.
  * Add README.source describing get-orig-source in debian/rules.
  * Disable package optimisation option as it might clash with hardening
    compile options.
  * Include tests (all files in test/) in documentation package.
  * Fix VCS-* fields to contain canonical URIs.
  * Update Standards-Version to 3.9.4; no changes necessary.

 -- Tomasz Rybak <email address hidden> Thu, 20 Jun 2013 19:41:29 +0200

Ubuntu changes:

pycuda (2012.1-1ubuntu4) saucy; urgency=low

  * No change rebuild for Boost 1.53 transition.

 -- Dmitrijs Ledkovs <email address hidden> Fri, 24 May 2013 16:11:59 +0100

pycuda (2012.1-1ubuntu3) raring; urgency=low

  * Locate current Nvidia driver directory using /etc/ld.so.conf.d.

 -- Graham Inggs <email address hidden> Wed, 20 Feb 2013 19:30:46 +0200

pycuda (2012.1-1ubuntu2) quantal; urgency=low

  * Only call dh_sphinxdoc if building Architecture: all packages, since it
    unhelpfully fails if it finds no Sphinx documentation.

 -- Colin Watson <email address hidden> Wed, 10 Oct 2012 13:01:50 +0100

pycuda (2012.1-1ubuntu1) quantal; urgency=low

  * Build with --cudadrv-lib-dir=/usr/lib/nvidia-current to fix build
    failure.

 -- Colin Watson <email address hidden> Tue, 09 Oct 2012 19:05:05 +0100

sphinx documentation issue fixed in Debian.
Remaining Ubuntu changes:
Build-depend on nvidia-current | libcuda-5.0-1 (LP: #1129409).
Locate current Nvidia driver directory using /etc/ld.so.conf.d.

Graham Inggs (ginggs) on 2013-07-16
Changed in viennacl (Ubuntu):
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pyopencl (Ubuntu):
status: New → Confirmed
Graham Inggs (ginggs) on 2013-07-17
Changed in nvidia-cuda-toolkit (Ubuntu):
status: Confirmed → Fix Released
Graham Inggs (ginggs) on 2013-07-19
summary: - nvidia-graphics-drivers should indicate which versions of libcuda.so.1
- and libOpenCL.so.1 they include
+ Nvidia and AMD graphics drivers should indicate whether they provide
+ libcuda.so.1, libOpenCL.so.1, etc.
description: updated

Please merge starpu-contrib 1.0.5-1 (multiverse) from Debian unstable (contrib)

starpu-contrib (1.0.5-1) unstable; urgency=low

  * New upstream release.
  * Move starpu_top.1.gz to starpu-top package.
  * control, rules: upgrade to gcc-4.7.
  * control: Make libstarpu-dev also depend on libstarpufft and libstarpumpi
    (Closes: Bug#715121).
  * Bump Standards-Version to 3.9.4 (no changes).
  * patches/mpi_link: disable using mpicc --showme:link link flags: they bring
    unnecessary rpath.

 -- Samuel Thibault <email address hidden> Sat, 06 Jul 2013 09:42:41 +0200

Remaining Ubuntu changes:
* Build-depend on nvidia-current | libcuda-5.0-1 (LP: #1129409).
* Locate current Nvidia driver directory using /etc/ld.so.conf.d.

Changed in pyopencl (Ubuntu):
status: Confirmed → Fix Released
Changed in pycuda (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pycuda - 2013.1~git20130626-1ubuntu1

---------------
pycuda (2013.1~git20130626-1ubuntu1) saucy; urgency=low

  * Build-depend on nvidia-current | libcuda-5.0-1 (LP: #1129409).
  * Locate current Nvidia driver directory using /etc/ld.so.conf.d.
 -- Graham Inggs <email address hidden> Sun, 14 Jul 2013 12:22:51 +0200

Changed in pycuda (Ubuntu):
status: In Progress → Fix Released
Graham Inggs (ginggs) wrote :

@Sponsors Team: Please don't forget the starpu-contrib merge in comment #18.

Iain Lane (laney) wrote :

alternate build-depends don't really work - we always choose the first one. So I removed your first option & we'll use nvidia-current (please file another request if this should be changed). I also fixed the PPA version number. I'll now upload. Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package starpu-contrib - 1.0.5-1ubuntu1

---------------
starpu-contrib (1.0.5-1ubuntu1) saucy; urgency=low

  * Build-depend on nvidia-current | libcuda-5.0-1 (LP: #1129409).
  * Locate current Nvidia driver directory using /etc/ld.so.conf.d.

starpu-contrib (1.0.5-1) unstable; urgency=low

  * New upstream release.
  * Move starpu_top.1.gz to starpu-top package.
  * control, rules: upgrade to gcc-4.7.
  * control: Make libstarpu-dev also depend on libstarpufft and libstarpumpi
    (Closes: Bug#715121).
  * Bump Standards-Version to 3.9.4 (no changes).
  * patches/mpi_link: disable using mpicc --showme:link link flags: they bring
    unnecessary rpath.
 -- Graham Inggs <email address hidden> Thu, 25 Jul 2013 14:13:36 +0200

Changed in starpu-contrib (Ubuntu):
status: Confirmed → Fix Released
Graham Inggs (ginggs) wrote :

@laney: The way you did it is fine for Ubuntu, we don't have a libcuda1. Thanks for uploading!

Fix released on debian, this bug will be automatically fixed on the next sync

Changed in boinc (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → LocutusOfBorg (costamagnagianfranco)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package boinc - 7.2.22+dfsg-1

---------------
boinc (7.2.22+dfsg-1) unstable; urgency=low

  [ Gianfranco Costamagna ]
  * New upstream release

  [ Guo Yixuan ]
  * Removed boinc-amd-opencl, since fglrx-driver was removed from testing.

 -- Guo Yixuan <email address hidden> Sat, 19 Oct 2013 00:05:53 -0400

Changed in boinc (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in fglrx-installer (Ubuntu):
status: New → Confirmed
Changed in fglrx-installer-updates (Ubuntu):
status: New → Confirmed
1 comments hidden view all 122 comments
Scott Ritchie (scottritchie) wrote :

I'll note that wine and fglrx are not currently coinstallable due to this bug: https://bugs.launchpad.net/ubuntu/+source/wine1.6/+bug/1376587

Changed in fglrx-installer (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
status: Confirmed → Triaged
Changed in fglrx-installer-updates (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in fglrx-installer (Ubuntu):
importance: Undecided → Medium
status: Triaged → In Progress
Dmitry (talk-r) wrote :

Any news on it?

"Medium" importance? That users can't install fglrx and wine together? That's a game-breaker for a lot of people, I'd say. A lot more important than merely "medium".

Graham Inggs (ginggs) wrote :

See: https://wiki.ubuntu.com/Bugs/Bug%20importances

Most bugs are of medium importance, examples are:
* A bug that has a severe impact on a non-core application.
* A problem with a non-essential hardware component (removable network card, camera, webcam, music player, sound card, power management feature, printer, etc.)

Joakim (joakimuone) wrote :

According to that page, it should be rated as high importance.

* Has a severe impact on a small portion of Ubuntu users (estimated)
Yes, all users who wants to use fglrx and wine.
* A problem with an essential hardware component (disk controller, built-in networking, video card, keyboard, mouse)
Yes, package conflict for the video card driver.
* Prevents the application or any dependencies from functioning correctly at all
Yes, both wine and fglrx.
* Renders essential features or functionality of the application or dependencies broken or ineffective
Yes, both wine and fglrx.
* Impacts accessibility of a core application
Yes, fglrx.

You can't even get build-dep for wine.

Nevertheless, fixing this bug should be done before the final release of Ubuntu 14.10. If it can not be fixed easily, it would be better to remove the conflicting dependency from wine. Only a few users would be effected and they can fix it themselves by installing the necessary packages manually.

On 22-10-14 20:34:24, Joakim wrote:
> According to that page, it should be rated as high importance.
>
> * Has a severe impact on a small portion of Ubuntu users (estimated)
> Yes, all users who wants to use fglrx and wine.
> * A problem with an essential hardware component (disk controller, built-in networking, video card, keyboard, mouse)
> Yes, package conflict for the video card driver.
> * Prevents the application or any dependencies from functioning correctly at all
> Yes, both wine and fglrx.
> * Renders essential features or functionality of the application or dependencies broken or ineffective
> Yes, both wine and fglrx.
> * Impacts accessibility of a core application
> Yes, fglrx.
>
> You can't even get build-dep for wine.
>
> Nevertheless, fixing this bug should be done before the final release of
> Ubuntu 14.10. If it can not be fixed easily, it would be better to
> remove the conflicting dependency from wine. Only a few users would be
> effected and they can fix it themselves by installing the necessary
> packages manually.

The wine package lives in the universe repository, and this excludes it
from the essential and core packages (that usually live in main or
restricted).

The graphics driver provides core functionalities, wine does not. The
bug priority is right.

It was/is too late to fix this bug report for fglrx in 14.10, which also
depended on LP: #1382086 and LP: #1382091 (both fixed only a few hours
ago). I'll have to fix this in 15.04 (the next development release)
first, only then will it be reasonable to backport the fix.

Any news on a fix ?!? this is critical, not being able to use WINE in a deployment setting is a big NO

Paweł (mazur92) wrote :

So you're basically saying that we have to wait half a year to use both wine and fglrx? I'm not even sure if I will be able to build wine by myself with all this dependency hell around.

I'm afraid that I cannot wait 6 months for this to be fixed. It renders 14.10 useless for me, and I would have no choice other than to go back to 14.04

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: New → Confirmed

So what is the timeframe on this fix? I want to know whether nor not I need to downgrade to 14.04 for now.

Because of this critical bug I am downgrading to 14.04. This is the sort of problem that should be fixed in the beta.

Scott Ritchie (scottritchie) wrote :

You're not waiting 6 months for a fix -- you're waiting for the update to hit the vivid alpha archive before it then gets converted into an SRU to utopic.

Changed in fglrx-installer-updates (Ubuntu):
status: Confirmed → In Progress
Graham Inggs (ginggs) on 2015-02-25
Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: Confirmed → Invalid
Changed in fglrx-installer (Ubuntu):
status: In Progress → Fix Released
Changed in fglrx-installer-updates (Ubuntu):
status: In Progress → Fix Released
Graham Inggs (ginggs) on 2015-03-11
Changed in fglrx-installer (Ubuntu Trusty):
status: New → Confirmed
Changed in fglrx-installer (Ubuntu Utopic):
status: New → Confirmed
Changed in fglrx-installer-updates (Ubuntu Trusty):
status: New → Confirmed
Changed in fglrx-installer-updates (Ubuntu Utopic):
status: New → Confirmed
Changed in boinc (Ubuntu Trusty):
status: New → Invalid
Changed in boinc (Ubuntu Utopic):
status: New → Invalid
Changed in nvidia-cuda-toolkit (Ubuntu Trusty):
status: New → Invalid
Changed in nvidia-cuda-toolkit (Ubuntu Utopic):
status: New → Invalid
Changed in nvidia-graphics-drivers-304 (Ubuntu Trusty):
status: New → Invalid
Changed in nvidia-graphics-drivers-304 (Ubuntu Utopic):
status: New → Invalid
Graham Inggs (ginggs) on 2015-03-11
Changed in nvidia-graphics-drivers-304-updates (Ubuntu Trusty):
status: New → Invalid
Changed in nvidia-graphics-drivers-304-updates (Ubuntu Utopic):
status: New → Invalid
Changed in nvidia-graphics-drivers-310-updates (Ubuntu Trusty):
status: New → Invalid
Changed in nvidia-graphics-drivers-310-updates (Ubuntu Utopic):
status: New → Invalid
Changed in nvidia-graphics-drivers-313-updates (Ubuntu Trusty):
status: New → Invalid
Changed in nvidia-graphics-drivers-313-updates (Ubuntu Utopic):
status: New → Invalid
Changed in nvidia-graphics-drivers-319 (Ubuntu Trusty):
status: New → Invalid
Changed in nvidia-graphics-drivers-319 (Ubuntu Utopic):
status: New → Invalid
Changed in nvidia-graphics-drivers-319-updates (Ubuntu Trusty):
status: New → Invalid
Changed in nvidia-graphics-drivers-319-updates (Ubuntu Utopic):
status: New → Invalid
Changed in nvidia-graphics-drivers-340 (Ubuntu Trusty):
status: New → Invalid
Graham Inggs (ginggs) on 2015-03-11
Changed in nvidia-graphics-drivers-340 (Ubuntu Utopic):
status: New → Invalid
Changed in pycuda (Ubuntu Trusty):
status: New → Invalid
Changed in pycuda (Ubuntu Utopic):
status: New → Invalid
Changed in pyopencl (Ubuntu Trusty):
status: New → Invalid
Changed in pyopencl (Ubuntu Utopic):
status: New → Invalid
Changed in starpu-contrib (Ubuntu Trusty):
status: New → Invalid
Changed in starpu-contrib (Ubuntu Utopic):
status: New → Invalid
Changed in viennacl (Ubuntu Trusty):
status: New → Invalid
Changed in viennacl (Ubuntu Utopic):
status: New → Invalid
42 comments hidden view all 122 comments

hi @nukedathlonman I suggest you to propose a patch :)

@graham in my tests on trusty I can install both wine and fglrx together.

I can't install wine and nvidia-331-updates or nvidia-libopencl1-331-updates together.

So it seems a different bug, right?

Graham Inggs (ginggs) wrote :

> in my tests on trusty I can install both wine and fglrx together.
>
> I can't install wine and nvidia-331-updates or nvidia-libopencl1-331-updates together.

That is really strange. Just yesterday I tested that I could get wine and darktable working with OpenCL on NVIDIA, see LP: #1320217 comment 14.

What error message do you see?

Dan Muresan (danmbox) wrote :

The vivd package *still* doesn't provide opencl-icd, so after installing fglrx, python-pyopencl tries to pull in beignet...

@Graham

sudo apt-get install nvidia-libopencl1-331-updates wine
Reading package lists... Done
Building dependency tree
Reading state information... Done
nvidia-libopencl1-331-updates is already the newest version.
nvidia-libopencl1-331-updates set to manually installed.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine : Depends: wine1.6 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

------------------------------

sudo apt-get install wine
[snip]
The following packages will be REMOVED:
  nvidia-libopencl1-331-updates

ubuntu 14.04 with latest updates.

Graham Inggs (ginggs) wrote :

@danmbox:
> The vivd package *still* doesn't provide opencl-icd, so after installing
> fglrx, python-pyopencl tries to pull in beignet...

It seems this bug still needs some work in Vivid then.
Both fglrx-core and fglrx-updates-core should Provides: opencl-icd as they both ship /etc/OpenCL/vendors/*.icd.

Changed in fglrx-installer (Ubuntu):
status: Fix Released → Confirmed
Changed in fglrx-installer-updates (Ubuntu):
status: Fix Released → Confirmed
Graham Inggs (ginggs) wrote :

@LocutusOfBorg:
> The following packages will be REMOVED:
> nvidia-libopencl1-331-updates

That is the expect behaviour.

The NVIDIA OpenCL loader needs to be replaced by the OpenCL loader from ocl-icd-libopencl1 (the one which WINE was compiled against). (see LP: #1333008)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:15.200-0ubuntu2

---------------
fglrx-installer (2:15.200-0ubuntu2) vivid; urgency=medium

  * debian/control.in:
    - Provide opencl-icd (LP: #1129409).
 -- Alberto Milone <email address hidden> Thu, 19 Mar 2015 12:25:58 +0100

Changed in fglrx-installer (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer-updates - 2:15.200-0ubuntu2

---------------
fglrx-installer-updates (2:15.200-0ubuntu2) vivid; urgency=medium

  * debian/control.in:
    - Provide opencl-icd (LP: #1129409).
 -- Alberto Milone <email address hidden> Thu, 19 Mar 2015 12:34:49 +0100

Changed in fglrx-installer-updates (Ubuntu):
status: Confirmed → Fix Released

Can anybody please follow up with the SRU?
alsot this patch should be applied, right?
http://launchpadlibrarian.net/200634903/fglrx-installer_2%3A15.200-0ubuntu1_2%3A15.200-0ubuntu2.diff.gz

Graham Inggs (ginggs) wrote :

> Can anybody please follow up with the SRU?

For the SRU to happen, this bug description needs to be updated with the SRU template:
https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template
Then debdiffs for fglrx-installer and fglrx-installer-updates need to be attached (preferably after some positive feedback after testing in a PPA).
Then ubuntu-sponsors need to be subscribed (these packages are in the 'restricted' component, so I can't upload).

> alsot this patch should be applied, right?

Yes, we need Provides: opencl-icd. Let's wait a little to hear that this bug is now properly fixed in Vivid.

utopic debdiff for installer

utopic debdiff for updates

Uploading on ppa:costamagnagianfranco/locutusofborg-ppa

I don't know about the trusty fix.

summary: - Nvidia and AMD graphics drivers should indicate whether they provide
- libcuda.so.1, libOpenCL.so.1, etc.
+ [SRU] Nvidia and AMD graphics drivers should indicate whether they
+ provide libcuda.so.1, libOpenCL.so.1, etc.
description: updated

Hello Graham, or anyone else affected,

Accepted fglrx-installer-updates into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/fglrx-installer-updates/2:15.200-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in fglrx-installer-updates (Ubuntu Trusty):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in fglrx-installer (Ubuntu Trusty):
status: Confirmed → Fix Committed
Chris J Arges (arges) wrote :

Hello Graham, or anyone else affected,

Accepted fglrx-installer into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/fglrx-installer/2:15.200-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

And utopic?

they are both in the new queue... waiting for -release members to approve them

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of fglrx-installer-updates from trusty-proposed was performed and bug 1443016 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and tag 1443016 "bot-stop-nagging". Thanks!

tags: added: verification-failed
Tim Lunn (darkxst) wrote :

somebody uploaded the vivid fglrx to trusty-proposed!

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of fglrx-installer from trusty-proposed was performed and bug 1443668 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that bug 1443668 is not a regression, tag it "bot-stop-nagging". Thanks!

I've just uploaded fglrx-installer and fglrx-installer-updates 15.200-0ubuntu0.2 in trusty-proposed. They fix the regression described in LP: #1443668. Please accept them into trusty-proposed.

Hello Graham, or anyone else affected,

Accepted fglrx-installer into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fglrx-installer/2:14.201-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in fglrx-installer (Ubuntu Utopic):
status: Confirmed → Fix Committed
tags: removed: verification-failed
Changed in fglrx-installer-updates (Ubuntu Utopic):
status: Confirmed → Fix Committed
Timo Aaltonen (tjaalton) wrote :

Hello Graham, or anyone else affected,

Accepted fglrx-installer-updates into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fglrx-installer-updates/2:14.201-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

I tested it and I succeeded in installing them together.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for fglrx-installer has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer-updates - 2:14.201-0ubuntu2.1

---------------
fglrx-installer-updates (2:14.201-0ubuntu2.1) utopic-proposed; urgency=medium

  * debian/control.in:
    - Drop conflicts/provides/replaces libopencl1 and
      provide opencl-icd (LP: #1129409).
 -- Alberto Milone <email address hidden> Fri, 10 Apr 2015 11:59:34 +0200

Changed in fglrx-installer-updates (Ubuntu Utopic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:14.201-0ubuntu2.1

---------------
fglrx-installer (2:14.201-0ubuntu2.1) utopic-proposed; urgency=medium

  * debian/control.in:
    - Drop conflicts/provides/replaces libopencl1 and
      provide opencl-icd (LP: #1129409).
 -- Alberto Milone <email address hidden> Fri, 10 Apr 2015 11:41:45 +0200

Changed in fglrx-installer (Ubuntu Utopic):
status: Fix Committed → Fix Released

Hello Graham, or anyone else affected,

Accepted fglrx-installer into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fglrx-installer/2:15.200-0ubuntu0.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Chris J Arges (arges) wrote :

Hello Graham, or anyone else affected,

Accepted fglrx-installer-updates into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/fglrx-installer-updates/2:15.200-0ubuntu0.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

I could install fglrx-installer and wine1.6 together. everything seems fine to me.

thanks for fixing!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer - 2:15.200-0ubuntu0.3

---------------
fglrx-installer (2:15.200-0ubuntu0.3) trusty-proposed; urgency=medium

  * debian/fglrx.preinst.in, debian/fglrx.postinst.in:
    - Work around regression when upgrading from releases that do
      not have the -core package. For some reason, the
      update-alternatives command would remove newly installed
      files when previous versions of the same files belonged to
      the previous alternative (LP: #1443016, LP: #1129409).

fglrx-installer (2:15.200-0ubuntu0.2) trusty-proposed; urgency=medium

  * debian/control.in:
    - Allow the -core package to overwrite files that belong to
      fglrx. This prevents errors caused by the split into fglrx
      and fglrx-core (LP: #1443016, LP: #1129409).

fglrx-installer (2:15.200-0ubuntu0.1) trusty-proposed; urgency=medium

  * New upstream release:
    - Add support for X ABI 19.
  * debian/control.in, debian/com.ubuntu.amdcccle.pkexec.policy,
    debian/rules, debian/fglrx.dirs.in,
    debian/fglrx.install.in,
    debian/fglrx.links.in,
    debian/fglrx.postinst.in,
    debian/fglrx.postrm.in,
    debian/fglrx.preinst.in,
    debian/fglrx.prerm.in,
    debian/fglrx.grub-gfxpayload.in,
    debian/overrides/fglrx.in,
    debian/overrides/fglrx-core.in,
    debian/overrides/fglrx-dev.in,
    debian/fglrx-amdcccle.dirs.in,
    debian/fglrx-amdcccle.install.in,
    debian/fglrx-core.dirs.in,
    debian/fglrx-core.links.in,
    debian/fglrx-core.postinst.in,
    debian/fglrx-core.postrm.in,
    debian/fglrx-core.preinst.in,
    debian/fglrx-core.prerm.in,
    debian/fglrx-core.postrm.in:
    - Drop conflicts/provides/replaces libopencl1 and provide
      opencl-icd (LP: #1129409).
    - Make amdcccle depend on polkit-1.
    - Use pkexec for amdcccle when running Unity.
    - Split the minimal driver into the -core package.
    - Depend on the "file" package.
  * debian/fglrx-dev.links.in:
    - Add links for libOpenCL libGL.so, libAMDXvBA, libXvBAW.
  * debian/substvars:
    - Add support for X ABI 18 and 19.
  * debian/patches/series, amdxdg-su-add-support-for-pkexec.patch:
    - Leave the patch disabled for future reference and easier
      backporting.
  * debian/patches/call-amdcccle-with-full-path.diff:
    - Pass amdxdg the full path.
  * debian/dkms.conf.in,
    debian/dkms/patches/buildfix_kernel_3.15.patch,
    debian/dkms/patches/buildfix_kernel_3.17.patch,
    debian/dkms/patches/buildfix_kernel_3.19.patch:
    - Add support for Linux 3.15-3.19.
    - Leave the patches disabled for future reference and easier
      backporting.
    - Correct a typo that caused an incorrect dkms.conf to be
      generated from the template.
  * debian/71-fglrx.rules:
    - Tag the device for logind.

 -- Alberto Milone <email address hidden> Tue, 28 Apr 2015 17:00:05 +0200

Changed in fglrx-installer (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package fglrx-installer-updates - 2:15.200-0ubuntu0.3

---------------
fglrx-installer-updates (2:15.200-0ubuntu0.3) trusty-proposed; urgency=medium

  * debian/fglrx.preinst.in, debian/fglrx.postinst.in:
    - Work around regression when upgrading from releases that do
      not have the -core package. For some reason, the
      update-alternatives command would remove newly installed
      files when previous versions of the same files belonged to
      the previous alternative (LP: #1443016, LP: #1129409).

fglrx-installer-updates (2:15.200-0ubuntu0.2) trusty-proposed; urgency=medium

  * debian/control.in:
    - Allow the -core package to overwrite files that belong to
      fglrx. This prevents errors caused by the split into fglrx
      and fglrx-core (LP: #1443016, LP: #1129409).

fglrx-installer-updates (2:15.200-0ubuntu0.1) trusty-proposed; urgency=medium

  * New upstream release:
    - Add support for X ABI 19.
  * debian/control.in, debian/com.ubuntu.amdcccle.pkexec.policy,
    debian/rules, debian/fglrx-updates.dirs.in,
    debian/fglrx-updates.install.in,
    debian/fglrx-updates.links.in,
    debian/fglrx-updates.postinst.in,
    debian/fglrx-updates.postrm.in,
    debian/fglrx-updates.preinst.in,
    debian/fglrx-updates.prerm.in,
    debian/fglrx-updates.grub-gfxpayload.in,
    debian/overrides/fglrx-updates.in,
    debian/overrides/fglrx-updates-core.in,
    debian/overrides/fglrx-updates-dev.in,
    debian/fglrx-amdcccle-updates.dirs.in,
    debian/fglrx-amdcccle-updates.install.in,
    debian/fglrx-updates-core.dirs.in,
    debian/fglrx-updates-core.links.in,
    debian/fglrx-updates-core.postinst.in,
    debian/fglrx-updates-core.postrm.in,
    debian/fglrx-updates-core.preinst.in,
    debian/fglrx-updates-core.prerm.in,
    debian/fglrx-updates-core.postrm.in:
    - Drop conflicts/provides/replaces libopencl1 and provide
      opencl-icd (LP: #1129409).
    - Make amdcccle depend on polkit-1.
    - Use pkexec for amdcccle when running Unity.
    - Split the minimal driver into the -core package.
    - Depend on the "file" package.
  * debian/fglrx-updates-dev.links.in:
    - Add links for libOpenCL libGL.so, libAMDXvBA, libXvBAW.
  * debian/substvars:
    - Add support for X ABI 18 and 19.
  * debian/patches/series, amdxdg-su-add-support-for-pkexec.patch:
    - Leave the patch disabled for future reference and easier
      backporting.
  * debian/patches/call-amdcccle-with-full-path.diff:
    - Pass amdxdg the full path.
  * debian/dkms.conf.in,
    debian/dkms/patches/buildfix_kernel_3.15.patch,
    debian/dkms/patches/buildfix_kernel_3.17.patch,
    debian/dkms/patches/buildfix_kernel_3.19.patch:
    - Add support for Linux 3.15-3.19.
    - Leave the patches disabled for future reference and easier
      backporting.
    - Correct a typo that caused an incorrect dkms.conf to be
      generated from the template.
  * debian/71-fglrx.rules:
    - Tag the device for logind.

 -- Alberto Milone <email address hidden> Tue, 28 Apr 2015 17:13:24 +0200

Changed in fglrx-installer-updates (Ubuntu Trusty):
status: Fix Committed → Fix Released
oriolpont (oriolpont) wrote :

It is still not fixed for me: If we do not explicitly provide libopencl1, wine still requires ocl-icd-libopencl1 which installs a conflicting libOpenCL.so

Graham Inggs (ginggs) wrote :

@oriolpont: when you install wine, nvidia-libopencl1-* should be removed and ocl-icd-libopencl1 should be installed, nvidia-opencl-icd-* should remain in place.
You can have multiple OpenCL ICDs installed, but only one OpenCL ICD Loader (libOpenCL.so).

oriolpont (oriolpont) wrote :

That is the problem: There should be only one loader but there are two of them. fglrx at least (I ignore what is the case for nvidia) provides its own at /usr/lib/libOpenCL.so.1 and this conflicts with the one by ocl-icd-libopencl1 that goes to /usr/lib/x86_64-linux-gnu/libOpenCL.so.1. Both are the same version and the latter takes precedence, which is not what some software expects.

Graham Inggs (ginggs) wrote :

I suppose fglrx should split /usr/lib/libOpenCL.so.1 into a separate package that conflicts with ocl-icd-libopencl1.
But, seeing that the files do not collide, and that /usr/lib/x86_64-linux-gnu/libOpenCL.so.1 takes precedence (which I believe is what we want to be able to use OpenCL applications from the Ubuntu repositories), what is the problem?

oriolpont (oriolpont) wrote :

It is nearly impossible to know what the OpenCL programs require specifically. E.g., I did some testing and boinc-amd-opencl seems to work with the ICD loader by ocl-icd-libopencl1 but not with the specific one by fglrx; on the contrary, oclHashcat needs the specific libOpenCL.so.1 by fglrx but fails to run with the other; and yet sgminer will run with either.

On the other hand, in a 64-bit system it is not enough to provide libopencl1 (as I suggested in #117) because wine depends on wine-i386 (and so on libopencl1:i386 too), but awkwardly fglrx-core:amd64 installs the 32-bit /usr/lib32/libOpenCL.so.1.

Graham Inggs (ginggs) wrote :

@oriolpont: fglrx-installer has been removed from Xenial, so having two loaders should no longer be a problem.

Displaying first 40 and last 40 comments. View all 122 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.