[natty] /etc/kernel/postinst.d/nvidia-common: line 8: [: too many arguments

Bug #698327 reported by Philip Muškovac
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
nvidia-common (Ubuntu)
Fix Released
High
Alberto Milone

Bug Description

Binary package hint: nvidia-common

on todays updates I got:

update-initramfs: Generating /boot/initrd.img-2.6.37-12-generic
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/dkms 2.6.37-12-generic /boot/vmlinuz-2.6.37-12-generic
 * dkms: running auto installation service for kernel 2.6.37-12-generic

 * nvidia-current (260.19.29)...
   ...done.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 2.6.37-12-generic /boot/vmlinuz-2.6.37-12-generic
run-parts: executing /etc/kernel/postinst.d/nvidia-common 2.6.37-12-generic /boot/vmlinuz-2.6.37-12-generic
/etc/kernel/postinst.d/nvidia-common: line 8: [: too many arguments
run-parts: executing /etc/kernel/postinst.d/pm-utils 2.6.37-12-generic /boot/vmlinuz-2.6.37-12-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 2.6.37-12-generic /boot/vmlinuz-2.6.37-12-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 2.6.37-12-generic /boot/vmlinuz-2.6.37-12-generic

nvidia-detector returns:
NVIDIA card found (10de:0615)
Card 10de:0615 supported by driver 1000
none

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: nvidia-common 0.2.26
ProcVersionSignature: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
Uname: Linux 2.6.37-11-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Jan 6 22:32:15 2011
InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
 LANGUAGE=en_US.UTF-8
SourcePackage: nvidia-common

Revision history for this message
Philip Muškovac (yofel) wrote :
Revision history for this message
fejes (anthony-fejes) wrote :

Saw the same thing this evening. when apt-gets spat out errors about linux-generic being only half configured. Ended up running:

sudo dpkg -C
sudo dpkg --configure linux-image-2.6.37-12-generic
sudo dpkg --configure linux-image-generic
sudo dpkg --configure linux-generic

but saw the same error during the configure of linux-image-2.6.37-12-generic.

Revision history for this message
Fabien Tassin (fta) wrote :

Similar issue here.
Attached the scary alert I got during the last upgrade.

# nvidia-detector
NVIDIA card found (10de:0392)
Card 10de:0392 supported by driver 1000
Card 10de:0392 supported by driver 173
Card 10de:0392 supported by driver 96
none
# lspci -v -s 01:00.0
01:00.0 VGA compatible controller: nVidia Corporation G73 [GeForce 7600 GS] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: Micro-Star International Co., Ltd. Device 0413
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        Memory at fc000000 (64-bit, non-prefetchable) [size=16M]
        I/O ports at cc00 [size=128]
        [virtual] Expansion ROM at fe8e0000 [disabled] [size=128K]
        Capabilities: [60] Power Management version 2
        Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [78] Express Endpoint, MSI 00
        Capabilities: [100] Virtual Channel
        Capabilities: [128] Power Budgeting <?>
        Kernel driver in use: nvidia
        Kernel modules: nvidia-current, nouveau, nvidiafb

Changed in nvidia-common (Ubuntu):
status: New → Confirmed
Changed in nvidia-common (Ubuntu):
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-common - 0.2.27

---------------
nvidia-common (0.2.27) natty; urgency=low

  * nvidia-detector:
    - Initialise NvidiaDetection() with verbose=False. This should avoid
      problems when dealing with debconf (LP: #698327).
 -- Alberto Milone <email address hidden> Tue, 18 Jan 2011 18:15:44 +0100

Changed in nvidia-common (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers