Ubuntu

package linux-image-2.6.32-23-generic 2.6.32-23.37 failed to install/upgrade: run-parts: /etc/kernel/postinst.d/nvidia-common exited with return code 10

Reported by tburdge on 2010-07-03
950
This bug affects 96 people
Affects Status Importance Assigned to Milestone
nvidia-common (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: nvidia-common

1) Release: Ubuntu 10.04LTS
2) Package version: nvidia-common 0.2.23
3) Expected: Successful Automatic upgrade
4) Result: Update failed

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: linux-image-2.6.32-23-generic 2.6.32-23.37
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
NonfreeKernelModules: wl
Architecture: i386
CheckboxSubmission: 4efa57980ec17be6c95a814cbd747dd6
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Sat Jul 3 10:37:59 2010
ErrorMessage: run-parts: /etc/kernel/postinst.d/nvidia-common exited with return code 10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
SourcePackage: nvidia-common
Title: package linux-image-2.6.32-23-generic 2.6.32-23.37 failed to install/upgrade: run-parts: /etc/kernel/postinst.d/nvidia-common exited with return code 10

tburdge (tburdge222) wrote :
Jean-Baptiste Lallement (jibel) wrote :

I'm confirming this is issue because of duplicates.
This is similar to bug 303825 which was fixed in intrepid.

Changed in nvidia-common (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

Could someone affected by this error add the line 'set -x' (without the quotes) as 2nd line of the file /etc/kernel/header_postinst.d/nvidia-common , then open a terminal and run the command:
$ DEBCONF_DEBUG='developer' sudo /etc/kernel/header_postinst.d/nvidia-common

And attach the output of the command to this report. Thanks in advance.

Changed in nvidia-common (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Incomplete
LAZA (laza74) wrote :

Here the desired report:

~$ sudo DEBCONF_DEBUG='developer' sudo /etc/kernel/header_postinst.d/nvidia-common
[sudo] password for laza:
+ . /usr/share/debconf/confmodule
++ '[' '!' '' ']'
++ PERL_DL_NONLAZY=1
++ export PERL_DL_NONLAZY
++ '[' '' ']'
++ exec /usr/share/debconf/frontend /etc/kernel/header_postinst.d/nvidia-common
+ . /usr/share/debconf/confmodule
++ '[' '!' 1 ']'
++ '[' -z '' ']'
++ exec
++ '[' '' ']'
++ exec
++ DEBCONF_REDIR=1
++ export DEBCONF_REDIR
+ db_set nvidia-common/obsolete-driver false
+ _db_cmd 'SET nvidia-common/obsolete-driver' false
+ IFS=' '
+ printf '%s\n' 'SET nvidia-common/obsolete-driver false'
+ IFS='
'
+ read -r _db_internal_line
+ RET='10 nvidia-common/obsolete-driver doesn'\''t exist'
+ case ${_db_internal_line%%[ ]*} in
+ return 10

If you need more infos, just ask for it, your welcome!

Darkmike (mikefaille) wrote :

If I type this command first : "sudo DEBCONF_DEBUG='developer' sudo /etc/kernel/header_postinst"

or this command: DEBCONF_DEBUG='developer' sudo /etc/kernel/header_postinst.d/nvidia-common

I didn't receive any feedback.

But if I follow the procedure of Jean-Baptiste Lallement (with the "set -x" in the second line of /etc/kernel/header_postinst.d/nvidia-common),
the command "sudo DEBCONF_DEBUG='developer' sudo /etc/kernel/header_postinst"
works perfectly. Why? :)

The output:

+ . /usr/share/debconf/confmodule
++ '[' '!' '' ']'
++ PERL_DL_NONLAZY=1
++ export PERL_DL_NONLAZY
++ '[' '' ']'
++ exec /usr/share/debconf/frontend /etc/kernel/header_postinst.d/nvidia-common
+ . /usr/share/debconf/confmodule
++ '[' '!' 1 ']'
++ '[' -z '' ']'
++ exec
++ '[' '' ']'
++ exec
++ DEBCONF_REDIR=1
++ export DEBCONF_REDIR
+ db_set nvidia-common/obsolete-driver false
+ _db_cmd 'SET nvidia-common/obsolete-driver' false
+ IFS=' '
+ printf '%s\n' 'SET nvidia-common/obsolete-driver false'
+ IFS='
'
+ read -r _db_internal_line
+ RET='10 nvidia-common/obsolete-driver doesn'\''t exist'
+ case ${_db_internal_line%%[ ]*} in
+ return 10

Darkmike (mikefaille) wrote :

My output seem to be good I think...

Jean-Baptiste Lallement (jibel) wrote :

Thanks for the output. This is exactly same trace than bug 533970 which was 'fixed' in 0.2.22. I'm marking this report as triaged.

Changed in nvidia-common (Ubuntu):
status: Incomplete → Triaged
Darkmike (mikefaille) wrote :

Some more output:

run-parts: /etc/kernel/header_postinst.d/nvidia-common exited with return code 10
Failed to process /etc/kernel/header_postinst.d at /var/lib/dpkg/info/linux-headers-2.6.32-24-generic.postinst line 110.
dpkg: error processing linux-headers-2.6.32-24-generic (--configure):
 subprocess installed post-installation script returned error exit status 2
Errors were encountered while processing:
 linux-image-2.6.32-24-generic
 linux-headers-2.6.32-24-generic

Darkmike (mikefaille) wrote :

To fix it:
sudo aptitude reinstall nvidia-common

LAZA (laza74) wrote :

Yes, you're right!

Done and fixed - THANKS !!!

De jod gre ekj e - ad tt van xa cem jl ent

Ac jmv ade xs mic Qu at alifi bbp cati glc ons available from prestigious
Non-Ac jgc cre it dit flu ed Un ehp ive aw rsi bkk ties

Do you have the kn sb owl ojg edge and the experience but lack the qua iz lifica kuh tio mcg ns?

Are you getting turned down time and time again for the job of your
dreams because you just don't have the right letters after your name?

Get the pre qz sti hsk ge that you deserve today!

Move ahead in your ca nv re vux er today!

Bache mur lors, Mast xym ers and Doct le orate Degr nt ees available in y our field!

No exa bad minations! No cl zk asses! No textbo nft oks!

Call to register and receive your qu ws alifi lst catio jdb ns within days!

Leave a Mes gx sage 24 ho nc urs a day 7 da bpy ys a we qee ek!

+ 1 - 64 hxb 6 - 5 jyl 37 - 17 ycp 32

Co zwt nfid je enti xa ali rz ty as gk su gcy red!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers