jockey-gtk crashed with OSError in _execute_child()

Bug #518879 reported by KevinM on 2010-02-08
102
This bug affects 18 people
Affects Status Importance Assigned to Milestone
nvidia-common (Ubuntu)
Medium
Alberto Milone

Bug Description

Using Ubuntu Lucid kernel 2.6.32-12-generic #17-Ubuntu SMP Fri Feb 5 08:16:30 UTC 2010 x86_64 GNU/Linux
System up to date as of 08/02/10 3.55PM UTC.
Just opened Firefox and this error occurred.

ProblemType: Crash
Architecture: amd64
CurrentDmesg:
 [ 21.270017] eth0: no IPv6 routers present
 [ 73.800040] Clocksource tsc unstable (delta = -247386247 ns)
Date: Mon Feb 8 15:46:38 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/jockey-gtk
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100206)
InterpreterPath: /usr/bin/python2.6
Lsusb:
 Bus 002 Device 007: ID 0001:0000 Fry's Electronics
 Bus 002 Device 002: ID 046d:c512 Logitech, Inc. LX-700 Cordless Desktop Receiver
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
NonfreeKernelModules: nvidia
Package: jockey-gtk 0.5.6-0ubuntu2
PackageArchitecture: all
ProcAttrCurrent: unconfined (enforce)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-12-generic root=UUID=53cbfa0b-9cf9-4c8d-8fd4-f062001a500f ro quiet splash
ProcCmdline: /usr/bin/python /usr/bin/jockey-gtk
ProcEnviron:
 PATH=(custom, no user)
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
PythonArgs: ['/usr/bin/jockey-gtk']
SourcePackage: jockey
Title: jockey-gtk crashed with OSError in _execute_child()
Uname: Linux 2.6.32-12-generic x86_64
UserGroups:

dmi.bios.date: 08/05/2005
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 6.00 PG
dmi.board.name: NF-CK804
dmi.chassis.type: 3
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr6.00PG:bd08/05/2005:svn:pn:pvr:rvn:rnNF-CK804:rvr:cvn:ct3:cvr:

KevinM (kevbert1) wrote :
tags: removed: need-duplicate-check
Ara Pulido (ara) on 2010-02-16
visibility: private → public
Alberto Milone (albertomilone) wrote :

This bug is caused by the lack of a complete "PATH" environment variable in the alternatives library provided by nvidia-common.

Thanks for reporting the problem.

Changed in jockey (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Alberto Milone (albertomilone)
affects: jockey (Ubuntu) → nvidia-common (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-common - 0.2.20

---------------
nvidia-common (0.2.20) lucid; urgency=low

  * NvidiaDetector/alternatives.py:
    - Make sure that the PATH environment variable is set
      so that subprocess knows where to find binaries in
      /sbin (LP: #518879).
 -- Alberto Milone <email address hidden> Tue, 16 Feb 2010 16:35:35 +0100

Changed in nvidia-common (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers