nvidia drivers don't work due to -Q in obsolete /etc/modprobe.d/lrm-video

Bug #467490 reported by Ted Parvu on 2009-10-31
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nvidia-common (Ubuntu)
High
Alberto Milone
Karmic
Low
Unassigned
Lucid
High
Alberto Milone

Bug Description

I am not sure what is going on here but I recently upgraded from 8.04 to 9.10 and my nvidia drivers aren't working. I couldn't add via the "hardware drivers" app. It just didn't work.

When I tried to add using apt-get it still didn't work. I tried inserting the nvidia module using modprobe and I got and error stating that "Q" was an invalid option. After some scouring of the web I found a reference suggesting that I comment out lines in /etc/modprobe.d/lrm-video so I tried commenting out a line in this file. What do you know it worked. Here is a copy of that file;

# Make nvidia/nvidia_legacy and fglrx use /sbin/lrm-video to load
install fglrx /sbin/lrm-video fglrx $CMDLINE_OPTS
#install nvidia /sbin/lrm-video nvidia $CMDLINE_OPTS
install nvidia_legacy /sbin/lrm-video nvidia_legacy $CMDLINE_OPTS
install nvidia_new /sbin/lrm-video nvidia_new $CMDLINE_OPTS

So, now I have a working nvidia driver. However this seems to have broken my audio. :(

I have no idea what this file does or what I have done by commenting out this line other than getting the nvidia driver to finally load.

I have no idea why commenting this out would cause my audio to fail? Any help would be appreciated.

thanks,

--Ted

ProblemType: Bug
Architecture: i386
Date: Sat Oct 31 16:31:05 2009
DistroRelease: Ubuntu 9.10
GdmLog:
 Fatal server error:
 Server is already active for display 0
  If this server is no longer running, remove /tmp/.X0-lock
  and start again.
GdmLogOld:
 Fatal server error:
 Server is already active for display 0
  If this server is no longer running, remove /tmp/.X0-lock
  and start again.
MachineType: System manufacturer System Product Name
NonfreeKernelModules: nvidia dm_raid45 xor usbhid usb_storage ati_agp r8169 mii agpgart
Package: nvidia-glx-185 185.18.36-0ubuntu9
ProcCmdLine: root=UUID=dc199ea7-e35b-4271-bd97-6b30d7aa06c3 ro quiet splash
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic-pae
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SourcePackage: nvidia-graphics-drivers-180
Uname: Linux 2.6.31-14-generic-pae i686
XsessionErrors: (polkit-gnome-authentication-agent-1:3819): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
dmi.bios.date: 10/22/2008
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: ASUS M2A-VM ACPI BIOS Revision 2201
dmi.board.name: M2A-VM
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: 1.XX
dmi.chassis.asset.tag: 123456789000
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrASUSM2A-VMACPIBIOSRevision2201:bd10/22/2008:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM2A-VM:rvr1.XX:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-14-generic-pae

Ted Parvu (ted-parvu) wrote :
null (domfiore) on 2009-11-01
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: New → Confirmed
Ted Parvu (ted-parvu) wrote :

OK, I have done a little more digging into this. It seems that the problem lies in the /sbin/lrm-video script.

The script call modeprobe with a "-Q" option which is invalid.

if [ -e /etc/default/envy-dkms ]; then
      modprobe --ignore-install -Qb $@ $XORG
    else
      modprobe --ignore-install -Qb $@ $MODULE
    fi

Commenting out the line in /etc/modprobe.d/lrm-video as far as I can figure, tells modeprobe not to call the lrm-video script and just loads the nvidia module into the kernel and all works.

As for the sound issue I think something must have gotten uninstalled when I was installing the envyng-core package or something else. I installed the linux-backports-modules-* packages and something in one of those got my sound working again.

Bryce Harrington (bryce) on 2009-11-04
summary: - nvidia drivers don't work
+ nvidia drivers don't work due to line in /etc/modprobe.d/lrm-video

Interesting, according to packages.ubuntu.com, lrm-video is no longer part of any ubuntu package; the last time it was provided was in intrepid.

My guess is that no upgrade process removed the file (as should have happened), and so it's been sitting on your system. By Karmic, it has bitrotted to the point that some of its syntax (-Q) is no longer valid... and boom.

As a workaround, you can safely just delete the /sbin/lrm-video file, but we'll leave the bug open since that needs to be done by the upgrader.

summary: - nvidia drivers don't work due to line in /etc/modprobe.d/lrm-video
+ nvidia drivers don't work due to -Q in obsolete /etc/modprobe.d/lrm-
+ video
Changed in nvidia-graphics-drivers-180 (Ubuntu):
assignee: nobody → Bryce Harrington (bryceharrington)
importance: Undecided → High
status: Confirmed → Triaged
Andy Whitcroft (apw) wrote :

Could we get the output of the command below into the bug please:

    dpkg -l | grep linux-restricted

and also:

    dpkg -l | grep linux-image

Thanks!

Download full text (6.1 KiB)

On Wednesday 04 November 2009 12:03:13 pm Andy Whitcroft wrote:
> Could we get the output of the command below into the bug please:
>
> dpkg -l | grep linux-restricted
>
> and also:
>
> dpkg -l | grep linux-image
>
> Thanks!
>

Oops, I did a ;

sudo apt-get purge linux-restricted-modules-common

Before I read this email. After rebooting all still seems well.

Here it is though;

tjp@lightning:archives\>dpkg -l | grep linux-restricted
rc linux-restricted-modules-2.6.24-19-generic 2.6.24.13-19.45
Non-free Linux 2.6.24 modules on x86/x86_64
rc linux-restricted-modules-2.6.24-19-xen 2.6.24.13-19.45
Non-free Linux 2.6.24 modules on Xen
rc linux-restricted-modules-2.6.24-21-generic 2.6.24.14-21.51
Non-free Linux 2.6.24 modules on x86/x86_64
rc linux-restricted-modules-2.6.24-21-xen 2.6.24.14-21.51
Non-free Linux 2.6.24 modules on Xen
rc linux-restricted-modules-2.6.24-22-generic 2.6.24.14-22.53
Non-free Linux 2.6.24 modules on x86/x86_64
rc linux-restricted-modules-2.6.24-22-xen 2.6.24.14-22.53
Non-free Linux 2.6.24 modules on Xen
rc linux-restricted-modules-2.6.24-23-generic 2.6.24.16-23.56
Non-free Linux 2.6.24 modules on x86/x86_64
rc linux-restricted-modules-2.6.24-23-xen 2.6.24.16-23.56
Non-free Linux 2.6.24 modules on Xen
rc linux-restricted-modules-2.6.24-24-generic 2.6.24.18-24.1
Non-free Linux 2.6.24 modules on x86/x86_64
rc linux-restricted-modules-2.6.24-24-xen 2.6.24.18-24.1
Non-free Linux 2.6.24 modules on Xen
rc linux-restricted-modules-2.6.24-25-generic 2.6.24.18-25.2
Non-free Linux 2.6.24 modules on x86/x86_64
rc linux-restricted-modules-2.6.24-25-xen 2.6.24.18-25.2
Non-free Linux 2.6.24 modules on Xen

This might help though;

tjp@lightning:archives\>pwd
/var/cache/apt/archives
tjp@lightning:archives\>ls -l linux-res*
-rw-r--r-- 1 root root 18660592 2009-10-21 16:08 linux-restricted-
modules-2.6.24-25-generic_2.6.24.18-25.2_i386.deb
-rw-r--r-- 1 root root 11634382 2009-10-21 16:08 linux-restricted-
modules-2.6.24-25-xen_2.6.24.18-25.2_i386.deb
-rw-r--r-- 1 root root 29370 2009-10-21 16:08 linux-restricted-modules-
common_2.6.24.18-25.2_all.deb
-rw-r--r-- 1 root root 26636 2009-10-21 20:39 linux-restricted-modules-
generic_2.6.24.25.27_i386.deb
-rw-r--r-- 1 root root 26630 2009-10-21 20:39 linux-restricted-modules-
xen_2.6.24.25.27_i386.deb
tjp@lightning:archives\>pwd
/var/cache/apt/archives
tjp@lightning:archives\>

tjp@lightning:archives\>dpkg -l | grep linux-image
rc linux-image-2.6.24-19-generic 2.6.24-19.41
Linux kernel image for version 2.6.24 on x86
rc lin...

Read more...

Bryce Harrington (bryce) wrote :

Thanks, one more question, you mention you upgraded from 8.04 to 9.10. Did you do the upgrade as 8.04->8.10, then 8.10->9.04, and then 9.04->9.10, or did you do 8.04->9.10 all in one go?

Ted Parvu (ted-parvu) wrote :

On Thursday 05 November 2009 01:26:00 am you wrote:
> Thanks, one more question, you mention you upgraded from 8.04 to 9.10.
> Did you do the upgrade as 8.04->8.10, then 8.10->9.04, and then
> 9.04->9.10, or did you do 8.04->9.10 all in one go?
>

Went from 8.04 --> 9.10 all in one go.

I had been running 8.04 for probably close to a year.

--
I know now as men accept the time clock of the wilderness, their lives become
entirely different. It is one of the great compensations of primitive
experience, and when one finally reaches the point where days are governed by
daylight and dark, rather than by schedules, where one eats if hungry and
sleeps when tired, and becomes completely immersed in the ancient rhythms,
then one begins to live. -- Sigurd Olson

Bryce Harrington (bryce) wrote :

On Thu, Nov 05, 2009 at 02:33:18PM -0000, Ted Parvu wrote:
> On Thursday 05 November 2009 01:26:00 am you wrote:
> > Thanks, one more question, you mention you upgraded from 8.04 to 9.10.
> > Did you do the upgrade as 8.04->8.10, then 8.10->9.04, and then
> > 9.04->9.10, or did you do 8.04->9.10 all in one go?
> >
>
> Went from 8.04 --> 9.10 all in one go.
>
> I had been running 8.04 for probably close to a year.

Aha! Okay that explains it.

Yeah, as a general rule we recommend people upgrade either from LTS to
LTS, or from release N to release N+1, as these are the scenarios we
focus on testing during development. Upgrades that skip releases are
not tested so well (it becomes a combinatorial explosion of options)
and I can imagine that an issue like this would arise. I would be
surprised if this is the only issue found.

Still, let's keep the bug open. This issue definitely needs solved for
Lucid.

Bryce

Ted Parvu (ted-parvu) wrote :

On Thursday 05 November 2009 01:42:11 pm you wrote:
> Aha! Okay that explains it.
>
> Yeah, as a general rule we recommend people upgrade either from LTS to
> LTS, or from release N to release N+1, as these are the scenarios we
> focus on testing during development. Upgrades that skip releases are
> not tested so well (it becomes a combinatorial explosion of options)
> and I can imagine that an issue like this would arise. I would be
> surprised if this is the only issue found.
>

Hmm, that is interesting. I was waiting for the 9.10 release because KDE 4.2
wasn't there yet. KDE3 was working pretty well for me and I didn't feel KDE4
was ready for prime time until 4.3.

Once 9.10 was out the upgrader took me straight to that version with no notice
or option to go to 9.04

I guess I didn't think about the LTS releases, I was looking at the KDE
releases...

something to think about....

--
I know now as men accept the time clock of the wilderness, their lives become
entirely different. It is one of the great compensations of primitive
experience, and when one finally reaches the point where days are governed by
daylight and dark, rather than by schedules, where one eats if hungry and
sleeps when tired, and becomes completely immersed in the ancient rhythms,
then one begins to live. -- Sigurd Olson

Bryce Harrington (bryce) wrote :

I'm marking this as high priority for Lucid since we definitely want LTS->LTS upgrades to work smoothly.
It would be nice to fix for Hardy->Karmic, so I'm leaving a task for that, however I think it is much less critical since we recommend users upgrade sequentially rather than jumping releases so am setting priority for this aspect of the task to low.

Changed in nvidia-graphics-drivers-180 (Ubuntu Karmic):
importance: Undecided → Low
status: New → Triaged
Mark B (mark-barnes) wrote :

simply removing /sbin/lrm-video did NOT work for me.

I did the very same upgrade: 8.04 -> 9.10 (won't skip releases like this again)

Jay (cowb0y) wrote :

To clarify/summarize: When upgrading directly from 8.04 to 9.10 (Kubuntu Karmic Upgrader), the following minimal change can be made to prevent the nvidia binary driver from failing to load:

1. edit the lrm-video file:
sudo nano -w /etc/modprobe.d/lrm-video

2. comment out the following line with a hash mark:
#install nvidia /sbin/lrm-video nvidia $CMDLINE_OPTS

3. reboot, or restart the X server

Note for KDE4 users: when the nvidia driver is working again, your screen resolution may increase on login, then decrease again, making your panel inaccessible (my panel is set to autohide). Create a new panel, add a system tray widget to it, then run krandrtray. Now use krandrtray to increase your screen resolution to maximum, and the panel should reappear.

Alberto Milone (albertomilone) wrote :

@Mark B
If that didn't work for you then you must be experiencing a different problem

Removing /etc/modprobe.d/lrm-video is the right solution. I'll make sure that nvidia-common takes care of this.

affects: nvidia-graphics-drivers-180 (Ubuntu Lucid) → nvidia-common (Ubuntu Lucid)
Changed in nvidia-common (Ubuntu Lucid):
assignee: Bryce Harrington (bryceharrington) → Alberto Milone (albertomilone)
Changed in nvidia-common (Ubuntu Lucid):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-common - 0.2.21

---------------
nvidia-common (0.2.21) lucid; urgency=low

  * Make sure that /etc/modprobe.d/lrm-video is removed
    so that it doesn't interfere with nvidia (LP: #467490).
  * debian/nvidia-common.postinst:
    - Remove db_stop as suggested by Colin Watson, as it
      can do more harm than good there.
    - Move the debconf part into the postinst and get rid
      of the config script (which was run before
      nvidia-common was configured, with unpredictable
      results). Thanks to Colin Watson for the advice.
    - Don't test the existence of nvidia-detector.
  * share/obsolete:
    - Add nvidia-glx-{190|195} so as to take care of
      packages from PPAs.
 -- Alberto Milone <email address hidden> Wed, 03 Mar 2010 13:13:51 +0100

Changed in nvidia-common (Ubuntu Lucid):
status: In Progress → Fix Released
Rolf Leggewie (r0lf) wrote :

karmic has seen the end of its life and is no longer receiving any updates. Marking the karmic task for this ticket as "Won't Fix".

Changed in nvidia-common (Ubuntu Karmic):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers