Add package nvidia-experimental for tracking nvidia beta drivers

Bug #1047681 reported by Bryce Harrington on 2012-09-07
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Wishlist
Unassigned
Precise
Wishlist
Alberto Milone
Quantal
Wishlist
Unassigned
Raring
Wishlist
Unassigned
nvidia-common (Ubuntu)
Wishlist
Unassigned
Precise
Wishlist
Alberto Milone
Raring
Wishlist
Unassigned
nvidia-graphics-drivers-experimental-304 (Ubuntu)
Wishlist
Alberto Milone
Precise
Wishlist
Alberto Milone
Quantal
Wishlist
Alberto Milone
Raring
Wishlist
Alberto Milone
nvidia-graphics-drivers-experimental-310 (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
nvidia-settings-experimental-304 (Ubuntu)
Wishlist
Alberto Milone
Precise
Wishlist
Alberto Milone
Quantal
Wishlist
Alberto Milone
Raring
Wishlist
Alberto Milone
nvidia-settings-experimental-310 (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

[Impact]
NVIDIA posts beta versions of their drivers to be tested over several weeks. These drivers usually include important features and fixes but also sometimes include known issues or regressions that make them unsuitable or too risky for us to consider inclusion in the nvidia-current-updates package.

However certain commercial Linux games require features/fixes present only in these NVIDIA beta drivers at the time of their release. Ubuntu users who purchase these games currently have to manually install the beta driver (or wait a month or two for it to appear in -updates). Providing these drivers via nvidia-experimental will enable them to install and run the game within the Ubuntu packaging system.

[Fix]
The nvidia-experimental-NNN binary package (and associated nvidia-setup-NNN) is established (provided by the nvidia-graphics-drivers-experimental source package) for quantal 12.10 and precise 12.04. This uses the packaging scripts from nvidia-current-updates, with the renamed package and new .run files.

The nvidia-experimental-NNN package will be visible to users via Jockey as normal, due to logic provided in nvidia-common. When a user installs the experimental package, any other nvidia drivers will be disabled. They will remain on the selected nvidia-experimental-NNN until they upgrade to a new Ubuntu release or LTS point release, at which point they'll be returned to nvidia-current. They can of course manually switch from nvidia-experimental-NNN back to nvidia-current or nvidia-current-updates (or some newer nvidia-experimental-MMM) if they wish.

The control file for the experimental package proposed for precise has some differences from the one in quantal, and also has some differences against the non-experimental nvidia driver in precise. Here is an explanation of those differences in turn:

* Conflicts/Replaces on nvidia-*-modaliases (from precise's nvidia package) are no longer needed. The modaliases packages were used in previous releases but no longer exist in precise. Since people can't upgrade from those previous versions directly to nvidia*experimental, there is no need to have Conflicts/Replaces.

* Conflicts/Replaces/Provides of various nvidia/fglrx packages (from quantal's nvidia-experimental package) are only needed for quantal forward. These are required by the new restricted drivers UI in quantal. Since that UI is not in precise, we don't need it in precise. (Ref. quantal changelog entry for nvidia-graphics-drivers 304.43-0ubuntu3.)

[Regression Potential]
The reason we're adding this package in the first place is because of concerns that beta drivers will have a high risk of regressions. Thus, users need to be aware they are taking these risks when they opt-in to the driver.

As mentioned above, nvidia-current and nvidia-current-updates will still be available to them in case they have problems. In a worst case scenario they may need to do this from a recovery session.

Bryce Harrington (bryce) on 2012-09-07
Changed in jockey (Ubuntu):
status: New → In Progress
Changed in nvidia-graphics-drivers (Ubuntu):
status: New → In Progress
Changed in jockey (Ubuntu):
importance: Undecided → Wishlist
Changed in nvidia-graphics-drivers (Ubuntu):
importance: Undecided → Wishlist
affects: nvidia-graphics-drivers (Ubuntu) → nvidia-common (Ubuntu)
Changed in nvidia-common (Ubuntu Precise):
status: New → In Progress
Changed in jockey (Ubuntu Precise):
status: New → In Progress
importance: Undecided → Wishlist
Changed in nvidia-common (Ubuntu Precise):
importance: Undecided → Wishlist
Bryce Harrington (bryce) on 2012-09-20
Changed in nvidia-graphics-drivers-experimental-304 (Ubuntu Precise):
importance: Undecided → Wishlist
status: New → In Progress
Changed in nvidia-graphics-drivers-experimental-304 (Ubuntu Quantal):
importance: Undecided → Wishlist
status: New → In Progress
Changed in nvidia-settings-experimental-304 (Ubuntu Precise):
importance: Undecided → Wishlist
status: New → In Progress
Changed in nvidia-settings-experimental-304 (Ubuntu Quantal):
importance: Undecided → Wishlist
status: New → In Progress
description: updated
Changed in nvidia-common (Ubuntu Precise):
assignee: nobody → Alberto Milone (albertomilone)
no longer affects: nvidia-common (Ubuntu Quantal)
Changed in nvidia-graphics-drivers-experimental-304 (Ubuntu Precise):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-experimental-304 (Ubuntu Quantal):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-settings-experimental-304 (Ubuntu Precise):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-settings-experimental-304 (Ubuntu Quantal):
assignee: nobody → Alberto Milone (albertomilone)
Changed in jockey (Ubuntu Precise):
assignee: nobody → Alberto Milone (albertomilone)
Bryce Harrington (bryce) on 2012-09-20
Changed in nvidia-settings-experimental-304 (Ubuntu Quantal):
status: In Progress → Fix Released
Changed in nvidia-graphics-drivers-experimental-304 (Ubuntu Quantal):
status: In Progress → Fix Released
Changed in nvidia-common (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in jockey (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in nvidia-graphics-drivers-experimental-304 (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in nvidia-settings-experimental-304 (Ubuntu Precise):
status: In Progress → Fix Committed
Bryce Harrington (bryce) on 2012-09-26
description: updated

Hello Bryce, or anyone else affected,

Accepted nvidia-graphics-drivers-experimental-304 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-experimental-304/304.48-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Adam Conrad (adconrad) wrote :

Hello Bryce, or anyone else affected,

Accepted nvidia-settings-experimental-304 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nvidia-settings-experimental-304/304.48-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Adam Conrad (adconrad) wrote :

Hello Bryce, or anyone else affected,

Accepted jockey into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/jockey/0.9.7-0ubuntu7.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Adam Conrad (adconrad) wrote :

Hello Bryce, or anyone else affected,

Accepted nvidia-common into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nvidia-common/1:0.2.44.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Bryce Harrington (bryce) wrote :

I have tested this on a precise-proposed box with a supported nvidia card.

nvidia-common and jockey install cleanly and do not crash or exhibit bugs when run. However I found one flaw that needs correction.

The nvidia-experimental-304 drivers support three Xserver ABI versions: 11, 12, and 13. However, jockey's oslib.py functionality isn't prepared to handle multiple ABI's; it just detects the last in the list. On quantal our Xserver is ABI 13, so that works fine. But on precise our ABI is 11, so 11 != 13, and so Jockey figures the experimental driver isn't valid and omits it from the list (with an error to this effect in the jockey log file).

Either we need to make jockey's logic smarter when encountering multiple supported ABIs, or simplify the nvidia-experimental-304 driver package to only advertise support for ABI 11. I prefer the former solution, as a better long term solution.

Bryce Harrington (bryce) wrote :

Couple more flaws:

1. The list of drivers is unsorted. This didn't matter when we had only 2-4 drivers, but with 4-6 drivers it becomes confusing. The order of the nvidia drivers is essentially random (the code is just getting dict.keys()) so sometimes the experimental driver appears first. This could be a problem if users accidentally just pick whatever's at the top of the list. The experimental drivers should sort towards the bottom of the list ideally. As we add more experimental drivers, this will become a bigger problem...

2. The description and rationale from the experimental driver is not getting populated from the control file, as per the plan. It just uses the standard nvidia driver description.

Bryce Harrington (bryce) wrote :

I have uploaded new nvidia-common and jockey packages for precise-proposed with fixes for the aforementioned issues.

I have also sent branches to the maintainers of these packages for review.

tags: added: verification-failed
removed: verification-needed
tags: removed: verification-failed
Chris Halse Rogers (raof) wrote :

Hello Bryce, or anyone else affected,

Accepted nvidia-common into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nvidia-common/1:0.2.44.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Chris Halse Rogers (raof) wrote :

Hello Bryce, or anyone else affected,

Accepted jockey into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/jockey/0.9.7-0ubuntu7.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Bryce Harrington (bryce) on 2012-10-02
tags: added: verification-done
removed: verification-needed
Bryce Harrington (bryce) wrote :

1. Passed on my own hardware. I removed my local changes, downgraded to the versions of jockey-common jockey-gtk and nvidia-common currently in precise. Then I enabled -proposed, updated, upgraded the three packages, ran jockey-gtk and verified it works. The experimental driver is displayed correctly in the GUI. I then went ahead and installed it and rebooted, and verified it came up with that driver loaded and unity working normally.

2. Passed on independent verification. I solicited a random nvidia/precise user on #ubuntu-devel (thanks again ion!), had them repeat the above steps (except for the actual driver installation), and verify that the experimental driver was available for them as well.

Thus, verification passed.

The one caveat I should add for completeness is that if the user updates but does not upgrade, then running jockey won't work, because the jockey currently in precise can't cope with there being drivers named "experimental-NNN" in the archive. The fix is of course to do the upgrade, but I am a little worried some users may get caught by this. One way to minimize this might be to roll out the nvidia-common and jockey changes *now*, and hold off a few days on introducing the -experimental-304 packages, but maybe I'm being overcautious?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-common - 1:0.2.44.2

---------------
nvidia-common (1:0.2.44.2) precise-proposed; urgency=low

  * NvidiaDetector/nvidiadetector.py: When a package has multiple words
    separated with -'s, use only the last element as the driver version.
    (LP: #1047681)

nvidia-common (1:0.2.44.1) precise-proposed; urgency=low

  [Alberto Milone]
  * NvidiaDetector/nvidiadetector.py:
    - Add support for -experimental flavours (LP: #1047681).
  * Don't write to /usr/share for hybrid graphics
    detection, use /var/lib instead (LP: #976779).

  [Bryce Harrington]
  * nvidia-common.templates: Fix lintian error (trailing whitespace)
 -- Bryce Harrington <email address hidden> Thu, 27 Sep 2012 22:27:56 -0700

Changed in nvidia-common (Ubuntu Precise):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.9.7-0ubuntu7.3

---------------
jockey (0.9.7-0ubuntu7.3) precise-proposed; urgency=low

  * Improve support for the nvidia-experimental-304 package
    (LP: #1047681)
    - When displaying list of video drivers, sort them alphabetically.
    - Allow experimental drivers to fallback to the description from debian/control
    - Insert spaces when appending lines from the control file description.
      Fixes bad formatting in jockey's package description.
    - Handle multiple abi versions. Fixes bug preventing experimental
      drivers from being displayed in jockey.

jockey (0.9.7-0ubuntu7.2) precise-proposed; urgency=low

  * data/handlers/nvidia.py:
    - Add support for the nvidia-experimental-304 package (LP: #1047681).
 -- Bryce Harrington <email address hidden> Fri, 28 Sep 2012 19:01:40 -0700

Changed in jockey (Ubuntu Precise):
status: Fix Committed → Fix Released
Vadim Peretokin (vperetokin) wrote :

Hello,

I've received this update while not being subscribed to precise-proposed, but I am subscribed to -updates per comment #12. I launched hardware drivers to look at the experimental driver, but it is not listed in my drivers list - see screenshot.

Is this expected?

Bryce Harrington (bryce) wrote :

@Vadim, totally expected and the intended behavior. In fact thanks for confirming things are working as designed.

We're just landing the infrastructure right now. You won't see new beta drivers listed here until NVIDIA publicly announces one.

Bryce Harrington (bryce) wrote :

(Well, we may push the 304 driver package out within a week or so, but that's a stable driver not a true beta driver.)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-experimental-304 - 304.48-0ubuntu0.1

---------------
nvidia-graphics-drivers-experimental-304 (304.48-0ubuntu0.1) precise-proposed; urgency=low

  * Initial release
    (LP: #1047681)
 -- Alberto Milone <email address hidden> Mon, 24 Sep 2012 16:39:44 +0200

Changed in nvidia-graphics-drivers-experimental-304 (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-settings-experimental-304 - 304.48-0ubuntu0.1

---------------
nvidia-settings-experimental-304 (304.48-0ubuntu0.1) precise-proposed; urgency=low

  * Initial release
    (LP: #1047681).
 -- Alberto Milone <email address hidden> Mon, 24 Sep 2012 16:39:08 +0200

Changed in nvidia-settings-experimental-304 (Ubuntu Precise):
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

setting the jockey quantal part to wontfix because jockey got deprecated there

Changed in jockey (Ubuntu Quantal):
status: In Progress → Won't Fix

Hello Bryce, or anyone else affected,

Accepted jockey into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/jockey/0.9.7-0ubuntu7.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Bryce Harrington (bryce) on 2012-10-24
tags: added: verification-done
removed: verification-needed
Bryce Harrington (bryce) wrote :

Verified with the jockey update that nvidia-experimental-310 installs properly. System reboots into a working system.

(For full disclosure I did have a keyboard failure on boot, but that's not likely to be due to the video driver. Replugging it in restored its functionality. I am guessing it's due to some quirk of the KVM the keyboard is plugged into.)

Eugene Romanenko (eros2) wrote :

Please update the 304 driver package, as 304.60 is released and stated as "Certified" by NVIDIA.

Bryce Harrington (bryce) wrote :

I believe no further work is required on this bug so closing out the last task. If this is incorrect please reopen with list of things we need to tend to still.

Changed in jockey (Ubuntu):
status: In Progress → Fix Released
Changed in nvidia-common (Ubuntu):
status: In Progress → Fix Released
Bryce Harrington (bryce) on 2012-11-12
Changed in nvidia-settings-experimental-310 (Ubuntu Precise):
status: New → Fix Released
Changed in nvidia-graphics-drivers-experimental-310 (Ubuntu Precise):
status: New → Fix Released
no longer affects: jockey (Ubuntu Oneiric)
no longer affects: nvidia-common (Ubuntu Oneiric)
no longer affects: nvidia-graphics-drivers-experimental-304 (Ubuntu Oneiric)
no longer affects: nvidia-graphics-drivers-experimental-310 (Ubuntu Oneiric)
no longer affects: nvidia-settings-experimental-304 (Ubuntu Oneiric)
no longer affects: nvidia-settings-experimental-310 (Ubuntu Oneiric)
Bryce Harrington (bryce) wrote :

@eros2, file a separate bug report. This one is just for tracking the introduction of the experimental packages, not updates.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-experimental-310 (Ubuntu):
status: New → Confirmed
Changed in nvidia-settings-experimental-310 (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) on 2013-04-15
no longer affects: nvidia-graphics-drivers-experimental-310 (Ubuntu Raring)
no longer affects: nvidia-settings-experimental-310 (Ubuntu Raring)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions