compiz crashed with SIGSEGV in af_face_globals_is_digit() from af_loader_load_g() from af_loader_load_glyph() from af_autofitter_load_glyph() from FT_Load_Glyph() from _cairo_ft_scaled_glyph_init() from ... from nux::TextEntry::DrawText()

Bug #959323 reported by Todd Howe on 2012-03-19
148
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Nux
Invalid
High
Unassigned
Unity
Invalid
High
Unassigned
5.0
Invalid
High
Unassigned
nux (Ubuntu)
High
Unassigned

Bug Description

While starting up the system, hit Super key and started typing in 'liferea'. Got as far as 'life'

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: libnux-2.0-0 2.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-19.30-generic 3.2.11
Uname: Linux 3.2.0-19-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Mon Mar 19 10:22:37 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
ProcCmdline: compiz
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f3b3e1438a3: cmp 0x8(%rdx),%rax
 PC (0x7f3b3e1438a3) ok
 source "0x8(%rdx)" (0x00000008) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libfreetype.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libfreetype.so.6
 FT_Load_Glyph () from /usr/lib/x86_64-linux-gnu/libfreetype.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libcairo.so.2
 ?? () from /usr/lib/x86_64-linux-gnu/libcairo.so.2
Title: compiz crashed with SIGSEGV in FT_Load_Glyph()
UpgradeStatus: Upgraded to precise on 2012-03-10 (8 days ago)
UserGroups: adm cdrom dip lpadmin mythtv plugdev sambashare sudo

Todd Howe (tehowe) wrote :

StacktraceTop:
 af_face_globals_is_digit (gindex=85, globals=<optimized out>) at /build/buildd/freetype-2.4.8/freetype-2.4.8/src/autofit/afglobal.c:312
 af_loader_load_g (loader=<optimized out>, scaler=0x7fffb6c8f420, glyph_index=85, load_flags=68097, depth=0) at /build/buildd/freetype-2.4.8/freetype-2.4.8/src/autofit/afloader.c:437
 af_loader_load_glyph (load_flags=<optimized out>, gindex=<optimized out>, face=<optimized out>, loader=<optimized out>) at /build/buildd/freetype-2.4.8/freetype-2.4.8/src/autofit/afloader.c:539
 af_autofitter_load_glyph (module=<optimized out>, slot=<optimized out>, size=<optimized out>, glyph_index=<optimized out>, load_flags=<optimized out>) at /build/buildd/freetype-2.4.8/freetype-2.4.8/src/autofit/afmodule.c:64
 FT_Load_Glyph (load_flags=66048, glyph_index=85, face=0x2994630) at /build/buildd/freetype-2.4.8/freetype-2.4.8/src/base/ftobjs.c:681

Changed in nux (Ubuntu):
importance: Undecided → Medium
summary: - compiz crashed with SIGSEGV in FT_Load_Glyph()
+ compiz crashed with SIGSEGV in af_face_globals_is_digit()
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu):
status: New → Confirmed
visibility: private → public
summary: - compiz crashed with SIGSEGV in af_face_globals_is_digit()
+ compiz crashed with SIGSEGV in af_face_globals_is_digit() from
+ af_loader_load_g() from af_loader_load_glyph() from
+ af_autofitter_load_glyph() from FT_Load_Glyph() from
+ _cairo_ft_scaled_glyph_init()
summary: compiz crashed with SIGSEGV in af_face_globals_is_digit() from
af_loader_load_g() from af_loader_load_glyph() from
af_autofitter_load_glyph() from FT_Load_Glyph() from
- _cairo_ft_scaled_glyph_init()
+ _cairo_ft_scaled_glyph_init() from ... from nux::TextEntry::DrawText()
Changed in nux:
status: New → Confirmed
importance: Undecided → High
Changed in unity:
status: New → Confirmed
importance: Undecided → High
milestone: none → 5.12.0
Daniel van Vugt (vanvugt) wrote :

This bug is possibly the same as bug 965748, which is also reported in:
https://bugzilla.redhat.com/show_bug.cgi?id=761100

Didier Roche (didrocks) on 2012-04-27
Changed in unity:
milestone: 5.12.0 → 5.14.0
tags: added: quantal running-unity
Changed in unity:
milestone: 5.14.0 → 5.16.0
Changed in unity:
milestone: 5.16.0 → 5.18.0
Changed in unity:
milestone: 5.18.0 → 7.0.0
Stephen M. Webb (bregma) on 2013-04-04
Changed in unity:
milestone: 7.0.0 → 7.0.1
Stephen M. Webb (bregma) on 2013-05-02
Changed in unity:
milestone: 7.0.1 → 7.1.0
Stephen M. Webb (bregma) on 2013-07-26
Changed in unity:
milestone: 7.1.0 → 7.1.1
Stephen M. Webb (bregma) wrote :

This problem has been obviated by a change to the libfreetype upstream source [1] released in libfreetype6_2.4.9.

[1] http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/src/autofit/afloader.c?id=5621fdd412a0b02a5ed858baa7c2a9db4795ae1f

Changed in unity:
milestone: 7.1.1 → none
status: Confirmed → Invalid
no longer affects: unity/6.0
Changed in nux:
status: Confirmed → Invalid
Changed in nux (Ubuntu):
status: Confirmed → Fix Released
Vadim Peretokin (vperetokin) wrote :

The same issue happend for me on 12.04 just now.

Changed in nux (Ubuntu):
status: Fix Released → Invalid
importance: Medium → High
tags: added: rls-w-incoming
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.