llvmpipe software rendering needs blacklisting in unity-support-test

Bug #926859 reported by stefen burlew
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Undecided
Unassigned
Unity
Fix Released
Undecided
Unassigned
Unity Distro Priority
High
Unassigned
nux (Ubuntu)
High
Didier Roche
Precise
High
Didier Roche
unity (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

Precise Pangolin 12.04 alpha-2

clean install from usb stick

upon login desktop goes black with top panel still visible. Any window opened fights to stay on top of desktop-background, overlay of windows leaves artifacts of lower windows and using ALT+mouse is the only way to raise window to top of stack.

Left click on desktop causes all windows to drop to bottom of stack and desktop-background to come to top briefly before dropping back again.

Left click and drag on desktop creates red "selection areas" to remain on desktop and destroy other windows.

Suspect openchrome driver not supporting graphics request.

Keyboard and mouse lag behind use by almost a second in response.

Xdiagnose crashes before opening.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: xorg 1:7.6+10ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic-pae 3.2.2
Uname: Linux 3.2.0-12-generic-pae i686
.tmp.unity.support.test.0:

ApportVersion: 1.91-0ubuntu1
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,resize,regex,grid,snap,mousepoll,imgpng,place,vpswitch,move,gnomecompat,wall,animation,session,expo,fade,scale,workarounds,ezoom,unityshell]
CompositorRunning: compiz
Date: Sat Feb 4 11:45:22 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes, whatever it takes to get this fixed in Ubuntu
GraphicsCard:
 VIA Technologies, Inc. CN896/VN896/P4M900 [Chrome 9 HC] [1106:3371] (rev 01) (prog-if 00 [VGA controller])
   Subsystem: CLEVO/KAPOK Computer Device [1558:0669]
MachineType: CLEVO CO. M660SR
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-12-generic-pae root=UUID=e0832db5-80a9-4a48-93be-9a9dc790e747 ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/30/2007
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: 6.00
dmi.board.asset.tag: Tag 12345
dmi.board.name: M660SR
dmi.board.vendor: CLEVO Co.
dmi.board.version: VT6363A
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: VIA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvr6.00:bd11/30/2007:svnCLEVOCO.:pnM660SR:pvrVT6363A:rvnCLEVOCo.:rnM660SR:rvrVT6363A:cvnVIA:ct1:cvrN/A:
dmi.product.name: M660SR
dmi.product.version: VT6363A
dmi.sys.vendor: CLEVO CO.
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu8
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0~rc2-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0~rc2-0ubuntu4
version.xserver-xorg-core: xserver-xorg-core 2:1.11.3-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901-1ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Related branches

Revision history for this message
stefen burlew (steveburlew) wrote :
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

I think you're using unity 3d by "accident", which is now possible with the new llvmpipe software rasterizer. Try choosing the unity-2d session from the login screen, does it work normally?

Changed in xorg (Ubuntu):
status: New → Incomplete
Robert Hooker (sarvatt)
affects: xorg (Ubuntu) → mesa (Ubuntu)
Revision history for this message
Robert Hooker (sarvatt) wrote :

While this is indeed a bug in mesa, there is already handling in unity-support-test in nux to handle software rendering and it should be extended to also block llvmpipe because it's not going to be able to run unity in 12.04. You can reproduce this bug when using mesa by exporting LIBGL_ALWAYS_SOFTWARE=1. just adding "on llvmpipe" similar to "on softpipe" in this snippet from unity-support-test in nux would be enough

  // Check for software rendering.
  if (results->renderer != NULL &&
      (strncmp (results->renderer, "Software Rasterizer", 19) == 0 ||
       strncmp (results->renderer, "Mesa X11", 8) == 0 ||
       strstr (results->renderer, "on softpipe") != NULL)) {
    results->flags |= FLAG_SOFTWARE_RENDERING;

Here are the strings for llvmpipe:
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x300)
OpenGL version string: 2.1 Mesa 8.0-rc2
OpenGL shading language version string: 1.20

affects: mesa (Ubuntu) → nux (Ubuntu)
Changed in nux (Ubuntu):
importance: Undecided → High
status: Incomplete → Triaged
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
summary: - Desktop almost useless - due to corruption and flikering
+ llvmpipe software rendering needs blacklisting in unity-support-test
Revision history for this message
stefen burlew (steveburlew) wrote :

I have done update/upgrade with apt/update-manager for the last three days - was not able to get back to check the status of this bug though.

Logging in with unity-2d seems to have corrected all the previous errors I was having though.

Xdiagnose still crashing (unrelated? - bug #903484)

Timo Aaltonen (tjaalton)
Changed in nux (Ubuntu):
milestone: none → ubuntu-12.04-beta-1
tags: added: rls-mgr-p-tracking
Didier Roche (didrocks)
Changed in unity-distro-priority:
status: New → Fix Committed
importance: Undecided → High
Revision history for this message
Jason Smith (jassmith) wrote :

Nah, we are just going to fix the flickering issue. Its trivial to do :)

Changed in unity:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Jason Smith (jassmith)
milestone: none → 5.6.0
importance: Critical → High
Changed in nux (Ubuntu):
status: Triaged → Invalid
Robert Hooker (sarvatt)
Changed in nux (Ubuntu):
milestone: ubuntu-12.04-beta-1 → none
Revision history for this message
Stéphane Graber (stgraber) wrote :

Jason: Will fixing the flickering also get my CPU usage down from 50% to something reasonable?

I'd like to be able to have my usual 10 VMs running ubiquity without my laptop dying because of the CPU usage of doing compiz in software...

Revision history for this message
Stéphane Graber (stgraber) wrote :

Another use case for you I just got reminded of, LTSP (that ships in Ubuntu Alternate).

In the past we had two categories of thin clients:
 - These that support 3D acceleration over the network (intel based mostly)
 - These that don't

The first would get compiz and unity-3d the other would get unity-2d. This was all fine and we could have somewhere between 70-80 sessions like that opened on a regular server as unity-2d wasn't using much resource and compiz with GL over the network was offloading quite a bit to the thin client, making it pretty lightweight too.

Now, doing similar tests with llvvmpipe, we're pretty much going from 70-80 sessions down to 10 or so, because of the very high CPU and bandwidth requirement that comes with doing all the nice flashy stuff on the server rather than the client and then sending all that over the network. That's for when we can actually get a unity session opened, most of the time, we just get half the panel rendered and it gets stuck there.

Don't get me wrong, I find llvmpipe extremely interesting and I've been looking forward to that for a while, but that's something that should be opt-in, not a default. We have unity-2d and it works really quite well, I see no reason to stop using it and instead running compiz on software rendering.

I'd think making the llvmpipe stuff optional, using a gsettings key or option in the .desktop or whatever would be fine for everyone. People who want llvmpipe will be able to flick that switch, others will get a nice, fast and quiet experience using unity-2d on their non-3D capable hardware.

Some people asked on IRC "why don't you just select unity-2d", well, the problem is that you don't have a choice on a live media, it's always booting in unity 3d and needs the fallback to unity-2d. Currently, forcing to unity-2d requires a hack at boot time in the initramfs... As for LTSP, sure we could change the default session, but that'd be bad as a lot of recent thin clients can actually run compiz with hardware acceleration just fine. I really believe the fix needs to go in unity-support-test.

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

targeting for Beta 1, it make live session in VMs almost unusable and VMs are widely used by testers.

Changed in unity (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → High
milestone: none → ubuntu-12.04-beta-1
Revision history for this message
Didier Roche (didrocks) wrote :

We will blacklist llvmpipe for -3d in ubuntu right now for beta1.

Changed in unity (Ubuntu Precise):
status: Confirmed → Fix Committed
Changed in nux (Ubuntu Precise):
status: Invalid → Fix Committed
Changed in unity (Ubuntu Precise):
status: Fix Committed → Triaged
Changed in nux (Ubuntu Precise):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Didier Roche (didrocks)
milestone: none → ubuntu-12.04-beta-1
Changed in unity (Ubuntu Precise):
milestone: ubuntu-12.04-beta-1 → none
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 2.4.0-0ubuntu2

---------------
nux (2.4.0-0ubuntu2) precise; urgency=low

  * debian/patches/01_blacklist_llvmpipe.patch:
    - Blacklist llvmpipe (LP: #926859)
 -- Didier Roche <email address hidden> Mon, 27 Feb 2012 12:00:10 +0100

Changed in nux (Ubuntu Precise):
status: Fix Committed → Fix Released
Revision history for this message
Jason Smith (jassmith) wrote :

Fixing the flickering plus a repaint fix going into compiz will dramatically lower CPU usage. We have some other fixes that will lower the usage also.

Didier Roche (didrocks)
Changed in unity:
milestone: 5.6.0 → 5.8.0
Revision history for this message
Alberto Ruiz (alberto.ruiz) wrote :

Stephane, just a comment though, Unity 2D will stop being OpenGL-less once Qt5 is out (though we can stick to Qt4).

There are very good reasons to improve the llvmpipe experience, however, I do agree, that if we cannot achieve a decent experience _right now_, we should avoid shipping it by default.

Didier Roche (didrocks)
no longer affects: unity (Ubuntu)
tags: added: rls-p-tracking
Didier Roche (didrocks)
Changed in unity:
milestone: 5.8.0 → 5.10.0
Didier Roche (didrocks)
no longer affects: unity (Ubuntu Precise)
Revision history for this message
Didier Roche (didrocks) wrote :

putting the downstream task as "fix released" as the release team tracker open downstream tasks which are invalid in this case.

Changed in unity (Ubuntu Precise):
status: New → Fix Released
Didier Roche (didrocks)
Changed in unity:
milestone: 5.10.0 → 5.12.0
Didier Roche (didrocks)
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Didier Roche (didrocks)
Changed in unity:
milestone: 5.12.0 → 5.14.0
Changed in unity:
assignee: Jason Smith (jassmith) → nobody
Omer Akram (om26er)
Changed in unity:
status: Confirmed → Fix Released
Didier Roche (didrocks)
Changed in unity:
status: Fix Released → Triaged
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

No longer affects Unity. This is a Nux issue.

no longer affects: unity
Revision history for this message
Didier Roche (didrocks) wrote :

@Daniel: if it's a nux issue, please open a nux upstream task

Revision history for this message
Didier Roche (didrocks) wrote :

Remember that comment as well: https://bugs.launchpad.net/nux/+bug/926859/comments/5
Jason told it was an issue in unity itself

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Fix released in Nux.

Also note this entire bug is now irrelevant. Because LLVMpipe now works (bug 1021104) and should not be blacklisted any more.

Changed in nux:
status: New → Fix Released
Changed in unity:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers