Ubuntu

compiz crashed with SIGSEGV in std::list<unity::debug::Introspectable*, std::allocator<unity::debug::Introspectable*> >::remove()

Reported by Octavian Damiean on 2012-01-13
120
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Nux
Critical
Unassigned
Unity
Critical
Thomi Richards
nux (Ubuntu)
Critical
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

This crash occured while Unity 5.0 testing at the step where you have to change a launcher icon's position and remove or add an icon to the launcher and then restart Unity by clicking the Test button.

Unity was restarted but presented a crash report.

Steps to reporduce:
1.) Run Unity Testing
2.) Get to the described test.
3.) Follow the instructions.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: libnux-2.0-0 2.0.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-8.15-generic-pae 3.2.0
Uname: Linux 3.2.0-8-generic-pae i686
ApportVersion: 1.90-0ubuntu2
Architecture: i386
Date: Fri Jan 13 22:32:36 2012
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120108)
ProcCmdline: compiz
SegvAnalysis:
 Segfault happened at: 0xb4788580 <_ZNSt4listIPN5unity5debug14IntrospectableESaIS3_EE6removeERKS3_+48>: cmp %edx,0x8(%esi)
 PC (0xb4788580) ok
 source "%edx" ok
 destination "0x8(%esi)" (0x00000008) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 std::list<unity::debug::Introspectable*, std::allocator<unity::debug::Introspectable*> >::remove(unity::debug::Introspectable* const&) () from /usr/lib/compiz/libunityshell.so
 unity::debug::Introspectable::~Introspectable() () from /usr/lib/compiz/libunityshell.so
 unity::dash::SearchBar::~SearchBar() () from /usr/lib/compiz/libunityshell.so
 unity::dash::SearchBar::~SearchBar() () from /usr/lib/compiz/libunityshell.so
 nux::Object::Destroy() () from /usr/lib/libnux-core-2.0.so.0
Title: compiz crashed with SIGSEGV in std::list<unity::debug::Introspectable*, std::allocator<unity::debug::Introspectable*> >::remove()
UpgradeStatus: Upgraded to precise on 2012-01-12 (0 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Octavian Damiean (mainerror) wrote :

StacktraceTop:
 std::list<unity::debug::Introspectable*, std::allocator<unity::debug::Introspectable*> >::remove (this=0x8bce03c, __value=@0xbf7fe0cc) at /usr/include/c++/4.6/bits/list.tcc:249
 unity::debug::Introspectable::~Introspectable (this=0x89be300, __in_chrg=<optimized out>) at /build/buildd/unity-5.0.0/plugins/unityshell/src/Introspectable.cpp:34
 unity::dash::SearchBar::~SearchBar (this=0x89be300, __in_chrg=<optimized out>) at /build/buildd/unity-5.0.0/plugins/unityshell/src/DashSearchBar.cpp:127
 unity::dash::SearchBar::~SearchBar (this=0x89be300, __in_chrg=<optimized out>) at /build/buildd/unity-5.0.0/plugins/unityshell/src/DashSearchBar.cpp:133
 nux::Object::Destroy (this=0x89be314) at ./Object.cpp:338

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Didier Roche (didrocks) on 2012-02-01
Changed in unity:
status: New → Confirmed
Changed in nux:
status: New → Confirmed
Changed in nux (Ubuntu):
importance: Medium → Critical
visibility: private → public
Changed in nux (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

Is anyone still experiencing this with latest version of libnux-2.0-0 ( 2.2.0-0ubuntu1 ) ?

tags: added: rls-mgr-p-tracking
Changed in nux (Ubuntu):
status: Confirmed → Incomplete

Hello Jean-Baptiste,

I had one crash today (before update-manager kicked in, happened while
connecting to a wireless network. When I checked the box "show password"
compiz crashed.
Bug report was created and sent.

Best regards,

Bram van Munster.

Jean-Baptiste Lallement schreef op do 09-02-2012 om 10:38 [+0000]:

> Thanks for your report.
>
> Is anyone still experiencing this with latest version of libnux-2.0-0 (
> 2.2.0-0ubuntu1 ) ?
>
> ** Tags added: rls-mgr-p-tracking
>
> ** Changed in: nux (Ubuntu)
> Status: Confirmed => Incomplete
>

David Barth (dbarth) on 2012-02-10
Changed in unity:
milestone: none → 5.6.0
assignee: nobody → Jay Taoko (jaytaoko)
importance: Undecided → Critical
Changed in nux (Ubuntu):
milestone: none → ubuntu-12.04-beta-1
Omer Akram (om26er) on 2012-02-13
Changed in nux (Ubuntu):
status: Incomplete → Confirmed
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Jay Taoko (jaytaoko)
Changed in nux:
importance: Undecided → Critical
Thomi Richards (thomir) wrote :

This was fixed in unity, revision 1876, on Sun 2012-01-29. When I fixed it I didn't see this bug report.

If it still happens in the latest uinity builds it'd be good to get another stack trace.

Cheers,

Changed in unity:
assignee: Jay Taoko (jaytaoko) → Thomi Richards (thomir)
status: Confirmed → Fix Committed
Tim Penhey (thumper) on 2012-02-14
Changed in unity:
milestone: 5.6.0 → 5.4.0
Changed in nux:
status: Confirmed → Invalid
Changed in nux (Ubuntu):
status: Confirmed → Invalid
assignee: Jay Taoko (jaytaoko) → nobody
Didier Roche (didrocks) on 2012-02-17
Changed in nux:
status: Invalid → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-02-20
Changed in unity (Ubuntu):
status: New → Fix Released
Robert Hooker (sarvatt) on 2012-02-23
Changed in nux (Ubuntu):
milestone: ubuntu-12.04-beta-1 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers