compiz crashed with SIGSEGV in nux::GridHLayout::KeyNavIterationRowOrder()

Bug #916088 reported by Erick John Cuevas on 2012-01-13
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Critical
Andrea Azzarone
Unity
Fix Released
Undecided
Unassigned
nux (Ubuntu)
Critical
Andrea Azzarone
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I dont know what just happen, but it says that there was an error in compiz.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: libnux-2.0-0 2.0.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-8.15-generic 3.2.0
Uname: Linux 3.2.0-8-generic i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Date: Fri Jan 13 23:59:12 2012
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20111129.1)
ProcCmdline: compiz
Signal: 11
SourcePackage: nux
StacktraceTop:
 nux::GridHLayout::KeyNavIterationRowOrder(nux::KeyNavDirection) () from /usr/lib/libnux-2.0.so.0
 nux::GridHLayout::KeyNavIteration(nux::KeyNavDirection) () from /usr/lib/libnux-2.0.so.0
 nux::WindowCompositor::KeyboardEventCycle(nux::Event&) () from /usr/lib/libnux-2.0.so.0
 nux::WindowCompositor::ProcessEvent(nux::Event&) () from /usr/lib/libnux-2.0.so.0
 nux::WindowThread::ExecutionLoop(unsigned int) () from /usr/lib/libnux-2.0.so.0
Title: compiz crashed with SIGSEGV in nux::GridHLayout::KeyNavIterationRowOrder()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

StacktraceTop:
 nux::GridHLayout::KeyNavIterationRowOrder (this=0xb546d210, direction=nux::KEY_NAV_DOWN) at ./GridHLayout.cpp:676
 nux::GridHLayout::KeyNavIteration (this=0xb546d210, direction=nux::KEY_NAV_DOWN) at ./GridHLayout.cpp:825
 nux::WindowCompositor::KeyboardEventCycle (this=0x8ca1d48, event=...) at ./WindowCompositor.cpp:1008
 nux::WindowCompositor::ProcessEvent (this=0x8ca1d48, event=...) at ./WindowCompositor.cpp:1055
 nux::WindowThread::ExecutionLoop (this=0x8b85eb0, timer_id=0) at ./WindowThread.cpp:570

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu):
status: New → Confirmed
visibility: private → public
Average John (averagejohn) wrote :

My test case:

1) Press Super to open the Dash
2) Press Tab to go the applications dash
3) Click on Filter results
4) Click on any category except Accessories
5) Now click on accessories and press the Arrow Down key (maybe more than once). This will cause this crash.

Andrea Azzarone (azzar1) on 2012-01-18
Changed in nux:
importance: Undecided → Critical
status: New → Confirmed
Andrea Azzarone (azzar1) on 2012-01-18
Changed in nux:
assignee: nobody → Andrea Azzarone (andyrock)
Changed in nux (Ubuntu):
assignee: nobody → Andrea Azzarone (andyrock)
Changed in nux:
status: Confirmed → In Progress
Changed in nux (Ubuntu):
status: Confirmed → In Progress
Andrea Azzarone (azzar1) on 2012-01-19
Changed in nux:
status: In Progress → Fix Committed
Changed in nux (Ubuntu):
status: In Progress → Fix Committed
Andrea Azzarone (azzar1) on 2012-01-19
Changed in nux:
status: Fix Committed → In Progress
Changed in nux (Ubuntu):
status: Fix Committed → In Progress
Andrea Azzarone (azzar1) on 2012-01-20
Changed in nux:
status: In Progress → Fix Committed
Changed in nux (Ubuntu):
status: In Progress → Fix Committed
Tim Penhey (thumper) on 2012-01-23
Changed in nux:
milestone: none → 2.2
Didier Roche (didrocks) on 2012-02-01
Changed in unity:
status: New → Fix Committed
Changed in nux (Ubuntu):
importance: Medium → Critical
Jay Taoko (jaytaoko) on 2012-02-02
Changed in unity:
milestone: none → 5.2.0
Jay Taoko (jaytaoko) on 2012-02-02
Changed in nux:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-02-03
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 2.2.0-0ubuntu1

---------------
nux (2.2.0-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Dash - Behaviour of the 'All' button in the Dash filters broken in
      several ways (LP: #841864)
    - Launcher, Spread - Clicking on a Launcher app icon a second time to
      close a spread is broken (LP: #893670)
    - launcher not hiding in one design-specified case (LP: #919162)
    - compiz crashed with SIGSEGV in
      nux::GridHLayout::KeyNavIterationRowOrder() (LP: #916088)
  * Cherry-pick an additional fix for boot time
 -- Didier Roche <email address hidden> Fri, 03 Feb 2012 11:35:48 +0100

Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers