compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator std::string()

Bug #869109 reported by Curtis Hovey on 2011-10-06
82
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
High
Gord Allott
nux (Ubuntu)
High
Unassigned
Oneiric
Undecided
Unassigned
unity (Ubuntu)
High
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

After updating my software (not logging out), I opened Unity's run command dash and clicked on a command I frequently run. compiz crashed.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: libnux-1.0-0 1.14.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
NonfreeKernelModules: nvidia wl
ApportVersion: 1.23-0ubuntu2
Architecture: i386
CrashCounter: 1
Date: Thu Oct 6 08:05:01 2011
ExecutablePath: /usr/bin/compiz
ProcCmdline: compiz
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xb3c7da65 <_ZNK3nux10ROPropertyISsEcvSsEv+37>: mov 0x4(%edx),%esi
 PC (0xb3c7da65) ok
 source "0x4(%edx)" (0xe2c5c1bd) not located in a known VMA region (needed readable region)!
 destination "%esi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 nux::ROProperty<std::string>::operator std::string() const () from /usr/lib/compiz/libunityshell.so
 unity::dash::ResultViewGrid::OnOnKeyNavFocusChange(nux::Area*) () from /usr/lib/compiz/libunityshell.so
 sigc::internal::slot_call1<sigc::bound_mem_functor1<void, unity::dash::ResultViewGrid, nux::Area*>, void, nux::Area*>::call_it(sigc::internal::slot_rep*, nux::Area* const&) () from /usr/lib/compiz/libunityshell.so
 sigc::internal::signal_emit1<void, nux::Area*, sigc::nil>::emit(sigc::internal::signal_impl*, nux::Area* const&) () from /usr/lib/libnux-1.0.so.0
 nux::WindowCompositor::SetKeyFocusArea(nux::InputArea*) () from /usr/lib/libnux-1.0.so.0
Title: compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator std::string()
UpgradeStatus: Upgraded to oneiric on 2011-09-23 (12 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Curtis Hovey (sinzui) wrote :

StacktraceTop:
 empty (this=<optimized out>) at /usr/include/sigc++-2.0/sigc++/functors/slot_base.h:273
 operator() (this=0x9236788) at /usr/include/sigc++-2.0/sigc++/functors/slot.h:439
 nux::ROProperty<std::string>::operator std::string (this=0x923677c) at /usr/include/Nux-1.0/NuxCore/Property-inl.h:142
 unity::dash::ResultViewGrid::OnOnKeyNavFocusChange (this=0xaee439a0, area=0xaee439a0) at /build/buildd/unity-4.22.0/plugins/unityshell/src/ResultViewGrid.cpp:497
 operator() (this=0xaee43ec4, _A_a1=<optimized out>) at /usr/include/sigc++-2.0/sigc++/functors/mem_fun.h:1851

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
importance: Undecided → High
Changed in nux (Ubuntu):
importance: Medium → High
Changed in unity:
milestone: none → 4.24.0
Changed in unity (Ubuntu):
status: New → Confirmed
Gord Allott (gordallott) on 2011-10-10
Changed in unity:
status: New → In Progress
assignee: nobody → Gord Allott (gordallott)
Neil J. Patel (njpatel) on 2011-10-10
Changed in nux (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Gord Allott (gordallott) wrote :

Testcase:

Open the dash, search for an item and click on the item,

should never crash

Didier Roche (didrocks) on 2011-10-14
Changed in nux (Ubuntu):
status: Fix Committed → Invalid
Omer Akram (om26er) on 2011-10-16
Changed in nux (Ubuntu Oneiric):
status: New → Invalid
Omer Akram (om26er) on 2011-10-16
Changed in unity:
status: Fix Committed → Fix Released

Hello Curtis, or anyone else affected,

Accepted unity into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Miklos Juhasz (mjuhasz) wrote :

The proposed version works as expected, no crash happened.
I executed the testcase given by Gord Allott in comment #7. I repeated the steps about 10 times on 3 different installations.

Omer Akram (om26er) on 2011-10-18
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu2

---------------
unity (4.24.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - SRU0-Regression: scrollbar displacement caused dash rows to show less
      icons (LP: #875023)
    - Really reverts the UI change that was still uploaded even if we had
      reverted it…

unity (4.24.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release and some cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #864758)
    - unity panel menus don't stay open when clicked on second monitor
      (LP: #869196)
    - (oneiric) menu bar in wrong place and invisible (LP: #845856)
    - Lens range widgets do not function correctly (LP: #862996)
    - Cannot raise window from panel after minimize (LP: #863114)
    - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
      (LP: #843280)
    - Windows get corrupted sometimes when semi-maximizing them. (LP: #865177)
    - Automaximization happens on unminimize (LP: #868930)
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #869109)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - F10 opens a random menu item when it should open the first one
      [regression] (LP: #862849)
    - Switching desktops after using showdesktop can cause hidden windows to
      become "active" (LP: #864503)
    - Clicking blank space on top panel doesn't raise maximized window to
      front (LP: #864708)
    - unity launcher loses track of deja-dup windows (LP: #865051)
    - Dash - App Lens 'Rating' filter behaves incorrectly (LP: #865482)
    - Launcher does not show on "Show desktop" (LP: #867959)
    - ibus character selection window not drawn (LP: #867885)
    - the dash's entry get wrongly colored on left or right key use
      (LP: #868434)
    - [ibus] Pressing down when ibus is active moves focus (LP: #872730)
    - Double-click on the dash top panel is taken effect on the window
      underneith (LP: #870844)
 -- Didier Roche <email address hidden> Tue, 18 Oct 2011 12:47:54 +0200

Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.24.0-0ubuntu2b1

---------------
unity (4.24.0-0ubuntu2b1) oneiric-proposed; urgency=low

  * No-change reupload because of broken powerpc build.

unity (4.24.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick upstream:
    - SRU0-Regression: scrollbar displacement caused dash rows to show less
      icons (LP: #875023)
    - Really reverts the UI change that was still uploaded even if we had
      reverted it…

unity (4.24.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release and some cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #864758)
    - unity panel menus don't stay open when clicked on second monitor
      (LP: #869196)
    - (oneiric) menu bar in wrong place and invisible (LP: #845856)
    - Lens range widgets do not function correctly (LP: #862996)
    - Cannot raise window from panel after minimize (LP: #863114)
    - unity-panel-service crashed with SIGSEGV in g_closure_invoke()
      (LP: #843280)
    - Windows get corrupted sometimes when semi-maximizing them. (LP: #865177)
    - Automaximization happens on unminimize (LP: #868930)
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #869109)
    - Dash - horizental divider line in between categories incorrectly drawn
      (LP: #841750)
    - F10 opens a random menu item when it should open the first one
      [regression] (LP: #862849)
    - Switching desktops after using showdesktop can cause hidden windows to
      become "active" (LP: #864503)
    - Clicking blank space on top panel doesn't raise maximized window to
      front (LP: #864708)
    - unity launcher loses track of deja-dup windows (LP: #865051)
    - Dash - App Lens 'Rating' filter behaves incorrectly (LP: #865482)
    - Launcher does not show on "Show desktop" (LP: #867959)
    - ibus character selection window not drawn (LP: #867885)
    - the dash's entry get wrongly colored on left or right key use
      (LP: #868434)
    - [ibus] Pressing down when ibus is active moves focus (LP: #872730)
    - Double-click on the dash top panel is taken effect on the window
      underneith (LP: #870844)
 -- Martin Pitt <email address hidden> Tue, 25 Oct 2011 07:01:51 +0200

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers