compiz crashed with SIGSEGV in nux::BaseWindow::GetInputWindowId() (when onboard is used)

Bug #865890 reported by Veb on 2011-10-04
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Nux
Invalid
High
Sam Spilsbury
Unity
Fix Released
High
Sam Spilsbury
nux (Ubuntu)
High
Sam Spilsbury
Oneiric
High
Sam Spilsbury
unity (Ubuntu)
High
Sam Spilsbury
Oneiric
High
Sam Spilsbury

Bug Description

SRU TEST CASE

1. Start a terminal from the launcher
2. Type 'onboard' <enter>
3. Type in the terminal, then click on keys on the onscreen keyboard
4. Verify that compiz does not crash

Just tried Upgrading from 11.04 to 11.10 beta. I expected failures.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: libnux-1.0-0 1.14.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
CrashCounter: 1
Date: Tue Oct 4 00:32:38 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcCmdline: compiz
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fb2ca998c30 <_ZN3nux10BaseWindow16GetInputWindowIdEv>: mov 0x448(%rdi),%rdi
 PC (0x7fb2ca998c30) ok
 source "0x448(%rdi)" (0x00000448) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 nux::BaseWindow::GetInputWindowId() () from /usr/lib/libnux-1.0.so.0
 UnityWindow::UnityWindow(CompWindow*) () from /usr/lib/compiz/libunityshell.so
 PluginClassHandler<UnityWindow, CompWindow, 0>::get(CompWindow*) () from /usr/lib/compiz/libunityshell.so
 CompPlugin::VTableForScreenAndWindow<UnityScreen, UnityWindow>::initWindow(CompWindow*) () from /usr/lib/compiz/libunityshell.so
 CompScreen::initPluginForScreen(CompPlugin*) ()
Title: compiz crashed with SIGSEGV in nux::BaseWindow::GetInputWindowId()
UpgradeStatus: Upgraded to oneiric on 2011-10-04 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Veb (crazyness003) wrote :

StacktraceTop:
 nux::BaseWindow::GetInputWindowId (this=0x0) at ./BaseWindow.cpp:362
 UnityWindow::UnityWindow (this=0x272d720, window=0x1e73720) at /build/buildd/unity-4.20.0/plugins/unityshell/src/unityshell.cpp:2390
 getInstance (base=0x1e73720) at /usr/include/compiz/core/pluginclasshandler.h:159
 PluginClassHandler<UnityWindow, CompWindow, 0>::get (base=0x1e73720) at /usr/include/compiz/core/pluginclasshandler.h:185
 CompPlugin::VTableForScreenAndWindow<UnityScreen, UnityWindow>::initWindow (this=<optimized out>, w=<optimized out>) at /usr/include/compiz/core/plugin.h:249

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu):
status: New → Confirmed
Changed in nux:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in nux (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in nux:
status: New → Fix Committed
status: Fix Committed → In Progress
Changed in nux (Ubuntu):
status: Confirmed → In Progress
Changed in nux:
milestone: none → 1.0.1
Sebastien Bacher (seb128) wrote :

seems to happen when enabled "onscreen keyboard", i.e running onboard

Sebastien Bacher (seb128) wrote :

it's the same issue than bug #783439 it seems

Changed in unity:
milestone: none → 4.26.0
Changed in nux (Ubuntu):
importance: Medium → High
Changed in unity:
importance: Undecided → High
Changed in nux:
importance: Undecided → High
Changed in unity (Ubuntu):
importance: Undecided → High
summary: - compiz crashed with SIGSEGV in nux::BaseWindow::GetInputWindowId()
+ compiz crashed with SIGSEGV in nux::BaseWindow::GetInputWindowId() (when
+ onboard is used)
Changed in unity (Ubuntu Oneiric):
status: New → In Progress
Changed in unity:
status: New → In Progress
Omer Akram (om26er) on 2011-10-15
Changed in nux:
milestone: 1.0.1 → none
status: In Progress → Invalid
Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity (Ubuntu Oneiric):
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in nux (Ubuntu):
status: In Progress → Invalid
Changed in nux (Ubuntu Oneiric):
status: In Progress → Invalid
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Didier Roche (didrocks) on 2011-10-25
Changed in unity (Ubuntu):
status: In Progress → Fix Committed

Hello Veb, or anyone else affected,

Accepted unity into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Oneiric):
status: In Progress → Fix Committed
tags: added: verification-needed
Omer Akram (om26er) on 2012-01-18
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
David Barth (dbarth) on 2012-01-26
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.28.0-0ubuntu2

---------------
unity (4.28.0-0ubuntu2) oneiric-proposed; urgency=low

  * Cherry-pick some additional fixes:
    - fix a regression where transparency is setup on the panel (LP: #830949)
    - the wrong commit causing a crash was revert. Revert the revert and
      revert the right guilty commit.

unity (4.28.0-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release.
    - don't segfault in geis_configuration_get_value() (lp: #850623)
    - get focus on dash by pressing the super key first time after login
      (lp: #860805)
    - clicking on panel when dash is open no longer causes maximized window
      to raise (lp: #873100)
    - window management, alt-tab - After using 'show desktop' to minimise all
      windows, opening any new window also incorrectly restores all
      the minimised windows (lp: #871801)
    - compiz crashed with SIGSEGV in
      unity::switcher::SwitcherModel::DetailSelectionWindow() (lp: #834630)
    - compiz crashed with SIGSEGV in g_strcmp0() (lp: #832151)
    - compiz crashed with SIGSEGV in nux::BaseWindow::GetInputWindowId()
      (when onboard is used) (lp: #865890)
    - fix multi-monitor crashers (lp: #838128, #864037, #864784, #868120)
    - Fix SIGSEGV after SwitcherController desctruction (lp: #887465)
    - Fix for "right-clicking launcher when choosing a workspace causes
      quicklists to freeze" (lp: #791810)
  * debian/patches/add_postrelease_buildfix.patch:
    - add post-release fix to build in a clean env
  * backport some additional reverts or regression fixes
 -- Didier Roche <email address hidden> Thu, 19 Jan 2012 09:54:44 +0100

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers