Ubuntu

compiz crashed with SIGSEGV in nux::WindowThread::IsInsideLayoutCycle()

Reported by Dmitry Shachnev on 2011-10-02
62
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Nux
High
Unassigned
Unity
High
Unassigned
nux (Ubuntu)
High
Unassigned

Bug Description

Similar to bug 762258 and bug 764985, but they are marked fixed.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: libnux-1.0-0 1.14.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu2
Architecture: i386
CrashCounter: 1
Date: Sun Oct 2 19:25:25 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100318)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=ru:en
 LANG=ru_RU.utf8
 LC_MESSAGES=ru_RU.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x17aeda4 <_ZNK3nux12WindowThread19IsInsideLayoutCycleEv+4>: movzbl 0x130(%eax),%eax
 PC (0x017aeda4) ok
 source "0x130(%eax)" (0x00000130) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 nux::WindowThread::IsInsideLayoutCycle() const () from /usr/lib/libnux-1.0.so.0
 nux::Area::ReconfigureParentLayout(nux::Area*) () from /usr/lib/libnux-1.0.so.0
 nux::Area::SetMinimumHeight(int) () from /usr/lib/libnux-1.0.so.0
 unity::dash::ResultViewGrid::SizeReallocate() () from /usr/lib/compiz/libunityshell.so
 unity::dash::ResultViewGrid::RemoveResult(unity::dash::Result&) () from /usr/lib/compiz/libunityshell.so
Title: compiz crashed with SIGSEGV in nux::WindowThread::IsInsideLayoutCycle()
UpgradeStatus: Upgraded to oneiric on 2011-09-02 (30 days ago)
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev nopasswdlogin plugdev sambashare tape video

Related branches

Dmitry Shachnev (mitya57) wrote :
visibility: private → public

StacktraceTop:
 nux::WindowThread::IsInsideLayoutCycle (this=0x0) at ./WindowThread.cpp:785
 IsComputingLayout (this=<optimized out>) at ./WindowThread.h:172
 nux::Area::ReconfigureParentLayout (this=0xa2ca6a0, child=0x0) at ./Area.cpp:422
 nux::Area::SetMinimumHeight (this=0xa2ca6a0, h=132) at ./Area.cpp:230
 unity::dash::ResultViewGrid::SizeReallocate (this=0xa2ca6a0) at /build/buildd/unity-4.20.0/plugins/unityshell/src/ResultViewGrid.cpp:263

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu):
status: New → Confirmed
Jay Taoko (jaytaoko) on 2011-10-25
Changed in nux:
status: New → Fix Committed
Changed in unity:
status: New → Fix Committed
Didier Roche (didrocks) on 2011-10-25
Changed in nux (Ubuntu):
status: Confirmed → Fix Committed
importance: Medium → Critical
Omer Akram (om26er) on 2011-12-08
Changed in unity:
importance: Undecided → High
Changed in nux:
importance: Undecided → High
Changed in nux (Ubuntu):
importance: Critical → High
Gord Allott (gordallott) on 2012-01-12
Changed in unity:
milestone: none → 5.0.0
Didier Roche (didrocks) on 2012-01-12
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 2.0.0-0ubuntu1

---------------
nux (2.0.0-0ubuntu1) precise; urgency=low

  [ Aurélien Gâteau ]
  * New upstream release:
    - compiz crashed with SIGSEGV in nux::ROProperty<std::string>::operator
      std::string() (LP: #881106)
    - compiz crashed with SIGSEGV in
      nux::WindowCompositor::FindKeyFocusAreaFrom() (LP: #860852)
    - compiz crashed with SIGSEGV in nux::Area::FindKeyFocusArea()
      (LP: #848952)
    - compiz crashed with SIGILL in typeinfo for std::ostream() (LP: #849881)
    - compiz crashed with SIGSEGV in nux::WindowThread::IsInsideLayoutCycle()
      (LP: #864686)
    - Select quicklist items with just one right click (LP: #688830)
    - OnMouseDoubleClick in InputArea isn't working (LP: #708020)
    - Menubar - horizontal scroll over a menu opens it (LP: #775872)
    - Clicking on a dash category header should not give it keyboard focus
      (LP: #905921)
    - Horizontal scroll on maximize/restore window control restores window.
      (LP: #809717)
    - Horizontally scrolling while highlighting an item in the dash or on an
      indicator will open the item. (LP: #837004)
    - compiz crashed with SIGSEGV in free() (LP: #864446)
    - Mouse wheel doesn't works if the mouse pointer is inside dash scrollbar.
      (LP: #888819)
  * debian/rules, debian/control:
    - add nuxabiversion capability as upstream is breaking a lot the ABI
      wasn't bumping the soname. Create a virtual package similar to what
      we already do in compiz to ensure we dep on the right version.
      Remove the makeshlibs override then as not needed anymore.
    - bump to nux 2.0 with new libnux-2.0-0, libnux-2.0-common, libnux-2.0-dev
      packages. Make the necessary changes in .install files as well
    - don't ship anymore the -doc package.
  * debian/nux-tools.install:
    - move the apport file there instead of the -common package to enable
      co-instability
 -- Didier Roche <email address hidden> Fri, 13 Jan 2012 09:04:48 +0100

Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers