compiz crashed with SIGSEGV in main_arena()

Bug #845748 reported by Pedro Villavicencio on 2011-09-09
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Medium
Unassigned
nux (Ubuntu)
Medium
Unassigned

Bug Description

I switched from the 1 workspace waited like 5 seconds and compiz crashed.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: libnux-1.0-0 1.8.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0-3.4-generic-pae 3.0.0-rc5
Uname: Linux 3.0-3-generic-pae i686
ApportVersion: 1.22.1-0ubuntu2
Architecture: i386
CheckboxSubmission: 4afb8c68a8fa5938a80183a271a939ea
CheckboxSystem: c460f5739f7c8446c3d18c3e0e7c5745
Date: Fri Sep 9 12:52:11 2011
ExecutablePath: /usr/bin/compiz
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, no user)
 LANG=es_CL.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xb6e526d8 <main_arena+728>: shlb (%esi)
 PC (0xb6e526d8) in non-executable VMA region: 0xb6e52000-0xb6e55000 rw-p None
 source "(%esi)" (0x0a176b38) ok
SegvReason: executing writable VMA None
Signal: 11
SourcePackage: nux
StacktraceTop:
 main_arena () from /lib/i386-linux-gnu/libc.so.6
 nux::Area::FindKeyFocusArea(unsigned int, unsigned long, unsigned long) () from /usr/lib/libnux-1.0.so.0
 nux::View::FindKeyFocusArea(unsigned int, unsigned long, unsigned long) () from /usr/lib/libnux-1.0.so.0
 nux::Area::FindKeyFocusArea(unsigned int, unsigned long, unsigned long) () from /usr/lib/libnux-1.0.so.0
 nux::View::FindKeyFocusArea(unsigned int, unsigned long, unsigned long) () from /usr/lib/libnux-1.0.so.0
Title: compiz crashed with SIGSEGV in main_arena()
UpgradeStatus: Upgraded to oneiric on 2011-07-06 (65 days ago)
UserGroups: adm admin audio cdrom dialout fuse lpadmin netdev plugdev sambashare video

Pedro Villavicencio (pedro) wrote :

StacktraceTop:
 main_arena () from /tmp/tmpLSQs92/lib/i386-linux-gnu/libc.so.6
 FindKeyFocusArea (special_keys_state=786432, x11_key_code=65513, key_symbol=7, this=<optimized out>) at ./Area.cpp:962
 nux::Area::FindKeyFocusArea (this=0xa10da50, key_symbol=7, x11_key_code=65513, special_keys_state=786432) at ./Area.cpp:952
 FindKeyFocusArea (special_keys_state=786432, x11_key_code=65513, key_symbol=7, this=<optimized out>) at ./View.cpp:649
 nux::View::FindKeyFocusArea (this=0xa0699a0, key_symbol=7, x11_key_code=65513, special_keys_state=786432) at ./View.cpp:639

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Changed in nux (Ubuntu):
status: New → Confirmed
omarly666 (omarly666) wrote :

bug fixed on all other bugs, so i guess this is it. all updates done and dual-screen. difficulties now gonna restart

I just encountered one more incidence minutes ago and have to press Cirl+Alt
+F1 to run sudo restart lightdm at console.

At that time, I had chrome open, empathy open. I trid to use
Cirl+Shift+Alt+Down to move my current window, which is chrome, down to
another virtual desktop. Then suddenly, compiz restarted twice, the unity
panel in the top was gone, and I had to restart X.

Is it the same problem? Or do I need to report a new bug? Thanks.

On Fri, Sep 16, 2011 at 2:41 AM, omarly666 <email address hidden>wrote:

> bug fixed on all other bugs, so i guess this is it. all updates done and
> dual-screen. difficulties now gonna restart
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/845748
>
> Title:
> compiz crashed with SIGSEGV in main_arena()
>
> Status in “nux” package in Ubuntu:
> Confirmed
>
> Bug description:
> I switched from the 1 workspace waited like 5 seconds and compiz
> crashed.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: libnux-1.0-0 1.8.0-0ubuntu1
> ProcVersionSignature: Ubuntu 3.0-3.4-generic-pae 3.0.0-rc5
> Uname: Linux 3.0-3-generic-pae i686
> ApportVersion: 1.22.1-0ubuntu2
> Architecture: i386
> CheckboxSubmission: 4afb8c68a8fa5938a80183a271a939ea
> CheckboxSystem: c460f5739f7c8446c3d18c3e0e7c5745
> Date: Fri Sep 9 12:52:11 2011
> ExecutablePath: /usr/bin/compiz
> ProcCmdline: compiz
> ProcEnviron:
> PATH=(custom, no user)
> LANG=es_CL.UTF-8
> SHELL=/bin/bash
> SegvAnalysis:
> Segfault happened at: 0xb6e526d8 <main_arena+728>: shlb (%esi)
> PC (0xb6e526d8) in non-executable VMA region: 0xb6e52000-0xb6e55000 rw-p
> None
> source "(%esi)" (0x0a176b38) ok
> SegvReason: executing writable VMA None
> Signal: 11
> SourcePackage: nux
> StacktraceTop:
> main_arena () from /lib/i386-linux-gnu/libc.so.6
> nux::Area::FindKeyFocusArea(unsigned int, unsigned long, unsigned long)
> () from /usr/lib/libnux-1.0.so.0
> nux::View::FindKeyFocusArea(unsigned int, unsigned long, unsigned long)
> () from /usr/lib/libnux-1.0.so.0
> nux::Area::FindKeyFocusArea(unsigned int, unsigned long, unsigned long)
> () from /usr/lib/libnux-1.0.so.0
> nux::View::FindKeyFocusArea(unsigned int, unsigned long, unsigned long)
> () from /usr/lib/libnux-1.0.so.0
> Title: compiz crashed with SIGSEGV in main_arena()
> UpgradeStatus: Upgraded to oneiric on 2011-07-06 (65 days ago)
> UserGroups: adm admin audio cdrom dialout fuse lpadmin netdev plugdev
> sambashare video
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/nux/+bug/845748/+subscriptions
>

Reeyarn (reeyarn) wrote :

I just encountered one more incidence minutes ago and have to press Cirl+Alt +F1 to run sudo restart lightdm at console.

At that time, I had chrome open, empathy open. I trid to use Cirl+Shift+Alt+Down to move my current window, which is chrome, down to another virtual desktop. Then suddenly, compiz restarted twice, the unity panel in the top was gone, and I had to restart X.

Is it the same problem? Or do I need to report a new bug? Thanks.

Pedro Villavicencio (pedro) wrote :

haven't seen this in a while, so closing it as fixed.

Changed in nux (Ubuntu):
status: Confirmed → Fix Released
Changed in nux:
importance: Undecided → Medium
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers