unity_support_test crashed with SIGSEGV in fclose()

Bug #843369 reported by SarahSlean on 2011-09-06
This bug affects 203 people
Affects Status Importance Assigned to Milestone
Nux
High
Unassigned
Unity
High
Didier Roche
nux (Ubuntu)
High
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

on virtual box

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: nux-tools 1.6.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic i686
.tmp.unity.support.test.1:

Architecture: i386
CompizPlugins: [core,bailer,detection,gtkloader,composite,opengl,imgjpeg,decor,resize,mousepoll,compiztoolbox,wall,place,resizeinfo,move,snap,debugspew,imgsvg,screenshot,text,zoom,grid,copytex,inotify,dbus,commands,water,put,imgpng,kde,vpswitch,annotate,regex,gnomecompat,animation,blur,session,neg,thumbnail,colorfilter,unitymtgrabhandles,kdecompat,obs,workarounds,expo,ezoom,staticswitcher,fade,opacify,scale,unityshell,scaleaddon]
CompositorRunning: None
Date: Wed Sep 7 01:06:56 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 virtualbox-guest, 4.1.2, 3.0.0-10-generic, i686: installed
 virtualbox-guest, 4.1.2, 3.0.0-9-generic, i686: installed
ExecutablePath: /usr/lib/nux/unity_support_test
GraphicsCard: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef] (prog-if 00 [VGA controller])
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110803.1)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
MachineType: innotek GmbH VirtualBox
ProcCmdline: /usr/lib/nux/unity_support_test
ProcEnviron:
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-10-generic root=UUID=1658b45c-025b-4b2b-8786-e022b702d20b ro quiet splash vt.handoff=7
Renderer: Software
SegvAnalysis:
 Segfault happened at: 0x828f82 <fclose+34>: cmpb $0x0,0x46(%esi)
 PC (0x00828f82) ok
 source "$0x0" ok
 destination "0x46(%esi)" (0x00000046) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 fclose () from /lib/i386-linux-gnu/libc.so.6
 ?? ()
 __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
 ?? ()
Title: unity_support_test crashed with SIGSEGV in fclose()
UnitySupportTest: Error: command ['/usr/lib/nux/unity_support_test', '-p', '-f'] failed with exit code -11: OpenGL Warning: Failed to connect to host. Make sure 3D acceleration is enabled for this VM.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH
version.compiz: compiz 1:0.9.5.92+bzr2791-0ubuntu2
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

SarahSlean (yoda4) wrote :
visibility: private → public

StacktraceTop:
 _IO_new_fclose (fp=0x0) at iofclose.c:52
 main (argc=1, argv=0xbfb5e644) at unity_support_test.c:608

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Changed in nux (Ubuntu):
status: New → Confirmed
Paul Hoell (hoellp) wrote :

I also had a few of these. I'm attaching my apport crashreport...

The reporter looks to use german locale, which is also true for me.

I'm on bare metal though, not in a VM.

Paul Hoell (hoellp) wrote :
jerrylamos (jerrylamos) wrote :

On real hardware, 3.33 gHz Compaq Presario, ati radeon xpress 200

Beta 1 install Updated as of 8 September whole pile of crashes including this one.

tags: added: bugpattern-needed
David R. Hedges (p14nd4) wrote :

Adding the comment from my bug, which was marked as a duplicate of this:
When I saw this crash, I was running Ubuntu 11.10 (64bit) in vmware workstation 7.1.4 (host is Windows 7 64-bit). I do have vmware set to "Accelerate 3D Graphics", but it seems like sometimes Ubuntu doesn't recognize this fact (i.e. the dock isn't semi-transparent). Most of the vmware tools wouldn't install, but vmware-user seems to run, allowing me to auto-fit guest window.

Getting this today on real hardware (amd64) whenever I report a bug, including trying to report this bug. However the actual reporting of the bug seems to continue normally.

Doesn't seem to be a relevant file in /var/crash to upload. seems only way i could is to continue to report as a new bug despite knowing it's a duplicate of this.

crtm (carlosrtm) wrote :

today, after update, then crash

gerstrong (gerstrong) wrote :

me too. :( Not trying on Virtual Box...

Rainer Rohde (rainer-rohde) wrote :

Crashed on me when I was trying to report a Compiz crash...

Beuntje-ict (beuntje-ict) wrote :

Crashed on me when I was trying to report a Compiz crash...

Mathieu Marquer (slasher-fun) wrote :

Same: crashed when trying to report a compiz crash (#806140)

I think it might be related to this bug:
https://bugs.launchpad.net/unity/+bug/808286

screenshot of what was happening:

A Edwards (abedwardsw) wrote :

same bug here in vbox

Didier Roche (didrocks) on 2011-09-12
Changed in unity:
status: New → Triaged
importance: Undecided → High
status: Triaged → Fix Committed
Changed in nux (Ubuntu):
importance: Medium → High
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
Changed in nux (Ubuntu):
status: Confirmed → Fix Committed
Changed in nux:
status: New → Triaged
Changed in unity:
milestone: none → 4.16.0
Changed in nux:
status: Triaged → Fix Committed
importance: Undecided → High
Mickael-goetz (mickael-goetz) wrote :

I had this bug today (monday 12 september 2011) on bêta 1 with full update.
The same bug appeared a second time while Apport was gathering infos about this one.
I had the unity dash opened and was trying to make a search among the files with 5 stars when the bug occured ; but I'm not sure if it's related...

DeadlyWolf (deadlywolf051) wrote :

This happened 13 september after updating and using Jockey to install Nvidia Driver, I had just rebooted and was seeing how the nvidia driver was performing by switching workspaces. It also occurred while Apport was gathering info.

Didier Roche (didrocks) on 2011-09-15
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 1.10.0-0ubuntu1

---------------
nux (1.10.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in nux::GpuDevice::GetGpuInfo()
      (LP: #765375)
    - compiz crashed with SIGSEGV in nux::WindowCompositor::SetKeyFocusArea()
      (LP: #846059)
    - unity_support_test crashed with SIGSEGV in fclose() (LP: #843369)
    - compiz crashed with SIGSEGV in nux::Area::FindKeyFocusArea()
      (LP: #815114)
 -- Didier Roche <email address hidden> Thu, 15 Sep 2011 18:42:58 +0200

Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers