compiz crashed with SIGSEGV in sigc::signal_base::impl()

Bug #831769 reported by bcbc on 2011-08-23
592
This bug affects 71 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
High
Tim Penhey
Unity
Fix Released
High
Tim Penhey
nux (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned
unity (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

Changed a setting in compiz config settings manager (turned off Window decoration in the Effects group).
Note: using compiz-testing PPA (compiz-testing-0.9.5.0)

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity 4.8.2-0ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-9.12-generic 3.0.3
Uname: Linux 3.0.0-9-generic i686
Architecture: i386
CrashCounter: 1
Date: Mon Aug 22 22:26:27 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110803.1)
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xbfae2e <_ZNK4sigc11signal_base4implEv+30>: mov 0x4(%edi),%esi
 PC (0x00bfae2e) ok
 source "0x4(%edi)" (0x00000084) not located in a known VMA region (needed readable region)!
 destination "%esi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 sigc::signal_base::impl() const () from /usr/lib/libsigc-2.0.so.0
 sigc::signal_base::connect(sigc::slot_base const&) () from /usr/lib/libsigc-2.0.so.0
 UnityScreen::UnityScreen(CompScreen*) () from /usr/lib/compiz/libunityshell.so
 PluginClassHandler<UnityScreen, CompScreen, 0>::get(CompScreen*) () from /usr/lib/compiz/libunityshell.so
 CompPlugin::VTableForScreenAndWindow<UnityScreen, UnityWindow>::initScreen(CompScreen*) () from /usr/lib/compiz/libunityshell.so
Title: compiz crashed with SIGSEGV in sigc::signal_base::impl()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

bcbc (bcbc) wrote :
description: updated

StacktraceTop:
 sigc::signal_base::impl() const () from /tmp/tmp32t4cX/usr/lib/libsigc-2.0.so.0
 sigc::signal_base::connect(sigc::slot_base const&) () from /tmp/tmp32t4cX/usr/lib/libsigc-2.0.so.0
 connect (slot_=<optimized out>, this=<optimized out>) at /usr/include/sigc++-2.0/sigc++/signal.h:2661
 UnityScreen::UnityScreen (this=0x97155b0, screen=0x92852f0) at /build/buildd/unity-4.8.2/plugins/unityshell/src/unityshell.cpp:148
 getInstance (base=<optimized out>) at /usr/include/compiz/core/pluginclasshandler.h:159

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Changed in compiz (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) on 2011-08-24
visibility: private → public
tags: added: bugpattern-needed
tags: removed: bugpattern-needed
tags: added: bugpattern-written
Jack Leigh (leighman) wrote :

Just got this when disabling and enabling the unity plugin in oneiric beta 2

Guillermo Ferro Parra (gferrop) wrote :

help

Changed in compiz (Ubuntu):
importance: Medium → Critical
Changed in compiz (Ubuntu Oneiric):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
milestone: none → ubuntu-11.10
tags: added: rls-mgr-o-tracking
David Barth (dbarth) on 2011-09-23
Changed in compiz (Ubuntu Oneiric):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Tim Penhey (thumper)
Changed in unity:
assignee: nobody → Tim Penhey (thumper)
importance: Undecided → High
Changed in compiz (Ubuntu Oneiric):
importance: Critical → High
Changed in unity:
status: New → Triaged
milestone: none → 4.18.0
maxstevens (mho-607) wrote :

This error popped up after I unchecked wobbly windows in compiz-settings-manager.

Didier Roche (didrocks) on 2011-09-26
Changed in unity:
milestone: 4.18.0 → 4.20.0
Guillermo Ferro Parra (gferrop) wrote :

oder problems by compiz

Klaus Reichl (klaus-reichl) wrote :

Triggered the problem enabling "screenshot" in ccsm.

Hey, actually I wanted to report a general problem with ccsm and compiz/unity, where I wanted screenshots.
Is there anybody out there, who has Ubuntu 11.10 oneiric and ubuntu/3D (unity) running config'd with ccsm?

Download full text (3.7 KiB)

Hi Klaus

Yes I have had Unity 3D working in Oneiric Beta. I think are are plenty of
problems related to the Unity Plugin. It seems though to be a bit more
stable after the latest Beta 2 updates have come through and been applied.
Sometimes I have started CCSM, switched on say, Window Decorations or the
Desktop Cube and have then tried to resolve plugin conflicts. This is the
point where the system reports a Compiz crash.

I think the best strategy is to uncheck the Unity Plugin in CCSM, switch on
the effects you want, resolve any conflicts and then switch on the Unity
Plugin again. Sometimes an attempt to start Gnome 3 instead of Unity 3D
results in the Unity Plugin unchecking itself and then you have to start the
whole thing once more from the beginning. This whole idea of the Unity
Desktop being so dependent on a Compiz Plugin is not a wonderful idea IHMO.
The thing is still fundamentally broken sadly.
Gnome 3 will not run properly at all on my system even if gnome-shell is
installed in its latest incarnation.

On another subject entirely to you have a relative called Werner Reichl in
Vienna? He runs a training centre here in Vienna and does Linux training
there.

MfG,

Best regards

Jack

On 27 September 2011 20:04, Klaus Reichl <email address hidden> wrote:

> Triggered the problem enabling "screenshot" in ccsm.
>
> Hey, actually I wanted to report a general problem with ccsm and
> compiz/unity, where I wanted screenshots.
> Is there anybody out there, who has Ubuntu 11.10 oneiric and ubuntu/3D
> (unity) running config'd with ccsm?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (845895).
> https://bugs.launchpad.net/bugs/831769
>
> Title:
> compiz crashed with SIGSEGV in sigc::signal_base::impl()
>
> Status in Unity:
> Triaged
> Status in “compiz” package in Ubuntu:
> Confirmed
> Status in “compiz” source package in Oneiric:
> Confirmed
>
> Bug description:
> Changed a setting in compiz config settings manager (turned off Window
> decoration in the Effects group).
> Note: using compiz-testing PPA (compiz-testing-0.9.5.0)
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: unity 4.8.2-0ubuntu4
> ProcVersionSignature: Ubuntu 3.0.0-9.12-generic 3.0.3
> Uname: Linux 3.0.0-9-generic i686
> Architecture: i386
> CrashCounter: 1
> Date: Mon Aug 22 22:26:27 2011
> ExecutablePath: /usr/bin/compiz
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386
> (20110803.1)
> ProcCmdline: compiz
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SegvAnalysis:
> Segfault happened at: 0xbfae2e <_ZNK4sigc11signal_base4implEv+30>: mov
> 0x4(%edi),%esi
> PC (0x00bfae2e) ok
> source "0x4(%edi)" (0x00000084) not located in a known VMA region (needed
> readable region)!
> destination "%esi" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: unity
> StacktraceTop:
> sigc::signal_base::impl() const () from /usr/lib/libsigc-2.0.so.0
> sigc::signal_base::connect(sigc::slot_base const&) () from
> /usr/lib/libsigc-2.0.so.0
> UnityScreen::UnityScreen(CompScreen*) () from
> /usr/lib/compiz/libunityshell.so
>...

Read more...

Tim Penhey (thumper) on 2011-09-28
Changed in nux:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Tim Penhey (thumper)
Changed in unity:
status: Triaged → In Progress
Tim Penhey (thumper) on 2011-09-28
Changed in nux:
status: In Progress → Fix Committed
Tim Penhey (thumper) on 2011-09-28
Changed in compiz (Ubuntu Oneiric):
assignee: Tim Penhey (thumper) → nobody
Tim Penhey (thumper) on 2011-09-28
Changed in unity:
status: In Progress → Fix Committed
Omer Akram (om26er) on 2011-09-28
affects: compiz (Ubuntu Oneiric) → nux (Ubuntu Oneiric)
Changed in nux (Ubuntu Oneiric):
milestone: ubuntu-11.10 → none
milestone: none → ubuntu-11.10
Changed in unity (Ubuntu Oneiric):
importance: Undecided → High
status: New → Confirmed
Changed in nux (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Changed in unity (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-09-29
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 1.14.0-0ubuntu1

---------------
nux (1.14.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in nux::WindowCompositor::FindKeyFocusArea()
      (LP: #845873)
    - compiz crashed with SIGSEGV in sigc::signal_base::impl() (LP: #831769)
    - can't maximize windows on second monitor and Qt windows displayed in
      wrong place (LP: #861341)
    - Dash - Dash should support drag and drop to external applications
      (LP: #857431)
    - Dash - When the Dash is re-opened and statefully displaying a previous
      query, it should be possible to add to the query by pressing the 'right
      arrow cursor key' (LP: #841828)
    - blacklist old geforce fx cards for unity-3d (LP: #769402)
  * debian/control:
    - build-dep on libxinerama-dev
 -- Didier Roche <email address hidden> Thu, 29 Sep 2011 18:46:45 +0200

Changed in nux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2011-09-29
Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package unity - 4.20.0-0ubuntu1

---------------
unity (4.20.0-0ubuntu1) oneiric; urgency=low

  * New upstream release + cherry-pick:
    - compiz crashed with SIGSEGV in PluginClassHandler<UnityWindow,
      CompWindow, 0>::get() (LP: #835259)
    - dash does not scroll down during keyboard navigation (LP: #852506)
    - compiz crashed with SIGSEGV in _XFreeEventCookies() (LP: #851472)
    - compiz crashed with SIGSEGV in g_object_unref() (LP: #847512)
    - compiz crashed with SIGSEGV in nux::WindowCompositor::MouseEventCycle()
      (LP: #831678)
    - compiz and X can disagree on the stacking order (LP: #845719)
    - compiz crashed with SIGSEGV in unity::dash::LensView::OnResultAdded()
      (LP: #855252)
    - CCSM crashes Unity (LP: #861643)
    - compiz crashed with SIGSEGV in PrivateWindow::addWindowStackChanges()
      (LP: #862115)
    - Touch - When dragging a window with a 3 touch, dragging to the top
      should show the maximize gesture preview. (LP: #750316)
    - compiz crashed with SIGABRT in raise() (LP: #750386)
    - Launcher - Spread should not affect the state of window (LP: #764673)
    - [UIFe] Add system setting icon to Launcher (LP: #764744)
    - compiz crashed with SIGABRT in raise() [Merely unchecking the Unity
      plugin is enough to crash Compiz...] (LP: #823386)
    - Launcher - does not hide if revealed from top 24px of the left edge of
      the screen (LP: #835989)
    - Clickable areas of previously active window remains on 'Show Desktop'
      (LP: #836325)
    - Cannot search for some apps in Dash (LP: #837075)
    - Dash - Search box cursor not responding correctly to focus (LP: #839704)
    - Multi-display: Application menu only showing on primary screen
      (LP: #845212)
    - Ellipsized values in size filter (LP: #851359)
    - (oneiric) dash result expansions don't display icons (LP: #854615)
    - run the wrong command if enter is hit before the view is refreshed
      (LP: #856205)
    - Java application windows cut-off/truncated/not displayed properly
      (LP: #857201)
    - compiz crashed with SIGSEGV in sigc::signal_base::impl() (LP: #831769)
    - Minimizing a window should switch focus to the windows underneath it
      (breaks restore) (LP: #859885)
    - Ratings filter allows ratings > 1.0 (LP: #861255)
    - Serious Unity problem stuck in spread when dragging icons back to the
      dash (LP: #862045)
    - Must use hardware keyboard to perform search for applications in Unity
      (LP: #739812)
    - Files lens should also search Downloads (LP: #748915)
    - The dash crosses the monitor boundary when resolution is 1152x864 or
      lesser width (LP: #765338)
    - Dash - dragging a file outside of the Desktop Dash should close the Dash
      (LP: #764641)
    - Text in Dash search text box overflows and doesn't crop with longer
      strings; RtL input starts in wrong place (LP: #834765)
    - Where the average background colour is either very light or dark, adjust
      this value to darken/lighten in order to preserve readability
      (LP: #837993)
    - Dash does not resize when I connect to an external display and mirror
      displays (LP: #83813...

Read more...

Changed in unity (Ubuntu Oneiric):
status: Fix Committed → Fix Released

after turn on jpg file in compiz config round qube

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers