compiz crashed with SIGSEGV in SimpleLauncherIcon::ReloadIcon()

Bug #825587 reported by Anthony Harrington on 2011-08-13
268
This bug affects 38 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Undecided
Unassigned
nux (Ubuntu)
Critical
Unassigned
unity (Ubuntu)
Critical
Unassigned

Bug Description

TEST CASE:
1. Load an Audio CD

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: libnux-1.0-0 1.2.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-8.10-generic 3.0.1
Uname: Linux 3.0.0-8-generic x86_64
Architecture: amd64
CrashCounter: 1
Date: Sat Aug 13 01:11:25 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f5819bc4055 <_ZN18SimpleLauncherIcon10ReloadIconEv+37>: mov (%rdi),%rax
 PC (0x7f5819bc4055) ok
 source "(%rdi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 SimpleLauncherIcon::ReloadIcon() () from /usr/lib/compiz/libunityshell.so
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: compiz crashed with SIGSEGV in SimpleLauncherIcon::ReloadIcon()
UpgradeStatus: Upgraded to oneiric on 2011-08-12 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

visibility: private → public
Changed in nux (Ubuntu):
status: New → Confirmed
_oOMOo_ (hermann-blaxhall) wrote :

Provoked this bug by doing the following:

Inserted audio cd. Cd icon showed up fine in Unity dock but I realised I'd not installed sound-juicer
Ejected CD & installed sound-juicer
Re-inserted cd and compiz crashed

Christopher (soft-kristal) wrote :

I happened to me when I launched a Wine program (PopTray) which has a panel icon. As there are issues with other panel icons, it may be related.

Sam_ (and-sam) wrote :

Pattern here:
Due to Bug #825786 did twice apt-get -f install and rebooted.
After second reboot got apport report, during upload a second crash happened, dialog displayed same pattern.
System runs stable.

tags: added: needs-bugpattern
Omer Akram (om26er) wrote :

Not totally clear on the tag but I have seen it used when there is a large number of duplicates for the bug this has only ONE.

tags: removed: needs-bugpattern
Changed in nux (Ubuntu):
importance: Undecided → Critical
Changed in unity (Ubuntu):
importance: Undecided → Critical
affects: nux → unity
Omer Akram (om26er) wrote :

seems to me like its more related to the launcher code and have nothing to do with NUX

Changed in unity (Ubuntu):
status: New → Confirmed
Sam_ (and-sam) wrote :

Apport itself assigned to nux while reporting.

Omer Akram (om26er) wrote :

Apport is wrong sometimes :)

Omer Akram (om26er) wrote :

If anyone could reliably reproduce this crash I could upload a unity version to my ppa just to check if fix to bug 741652 also resolves this issue as well. I just think both are closely related.

Changed in unity:
status: New → Confirmed
description: updated
Sam_ (and-sam) wrote :

Test case #1 loading an audio cd didn't trigger a crash here.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 4.8.0-0ubuntu3

---------------
unity (4.8.0-0ubuntu3) oneiric; urgency=low

  * Backport r1373 to fix a segfault happening on theme updates (lp: #825587)
    (lp: #741652)
  * Backport r1380 to fix an alt-tab switcher segfault (lp: #825148)
  * Backport r1381 to fix a session start compiz segfault (lp: #825040)
 -- Sebastien Bacher <email address hidden> Thu, 18 Aug 2011 11:21:50 +0200

Changed in unity (Ubuntu):
status: Confirmed → Fix Released

StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()

Changed in nux (Ubuntu):
status: Confirmed → Invalid

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate an useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

libgcc1 version 1:4.6.1-6ubuntu3 required, but 1:4.6.1-7ubuntu2 is available
outdated debug symbol package for libtiff4: package version 3.9.5-1ubuntu1 dbgsym version 3.9.4-5ubuntu6
libglib2.0-0 version 2.29.14-0ubuntu1 required, but 2.29.16-0ubuntu2 is available
outdated debug symbol package for libthai0: package version 0.1.15-2 dbgsym version 0.1.14-2ubuntu1
libc-bin version 2.13-16ubuntu2 required, but 2.13-17ubuntu2 is available
libffi6 version 3.0.10~rc8-6 required, but 3.0.11~rc1-1 is available
fontconfig version 2.8.0-3ubuntu1 required, but 2.8.0-3ubuntu2 is available
libstdc++6 version 4.6.1-6ubuntu3 required, but 4.6.1-7ubuntu2 is available
libnux-1.0-0 version 1.2.0-0ubuntu2 required, but 1.2.2-0ubuntu2 is available
gcc-4.6-base version 4.6.1-6ubuntu3 required, but 4.6.1-7ubuntu2 is available
outdated debug symbol package for libsigc++-2.0-0c2a: package version 2.2.9-1 dbgsym version 2.2.4.2-1ubuntu1
multiarch-support version 2.13-16ubuntu2 required, but 2.13-17ubuntu2 is available
libc6 version 2.13-16ubuntu2 required, but 2.13-17ubuntu2 is available
outdated debug symbol package for libdatrie1: package version 0.2.4-3 dbgsym version 0.2.4-1
ttf-dejavu-core version 2.33-1 required, but 2.33-1ubuntu1 is available
fontconfig-config version 2.8.0-3ubuntu1 required, but 2.8.0-3ubuntu2 is available
libnux-1.0-common version 1.2.0-0ubuntu2 required, but 1.2.2-0ubuntu2 is available
libfontconfig1 version 2.8.0-3ubuntu1 required, but 2.8.0-3ubuntu2 is available
outdated debug symbol package for libdbus-1-3: package version 1.4.12-4ubuntu2 dbgsym version 1.4.6-1ubuntu6.1
outdated debug symbol package for libglibmm-2.4-1c2a: package version 2.28.1-1 dbgsym version 2.28.0-1

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-amd64-retrace
Robert Carr (robertcarr) on 2011-09-15
Changed in unity:
status: Confirmed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers