compiz crashed with SIGSEGV in nux::Area::FindKeyFocusArea()

Bug #815114 reported by Bryan Moore
470
This bug affects 92 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
High
Jay Taoko
Unity
Fix Released
High
Unassigned
nux (Ubuntu)
High
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Description: Ubuntu oneiric (development branch)
Release: 11.10
compiz:
  Installed: 1:0.9.5.0-0ubuntu1
  Candidate: 1:0.9.5.0-0ubuntu1
  Version table:
 *** 1:0.9.5.0-0ubuntu1 0
        500 http://mirror.anl.gov/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: libnux-1.0-0 1.0.6-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-6.7-generic 3.0.0-rc7
Uname: Linux 3.0.0-6-generic i686
Architecture: i386
CrashCounter: 1
Date: Sat Jul 23 11:52:09 2011
Disassembly: => 0x0: Cannot access memory at address 0x0
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
ProcCmdline: compiz
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 ?? ()
 nux::Area::FindKeyFocusArea(unsigned int, unsigned long, unsigned long) () from /usr/lib/libnux-1.0.so.0
 nux::Area::FindKeyFocusArea(unsigned int, unsigned long, unsigned long) () from /usr/lib/libnux-1.0.so.0
 nux::View::FindKeyFocusArea(unsigned int, unsigned long, unsigned long) () from /usr/lib/libnux-1.0.so.0
 nux::Area::FindKeyFocusArea(unsigned int, unsigned long, unsigned long) () from /usr/lib/libnux-1.0.so.0
Title: compiz crashed with SIGSEGV in nux::Area::FindKeyFocusArea()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Revision history for this message
Bryan Moore (moore-bryan) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 ?? ()
 FindKeyFocusArea (this=0xb3b15d00, key_symbol=7, x11_key_code=65293, special_keys_state=0) at ./Area.cpp:962
 nux::Area::FindKeyFocusArea (this=0xb3b15d00, key_symbol=7, x11_key_code=65293, special_keys_state=0) at ./Area.cpp:952
 FindKeyFocusArea (this=0xb3b2b278, key_symbol=7, x11_key_code=65293, special_keys_state=0) at ./Area.cpp:962
 nux::Area::FindKeyFocusArea (this=0xb3b2b278, key_symbol=7, x11_key_code=65293, special_keys_state=0) at ./Area.cpp:952

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Revision history for this message
Victor Vargas (kamus) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

1. Is this reproducible?
2. If so, what specific steps should we take to recreate this bug? Be as detailed as possible.

This will help us to find and resolve the problem.

visibility: private → public
Changed in compiz (Ubuntu):
status: New → Incomplete
Victor Vargas (kamus)
affects: compiz (Ubuntu) → nux (Ubuntu)
Revision history for this message
Markus Spring (m-spring) wrote :

Same problem here - compiz immediately crashes after start of the GUI

Revision history for this message
Jacobsallan (jacobsallan) wrote :

I could not replicate this bug. I followed the instructions on https://help.ubuntu.com/community/CompositeManager/CompizFusion. I Tried the following: (1) Keyboard shortcut Alt-F2. (2) Enter the command 'compiz --replace'. (3) Wait. The window manager updated without problem. Tried 'gtk-window-decorator --replace' from within a terminal; successfully.

Running Ubuntu 11.10 alpha 3, installed by upgrading from 11.04.
uname -a:
Linux ceshannon 3.0.0-7-generic #9-Ubuntu SMP Fri Jul 29 21:27:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
LANG=en_US.UTF-8
SHELL=/bin/bash

compiz:
  Installed: 1:0.9.5.0-0ubuntu2

Revision history for this message
Andi Albrecht (andialbrecht) wrote :

It seems that I'm able to reproduce it in the following way:

- log into Unity desktop
- hit Alt-F2
- enter a command that opens a window (for me it's a bash script that runs gnome-terminal attaching to a screen session on a remote machine)

But I'm not really sure yet, that this always brings this bug up....

Omer Akram (om26er)
Changed in unity:
status: New → Confirmed
Changed in nux (Ubuntu):
status: Incomplete → Confirmed
affects: unity → nux
Revision history for this message
Ryan Kitty (gothickitty93) wrote :

I just experienced this issue while doing file operations with Nautilus. Also (don't think this is related), the window decorations have not been bringing the correct window to focus. Sometimes when I try to click on any button on the title bar, it acts like it's not there and routes the click to the program behind the window decoration. The window itself works, but it looses focus if I try to do this.

Revision history for this message
Brandon Bolton (brandon-bolton-224) wrote :

This is the same problem I just had, compiz crashed and locked everything up. The only thing I was doing was using Google Chrome and Bluefish.

Revision history for this message
Sam_ (and-sam) wrote :

Opened CCSM to disable Blur in unity-plugin, because dash is still a little lagging.
This reported Bug #832458 regarding ccsm occured again.
While reading in Firefox segfault in nux happened. Crash couldn't be reproduced. Installed compiz-core-dbgsym because the report included lots of lines debug symbol missing.
All windows disappeared, also the mouse cursor, after a short time waiting windows (gnome-terminal, ccsm, firefox) reappeared on same workspaces as before. Only the terminal window had moved to upper left corner.

Revision history for this message
Christopher Kyle Horton (christhehorton) wrote :

I just had this crash occur when I had a whole bunch of windows open across 3 workspaces, then tried using Super+S to get into Expo.

Revision history for this message
Christopher Kyle Horton (christhehorton) wrote :

...just experienced it again switching workspaces using Ctrl+Alt+Up Arrow Key, at the end of the switch.

Revision history for this message
Tim Penhey (thumper) wrote :

I had this last night. I'll be digging a bit more.

Changed in nux:
importance: Undecided → High
assignee: nobody → Tim Penhey (thumper)
Revision history for this message
Víctor Adrián de la Cruz Serrano (adriandcs) wrote :

I have seen that it usually happens to me after spending a bit of time in banshee then changing desktops with Ctrl+Alt+Arrow.

Revision history for this message
u-foka (ufooka) wrote :

Hy!

I experienced similar crashes mainly when using ctrl+alt+arrows, but sometimes with expo too, but yesterday I disabled texture compression in ccsm, and since there were no crash if I remember correctly!

I have a Lenovo T61 with an 1440x900 panel and Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller

Do you guys have texture compression enabled?

Andrea Azzarone (azzar1)
Changed in nux:
status: Confirmed → Fix Committed
Changed in nux (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks)
Changed in unity:
status: New → Fix Committed
importance: Undecided → High
milestone: none → 4.16.0
Tim Penhey (thumper)
Changed in nux:
assignee: Tim Penhey (thumper) → Jay Taoko (jaytaoko)
Revision history for this message
Artur Wyszyński (aljen) wrote :

everytime when i switch to console with CTRL-ALT-Fn and i switch back to xorg, compiz crashes - nvidia drivers

Revision history for this message
Lê Hoàng Phương (herophuong93) wrote :

Use Ctrl+Alt+Arrow and it crashes. Latest update today.

Revision history for this message
Thomas Marx (dy5hza58g) wrote :

compiz:
  Installiert: 1:0.9.5.94+bzr2803-0ubuntu1
  Kandidat: 1:0.9.5.94+bzr2803-0ubuntu1
  Versionstabelle:
 *** 1:0.9.5.94+bzr2803-0ubuntu1 0
        500 http://de.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages
        100 /var/lib/dpkg/status

Revision history for this message
Brandon Bolton (brandon-bolton-224) wrote :

I got this just now when I tried to switch desktops with CTRL + ALT + Arrow Keys.

Omer Akram (om26er)
Changed in nux (Ubuntu):
importance: Medium → High
milestone: none → ubuntu-11.10-beta-2
Revision history for this message
bwat47 (bwat47) wrote :

This happens to me randomly when I hit super + w to bring up the window switcher.

Didier Roche (didrocks)
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 1.10.0-0ubuntu1

---------------
nux (1.10.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in nux::GpuDevice::GetGpuInfo()
      (LP: #765375)
    - compiz crashed with SIGSEGV in nux::WindowCompositor::SetKeyFocusArea()
      (LP: #846059)
    - unity_support_test crashed with SIGSEGV in fclose() (LP: #843369)
    - compiz crashed with SIGSEGV in nux::Area::FindKeyFocusArea()
      (LP: #815114)
 -- Didier Roche <email address hidden> Thu, 15 Sep 2011 18:42:58 +0200

Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers