unity_support_test crashed with SIGSEGV

Bug #810182 reported by WindTux on 2011-07-13
668
This bug affects 103 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Critical
Jay Taoko
Unity
Fix Released
Critical
Jay Taoko
Unity Distro Priority
Undecided
Unassigned
nux (Ubuntu)
Critical
Jay Taoko
Precise
Critical
Unassigned
unity (Ubuntu)
Critical
Unassigned
Oneiric
Undecided
Unassigned
Precise
Critical
Unassigned

Bug Description

i was searching updates when it gave the error

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: nux-tools 1.0.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-5.6-generic 3.0.0-rc7
Uname: Linux 3.0.0-5-generic x86_64
Architecture: amd64
CrashCounter: 1
Date: Wed Jul 13 17:21:06 2011
ExecutablePath: /usr/lib/nux/unity_support_test
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110620)
ProcCmdline: /usr/lib/nux/unity_support_test
ProcEnviron:
 LANGUAGE=es_VE:es
 LANG=es_VE.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x4012c2: movzbl (%rbx,%rax,1),%edx
 PC (0x004012c2) ok
 source "(%rbx,%rax,1)" (0x00000007) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nux
Stacktrace:
 #0 0x00000000004012c2 in ?? ()
 No symbol table info available.
 No se puede acceder a la memoria en la dirección 0x7fff876d66c8
StacktraceTop: ?? ()
ThreadStacktrace:
 .
 Hilo 1 (Thread 1370):
 #0 0x00000000004012c2 in ?? ()
 No symbol table info available.
 No se puede acceder a la memoria en la dirección 0x7fff876d66c8
Title: unity_support_test crashed with SIGSEGV
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

WindTux (windtux) wrote :
visibility: private → public

StacktraceTop:
 get_opengl_version (argc=<value optimized out>, argv=0x7fff876d67a8) at unity_support_test.c:122
 main (argc=<value optimized out>, argv=0x7fff876d67a8) at unity_support_test.c:545

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Didier Roche (didrocks) on 2011-07-20
Changed in nux (Ubuntu):
importance: Medium → Critical
Changed in nux (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-07-29
Changed in unity:
status: New → Confirmed
Changed in nux:
status: New → Confirmed
tags: added: bugpattern-needed
Dan Wood (dan-wood) wrote :

I got this bug just after logging in to a fresh install of 11.10 beta, after had I rebooted to enable the proprietary NVIDIA drivers.

Apport collected a lot of info, but it seems to have eaten it?! Sorry!

tags: added: rls-mgr-o-tracking
David Barth (dbarth) on 2011-09-16
Changed in unity:
importance: Undecided → Medium
assignee: nobody → Jay Taoko (jaytaoko)
milestone: none → backlog
tags: removed: bugpattern-needed
tags: added: bugpattern-written

When using my laptop's discrete nvidia card Unity works fine, but when enabling the embedded intel card it fails as reported (Intel HD Graphics 3000 (SandyBridge)).

Interestingly when running glxinfo I just get:

  Error: couldn't find RGB GLX visual or fbconfig
  Xlib: extension "GLX" missing on display ":0".

A month back in the Oneiric cycle or so this intel card worked very well. So looks like a regression in the X stack or intel driver somewhere?

Keith Kessler (keithkessler) wrote :

This crash occurred shortly after I accidentally touched the touchscreen on my ASUS T101MT.

Please support this hardware better. There is no reason my session should crash (i.e., screen flashes and then I am brought back to a login screen) when I touch my touchscreen. You need a better default driver to handle unsupported hardware.

Eugene San (eugenesan) wrote :

Confirming #6 assumption.
GLX is broken on xserver-xorg-video-intel=2:2.15.901-1ubuntu2, while was functional in Beta2.

Prevents from running Unity-3D as well as Gnome-Shell.

Eugene San (eugenesan) wrote :

Just found the reason for GLX and unity_support_test failures, at least in my case.

nvidia-current driver replaces system GL libraries with it's own, breaking GLX.

With removal of nvidia-current, problem solved.

To #6, I am afraid concurrent Nvidia and Intel cards in 3D mode is currently impossible.

Didier Roche (didrocks) on 2011-09-30
Changed in unity:
importance: Medium → Critical
Id2ndR (id2ndr) wrote :

In my case, this bug appears because I restarted the computer on an old Linux version where nvidia driver is not fonctional.

Changed in nux (Ubuntu Oneiric):
milestone: none → ubuntu-11.10

I get this crash report on just upgraded natty to Oneiric on a Ibm Thinkpad

David Barth (dbarth) on 2011-10-06
Changed in unity:
milestone: backlog → 4.24.0
Changed in nux (Ubuntu Oneiric):
assignee: nobody → Jay Taoko (jaytaoko)
David Barth (dbarth) on 2011-10-06
Changed in nux:
importance: Undecided → Critical
assignee: nobody → Jay Taoko (jaytaoko)
Jay Taoko (jaytaoko) wrote :

Try "glxinfo" on the system and report what you get. If glxinfo fails, then there is a problem with the driver installation. You may also run "/usr/lib/nux/unity_support_test -p" and report what you get.

Changed in nux (Ubuntu Oneiric):
milestone: ubuntu-11.10 → oneiric-updates
Changed in nux (Ubuntu Precise):
status: New → Confirmed
importance: Undecided → Critical
status: Confirmed → New
importance: Critical → Undecided
status: New → Confirmed
importance: Undecided → Critical
sseitz (s-seitz) wrote :

On latest oneiric I've got following result:

/usr/lib/nux/unity_support_test -p
Segmentation fault (core dumped)

NVidia driver is 280.13, glxinfo is attached as file.

Jay Taoko (jaytaoko) wrote :

@sseitz
Thanks for the report. Do you think you can provide a stack trace of the crash in unity_support_test.
Also, when did the problem started to appear on your system? Did it started after an upgrade from Natty to Oneiric or following a recent but progressive upgrade of your system?

Also getting this error every time try to run a system update.

Runing glxinfo I get the following:

name of display: :0
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig

Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".

Kevin Daly (kedaly-yahoo) wrote :

I'm having the same problem as well.. Dual Intel & NVIDIA Vostro 3750

sseitz (s-seitz) wrote :

@Jay Taoko

Sorry for the late response, I don't know how to do a stack trace w/ symbols.

gdb --args /usr/lib/nux/unity_support_test -p

shows

Starting program: /usr/lib/nux/unity_support_test -p
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
0x08048ed2 in ?? ()

I assume this is doesn't help very much.

sseitz (s-seitz) wrote :

Thank's thomas,

i've done the backtraces with the original nux-tools and additionally with the nux-tools-dbgsym.
gdb output is attached.

sseitz (s-seitz) wrote :

regarding #19, see attachment.

Didier Roche (didrocks) on 2011-10-17
Changed in unity:
milestone: 4.24.0 → 4.26.0
Jay Taoko (jaytaoko) wrote :

This bug is related to the graphics stack. Having 2 gpus on the system, the graphics stack and all the tools involved have to make sure that the right opengl drivers are install. Until a fix is done on the graphics stack side, see if you can make sure that you only have either the Intel opengl libraries on your system or the other gpu's libraries.

Changed in nux:
status: Confirmed → Invalid
Changed in unity:
status: Confirmed → Invalid
Didier Roche (didrocks) on 2011-10-25
Changed in unity:
status: Invalid → Confirmed
Changed in nux:
status: Invalid → Confirmed
sseitz (s-seitz) wrote :

Regarding #21.
Thank You guys for trying to solve this issue, but I'm afraid I do not have to different kinds of GPU at that machine.
Indeed, it's a quad monitor setup on two identical GeForce 7300 LE using Oneiric's propriatery nvidia 280.13.
Just ask, if you need more logfiles, gdb outputs, etc... I'll post anything which could be helpful, cause it's a bad fact that (at least my own) multi monitor setups are getting worse by each release :(

Cory Maccarrone (darkstar6262) wrote :

Yeah, I have to agree with #22 - my system isn't even dual-monitor, it's a laptop with no other monitors attached. The NVIDIA gpu is the only one in the system.

Didier Roche (didrocks) on 2011-10-28
Changed in unity-distro-priority:
status: New → Fix Committed
Tim Penhey (thumper) on 2011-11-14
tags: added: udp
Tim Penhey (thumper) wrote :

@Cory, can you give more details on your graphics card and gpu?

There seem to be lots of duplicates of this bug. If you are having this issue, and you don't see your graphics card mentioned, please can you add the info to this bug?

Please also mention if you tend to have external monitors plugged in to laptops, or desktops with multiple monitors, systems with multiple GPUs, or anything you can think of that might be relevant.

Thanks.

Cory Maccarrone (darkstar6262) wrote :

My GPU is a Nvidia GeForceGT 130M (G96) discrete graphics card in a Lenovo Y550 laptop. I almost never have other monitors attached.

In all honesty I haven't seen this issue for a long time now, so I'd say it doesn't affect me anymore.

Changed in unity (Ubuntu Oneiric):
status: New → Invalid
Didier Roche (didrocks) on 2011-11-22
Changed in unity (Ubuntu Precise):
status: New → Confirmed
Jay Taoko (jaytaoko) wrote :

Many of the duplicate bugs report errors with loading of GLX.
         extension "GLX" missing on display ":0".
         Xlib: extension "GLX" missing on display ":0".
         Xlib: extension "GLX" missing on display ":0".

Many of the Xorg logs also report error in loading of the Nvidia or Nouveau driver. I will add a test to detect the presence of GLX on the system. If the system does not have GLX support, then unity_support_test will not continue further and the test will fail (but not crash).

Tim Penhey (thumper) on 2011-11-24
Changed in nux:
status: Confirmed → In Progress
Jay Taoko (jaytaoko) on 2011-11-27
Changed in nux:
status: In Progress → Fix Committed
Changed in unity:
status: Confirmed → Fix Committed
Changed in nux (Ubuntu Precise):
status: Confirmed → Fix Committed
Changed in unity (Ubuntu Precise):
status: Confirmed → Fix Committed
Omer Akram (om26er) on 2012-01-20
Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in nux (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Arnau (arnaugm) wrote :

In my case unity_support_test continues crashing with a segmentation fault.
I attach the glxinfo output.

Arnau (arnaugm) wrote :

I noticed that my crash is related with Separate X Screen + Xinerama configuration in two screens.
I'm using the last official Nvidia driver from their website, and I also tried with the versions available in "Addition drivers".

Using Twinview I don't have a crash.
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: Quadro 1000M/PCI/SSE2
OpenGL version string: 4.2.0 NVIDIA 290.10

Tim Penhey (thumper) on 2012-02-03
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
John Lea (johnlea) on 2012-04-11
tags: removed: udp
tags: added: running-unity
tags: added: raring

Since this bug:

- Is valid.
- Is well described.
- Is reported in the upstream project.
- Is ready to be worked on by a developer.

It's already triaged.

Changed in nux (Ubuntu Oneiric):
status: Confirmed → Triaged
Changed in unity (Ubuntu):
importance: Undecided → Critical
Changed in unity (Ubuntu Precise):
importance: Undecided → Critical

Is bug #1190333 really a duplicate of this bug?

tags: added: saucy
Colin Law (colin-law) wrote :

Bug #1213319 has just been marked as a dup of this, but since it has only just started happening following an update to nux-tools to 4.0.2+13.10.20130816.2-0ubuntu1 on Saucy it is difficult to see how it can be the same bug that is marked with Oneiric as a milestone on nux and is marked fix released on Precise. Could it be a new bug?
Strangely Bug #1213319 seems to be inaccessible at the moment, hopefully just a temporary problem.

I'm running Precise on an Nvidia ION system (single GPU).
/usr/lib/nux/unity_support_test
shows
Segmentation fault (core dumped)

jsass (sass-joel) wrote :

I am having the same issue as reported above. Nux is causing the problems, and I am running 2 nvidia 120GT video cards w/two monitors.

Adolfo Jayme (fitojb) on 2014-10-18
no longer affects: nux (Ubuntu Oneiric)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers