Unity crashes if you open a quicklist and then the corresponding launcher icon closes

Bug #801413 reported by Adolfo Jayme on 2011-06-24
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Undecided
Unassigned
Unity
Fix Released
Medium
Marco Trevisan (Treviño)
nux (Ubuntu)
Medium
Canonical Desktop Experience Team
Oneiric
Medium
Canonical Desktop Experience Team
unity (Ubuntu)
Undecided
Marco Trevisan (Treviño)
Oneiric
Undecided
Unassigned

Bug Description

Steps to reproduce:

1. Open a windows that you know it takes a little while to close (example.: Google Chrome with 8 tabs)
2. Click the X to close it and then immediately right-click its launcher icon to open the quicklist.
3. When the window finally gets closed and the launcher icon dissapear, the quicklist stays as “orphan” and Unity crashes.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 3.8.16-0ubuntu2
ProcVersionSignature: Ubuntu 3.0-1.2-generic 3.0.0-rc3
Uname: Linux 3.0-1-generic i686
NonfreeKernelModules: wl
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
Date: Thu Jun 23 21:38:22 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcEnviron:
 LANGUAGE=es_MX:en
 PATH=(custom, no user)
 LANG=es_MX
 LC_MESSAGES=es_MX.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-06-17 (6 days ago)

Related branches

Adolfo Jayme (fitojb) wrote :
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

I can reproduce it with the steps indicated. Looks like a nux bug according to the trace. Moving there and setting to triaged/high.

affects: unity (Ubuntu) → nux (Ubuntu)
Changed in nux (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
importance: Undecided → High
status: New → Triaged
Jean-Baptiste Lallement (jibel) wrote :
Changed in unity:
status: New → Confirmed
Didier Roche (didrocks) on 2011-06-24
Changed in unity:
status: Confirmed → Triaged
Changed in nux:
status: New → Triaged
David Barth (dbarth) on 2011-07-20
Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
importance: Undecided → High
milestone: none → 4.4.0
Didier Roche (didrocks) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
Jay Taoko (jaytaoko) wrote :

I am not sure this bug still applies. Please re-test.
Also, is there a way to reproduce this bug reliably without involving the user action speed?

David Barth (dbarth) wrote :

I've tried to reproduce, but it's actually very tricky. I think it's worth keeping around as a reminder, but that would be a rare crasher for me.
Please reopen if you can get a backtrace with symbols, or an apport retrace of the issue.

Thanks

Changed in unity:
importance: High → Medium
Changed in nux (Ubuntu Oneiric):
importance: High → Medium
Changed in unity:
milestone: 4.8.0 → backlog
Andrea Azzarone (azzar1) wrote :

@dbarth, i think that mounting a usb pen drive, opening its launcher icon quicklist and removing manually the pen drive should crash unity.

David Barth (dbarth) wrote :

@andyrock: can you generate a stack trace of the error? that would help narrow down the issue and know where to fix in the code. thanks

Andrea Azzarone (azzar1) wrote :

@dbarth

Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking

This is my backtrace.

An easy way to get unity crashing is to:

 - Add some .desktop files to ~/.local/share/applications
 - Drag them to the launcher to make them show there
 - Run something like sleep 5 && ~/.local/share/applications/desktop_file.desktop /tmp
 - Open the quicklist
 - Wait for crash (sigh!)

Changed in nux:
status: Triaged → Invalid
Changed in unity:
assignee: Jay Taoko (jaytaoko) → Marco Trevisan (Treviño) (3v1n0)
status: Triaged → In Progress

I should have fixed this in my branch lp:~3v1n0/unity/quicklist-hide-fix (commit 1502, http://bazaar.launchpad.net/~3v1n0/unity/quicklist-hide-fix/revision/1502)

Basically it seems related to compiz or Nux since after clicking on a quicklist, we're waiting for a click outside its area to hide that.
If the quicklist is forced to close this can't happen anymore, so we need to hide it and stop monitoring for events before removing the launcher icon.

Gord Allott (gordallott) on 2011-09-08
Changed in unity:
milestone: backlog → 4.14.0
status: In Progress → Fix Committed
Changed in nux (Ubuntu Oneiric):
status: Triaged → Fix Committed
Didier Roche (didrocks) on 2011-09-08
Changed in nux:
status: Invalid → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 1.8.0-0ubuntu1

---------------
nux (1.8.0-0ubuntu1) oneiric; urgency=low

  * New upstream release.
    - Unity crashes if you open a quicklist and then the corresponding
      launcher icon closes (LP: #801413)
  * debian/control:
    - bump shlib
    - remove shlibs restriction (no more ABI breakage until finale)
 -- Didier Roche <email address hidden> Thu, 08 Sep 2011 20:06:12 +0200

Changed in nux (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Oneiric):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers