Ubuntu

compiz crashed with SIGSEGV in nux::IOpenGLShaderProgram::Begin()

Reported by zniavre on 2011-04-21
128
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Nux
High
Unassigned
Unity
Critical
Jay Taoko
nux (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

unity can't start with nvidia173.14.30

----------

Install the version in -proposed
Test case on those systems using the nvidia-legacy driver:
1. try starting a Unity session
2. verify that the system switches automatically to the classic session

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: libnux-0.9-0 0.9.46-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Thu Apr 21 11:13:26 2011
ExecutablePath: /usr/bin/compiz
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=fr_FR:en
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x163cd75 <_ZN3nux20IOpenGLShaderProgram5BeginEv+21>: mov 0x34(%eax),%eax
 PC (0x0163cd75) ok
 source "0x34(%eax)" (0x00000034) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 nux::IOpenGLShaderProgram::Begin() () from /usr/lib/libnux-graphics-0.9.so.0
 nux::GraphicsEngine::QRP_GLSL_1Tex(int, int, int, int, nux::ObjectPtr<nux::IOpenGLBaseTexture>, nux::TexCoordXForm&, nux::Color const&) () from /usr/lib/libnux-graphics-0.9.so.0
 nux::GraphicsEngine::QRP_1Tex(int, int, int, int, nux::ObjectPtr<nux::IOpenGLBaseTexture>, nux::TexCoordXForm&, nux::Color const&) () from /usr/lib/libnux-graphics-0.9.so.0
 nux::WindowCompositor::PresentBufferToScreen(nux::ObjectPtr<nux::IOpenGLBaseTexture>, int, int, bool, bool, float) () from /usr/lib/libnux-0.9.so.0
 nux::WindowCompositor::RenderTopViews(bool, std::list<nux::ObjectWeakPtr<nux::BaseWindow>, std::allocator<nux::ObjectWeakPtr<nux::BaseWindow> > >&, bool, bool) () from /usr/lib/libnux-0.9.so.0
Title: compiz crashed with SIGSEGV in nux::IOpenGLShaderProgram::Begin()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

zniavre (zniavre2048-gmail) wrote :

StacktraceTop:
 nux::IOpenGLShaderProgram::Begin (this=0x0) at ./IOpenGLGLSLShader.cpp:573
 nux::GraphicsEngine::QRP_GLSL_1Tex (this=0x9960dd8, x=0, y=24, width=50, height=1056, DeviceTexture=..., texxform0=..., color0=...) at ./RenderingPipeGLSL.cpp:956
 nux::GraphicsEngine::QRP_1Tex (this=0x9960dd8, x=0, y=24, width=50, height=1056, DeviceTexture=..., texxform0=..., color0=...) at ./RenderingPipe.cpp:322
 nux::WindowCompositor::PresentBufferToScreen (this=0x9aaf120, HWTexture=..., x=0, y=24, RenderToMainTexture=false, BluredBackground=false, opacity=1) at ./WindowCompositor.cpp:1461
 nux::WindowCompositor::RenderTopViews (this=0x9aaf120, force_draw=true, WindowList=..., drawModal=false, use_fbo=true) at ./WindowCompositor.cpp:1162

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Didier Roche (didrocks) on 2011-04-21
visibility: private → public
Changed in nux:
status: New → Triaged
Changed in unity:
status: New → Triaged
Changed in nux (Ubuntu):
status: New → Triaged
Changed in unity:
importance: Undecided → High
Changed in nux:
importance: Undecided → High
Changed in nux (Ubuntu):
importance: Medium → High
Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
milestone: none → 3.8.12
David Barth (dbarth) wrote :

Since it is functionally equivalent, we recommend to only SRU a fix for this problem and not block the image generation for this bug.

The resolution path we are taking is to:
- first blacklist the nvidia-legacy driver for unity, and force a fallback to the classic session; for reference the nvidia-legacy driver was previously not compatible with the new xorg release
- then provide a fix as soon as we can design one

At install time, the users of such cards will have to download the driver in all cases. Either they will get a safe workaround, or a proper fix if available at this point.

Jay Taoko (jaytaoko) wrote :

It looks like we have Geforce FX class of GPUs trying to take the GLSL shader code path. I have created a branch to resolve that, assuming that the Geforce FX will be able to run the ARB shader code path.
I don't have this type of card right now, but Cimi will report if the fix resolves the issue.

Changed in nux:
status: Triaged → In Progress
Changed in unity:
status: Triaged → In Progress
Changed in nux (Ubuntu):
status: Triaged → In Progress

who could build a package for me? I will be back in a hour and a half, and
the PC with the fx is slow...

Andrea Cimitan (cimi) wrote :

note: it's the first time I run unity on this pc.

with your branch, unity runs... though I don't have icons on the launcher (but the dash is fine)

Andrea Cimitan (cimi) wrote :

in other words, I dunno if it's related or not, or if it's another bug.
I'm going to bed... cheers all

David Barth (dbarth) on 2011-04-22
Changed in unity:
importance: High → Critical
Andrea Cimitan (cimi) wrote :
Loïc Molinari (loic.molinari) wrote :

Our assumptions were correct, it seems like GLSL's been enabled for some reasons on that new driver for these chips. I guess the icons are black because the fragment programs used by the launcher exceed the GPU caps and the driver fallbacks to a set-fragment-color-to-black shader.

Jay Taoko (jaytaoko) wrote :

I have submitted a fix to prevent the GeForce FX GPUs from using the GLSL shader code path. In addition, these GPUs have been added to the black list. For now, the recommended option for the GeForce FX GPUs is Unity 2D.

Changed in nux:
status: In Progress → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
zniavre (zniavre2048-gmail) wrote :

good morning

as funny workaround i installed virtualbox 4.04 and unity can run in fullscreen mode...

that situation is quite strange no ? fx5500 and 173.14.30 drivers are "blacklisted" but vbox can handle unity even if it's a bit slow it still usable.

Casper Aleva (tonus) wrote :

Jay, is your fix supposed to be in natty-proposed? Cause I don't see it there.

Omer Akram (om26er) on 2011-04-24
Changed in nux (Ubuntu):
status: In Progress → Fix Committed
Didier Roche (didrocks) wrote :

it will be in -proposed on Wednesday.

Didier Roche (didrocks) on 2011-04-27
Changed in unity:
status: Fix Committed → Fix Released
Changed in nux:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2011-04-27
description: updated

Accepted nux into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
zniavre (zniavre2048-gmail) wrote :

unity can run now with nvidia 173.14.30

there is the same bug of the no-icons-in-launcher than nouveau

it does not launch alone but i need to unity --replace manualy

the only bug it is gnome-panel is running too

i hav made a new user to check the session worrie but it does the same

John Cottier (j-cottier) wrote :

I think Bug #728745 may be a duplicate of this. The desktop *appears* to be unresponsive, but actually is just hiding the response.

Aaron Plattner (aplattner) wrote :

Jay, can you describe in more detail what criteria Unity uses to make this decision? Nothing should have changed in the driver between 173.14.28 and 173.14.30 that would have affected this.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 0.9.48-0ubuntu1

---------------
nux (0.9.48-0ubuntu1) natty-proposed; urgency=low

  * New upstream release.
    - fix compiz crashed with SIGSEGV in nux::IOpenGLShaderProgram::Begin()
      (LP: #768178)
    - launcher loses focus (LP: #763883)
 -- Didier Roche <email address hidden> Wed, 27 Apr 2011 09:32:26 +0200

Changed in nux (Ubuntu Natty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to oneiric as well.

Changed in nux (Ubuntu):
status: Fix Committed → Fix Released

I still get the "This driver is activated but not currently in use" message in jockey with nux-tools 0.9.48-0ubuntu1, libnux-0.9-0 0.9.48-0ubuntu1, and libnux-0.9-common 0.9.48-0ubuntu1 installed. The "This driver is activated but not currently in use" was an easy to find symptom of Bug #772207, which, however, was decided to be a Duplicates of this bug.

What is more, now (by mere coincidence or caused by nux 0.9.48-0ubuntu1) suspend and hibernate using nouveau are no longer working. Btw: no unity. nouveau was doing a very good job, even vga out to a beamer by just plugging it in. But this is also regressed now.

I'm tying to use my nvidia GeForce GT540M with the nvidia_current driver.

I must say that I really regret upgrading my production system to 11.04 -- sorry. Is that nux fun really worth the effort?

I appreciate any help.

Ghenghis (mystic-one) wrote :

Same for Nvidia Geoforce 9800m. Driver activated but not currently in use. Affects games run on wine, Unity 3d, other open gl games, rendering eof video on web ex. Youtube. I did the upgrade this morning that was pushed down the pipe and same results. Nvidia driver activated but not currently in use.

Sorry this is NOT fixed. I'm beginning to regret my Ubuntu Decision. Perhaps Debian is better, it takes longer for a distro release, but at least it's stable.

Soul-Sing (soulzing) wrote :

Same here: "This driver is activated but not currently in use."
~$ glxinfo | grep render
direct rendering: Yes
OpenGL renderer string: GeForce 7600 GT/PCI/SSE2
    GL_NV_vertex_program3, GL_NVX_conditional_render, GL_OES_depth24,
    GL_OES_fbo_render_mipmap, GL_OES_get_program_binary, GL_OES_mapbuffer,

APT (apt514) wrote :

I have a Sanyo avl-279 tv. With a Nvidia FX 5200 128mb. Asus a7n8x-vm400 mainboard.

I installed 11.04 alt 386 by usb. Nouveau is 1024x768 & 173.14.30 goes to 1360x768.
I need the higher resolutions OR the lines burn into my lcd like windows xp has done.

I found in Software Center to use a terminal to type Unity ?
It loaded a black dock with no Icons but my mouse lists them.

This really seems to be a small, big problem for people like me.

Please make an effort, once it's fixed we'll all be happy to see.

TheWhisp (daavis-90) wrote :

Yeah, I have the same problem with FX 5200. Everything is working smooth and fast except launcher, there's like no icons - they're blank, for example, when I move my mouse over it shows "Home Folder", I can click on it and it works. So the icons in launcher are not visible.

It would be very nice if this can be fixed, I personally switched from Mint to Ubuntu, because I really like Unity. And yeah, of course there is Unity 2d, but it's not kind of what I want...

Dave Krout (davidtkraut) on 2011-08-03
Changed in nux (Ubuntu):
assignee: nobody → Dave Krout (davidtkraut)
assignee: Dave Krout (davidtkraut) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers