compiz crashed with SIGSEGV in operator->()

Bug #741961 reported by Victor Vargas on 2011-03-24
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
High
Mirco Müller
Unity
Fix Released
High
Mirco Müller
nux (Ubuntu)
High
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I was working as usual with some gnome-terminal sessions, chromium, firefox4 and after click on audio indicator to listen some music (banshee) compiz gets unstable an finally crashed

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: libnux-0.9-0 0.9.36-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.38-generic-pae 2.6.38
Uname: Linux 2.6.38-7-generic-pae i686
Architecture: i386
CheckboxSubmission: efdd3a482986e933e1b92893bbb7c33b
CheckboxSystem: 2a6f54df59af338184485e85cbcf0d32
Date: Thu Mar 24 15:25:01 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=es_CL:en
 LANG=es_CL.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xb2b46e20 <sigc::internal::signal_emit0<void, sigc::nil>::emit(sigc::internal::signal_impl*)+144>: mov 0x8(%esi),%eax
 PC (0xb2b46e20) ok
 source "0x8(%esi)" (0x00000008) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 operator-> (impl=0xadf50a78) at /build/buildd/unity-3.6.8/src/Launcher.cpp:3789
 sigc::internal::signal_emit0<void, sigc::nil>::emit (impl=0xadf50a78) at /usr/include/sigc++-2.0/sigc++/signal.h:774
 emit (this=0x924e390) at /usr/include/sigc++-2.0/sigc++/signal.h:2671
 Launcher::EventLogic (this=0x924e390) at /build/buildd/unity-3.6.8/src/Launcher.cpp:2916
 Launcher::DrawContent (this=0x924e390, GfxContext=..., force_draw=false) at /build/buildd/unity-3.6.8/src/Launcher.cpp:2419
Title: compiz crashed with SIGSEGV in operator->()
UpgradeStatus: Upgraded to natty on 2011-03-21 (2 days ago)
UserGroups: admin libvirtd lp lpadmin sudo vboxusers

Related branches

Victor Vargas (kamus) wrote :

StacktraceTop:
 sigc::internal::signal_emit0<void, sigc::nil>::emit(sigc::internal::signal_impl*) () from /usr/lib/compiz/libunityshell.so
 Launcher::EventLogic() () from /usr/lib/compiz/libunityshell.so
 Launcher::DrawContent(nux::GraphicsEngine&, bool) () from /usr/lib/compiz/libunityshell.so
 nux::View::ProcessDraw (this=0x924e39c, GfxContext=..., force_draw=false) at ./View.cpp:268
 nux::Layout::ProcessDraw (this=0x92fae28, GfxContext=..., force_draw=false) at ./Layout.cpp:791

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Omer Akram (om26er) wrote :

could be duplicate of bug 729715

Didier Roche (didrocks) on 2011-03-25
Changed in nux (Ubuntu):
status: New → Triaged
importance: Medium → High
Changed in nux:
status: New → Triaged
importance: Undecided → High
Changed in unity:
status: New → Triaged
importance: Undecided → High
milestone: none → 3.8.2
Mirco Müller (macslow) on 2011-03-28
Changed in unity:
assignee: nobody → Mirco Müller (macslow)
Changed in nux:
assignee: nobody → Mirco Müller (macslow)
Mirco Müller (macslow) on 2011-03-28
Changed in unity:
status: Triaged → In Progress
Changed in nux:
status: Triaged → In Progress
Didier Roche (didrocks) on 2011-03-29
Changed in nux (Ubuntu):
status: Triaged → In Progress
Mirco Müller (macslow) on 2011-03-30
Changed in unity:
status: In Progress → Fix Committed
Changed in nux:
status: In Progress → Invalid
Didier Roche (didrocks) on 2011-04-01
Changed in nux:
status: Invalid → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 0.9.38-0ubuntu1

---------------
nux (0.9.38-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - compiz crashed with SIGSEGV in nux::View::PostProcessEvent2()
      (LP: #712498)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in brw_validate_state() (LP: #730707)
    - Finish Nux detection tool support (LP: #722089)
    - compiz crashed with SIGABRT in raise() (LP: #741942)
    - compiz crashed with SIGSEGV in PanelMenuView::ProcessEvent()
      (LP: #742139)
    - compiz crashed with SIGSEGV in operator->() (LP: #741961)
    - Graphics hardware capability detection (LP: #685208)
    - compiz crashed with SIGSEGV in nux::GraphicsDisplay::GrabPointer()
      (LP: #740784)
    - compiz crashed with SIGSEGV in nux::Area::InitiateResizeLayout()
      (LP: #741977)
    - compiz crashed with SIGSEGV in nux::GraphicsDisplay::GrabKeyboard()
      (LP: #742233)
    - Missing child addition signals on nux::Layout and nux::View
      (LP: #734803)
    - compiz crashed with SIGSEGV in
      nux::GpuRenderStates::SubmitChangeStates() (LP: #735908)
    - unity_support_test crashed with SIGSEGV (LP: #743848)
  * debian/control:
    - adding libpci-dev build-dep for the new lighter unity_support_tool
 -- Didier Roche <email address hidden> Fri, 01 Apr 2011 11:15:39 +0200

Changed in nux (Ubuntu):
status: In Progress → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers