compiz crashed with SIGSEGV in nux::GraphicsDisplay::GrabPointer()

Bug #740784 reported by François Laurent @FPGLaurent on 2011-03-23
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Medium
Jay Taoko
Unity
Fix Released
Medium
Unassigned
nux (Ubuntu)
Medium
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Mouse over the ubuntu logo
Then try to click the File Manager
Then (the window decorator I guess) crash, but everything seem to be ok.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: libnux-0.9-0 0.9.34-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
CrashCounter: 1
Date: Wed Mar 23 09:08:21 2011
Disassembly: => 0x80: Cannot access memory at address 0x80
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110201.2)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=C:fr_FR:fr:en_GB:en
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x80: Cannot access memory at address 0x80
 PC (0x00000080) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 ?? ()
 nux::GraphicsDisplay::GrabPointer(void (*)(bool, void*), void*, bool) () from /usr/lib/libnux-graphics-0.9.so.0
 nux::WindowCompositor::GrabPointerAdd(nux::InputArea*) () from /usr/lib/libnux-0.9.so.0
 PlacesController::Show() () from /usr/lib/compiz/libunityshell.so
 ?? () from /usr/lib/compiz/libunityshell.so
Title: compiz crashed with SIGSEGV in nux::GraphicsDisplay::GrabPointer()
UpgradeStatus: Upgraded to natty on 2011-03-21 (1 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

StacktraceTop:
 ?? ()
 nux::GraphicsDisplay::GrabPointer (this=0x1909090, callback=0, data=0x1a87420, replace_existing=<value optimized out>) at ./GraphicsDisplayX11.cpp:2474
 nux::WindowCompositor::GrabPointerAdd (this=0x1a87420, area=0x24c77d0) at ./WindowCompositor.cpp:1828
 PlacesController::Show (this=0x24c6250) at /build/buildd/unity-3.6.6/src/PlacesController.cpp:122
 ubus_server_pump_message_queue (server=<value optimized out>) at /build/buildd/unity-3.6.6/src/ubus-server.cpp:284

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
Alex Launi (alexlauni) on 2011-03-28
Changed in nux:
status: New → Confirmed
Changed in unity:
status: New → Confirmed
Changed in nux (Ubuntu):
status: New → Confirmed
Changed in nux:
assignee: nobody → Jay Taoko (jaytaoko)
Changed in unity:
importance: Undecided → Medium
Changed in nux:
importance: Undecided → Medium
Jay Taoko (jaytaoko) wrote :

Cannot reproduce. Jason has fixed a bug very similar to this one.

Changed in nux:
status: Confirmed → Fix Committed
Changed in unity:
status: Confirmed → Fix Committed
Changed in nux (Ubuntu):
status: Confirmed → Fix Committed
Jay Taoko (jaytaoko) on 2011-03-28
Changed in nux (Ubuntu):
status: Fix Committed → Confirmed
Didier Roche (didrocks) on 2011-03-29
Changed in nux (Ubuntu):
status: Confirmed → Fix Committed
Neil J. Patel (njpatel) on 2011-03-31
Changed in unity:
milestone: none → 3.8.2
Didier Roche (didrocks) on 2011-04-01
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 0.9.38-0ubuntu1

---------------
nux (0.9.38-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - compiz crashed with SIGSEGV in nux::View::PostProcessEvent2()
      (LP: #712498)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in brw_validate_state() (LP: #730707)
    - Finish Nux detection tool support (LP: #722089)
    - compiz crashed with SIGABRT in raise() (LP: #741942)
    - compiz crashed with SIGSEGV in PanelMenuView::ProcessEvent()
      (LP: #742139)
    - compiz crashed with SIGSEGV in operator->() (LP: #741961)
    - Graphics hardware capability detection (LP: #685208)
    - compiz crashed with SIGSEGV in nux::GraphicsDisplay::GrabPointer()
      (LP: #740784)
    - compiz crashed with SIGSEGV in nux::Area::InitiateResizeLayout()
      (LP: #741977)
    - compiz crashed with SIGSEGV in nux::GraphicsDisplay::GrabKeyboard()
      (LP: #742233)
    - Missing child addition signals on nux::Layout and nux::View
      (LP: #734803)
    - compiz crashed with SIGSEGV in
      nux::GpuRenderStates::SubmitChangeStates() (LP: #735908)
    - unity_support_test crashed with SIGSEGV (LP: #743848)
  * debian/control:
    - adding libpci-dev build-dep for the new lighter unity_support_tool
 -- Didier Roche <email address hidden> Fri, 01 Apr 2011 11:15:39 +0200

Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers