compiz crashed with SIGSEGV in brw_validate_state()

Bug #730707 reported by slechtvalk on 2011-03-07
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Undecided
Unassigned
Unity
Fix Released
Critical
Jay Taoko
nux (Ubuntu)
Medium
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

Compiz crashed suddenly and close all window borders

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: libnux-0.9-0 0.9.30-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
Architecture: i386
CrashCounter: 1
Date: Mon Mar 7 09:56:10 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Custom Live CD - Release i386
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=es_MX:en
 PATH=(custom, no user)
 LANG=es_MX.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xee34bd: mov %ecx,-0x10(%edx)
 PC (0x00ee34bd) ok
 source "%ecx" ok
 destination "-0x10(%edx)" (0x00000000) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 ?? () from /lib/libc.so.6
 ?? () from /usr/lib/dri/i965_dri.so
 ?? () from /usr/lib/dri/i965_dri.so
 brw_validate_state () from /usr/lib/dri/i965_dri.so
 brw_draw_prims () from /usr/lib/dri/i965_dri.so
Title: compiz crashed with SIGSEGV in brw_validate_state()
UpgradeStatus: Upgraded to natty on 2011-03-04 (3 days ago)
UserGroups: adm admin cdrom dialout lpadmin nopasswdlogin plugdev sambashare

slechtvalk (klank4135) wrote :

StacktraceTop:
 __memcpy_ssse3 () at ../sysdeps/i386/i686/multiarch/memcpy-ssse3.S:1090
 copy_array_to_vbo_array (brw=<value optimized out>, element=<value optimized out>, dst_stride=16) at /usr/include/bits/string3.h:52
 brw_prepare_vertices (brw=0x9fad5c0) at brw_draw_upload.c:439
 brw_validate_state (brw=0x9fad5c0) at brw_state_upload.c:397
 brw_try_draw_prims (ctx=0x9fad5c0, arrays=0x9fefd40, prim=0xbfced8a8, nr_prims=1, ib=0x0, index_bounds_valid=1 '\001', min_index=0, max_index=3) at brw_draw.c:362

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Neil J. Patel (njpatel) on 2011-03-07
Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
importance: Undecided → Critical
milestone: none → 3.6.8
status: New → Confirmed

Is this related to rearanging launchers? Since last update 3.6.2 to Unity, when i try to rearange app lauchers, Compiz crashes without even offering option to restart process...

Didier Roche (didrocks) on 2011-03-11
Changed in nux:
status: New → Confirmed
Changed in nux (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) on 2011-03-24
Changed in unity:
milestone: 3.6.8 → 3.8
Didier Roche (didrocks) on 2011-03-28
Changed in unity:
milestone: 3.8 → 3.8.2
Jay Taoko (jaytaoko) wrote :

Cannot reproduce. Also, need more info on the action that was being performed when the crash happened.
 Please, try the latest release of Unity and report if this bugs still happens.

Changed in unity:
status: Confirmed → Incomplete
Changed in nux:
status: Confirmed → Incomplete
Didier Roche (didrocks) on 2011-03-29
Changed in unity:
status: Incomplete → Confirmed
Changed in nux:
status: Incomplete → Confirmed
Didier Roche (didrocks) wrote :

@Jay: can you sync to revert all tasks? (you didn't revert the nux downstream one) when reverting to a previous state? You fooled my script ;) Setting back to Incomplete :)

Changed in nux:
status: Confirmed → Incomplete
Changed in unity:
status: Confirmed → Incomplete
Changed in nux (Ubuntu):
status: Confirmed → Incomplete
Jay Taoko (jaytaoko) on 2011-03-31
Changed in nux:
status: Incomplete → Confirmed
Changed in unity:
status: Incomplete → Confirmed
Changed in nux (Ubuntu):
status: Incomplete → Confirmed
Jason Smith (jassmith) on 2011-03-31
Changed in unity:
status: Confirmed → Fix Released
Changed in nux:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 0.9.38-0ubuntu1

---------------
nux (0.9.38-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - compiz crashed with SIGSEGV in nux::View::PostProcessEvent2()
      (LP: #712498)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in brw_validate_state() (LP: #730707)
    - Finish Nux detection tool support (LP: #722089)
    - compiz crashed with SIGABRT in raise() (LP: #741942)
    - compiz crashed with SIGSEGV in PanelMenuView::ProcessEvent()
      (LP: #742139)
    - compiz crashed with SIGSEGV in operator->() (LP: #741961)
    - Graphics hardware capability detection (LP: #685208)
    - compiz crashed with SIGSEGV in nux::GraphicsDisplay::GrabPointer()
      (LP: #740784)
    - compiz crashed with SIGSEGV in nux::Area::InitiateResizeLayout()
      (LP: #741977)
    - compiz crashed with SIGSEGV in nux::GraphicsDisplay::GrabKeyboard()
      (LP: #742233)
    - Missing child addition signals on nux::Layout and nux::View
      (LP: #734803)
    - compiz crashed with SIGSEGV in
      nux::GpuRenderStates::SubmitChangeStates() (LP: #735908)
    - unity_support_test crashed with SIGSEGV (LP: #743848)
  * debian/control:
    - adding libpci-dev build-dep for the new lighter unity_support_tool
 -- Didier Roche <email address hidden> Fri, 01 Apr 2011 11:15:39 +0200

Changed in nux (Ubuntu):
status: Confirmed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers