Ubuntu

compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void, sigc::nil>::emit()

Reported by Dennis English on 2011-03-05
506
This bug affects 62 people
Affects Status Importance Assigned to Milestone
Nux
Critical
Jason Smith
Unity
Critical
Jason Smith
nux (Ubuntu)
Critical
Jason Smith
Natty
Critical
Jason Smith
unity (Ubuntu)
Critical
Jason Smith
Natty
Critical
Jason Smith

Bug Description

x crashed, can't type but the mouse works.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: libnux-0.9-0 0.9.30-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sat Mar 5 16:27:57 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x901c3f7 <_ZN4sigc8internal12signal_emit0IvNS_3nilEE4emitEPNS0_11signal_implE+151>: mov 0x4(%eax),%edx
 PC (0x0901c3f7) ok
 source "0x4(%eax)" (0xe900000c) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 sigc::internal::signal_emit0<void, sigc::nil>::emit(sigc::internal::signal_impl*) () from /usr/lib/compiz/libunityshell.so
 Launcher::EventLogic() () from /usr/lib/compiz/libunityshell.so
 Launcher::DrawContent(nux::GraphicsEngine&, bool) () from /usr/lib/compiz/libunityshell.so
 nux::View::ProcessDraw(nux::GraphicsEngine&, bool) () from /usr/lib/libnux-0.9.so.0
 nux::Layout::ProcessDraw(nux::GraphicsEngine&, bool) () from /usr/lib/libnux-0.9.so.0
Title: compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void, sigc::nil>::emit()
UpgradeStatus: Upgraded to natty on 2011-03-03 (1 days ago)
UserGroups: adm admin cdrom dialout dip fax floppy fuse lpadmin plugdev sambashare tape video

StacktraceTop:
 empty (impl=0xa33f228) at /usr/include/sigc++-2.0/sigc++/functors/slot_base.h:273
 sigc::internal::signal_emit0<void, sigc::nil>::emit (impl=0xa33f228) at /usr/include/sigc++-2.0/sigc++/signal.h:774
 emit (this=0x9c02410) at /usr/include/sigc++-2.0/sigc++/signal.h:2671
 Launcher::EventLogic (this=0x9c02410) at /build/buildd/unity-3.6.0/src/Launcher.cpp:2805
 Launcher::DrawContent (this=0x9c02410, GfxContext=..., force_draw=false) at /build/buildd/unity-3.6.0/src/Launcher.cpp:2367

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
visibility: private → public
Alex Launi (alexlauni) on 2011-03-07
Changed in unity:
status: New → Confirmed
Changed in nux (Ubuntu):
status: New → Confirmed
Changed in nux:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Alex Launi (alexlauni) on 2011-03-11
Changed in nux:
importance: Undecided → High
assignee: nobody → Jay Taoko (jaytaoko)
Ben Witte (bjwitte) wrote :

not sure my bug was a duplicate, but I can confirm that the crash happens when i click transmission in the launcher when transmission is already open, a second transmission icon appears in the launcher panel and then compiz crashes

tags: added: bugpattern-needed
Omer Akram (om26er) wrote :

Yes, Ben I have the same symptoms and this is the right bug. Also I have noticed this crash only happens with non-favorite applications. i.e. those which are not pinned to the launcher.

Alan Musnikow (am) wrote :

I agree about "non-favorite" applications.
When I experienced duplicate bug #733586 I was using an application that was not pinned to the launcher when compiz crashed.

Omer Akram (om26er) on 2011-03-13
Changed in nux (Ubuntu):
importance: Medium → High
Alex Launi (alexlauni) on 2011-03-21
Changed in unity:
importance: Undecided → Critical
Changed in nux (Ubuntu):
importance: High → Critical
Changed in nux:
importance: High → Critical
Changed in nux (Ubuntu Natty):
milestone: none → ubuntu-11.04-beta-1
Didier Roche (didrocks) on 2011-03-25
Changed in unity:
milestone: none → 3.8.2
Changed in nux (Ubuntu Natty):
milestone: ubuntu-11.04-beta-1 → ubuntu-11.04
Kate Stewart (kate.stewart) wrote :

Fix is not ready, but in discussion with Didier, this is not a blocker for beta. Have moved milestone accordingly. Need to make sure its documented in release notes.

Changed in nux (Ubuntu Natty):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Changed in unity (Ubuntu Natty):
milestone: none → ubuntu-11.04
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
importance: Undecided → Critical
Brian Murray (brian-murray) wrote :

Bug 742974 looks to me like a duplicate of this one.

Jay Taoko (jaytaoko) wrote :

I cannot reproduce this bug with Unity trunk. Is there a fix already or is it a work in progress?

Changed in nux:
status: Confirmed → Incomplete
Changed in unity:
status: Confirmed → Incomplete
YangZhou (sink-cup) wrote :

It's difficult to reproduce .
I manually install Nvidia 9800GT driver on Ubuntu 10.10 x64,then I upgrade to Ubuntu 11.04 through network.It can't display desktop.
Then I uninstall Nvidia driver,reset xorg.conf,reboot,see 800x600 desktop,install Nvidia driver through Ubuntu system tools,reboot,unistall and install Nvidia driver in recovery mode,again and again,at last,I can see 1600x900 desktop.
But sometime It crash.

Alex Launi (alexlauni) on 2011-03-31
Changed in unity:
status: Incomplete → Confirmed
Changed in nux:
status: Incomplete → Confirmed
Neil J. Patel (njpatel) on 2011-03-31
Changed in unity:
assignee: nobody → Jason Smith (jassmith)
Changed in nux:
assignee: Jay Taoko (jaytaoko) → Jason Smith (jassmith)
status: Confirmed → In Progress
Changed in unity:
status: Confirmed → In Progress
Jason Smith (jassmith) on 2011-03-31
Changed in nux:
status: In Progress → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
Changed in nux (Ubuntu Natty):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Jason Smith (jassmith)
status: Confirmed → Fix Committed
Changed in unity (Ubuntu Natty):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Jason Smith (jassmith)
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-04-01
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 0.9.38-0ubuntu1

---------------
nux (0.9.38-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - compiz crashed with SIGSEGV in nux::View::PostProcessEvent2()
      (LP: #712498)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in brw_validate_state() (LP: #730707)
    - Finish Nux detection tool support (LP: #722089)
    - compiz crashed with SIGABRT in raise() (LP: #741942)
    - compiz crashed with SIGSEGV in PanelMenuView::ProcessEvent()
      (LP: #742139)
    - compiz crashed with SIGSEGV in operator->() (LP: #741961)
    - Graphics hardware capability detection (LP: #685208)
    - compiz crashed with SIGSEGV in nux::GraphicsDisplay::GrabPointer()
      (LP: #740784)
    - compiz crashed with SIGSEGV in nux::Area::InitiateResizeLayout()
      (LP: #741977)
    - compiz crashed with SIGSEGV in nux::GraphicsDisplay::GrabKeyboard()
      (LP: #742233)
    - Missing child addition signals on nux::Layout and nux::View
      (LP: #734803)
    - compiz crashed with SIGSEGV in
      nux::GpuRenderStates::SubmitChangeStates() (LP: #735908)
    - unity_support_test crashed with SIGSEGV (LP: #743848)
  * debian/control:
    - adding libpci-dev build-dep for the new lighter unity_support_tool
 -- Didier Roche <email address hidden> Fri, 01 Apr 2011 11:15:39 +0200

Changed in nux (Ubuntu Natty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 3.8.2-0ubuntu1

---------------
unity (3.8.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - does not display icons until hovered (LP: #726033)
    - Unity Launcher has black spaces where icons should be (LP: #729353)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::OnIconThemeChanged()
      (LP: #741652)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in free() (LP: #742300)
    - Unity can't get touch the touch initialization signals from GEIS
      (LP: #742555)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGSEGV in gdk_cairo_set_source_pixbuf()
      (LP: #744231)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - xterms broken in unity (LP: #692463)
    - Unity opens application menu on Alt+F10 shortcut (LP: #722674)
    - First four items in Dash begin "Find" "Find" "Find" "Find" (LP: #729002)
    - Increase the size of the top left Launcher reveal area from 1px to a
      slightly larger triangle that comes out of the top left corner
      (LP: #736034)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Keyboard navigation: quicklist not opening for Trash launcher item
      (LP: #741793)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in
      SimpleLauncherIcon::ActivateLauncherIcon() (LP: #742110)
    - Combo in the search bar did not disappear after the places was closed
      (LP: #742712)
    - Expo doesn't quit reliably when using keynav or shortcut (LP: #744196)
    - Make the BFB icon turn blue when an application goes urgent
      (LP: #744973)
    - Launcher - increase "launcher reveal %" for 'Fade and slide' launcher
      reveal transition to 65% (LP: #745602)
    - Arrows do not fade out with rest of launcher durring DND (LP: #746811)
    - Don't create windows over the launcher (LP: #688816)
    - Launcher - Indicate which application is currently focused with a
      glowing Launcher icon (LP: #676604)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - dynamic quicklists are not working (LP: #729074)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - it is still possible to quit unity from the panel (LP: #733725)
    - Selection does not fit small icons in Unity Dash (LP: #735746)
    - Unmounting media gives no error when failed (LP: #737633)
    - ATI/fglrx workaround patch (LP: #740298)
    - "Files & Folders" tooltip say...

Read more...

Changed in unity (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers