Ubuntu

[nvidia, 7300, 7400] display freeze when using unity desktop

Reported by Nizar Kerkeni on 2011-03-03
652
This bug affects 140 people
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
Undecided
Unassigned
Nux
High
Unassigned
Unity
High
Jon Anderson
nux (Ubuntu)
High
Unassigned
nvidia-graphics-drivers (Ubuntu)
Low
Unassigned

Bug Description

Upstream bug: http://www.nvnews.net/vbulletin/showthread.php?t=160115

when logging to unity desktop only the mouse cursor moves but no action can be done (opening a window and so).

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: unity 3.6.0-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] est un dossier: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 270.29 Wed Feb 23 16:16:53 PST 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-3ubuntu3)
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: None
Date: Thu Mar 3 23:32:40 2011
DistUpgraded: Log time: 2010-12-17 12:33:27.813978
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 270.29, 2.6.38-5-generic, i686: installed
 vboxhost, 4.0.4, 2.6.38-5-generic, i686: installed
GraphicsCard:
 nVidia Corporation G72M [GeForce Go 7400] [10de:01d8] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Sony Corporation Device [104d:81ef]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
InstallationMedia_: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
InstallationMedia__: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
InstallationMedia___: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
MachineType: Sony Corporation VGN-FE31H
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 LANGUAGE=fr_FR:fr:en_GB:en
 PATH=(custom, user)
 LANG=fr_FR.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-5-generic root=UUID=6af38058-c7c3-4680-8f1b-9fedc3d89d2f ro single
ProcVersionSignature_: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
ProcVersionSignature__: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
ProcVersionSignature___: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Renderer: Unknown
SourcePackage: unity
UpgradeStatus: Upgraded to natty on 2011-02-24 (6 days ago)
dmi.bios.date: 08/17/2006
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: R0170J3
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: 7R2M000000003d0b2f3d48aa3a3f
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: C3LMPW7F
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrR0170J3:bd08/17/2006:svnSonyCorporation:pnVGN-FE31H:pvrC3LMPW7F:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrC3LMPW7F:
dmi.product.name: VGN-FE31H
dmi.product.version: C3LMPW7F
dmi.sys.vendor: Sony Corporation
version.compiz: compiz 1:0.9.4-0ubuntu3
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1~git20110215.cc1636b6-0ubuntu2
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A

Nizar Kerkeni (nizarus) wrote :
Alex Launi (alexlauni) wrote :

Does unity show up, or do you have a blank desktop?

Changed in unity:
status: New → Incomplete
Alex Launi (alexlauni) on 2011-03-07
Changed in unity (Ubuntu):
status: New → Incomplete
Nizar Kerkeni (nizarus) wrote :

I don't have a blank screen : my background photo is displayed, unity launcher too. The top deskbar is also displayed but without the notification applets and menus.

Alex Launi (alexlauni) wrote :

Ok, would you be comfortable following these steps to obtain a stack trace for us?

Switch to tty1 (ctrl+alt+f1)
attach to it with gdb $ sudo gdb --attach `pgrep compiz`
at the gdb prompt $ set logging file compiz.txt
$ set logging on
$ bt
(ctrl+d) to exit gdb
now if you run $ export DISPLAY=:0
then $ metacity --replace
and change back to tty7 (ctrl+alt+f7) you should have metacity running and can give us the file compiz.txt that should be in your homefolder containing the backtrace.

Nizar Kerkeni (nizarus) wrote :

can you confirm that the firs command is
$ sudo gdb attach `pgrep compiz`
and not --attach ?
?field.comment=can you confirm that the firs command is
$ sudo gdb attach `pgrep compiz`
and not --attach ?
The result file is on attach.

Miguel Branco (arlanthir) wrote :

My display hangs whenever I run compiz too.
Same graphics card, Natty Beta. I think I already have driver version 270.30, from the repos.

Otacon1987 (orfeo18) wrote :

Same bug here: upgrade from Ubuntu 10.10 x64 using nvidia-current package.
My graphic card is nVidia Geforce Go 7300. After login Unity bar and Panel works, but the screen is not refreshed:
the system allows me to interact with the bar and windows, but i can't see a visual feedback.
Steps to analyze this behaviour:
1. Login without visual effects
2. Open a new terminal window
3. run unity --reset (and wait for finishing loading)
4. move the mouse cursor over window's borders to resize and resize the window.
5. move the mouse cursor over previous (actually shown) window's border - the mouse cursor doesn't change in "resize mode"
6. move the mouse cursor over new (you have to remember where you put your window's border in step 4) window border and the mouse cursor will change in "resize mode".

...Looks like a video refresh bug...

Zephcom (gmackenr) wrote :

Same bug here too. I get the same situation as Otacon1987. Video card is a GeForce 7300 GS.

Additional information.

My computer locked up during the upgrade and I had to cut the power to get it back. Rebooting resulted in mount errors and no GUI. I finished the upgrade with a live disk. GNOME desktop works fine.

Zephcom (gmackenr) wrote :

I changed the video drivers from the proprietary NVIDIA drivers to the experimental open source drivers. Unity is now working.

Otacon1987 (orfeo18) wrote :

Yep, Nuoveau fixes here too... (thx to Zephcom for the hint).

megathon (megathon) wrote :

Switching to noveau solved the issue for me too.

summary: - display freeze when using unity desktop
+ [nvidia, 7300] display freeze when using unity desktop
Otacon1987 (orfeo18) on 2011-04-18
summary: - [nvidia, 7300] display freeze when using unity desktop
+ [nvidia, 7300, 7400] display freeze when using unity desktop
Koen Verweij (kfverweij) wrote :

I have the same issue with a nvidia 7300 LE card.

Lorenzo De Liso (blackz) wrote :

I'm having a similar problem: Unity doesn't run completely and the session freezes. I don't think this is related to unity, it happens in the Ubuntu classic desktop session as well. It also happens in the session without any effect if I run compiz. With the nouveau driver all works good. My video card is a nvidia 7500 LE.

Sebastien Bacher (seb128) wrote :

could the users having that issue copy their lspci -v infos in the bug or their video card pci ids? those will be set in the list of cards that can't run unity so users will get classic GNOME rather than a broken unity

Changed in unity (Ubuntu):
status: Incomplete → New
Otacon1987 (orfeo18) wrote :

Here is mine, but now i'm using Nuoveau and Unity works well. With nvidia-current drivers unity gets broken!

Nizar Kerkeni (nizarus) wrote :

@Sebastien : We can run unity but with the nouveau driver and not with the nvidia-current driver.
My lspci file is in the first post.

Lorenzo De Liso (blackz) wrote :

Sebastien, the problem isn't unity. I get the freeze even with the Ubuntu classic session. To get a working session, I either need to choose the session without any graphic effect or use the nouveau driver. That's what made me think it's a problem in compiz.

Didier Roche (didrocks) wrote :

We are currently blacklisting those card to avoid non technical user to get a bad unity experience when upgrading to the nvidia binary driver.
For technical user wanting to use it with nouveau (we don't support nouveau with compiz or unity, be warned that you can get some memory leaks and other glitches depending on your card), you can set UNITY_FORCE_START=1 in /etc/environment to bypass the detection.

Please just report "lspci -nn" and not "lspci -v" as it hides the id we need and we need to dig in the map file to find it back ;). Otacon, I've done that for your case, no need to repost, thanks :)

Lorenzo De Liso (blackz) wrote :

Didier, like I said above, I get the freeze with the Ubuntu classic session as well. I don't think it has something to do with unity, has it?

Didier Roche (didrocks) on 2011-04-20
Changed in unity:
status: Incomplete → Fix Committed
importance: Undecided → High
assignee: nobody → Didier Roche (didrocks)
milestone: none → 3.8.12
affects: unity (Ubuntu) → nux (Ubuntu)
Changed in nux (Ubuntu):
importance: Undecided → High
status: New → Fix Committed
Changed in nux:
status: New → Fix Committed
importance: Undecided → High
Didier Roche (didrocks) wrote :

@Lorenzo: you're right. However, the detection tool is the same for unity and ubuntu classic session, hence the workaround for blacklisting will work for you :)
Of course, the real fix should be done in the nvidia blob driver where we have unfortunately no way to fix it ourself.

Otacon1987 (orfeo18) wrote :

@Didier: if you need testing or something else feel free to ask. I am able to write code, but I'm not so good with system logs/debugging. So you have to drive me through the bug-reporting (for me this will be a chance to learn something new).

@Lorenzo: you're right, i think that it's an nVidia + Compiz bug. That's why Unity crashes!!!

Didier Roche (didrocks) wrote :

@Otacon: the driver source code for nvidia isn't available unfortunately as it's a proprietary driver. So there is little hope for a fix here…

Something I need to know before blacklisting the cards is that, do you get the freeze at start or after a while using it?

Lorenzo De Liso (blackz) wrote :

Didier, I get the freeze some seconds after the start.

Otacon1987 (orfeo18) wrote :

@Didier: GDM shows correctly. After login desktop icons are shown after that panel and dock are shown but immediately after that the UI got frozen. As I descripted some comments above looks like there's a wrong UI refresh because mouse pointer changes his shape when over a window border (look @ post #7 for a better description)

megathon (megathon) wrote :
Nizar Kerkeni (nizarus) wrote :

In my case I get the freeze just after connecting to my session (the mouse pointer still move) but nothing is displayed on screen.
The lspci -nn is attached.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 0.9.46-0ubuntu3

---------------
nux (0.9.46-0ubuntu3) natty; urgency=low

  * Cherry-pick blacklisting additional driver + UNITY_FORCE_START env variable
    to bypass unity/compiz testing:
    - Partial screen corruption and poor performance on GeForce 6150
      (LP: #764379)
    - [nvidia, 7300, 7400] display freeze when using unity desktop
      (LP: #728745)
 -- Didier Roche <email address hidden> Wed, 20 Apr 2011 18:08:40 +0200

Changed in nux (Ubuntu):
status: Fix Committed → Fix Released

Here is the output from lspci on my system. The salient part is:

01:00.0 VGA compatible controller: nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: Dell Device 2003
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at ed000000 (32-bit, non-prefetchable) [size=16M]
        Memory at d0000000 (64-bit, prefetchable) [size=256M]
        Memory at ee000000 (64-bit, non-prefetchable) [size=16M]
        [virtual] Expansion ROM at ef000000 [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: nouveau
        Kernel modules: nouveau, nvidiafb

mikewhatever (mikewhatever) wrote :

I am curious, did the fix work for anyone? The problem is unchanged here.

mikewhatever (mikewhatever) wrote :

01:00.0 VGA compatible controller: nVidia Corporation G72M [GeForce Go 7400] (rev a1) (prog-if 00 [VGA controller])
 Subsystem: Hewlett-Packard Company Device 30a5
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at d1000000 (32-bit, non-prefetchable) [size=16M]
 Memory at c0000000 (64-bit, prefetchable) [size=256M]
 Memory at d0000000 (64-bit, non-prefetchable) [size=16M]
 Expansion ROM at <unassigned> [disabled]
 Capabilities: <access denied>
 Kernel driver in use: nvidia
 Kernel modules: nvidia-current, nouveau, nvidiafb

Didier Roche (didrocks) wrote :

@Mike:
Did you read this comment?
https://bugs.launchpad.net/ubuntu/+source/nux/+bug/728745/comments/18

Your hardware should be blacklisted now. If it's not the case, as said in the comment, please post lscpi -nn and not lspci -v.

Didier Roche (didrocks) on 2011-04-22
Changed in unity:
status: Fix Committed → Fix Released
Changed in nux:
status: Fix Committed → Fix Released

My video card is a nvidia 7300 LE and I get the freeze in unity some seconds after the login.With driver version "270.41.06" nothing is displayed on screen, I'm able to move the mouse pointer but I can't do anything else...with driver version "173.14.30" it seems to me that everything works out perfectly with unity.Has anyone tried the 173 driver?

Lorenzo De Liso (blackz) wrote :

With the nvidia-173 package all works properly for me too.

I have the exact same problem here with a 7500 LE card.

01:00.0 VGA compatible controller: nVidia Corporation G72 [GeForce 7500 LE] (rev a1) (prog-if 00 [VGA controller])
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
 Memory at d0000000 (64-bit, prefetchable) [size=256M]
 Memory at fc000000 (64-bit, non-prefetchable) [size=16M]
 [virtual] Expansion ROM at fe9e0000 [disabled] [size=128K]
 Capabilities: <access denied>
 Kernel driver in use: nvidia
 Kernel modules: nvidia-current, nouveau, nvidiafb

mikewhatever (mikewhatever) wrote :

Thanks Didier, I haven't bothered looking over all the comments, as I had thought that fixed meant it should be working.

I've just tested the nvidia-173 driver instead of the 270 one, and I can say unity is working now :)

Alexandre Jesus (alexandremrj) wrote :

I have now the nvidia-173 driver and unity works great. Had the previous freeze described.

Because it is blacklisted now I have to start unity manually but it works

Craig Kempson (ckempo) wrote :

Adding UNITY_FORCE_START=1 to /etc/environment as Didier suggests in #18, along with rolling back to the 17 driver, means my laptop's 7300 Go is now happily running Unity. Thanks to everyone, glad I found this bug.

Just upgraded to 11.04 this evening (about 1 hour ago) and experienced this error, so it appears that my card is not black listed. Please find lspci output attached.

I can also confirm that using the nvidia driver version 173 instead of current resolves the issue.

Jon Anderson (jbander) on 2011-04-30
Changed in unity:
assignee: Didier Roche (didrocks) → Jon Anderson (jbander)
Bryce Harrington (bryce) on 2011-06-01
Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
importance: Wishlist → Low
affects: nvidia-common → nvidia-drivers-ubuntu
description: updated
Changed in nvidia-drivers-ubuntu:
status: New → Confirmed
89 comments hidden view all 169 comments
John Cottier (j-cottier) wrote :

This was my experience with a fresh install of 11.10 release version on GeForce 7300 LE :-
First login was fine, but graphical actions very sluggish (several seconds to move a window). I presume this was the nouveau driver since it was not 2D desktop.

When prompted to install a driver for the video card, I selected the recommended one. After reboot this resulted in the usual garbled black and white boot splash and after login and a blank desktop. So I reboot and logged in with Ubuntu 2D, then selected the latest "Post release" driver. After reboot, the same garbled black and white boot splash, but the 3D desktop works. However the consoles (Ctrl+Alt+F1 etc) still do not work. You just get a blank screen, and returning via Ctrl+Alt+F7 gives a totally corrupted screen.

Okay, I understand the issue about the NVIDA drivers being propriety and
nothing can be done about them. But I fell for the understanding I
picked up somewhere that 11.10 had worked things out. In 11.04 I could
try the NVIDA drivers and then just select the Nouveau driver to get
back ground zero.

That didn't happen in 11.10. I don't have the option of selecting
Nouveau in the Advanced Driver area. And unfortunately 11.10 has moved
things all around and much of the instructions from 11.04 don't work.

Can someone provide step by step instructions on how to return to the
Nouveau drivers in 11.10? I promise I'll never trust an NVIDA driver
again. I'm comfortable using the terminal I just don't remember the
commands or know where to look for anything.

Thanks in advance for any help with this.

On Mon, 2011-10-17 at 08:54 +0000, John Cottier wrote:

> This was my experience with a fresh install of 11.10 release version on GeForce 7300 LE :-
> First login was fine, but graphical actions very sluggish (several seconds to move a window). I presume this was the nouveau driver since it was not 2D desktop.
>
> When prompted to install a driver for the video card, I selected the
> recommended one. After reboot this resulted in the usual garbled black
> and white boot splash and after login and a blank desktop. So I reboot
> and logged in with Ubuntu 2D, then selected the latest "Post release"
> driver. After reboot, the same garbled black and white boot splash, but
> the 3D desktop works. However the consoles (Ctrl+Alt+F1 etc) still do
> not work. You just get a blank screen, and returning via Ctrl+Alt+F7
> gives a totally corrupted screen.
>

Ray Nichols (ray-rdnichols) wrote :

John in #130

> after reboot, the same garbled black and white boot splash, but the 3D desktop works. However the consoles (Ctrl+Alt+F1 etc) still
> do not work. You just get a blank screen, and returning via Ctrl+Alt+F7 gives a totally corrupted screen.

Did you try the instructions I copied in #125 for Startup-Manager (admittedly that was in Natty).

John Cottier (j-cottier) wrote :

@Ray No I have not tried startup manager since it did not work in 10.04. I used the v86d framebuffer method to (sort of) fix that. But the none working console issue is quite disturbing. I wonder if it is related to the boot splash issue. IE some kernel mode that is borking something else. I was hoping this would be sorted out in 11.10 but it looks like maybe its 12.04 now.

Michał Małecki (michalus) wrote :

lspci -nn | grep VGA
07:00.0 VGA compatible controller [0300]: nVidia Corporation G71 [GeForce 7300 GS] [10de:01df] (rev a1)

Change "nvidia-current" to "nvidia-173" have solved problem for me. The "nouveau" didn't working for me properly (some problem with avalible resolution).

Herco van Brug (hercovanbrug) wrote :

I never had a problem with 11.04. but with 11.10 i get the occasional freeze from nvidia. going to 'additional drivers' and removing the nvidia driver completely solves the freeze.

I have yet to test it but the issue seems to be related to the power saving mode. if you add

      Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x2; PowerMizerDefaultAC=0x2"

to the xorg.conf, the system is stable, it will just never run at low or high power, just stick somewhere in the middle.

lspci says i have a 01:00.0 VGA compatible controller: nVidia Corporation GF106 [Quadro 2000M] (rev a1)

i hope nvidia and the 3.0 kernel guys figure out what's going on soon as currently i'm loosing production hours and i'm definitely not used to that from linux.

kyleabaker (kyleabaker) wrote :

Has anyone tested the new nvidia 290.03 driver?

http://ubuntuforums.org/showthread.php?t=1867054

iltony (iltony) wrote :

290.03 nvidia driver presents the same issue as 280.xx branch. I'm tryng to backport 260.xx branch, which shouldn't be affected by the bug, and see if it works. The procedure about backporting is explained here: http://ubuntuforums.org/showthread.php?t=1779132

scido (domi-mailing-list) wrote :

Please resolve this bug as soon as you can. I've got the same issue: after log in in LightDM, I get only the unity wallpaper and mouse cursor. Now I use nvidia-173, but it's very buggy (problem with dual monitors configuration, some freeze...). At least provide a nvidia-260 driver package, so we can upgrade it. I tried to installa previous driver versions (from PPA, from Nvidia site), luckless.

Thank You
Scido

Dell Precision M65
Nvidia Quadro FX 350M
Ubuntu 11.10
Nvidia driver 173.14.30

iltony (iltony) wrote :

Sorry, backporting 260.xx is not possibile since 260.xx branch is compiled against a different xorg ABI version than oneiric has, hence it does not work. Using IgnoreABI crashes x. However, using 173.xx branch (which works) is a huge regression in term of performance. Nouveau works, but it's kind of a regression (comparing to nvidia latest branch) too.

Dave Vree (hdave) wrote :

I used tried the 290.05 driver by activating the xorg-edgers PPA and am unhappy to report the problem remains. I have cross posted on the nvidia forums, but have had no response yet from nVidia.

Dave Vree (hdave) wrote :

Using the ubuntu-x-swat/x-updates ppa I was able to try out the 290.10 driver. Fedora users have reported success with this driver:

http://www.nvnews.net/vbulletin/showthread.php?p=2504236

However, I cannot even start X with this driver. Arch users have also reported this problem with 290.10. Looking at the Xorg.0.log file I see:

[ 15.583] (--) NVIDIA(0): Connected display device(s) on GeForce Go 7400 at PCI:1:0:0
[ 15.583] (--) NVIDIA(0): none
[ 15.583] (EE) NVIDIA(0): No display devices found for this X screen.
[ 16.020] (II) UnloadModule: "nvidia"
[ 16.020] (II) Unloading nvidia
[ 16.020] (II) UnloadModule: "wfb"
[ 16.020] (II) Unloading wfb
[ 16.020] (II) UnloadModule: "fb"
[ 16.020] (II) Unloading fb
[ 16.020] (EE) Screen(s) found, but none have a usable configuration.
[ 16.020]
Fatal server error:
[ 16.020] no screens found

Which means that with this driver, the adapter cannot detect me internal laptop display. Its been reported already here:

http://www.nvnews.net/vbulletin/showthread.php?t=168305

Hope this information helps us get closer to solution. As most people here already know, this bug not only keeps Unity 3D from being used but also the new Gnome3 shell as well. Until this gets fixed our only Desktop solution is Unity 2D.

pierre5933 (pierre-5933) wrote :

I have red rapidly this bug and it seems to bee the same , wee observe with Suse

with some difference it was more important with kde , but now I observe the same with gnome and kde ,
 it was solved with the driver
260.19.44 for suse 11.4 and kde 4.6

(my graphic cards is 7300 Gs)

The last trial I did was with 290.10 was perfect with gnome abd kde

If my information could help you !

Matt Hastings (sticky274885) wrote :

I used to have a problem with unity and nvidia, but I went into bios and changed my card's frame buffer size to 128mb and the problem was solved!

iltony (iltony) wrote :

This fixes the problem:
ftp://download.nvidia.com/XFree86/Linux-x86/275.43/

and for 64 bit users:
ftp://download.nvidia.com/XFree86/Linux-x86_64/275.43/

They state (http://www.nvnews.net/vbulletin/showthread.php?p=2510957):
* Fixed a regression that caused blank/white windows when exhausting video memory on GeForce 6 and 7 series GPUs while using composited desktops.

And that's true: tested and working. Hope for a fast update of nvidia-graphics-driver related package through synaptic. I installed the driver from NVIDIA binaries and am currently running GNOME 3 on Ubuntu 11.10; my video card is a NVIDIA GO 7300; can confirm nvidia driver 275.43 works properly (on my laptop).

I can confirm the driver listed in #144 fixes the issue. I am running Gnome Shell in Ubuntu 11.10 32 bit on a Dell Latitude D820 with an NVIDIA Quadro NVS 120M video card.

Anyone attempting to install this driver must blacklist the nouveau module first. You can do this by adding the following lines to the end of /etc/modprobe.d/blacklist.conf:
blacklist nouveau
options nouveau modeset=0

and then run:
sudo update-initramfs -u

and reboot your computer.

You should then be able to run the NVIDIA driver installers listed in post #144

Ouf........ I confirm that the driver 275.43 solve the problems for me too

I am running Unity 3D in ubuntu 11.10 32 bits

PC : Dell XPS M1210 graphic card nvidia GO 7400

Thanks to #144 and #145

Konstigt (konstigt) wrote :

Latest & greatest works (295.09) ! Still in beta but will probably be a stable release out soon..

http://www.nvnews.net/vbulletin/showthread.php?p=2514702

Yuan Fei (snowhawkyrf-126) wrote :

Thanks to #38 and #145, the driver 275.43 works on my asus a6j laptop. But the newest driver 290.10 on the NVIDIA website didn't work. After I installed it, I couldn't get to the login screen, only black screen with many words left there.

Ray Nichols (ray-rdnichols) wrote :

I've been using #145 but be aware that when the kernel changes you will need to re-install your Nvidia driver. There is no clear message (on booting) when this has happened but my system booted and stopped at a message:
Checking battery state ... [OK]

Re-install of the driver fixed the problem (the required side effect is to rebuild the kernel module).

BTW If you ever need to stop X in Oneiric, to re-install this driver, the service is now called lightdm.

When Ubuntu includes a driver greater than 275.43 it will be great to avoid this faff.

Bryce Harrington (bryce) wrote :

We're up to 290 in precise. Can someone verify this bug no longer occurs in Precise?

humber:~/ubuntu/mesa$ chet version nvidia-graphics-drivers
nvidia-graphics-drivers precise 290.10-0ubuntu2

Changed in nvidia-graphics-drivers (Ubuntu):
status: Triaged → Incomplete
Yuan Fei (snowhawkyrf-126) wrote :

I installed 290.10 downloaded from the NVIDIA website and it didn't work well. 275.43 is OK on my 11.10 precise 32bit. And as #149 said, I had to reintall it when the kernel upgraded.

Dave Vree (hdave) wrote :

Good News! The new nVidia beta driver 295.17 works! I tried it under oneric x86 32 bit with a GE Force 7400 Go card that has been blacklisted for Unity 3D and compiz for some time.

I installed the beta version via the xorg-edgers ppa here:

https://launchpad.net/~xorg-edgers/+archive/ppa?field.series_filter=oneiric

This is the first driver from nVidia that has worked with 3D in oneric for me.

Yuan Fei (snowhawkyrf-126) wrote :

Here is another good news:) Just now NVidia website released 295.20 and it fixed the bug with geforce 7 series. I installed it on my x86 32 bit with Geforce go 7300 and it works well.

Yuan Fei (snowhawkyrf-126) wrote :

So sorry to say that I have switched to GNOME3 and 295.20 still have bugs under this environment. When I search something begins with "vi" the gnome desktop crashes. I installed 275.43 back. I don't know if it can work well in unity.

Ofer (oferfrid-gmail) wrote :

I have a 7300 and after installing the 275.43 (see #145) the screen rendering was slow and I had to remove it.
Has anyone have a 7300 and can confirm that?

David Planella (dpm) wrote :

Al 03/02/12 23:32, En/na Bryce Harrington ha escrit:
> We're up to 290 in precise. Can someone verify this bug no longer
> occurs in Precise?
>
> humber:~/ubuntu/mesa$ chet version nvidia-graphics-drivers
> nvidia-graphics-drivers precise 290.10-0ubuntu2
>
>
> ** Changed in: nvidia-graphics-drivers (Ubuntu)
> Status: Triaged => Incomplete
>

This is fixed now for me with 295.20-0ubuntu1 \o/

Dave Vree (hdave) wrote :

Sorry to report that 295.20 is exhibiting intermittent freezing on Ubuntu 11.10 and Xubuntu 11.10. I am running 32 bit with an nVidia GE Force Go 7400. This is really disappointing as 12.04 is soon to arrive and we have no working driver to run Unity 3D with. I was using the version from ubuntu-x-swat PPA.

By the way, I have found that when experimenting with x-swat or xorg-edgers stuff the "ppa-purge" command is your friend -- resets everything back to normal with one command.

peterra (peter-rathjens) wrote :

The nvidia driver 295.20 works so far for me on Ubuntu 11.10. I'm using a
nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1) in my laptop.
Unfortunately the gtk-window-decorator dies from time to time:

gdb gtk-window-decorator
GNU gdb (Ubuntu/Linaro 7.3-0ubuntu2) 7.3-2011.08
Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /usr/bin/gtk-window-decorator...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/gtk-window-decorator
[Thread debugging using libthread_db enabled]

Program received signal SIGSEGV, Segmentation fault.
0x08056008 in meta_draw_window_decoration ()
(gdb) bt
#0 0x08056008 in meta_draw_window_decoration ()
#1 0x0805cfcb in ?? ()
#2 0xb76b4110 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3 0xb76b825f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4 0xb76b8990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5 0xb76b8f9b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6 0xb7b03fcf in gtk_main () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#7 0x0804fb28 in main ()

Jonathan Olmsted (jpolmsted) wrote :

I thought I would add my experience since I finally got around to trying out the suggestions mentioned in this post.

*Hardware* (relevant output from lspci -v)
05:00.0 VGA compatible controller: nVidia Corporation G72M [GeForce Go 7200] (rev a1) (prog-if 00 [VGA controller])
 Subsystem: Hewlett-Packard Company Device 30b7
 Flags: bus master, fast devsel, latency 0, IRQ 16
 Memory at c7000000 (32-bit, non-prefetchable) [size=16M]
 Memory at d0000000 (64-bit, prefetchable) [size=256M]
 Memory at c6000000 (64-bit, non-prefetchable) [size=16M]
 Expansion ROM at <unassigned> [disabled]
 Capabilities: <access denied>
 Kernel driver in use: nvidia
 Kernel modules: nvidia_current, nouveau, nvidiafb

*Driver*
nvidia 295.40

*OS*
Ubuntu 11.10 x86_64

*Method*
All I had to do was use the xorg-edgers ppa and everything else was automatic.

Thanks to all who have helped resolve this bug (if you see this). I am thrilled to finally have real Unity with a current driver.

I haven't had any of the segfaults mentioned above, but I have only been running it for a few hours.

Jonathan Olmsted (jpolmsted) wrote :

As an update, I do indeed experience the gtk-window-decorator bug from #158.

Mange (em-andersson) wrote :

These are my observations:
Using Unity 2D every once in a while the screen blinks, turns all white for a fraction of a second and then turns back.
Sometimes this is combined with menus, and other areas becomes messed up. (turned all white with individual pixels in other colors, sort of looking like corrupt pictures).

When I use Unity (3D) I noticed the same behavior just before the screen froze.

So my guess is that the problem isn't within Unity 3D but somewhere else.
Unity 2D manages to recover while Unity 3D freezes.

The problem with the blinking screen never occurred when I used Ubuntu 11 (without unity)

Ubuntu 12.04
GeForce Go 7300

Sergio Torres (sergiotca) wrote :

Sorry guys, can anyone say if this issue it's still relevant or has been already taken care? Ubuntu 12.10 is just around the corner and it will be awesome to have my card running Unity 3D without all the usual hassle.

Thank you!

Ubuntu 12.04
GeForce Go 7300

Jonathan Olmsted (jpolmsted) wrote :

I currently use Ubuntu 12.04 with the Unity (3D) and I have no problems. I have a GeForce Go 7200 card. I use the NVIDIA driver version 304.43 installed through the precise-proposed repo.

Ray Nichols (ray-rdnichols) wrote :

I've had no issues just using the supplied driver since switching to Precise. (I used to have to manually install a Nvidia driver.)

nicholsr@ubuntu01:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
nicholsr@ubuntu01:~$ lspci -nn | grep VGA
03:00.0 VGA compatible controller [0300]: NVIDIA Corporation G71 [GeForce 7300 GS] [10de:01df] (rev a1)
nicholsr@ubuntu01:~$ glxinfo | grep "OpenGL version"
OpenGL version string: 2.1.2 NVIDIA 295.40

mikewhatever (mikewhatever) wrote :

I've been tesing Unity for several days, with 12.04, Nvidia 295.40, and can also attest that the original problem is not present, and no segfaults either.

Hardware:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G72M [GeForce Go 7400] [10de:01d8] (rev a1)

Had to disable the blacklisting first by adding UNITY_FORCE_START=1 to /etc/environment.

John Cottier (j-cottier) wrote :

There seems to be more going on than just nvidia driver trouble. I have just installed 12.04 64 bit on a third machine with a more modern nvidia card (Geforce 9) and neither nouveau or nvidia driver will run unity. Thats three fails. Just a blank desktop (wallpaper) which seems to be a very common fault (tried most of the fixes). 3D drivers are working fine, excellently in fact. So it seems to be a compiz or unity bug.

John Cottier (j-cottier) wrote :

Thats with the 173 current and 173 post driver.

Xavier Verne (xavier-verne) wrote :

Short update in 2013 on this issue.

With :
- Up-to-date precise
- "current-updated" nvidia-drivers
- UNITY_FORCE_START=1 to /etc/environment
- Geforce Go 7400 on a laptop

I experience no freeze anymore (only few hours of use, but it seems to work).

I'm readily available if you need to make me execute some commands to pinpoint exact pb or root cause...You would have to drive me through it though.

I'm now a happy unity user, for this was a blocking issue for me (ubuntu-2d not a long term bet, as for say).

sudo lshw -class display
 *-display
       description: VGA compatible controller
       product: G72M [GeForce Go 7400]
       vendor: nVidia Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:d1000000-d1ffffff memory:b0000000-bfffffff(prefetchable) memory:d0000000-d0ffffff

mikewhatever (mikewhatever) wrote :

Been trying to run Unity with the nvidia-current-updates driver (304.43). Doesn't work!

Hardware:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G72M [GeForce Go 7400] [10de:01d8] (rev a1)

tgoner (tornadogoner) on 2013-04-06
Changed in nvidia-drivers-ubuntu:
status: Confirmed → Fix Released
Displaying first 40 and last 40 comments. View all 169 comments or add a comment.